Katgen

KL-systems

KOCH-LÖFFELHOLZ GmbH
KL-KatGen professionell 11.0

EDV-gestützt Preislisten und Kataloge erstellen

Der Katalogdaten-Manager

Der Katalog-Designer

Programmbeschreibung / Bedienung

04/13 11.00/903

Dieses Handbuch (Hilfefunktionen) sowie die darin beschriebene Software unterliegen lizenzrechtlichen Bestimmungen und dürfen nur in Übereinstimmung mit der Lizenzvereinbarung verwendet werden. Die Angaben und Daten dienen ausschließlich Informationszwecken und gelten unter Vorbehalt. Die Koch Löffelholz GmbH (KL-systems) übernimmt keinerlei Haftung oder Gewährleistung und Verantwortung für Folgeschäden auf Grund von Fehlern oder Ungenauigkeiten.

Die Software wird permanent aktualisiert, daher kann der aktuelle Maskeninhalt vom Screenshot in diesem Handbuch abweichen

Die in dieser Unterlage beschriebenen Programmfunktionen und Daten können ohne vorherige Ankündigung geändert werden.

Vervielfältigung (auch auszugsweise) nur mit schriftlicher Erlaubnis der KL-systems KOCH-LÖFFELHOLZ GmbH.

Alle Rechte vorbehalten.

Inhaltsübersicht 1

Schnell, problemlos, computergestützt Preislisten und Kataloge erstellen. 10

1 Die ersten Schritte. 14

1.1 Vorbereitende Überlegungen und Informationen. 14

1.2 Begriffe und Darstellungsarten. 15

1.3 Schritt für Schritt zum ersten Katalog. 18

1.4 Die Wege zu Ihrem Katalog. 21

2 Der Katalogdaten-Manager 22

2.1 Zwei Wege zum eigenen Katalog. 22

2.1.1 Automatische Katalogerstellung. 22

2.1.2 Manuelle Katalogerstellung. 23

2.2 Die Arbeitsansicht (der Katalogdaten-Manager) 24

2.2.1 Kataloggruppen-Zusätze. 25

2.2.2 Kataloggruppen-Zusatzdaten / Artikel-Zusatzdaten. 26

2.3 Der schnelle Einstieg: In Minuten zum eigenen Katalog. 27

2.3.1 Katalogerstellung ohne Verwendung von Artikelstammdaten. 27

2.3.2 Schneller geht es mit HOT-KEYs. 29

2.4 Katalogerstellung. 30

2.4.1 Anlegen eines neuen Kataloges. 30

2.4.2 Anlegen der Kataloggruppen. 31

2.4.2.1 Automatische Katalog-Erstellung (Direkt-Import von Artikeldaten) 31

2.4.2.2 Manuelles Anlegen der Kataloggruppen. 32

2.4.3 Darstellungsarten. 33

2.4.3.1 Darstellungsarten ohne integrierte Funktionen. 41

2.4.3.2 Vordefinierte Darstellungsarten. 44

2.4.3.3 Drucksteuerung mit unterschiedlichen Darstellungsarten. 52

2.4.4 Erfassen der Katalogpositionen (Artikeldaten) 53

2.4.5 Katalogerstellung unter Verwendung von Artikelstammdaten. 53

2.4.6 Katalog Preis-Aktualisierung unter Verwendung von Artikelstammdaten. 54

2.4.7 Manuelles Erfassen von Artikeldaten ohne Prüfung und Datenübernahme. 55

2.4.8 Manuelles Erfassen von Artikeldaten mit Prüfung und Datenübernahme. 55

2.4.9 Ändern der Reihenfolge der Positions-/Artikeldaten. 55

2.4.10 Ändern der Position (Reihenfolge) einzelner Kataloggruppen im Katalog. 55

2.4.11 Kopieren von Kataloggruppen. 55

2.4.12 Verwenden importierter Artikeldaten für die Katalogerstellung. 56

2.4.13 Artikel-Suchfilter 56

2.4.14 Verwalten Seiten- und Zwischenüberschriften. 58

2.5 Spaltensteuerung / Spaltenüberschriften der Kataloggruppen. 59

2.6 Die Kataloggruppenselektion. 60

2.6.1 Filter ja/nein. 60

2.6.2 Die Kataloggruppen Einzelselektion. 60

2.6.3 Selektieren Von Bis. 60

2.6.4 Alle löschen. 61

2.6.5 Selektion umkehren. 61

2.6.6 Anzeige. 61

2.7 Positionszusätze und Positionsdetails. 61

2.8 Katalogverwaltung. 62

2.8.1 Speichern des fertigen Kataloges. 62

2.8.2 Katalog unter anderem Namen speichern. 62

2.8.3 Bearbeiten eines vorhandenen Kataloges. 62

2.8.4 Katalog Daten Löschen (Datei leeren) 63

2.8.5 Katalog Dateien Löschen. 63

2.9 Zusatzmodul SK (Option, nicht in der Basislösung) 64

2.9.1 Individualkataloge, Kunden- / Aktionskataloge aus bestehenden Katalogen (Katalogdaten) erstellen. 65

2.9.1.1 Gesamtkatalog mit Sonderkonditionen. 65

2.9.1.2 Kunden- / Aktionskatalog mit Sonderkonditionen. 65

2.9.1.3 Kunden- / Aktionskatalog mit Listenpreisen. 66

2.9.1.4 Katalog mit den Artikeln eines oder mehrerer bestimmter Lieferanten. 66

2.9.2 Automatische Preisänderung über Sonderkonditionen. 66

2.9.2.1 Katalogdatenaktualisierung. 66

2.9.2.2 Automatische Preisermittlung bei der manuellen Erfassung eines Kataloges. 68

2.9.3 Automatische Preisänderungen in den Katalogdaten unter Berücksichtigung der hinterlegten Preisfindungsalgorithmen. 69

2.10 Der Datenimport 70

2.10.1 Der Datenimport im Überblick. 71

2.10.2 Der Datenimport Schritt für Schritt 73

2.10.2.1 Sicherungskopie des zu ändernden Kataloges und der Artikeldatei erstellen. 73

2.10.2.2 Aufruf der Funktion "Daten-Import“ 75

2.10.2.3 Die Importstruktur, Konfigurieren der Import-Schnittstelle. 76

2.10.2.4 Sortierung / Gruppierung. 78

2.10.2.5 Importstruktur (Erweiterungen) 79

2.10.2.6 Datenaktualisierung beim Datenimport (Update-Steuerung) (Kurzbeschreibung) 80

2.10.2.7 Sichtprüfung mittels Importtest 81

2.10.2.8 Starten des Datenimports (Ausführen) 82

2.10.3 Der Datenimport im Detail 83

2.10.3.1 Aufruf der Funktion "Daten-Import“ 83

2.10.3.2 Konfigurieren der Import-Schnittstelle Strukturverwaltung. 84

2.10.3.3 Verwalten der Importschnittstellen "Register Erweiterungen" 96

2.10.3.4 Automatische Überschriftenerzeugung. 97

2.10.3.5 Überschriften Zufall / Überschriften Artikel 97

2.10.3.6 Konvertierzusatzbefehle. 98

2.10.3.7 Importkonverter 99

2.10.3.8 automatisch zufallsabhängig Überschriften übernehmen. 101

2.10.3.9 Import Ausführen. 103

2.10.3.10 Verwalten der Import-Strukturen (ändern, löschen, kopieren) 104

2.10.3.11 Die Updatesteuerung beim Datenimport 105

2.10.3.12 Import ausführen. 112

2.10.3.13 Automatische Kategorienermittlung. 113

2.10.3.14 Automatischer Umbruch bei Spaltendarstellung. 115

2.10.3.15 Individuelle Schnittstellenlösungen. 117

2.10.3.16 Einlesen exportierter Artikeldaten in KL-KatGen zur Katalogaktualisierung. 117

2.10.3.17 Preisaktualisierung beim Katalogdruck bzw. der Kataloganzeige. 118

3 Der Katalog-Designer 119

3.1 Starten des Katalog-Designers. 119

3.2 Die Werkzeuge und Funktionen des Katalog-Designers. 120

3.3 Grundeinstellungen des Katalog-Designs (Seiteneinstellungen) 120

3.4 Die Katalogbereiche. 120

3.5 Die Katalog-Steuerelemente. 123

3.6 Datenfelder und Funktionen für den Druck. 124

3.6.1 Datenfelder für den Druck. 124

3.6.1.1 Tabellen und Datenfelder für den Druck der Kataloghauptdaten (Positionen und Artikel) 124

3.6.1.2 Tabellen und Datenfelder für den Druck Katalogergänzungsdaten (Inhaltsregister, Deckblätter, Zwischenblätter) 126

3.6.1.3 Datenfelder für den Druck. 127

3.6.1.4 Funktionen für den Druck. 134

3.6.1.5 Haupt-Steuerfunktionen. 134

3.7 Formatieren von Feld-Steuerelementen in einem Bericht 147

3.7.1 Formatieren von Feld-Steuerelement 147

3.7.2 Ändern von Schriftarten. 147

3.7.3 Ändern der Farbe von Bericht-Steuerelementen. 148

3.7.4 Ändern der Größe eines Steuerelements. 148

3.7.5 Mehrere Steuerelemente auf die gleiche Größe anpassen. 148

3.7.6 Formatieren eines Bildes. 148

3.7.7 Einpassen des Bildes in den Rahmen. 148

3.7.8 Ausfüllen des Rahmens mit dem Bild. 148

3.7.9 Zentrieren eines Bildes. 149

3.7.10 Gruppieren von Steuerelementen. 149

3.7.11 Aufheben der Gruppierung von Steuerelementen. 149

3.7.12 Ausrichten von Steuerelementen. 149

3.7.13 Steuerelemente zueinander ausrichten. 149

3.7.14 Zentrieren von Steuerelementen in einem Bereich. 149

3.7.15 Platzierung von Steuerelementen mit der Statusleiste oder dem Raster 149

3.7.16 Anordnen von Steuerelementen auf eine bestimmte Position. 150

3.7.17 Anzeigen von Rasterlinien. 150

3.7.18 Ändern der Abmessungen des Rasters. 150

3.7.19 Text in einem Feld-Steuerelement ausrichten. 150

3.7.20 Text in einem Feld ausrichten. 150

3.8 Einstellen der Druckoptionen für Steuerelemente. 150

3.8.1 Drucken von Steuerelementen mit Werten variabler Länge. 150

3.8.2 Festlegen, dass ein Feld mit seinem Wert vergrößert wird. 151

3.8.3 Festlegen, dass ein Feld verschiebbar wird. 151

3.8.4 Festlegen, dass Linien und Rechtecke vergrößert werden können. 151

3.8.5 Druck vergrößerbarer Steuerelemente in einem Rahmen. 151

3.8.6 Druck vergrößerbarer Steuerelemente untereinander 151

3.8.7 Festlegung der Bedingungen ob ein Bericht-Steuerelement gedruckt werden soll 152

3.9 Einstellen der Druckoptionen für Gruppen. 154

3.9.1 Festlegen von Seitenumbrüchen für Gruppen. 154

3.9.2 Auswählen einer Gruppenkopfoption. 154

3.9.3 Vermeiden von allein stehenden Gruppenköpfen. 154

3.9.4 Verhindern von allein stehenden Gruppenköpfen. 154

3.9.5 Drucken unterdrückter Werte beim Gruppenwechsel 154

3.9.6 Wiederholte Werte drucken, wenn sich die Gruppe ändert 154

3.9.7 Wiederholen von Gruppenköpfen. 155

3.9.8 Wiederholen des Gruppenkopfs auf der nächsten Seite. 155

3.9.9 Grundeinstellungen für Standardfunktionen in der Hauptmaske. 155

4 Kataloge Drucken und Design verwalten. 156

4.1 Kataloge Drucken. 157

4.2 Kataloge am Bildschirm anzeigen. 157

4.3 Design ändern. 158

4.4 Katalog-Design Auswahlarchiv. 158

4.5 Drucken von Teilbereichen eines Kataloges. 159

4.6 Preisoptionen. 160

4.6.1 Preisauswahl 160

4.6.2 Automatische Preisermittlung / Kunden- / Aktionskataloge (Zusatzmodul nicht in der Basislösung) 161

4.7 Optionen beim Katalogdruck. 163

4.8 Erstellen und Drucken Inhaltsverzeichnisse und Register 165

4.8.1 Standard-Register im Design des Kataloges erstellen. 166

4.8.1.1 Alphabetisches Register Standard. 167

4.8.1.2 Register alphabetisch sortiert nach Kategorien und Stichwort 168

4.8.1.3 Register Inhaltsverzeichnis. 170

4.8.1.4 Register nach Artikelnummer 171

4.8.1.5 Druck Preisliste / Register nach Seite (Programmoption, nicht im Standard) 172

4.8.1.6 Individual-Register (Programmoption, nicht im Standard) 172

4.8.2 Erstellen und Drucken des Deckblattes. 174

4.8.3 Erstellen und Drucken des Rückblattes. 174

4.9 Designverwaltung. 175

4.9.1 Programmerweiterungen / firmenspezifische Funktionen (Programmoption, nicht im Standard) 177

4.10 Der Sammeldruck. 178

4.10.1 Sammeldrucke erstellen. 178

5 Menü Katalogdaten verwalten. 179

5.1 Katalogdaten Neu. 179

5.2 Katalog Speichern unter 179

5.3 Katalogdaten Öffnen. 179

5.4 Artikel in den Positionen tauschen und löschen. 179

5.5 Verwalten Kataloggruppen. 180

5.6 Aktions-/Sonderpreiskatalogerfassung. 181

5.7 Kataloggruppen Selektion. 181

5.8 Überschriften. 181

5.9 Aktuelle Katalogdaten sichern. 181

5.10 Katalog zurücksichern. 182

5.11 Katalog Dateien Löschen. 182

5.12 Aktuelle Katalogdatei leeren. 182

5.13 Katalog Drucken und Designverwaltung. 182

6 Menü Stammdatenverwaltung. 183

6.1 Artikeldaten verwalten. 183

6.1.1 Artikel-Basisdaten. 183

6.1.2 Artikel Ergänzende Daten. 184

6.1.3 Artikelauswahl mit Filtern. 185

6.1.4 Artikel-Zusatzdaten. 185

6.1.5 Nutzungsvarianten der Zusatztexte. 187

6.1.6 Label setzen für formatierte Textfelder 187

6.1.7 Kataloggruppenzusatztexte (und Label) Kopieren. 189

6.1.8 Kataloggruppenzusatztexte und –Label Löschen. 189

6.2 Artikellisten. 190

6.3 Artikeldatei speichern unter 190

6.4 Artikeldatei wechseln. 190

6.5 Artikeldatei sichern. 190

6.6 Artikeldatei zurücksichern. 190

6.7 Aktuelle Datei leeren. 190

6.8 Kategorien/Artikelgruppen verwalten. 190

6.8.1 Automatische Kategorienermittlung beim Datenimport 192

6.8.2 Automatisierte Ermittlung der Katalogkategorien mit der Programmfunktion " Erstellen / Verwalten Kategorien 194

6.8.2.1 Ermittlung der Kategorien aus den Kataloggruppen des aktuellen Kataloges. 194

6.8.2.2 Ermittlung der Kategorien aus der KL-KatGen-eigenen Artikelstammdatei 194

6.8.2.3 Ermittlung der Kategorien aus der Importdatei 194

6.8.2.4 Ermittlung der Kategorien aus einer CSV-Datei 194

6.8.3 Manuelle Artikelgruppen/Kategorienverwaltung. 195

6.9 Kundenstamm / Aktionsstamm verwalten. 197

6.10 Kundengruppen verwalten. 199

6.11 Sonderkonditionen verwalten. 199

6.12 Hersteller und Lieferanten verwalten. 200

7 Auftragswesen. 202

7.1 Erfassen der Auftrags-/Angebotskopfdaten. 202

7.2 Erfassen der Auftrags-/Angebots-Positionen. 203

7.3 Drucken von Angeboten, Lieferscheinen und Datenblättern. 203

7.4 Anpassen des Designs von Angeboten, Lieferscheinen, Datenblättern und Briefen. 203

7.5 Briefe erstellen und drucken. 204

8 Menü Daten-Import/Export 205

8.1 Datenimport aus CSV-Datei 205

8.2 Datenexport 205

8.2.1 Export Katalogdaten. 205

8.2.2 Export Artikeldaten. 206

8.2.3 Export Registerdaten. 206

8.2.4 BMEcat Export (Option, nicht im Standard) – Auf Anfrage. 207

8.3 Katalogdaten-Transfer 208

8.3.1 Katalog-Transfer – Daten bereitstellen. 208

8.3.2 Katalog-Transfer – Daten übernehmen. 208

8.4 Datenimport aus Shopdaten. 208

8.5 Daten für Internetshop (Option, nicht in der Basislösung) 209

8.5.1 Daten für Internetshop (Option, nicht in der Basislösung) 209

8.5.2 Datenimport aus Internetshop (FTP) (Option, nicht in der Basislösung) 210

9 Menü Programmverwaltung. 211

9.1 Firmenstamm-Verwaltung. 211

9.2 Lizenznummer 212

9.3 Passcode-Verwaltung. 212

9.4 Pfad Bilddateien. 212

9.5 Programmsteuerung. 213

9.6 Verwalten Darstellungsarten. 213

9.6.1 Auswahl von Darstellungsarten anhand schematischer Darstellung. 215

9.6.2 Eigene Darstellungsarten. 215

9.7 Verwalten Spalten-Anzeige. 216

9.7.1 Erfassen / Verwalten einer Spaltenanzeige. 216

9.7.2 Zuweisen einer Spaltensteuerung. 219

9.8 Verwalten Steuerung Katalog-Gruppen-Nummern. 219

9.9 Verwalten Textbausteine. 220

9.10 Verwalten Textvariable. 221

9.11 Verwalten Textkonvertierung. 222

9.12 Steuerung kein Wiederholdruck. 222

9.13 Steuerung doch Wiederholdruck. 222

9.14 Verwalten Label-Zusatztexte. 223

9.15 Datenreorganisation. 223

9.16 Verwalten Parameterdatei 223

9.17 Standard-Designs wieder herstellen. 224

9.18 Anzeige Programminformation. 224

10 Was ist neu in KL-Katgen11?. 226

10.1 Neue Funktionen im Überblick. 226

10.2 KL-KatGen mit Dongle auf verschiedenen Computern nutzen. 227

10.3 Blitzkatalog und weitere Hilfen. 227

10.3.1 Der "Blitzkatalog" 228

10.3.2 Die neue Grundmaske. 229

10.3.3 Label Feldbezeichner 230

10.3.4 Artikelauswahl in der Artikelstammdatei bei der Katalogdatenerfassung mit integrierter Stammdatenpflege 232

10.3.5 Die Bildautomatik. 233

10.4 Neue Funktionen zur manuellen Pflege der Katalogdaten: 234

10.4.1 Artikel(daten) in den Positionen tauschen und löschen. 234

10.4.2 Aktions-/ Sonderpreiserfassung. 235

10.4.3 Verwaltung Katalogsortierung nach Kataloggruppen. 236

10.4.4 Katalog-Gruppen Zusatztexte. 238

10.4.4.1 Nutzungsvarianten der Zusatztexte. 238

10.4.5 Kataloggruppenzusatztexte Kopieren. 240

10.4.6 Kataloggruppenzusatztexte und –Labels Löschen. 240

10.5 Stammdatenverwaltung und -Listen. 241

10.5.1 Artikelstammverwaltung. 241

10.5.2 Neue Artikelauswahl und Suche. 241

10.5.3 Artikellisten. 242

10.5.4 Kunden Aktionsstammverwaltung. 243

10.5.5 Verwalten Kundengruppen. 243

10.5.6 Verwalten Sonderkonditionen. 244

10.5.7 Verwalten Hersteller- /Lieferantenstamm.. 244

10.5.8 Darstellungsarten. 245

10.5.9 Auswahl von Darstellungsarten. 246

10.5.10 Katalogstruktur mit Kategoriebaum verwalten. 247

10.5.11 Verwalten Textbausteine. 248

10.6 Daten Import / Export 249

10.6.1 Datenimport aus CSV. 249

10.6.1.1 Katalogdaten Aktualisieren. 249

10.6.2 Zusätzliche Datenfelder mit integrierten Funktionen. 250

10.6.3 Zusätzliche steuernde Importfelder 250

10.6.4 Anzeige und automatische Korrektur der Importdaten beim Import 251

10.7 Daten Export / Transfer 252

10.7.1 Export von Katalogdaten. 252

10.7.2 Export Artikelstammdaten. 252

10.7.3 Export Registerdaten. 253

10.8 Katalogdatentransfer 254

10.8.1 Katalogdaten nach Artikelstammdatei übertragen. 254

10.8.2 Katalogtransfer Daten bereit stellen / Katalogtransfer Daten übernehmen. 255

10.9 Auftragswesen. 256

10.9.1 Brieftexte erfassen und verwalten. 257

10.9.2 Datenimport aus Shopdateien (optional) 258

10.10 Aktualisieren der Daten in einem vorhandenen Katalog. 260

10.10.1 Manuelles Verwalten von Kataloggruppen. 260

10.10.1.1 Einfügen einer neuen Kataloggruppe. 260

10.10.1.2 Einfügen einer neuen leeren Kataloggruppe. 260

10.10.1.3 Löschen einer Kataloggruppe. 260

10.10.1.4 Kopieren, Verschieben einer einzelnen Kataloggruppe. 260

10.10.2 Kataloggruppen in einer Übersicht manuell verwalten. 261

10.11 Verwalten der Katalog-Positionen in einem vorhandenen Katalog. 262

10.11.1 Aktualisierung der Katalogpositionen durch erneuten Datenimport 262

10.11.2 Aktualisierung der Katalogpositionen beim Katalogdruck mit den Daten aus der Artikelstammdatei 263

10.11.3 Manuelles Verwalten der Katalogpositionen (Artikel) in der Grundmaske. 264

10.11.3.1 Die "Integrierte Positions-/Artikelstammverwaltung" 264

10.11.3.2 Die "Multi-Change Funktion" 264

10.11.3.3 Manuelles Hinzufügen von Katalogpositionen. 264

10.11.4 Manuelles Löschen von Katalogpositionen. 265

10.11.5 Manuelles Ändern von Katalogpositionen (Ändern der Werte eines Artikels) 265

10.11.6 Manuelles Ersetzen von Katalogpositionen (anderer Artikel) 265

10.11.7 Sofortige Aktualisierung im Artikelstamm.. 265

10.11.8 Die "Multi-Change Funktion" 266

10.11.9 Löschen von Positionen. 266

10.11.10 Löschen Artikelstamm.. 266

10.11.11 Artikelwerte / Positionswerte im Katalog ersetzen. 267

10.11.12 Artikel / Positionen im Katalog ersetzen. 267

10.11.13 Löschen Artikelstamm.. 267

10.11.14 Bestimmen der Update-Felder 267

10.11.15 Artikel Positionen im Katalog suchen. 268

10.11.16 Direkte Suche in den Katalogpositionen. 268

10.11.17 Indirekte Suche durch Artikelauswahl in der Artikelstammdatei mit Anzeige in welcher Kataloggruppe sich der entsprechende Artikel befindet. 270

11 Der Blitzkatalog "Was wollen Sie tun" 271

11.1 Sie haben folgende Programmfunktionen in dieser Maske zur Auswahl. 272

11.1.1 Datentest 272

11.1.2 nur Import 273

11.1.3 mit Anzeigen. 274

11.1.4 mit Drucken. 274

11.2 Demonstrationsmodus. 275

11.3 Expertenmodus (= Demonstrationsmodus deaktiviert) 275

11.3.1 Katalogname. 275

11.3.2 Importdatei 275

11.3.3 Automatisch einen Katalog aus einer Importdatei erstellen. 275

11.3.4 Daten aus einer Importdatei in die Artikelstammdatei übernehmen. 275

11.3.5 Ich möchte dabei Schritt für Schritt vom Programm geführt werden. 275

11.3.6 Hilfe Schnittstelle. 275

11.3.7 Darstellung. 275

11.3.8 Reportname. 275

11.3.9 Schnittstelle definieren. 275

12 Anleitung CSV-Schnittstelle. 276

13 Kalkulation. 279

13.1 Zuordnen der Kalkulationsnummern zu den Artikelstammdaten. 280

13.2 Die Kalkulationsparameter 281

13.3 Anlegen der Kalkulationsparameter 282

13.4 Kalkulationsparameter 284

13.5 Arten der Kalkulationsparameter 284

13.6 Vertikale Wertübernahme. 285

13.7 Basisvariable und Formeln. 286

13.7.1 Feste Basisvariable. 287

13.7.2 Individuelle Basisvariable. 288

13.7.3 Formeln. 288

13.8 VKFRUNDEN.. 290

13.8.1 Die Preisrundungs- / Korrekturtabelle. 292

14 Anhang. 294
Schnell, problemlos, computergestützt Preislisten und Kataloge erstellen.

Mit KL-KatGen erstellen Sie einfach und schnell Preislisten und Kataloge. KL-KatGen unterstützt Sie dabei mit zwei leistungsstarken Werkzeugen, dem "Katalogdaten-Manager" und dem "Katalog-Designer".

Einmal erstellte Kataloge können zukünftig in wenigen Minuten mit den Preisen aus Ihrem Warenwirtschaftssystem aktualisiert werden. Beliebig viele1, unterschiedliche Kataloge, Kataloge für einzelne Artikel, Artikelgruppen, spezielle Kunden, Kundengruppen oder für einzelne Aktionen können Sie so in Ihrem System erzeugen, verwalten und drucken. Und damit sich Ihre Kunden, selbst bei umfangreichen Katalogen schnell zurechtfinden können, erstellt KL-KatGen auf Wunsch, automatisiert ein entsprechendes Inhaltsverzeichnis.
Der Katalogdaten-Manager

Im Katalogdaten-Manager verwalten Sie die Daten, die im Katalog erscheinen sollen. Sie bestimmen welche Artikel und Leistungen, an welcher Stelle, mit welchen Zusatztexten und Abbildungen gedruckt werden. Sie definieren Seiten- und Zwischenüberschriften und ergänzen diese bei Bedarf mit erläuternden Texten. Sie ordnen die Reihenfolge der Artikel, legen fest welche Artikel zu Artikelgruppen zusammengefasst werden, generieren automatisch Kataloge und Preislisten aus Ihrem Warenwirtschaftssystem oder aus den Daten Ihrer Lieferanten, ergänzen diese mit Bildern und zusätzlichen Texten.

Die primären Aufgaben des "Katalogdaten-Managers":

- Erfassen der Katalogdaten (Ersterstellung)

- Pflege der Katalogdaten (Aktualisierung)

- Daten-Import/Export

Der Katalog-Designer

Bereits mit den mitgelieferten "Katalogdesigns" können Sie sofort Ihre ersten Kataloge und Ihre ersten Preislisten drucken. Wollen Sie jedoch das Erscheinungsbild der Kataloge und Preislisten entsprechend Ihren Anforderungen und persönlichen Designvorstellungen individuell verändern, so verfügt KL-KatGen bereits in der Basisversion über einen integrierten Katalog-Designer der es Ihnen ermöglicht die mitgelieferten Standard-Katalogdesigns auf Ihre Belange hin anzupassen oder neue Katalogversionen zu erstellen. So lassen sich beliebig viele Designs erstellen und verwalten und somit aus dem gleichen Datenbestand sowohl ansprechende Bild-Kataloge als auch einfache Preislisten erstellen.

Die primären Aufgaben des "Katalog-Designers":

- Erstellen / Ändern des Designs der Ausdrucke

Allgemeine Hinweise zur Programmbedienung

Bitte beachten Sie, dass Sie an jeder Stelle des Programms mit der F1-Taste einen kontextbezogenen Hilfetext angezeigt bekommen.
Eine weitere hilfreiche Einrichtung sind die so genannten "Tooltips", das heißt, Sie erhalten einen erläuternden Text zu einem Objekt (Eingabefeld, Button etc. )in einem hellgelben Fenster angezeigt, sobald Sie mit dem Mauszeiger auf das entsprechende Objekt zeigen.

Dies ist ein "Tooltip", d.h. ein Hilfetext den Sie erhalten, wenn Sie mit der Maus langsam über ein Objekt (z.B. Eingabefeld) ziehen

Möglichkeiten der Katalog- und Preislistenerstellung

Das endgültige Aussehen eines Kataloges wird durch die Daten, dem eigentlichen Inhalt und dem Design, das heißt, in welcher Form diese Daten zu drucken sind, festgelegt. Grundsätzlich bestimmt bei KL-KatGen die Reihenfolge der Daten innerhalb eines Kataloges die Reihenfolge der Darstellung im Katalog.

Die einzelnen Katalogpositionen (in der Regel die Artikel) werden im Katalog in Kataloggruppen
dargestellt.

Eine Kataloggruppe ist die Zusammenfassung von Katalogartikeln, die unter einer Beschreibung, ergänzt mit einem oder mehreren Bildern dargestellt werden sollen (z.B. ein Artikel in verschiedenen Größen oder Farben, ein Set oder ein Produkt mit Zubehör-/Ersatzteilen .
Der Begriff "Kataloggruppe" hat nichts mit Artikelgruppe oder Warengruppe zu tun.

Das Aussehen, das heißt, wie diese Daten gedruckt werden, lässt sich für einzelne Kataloggruppen individuell steuern. Die Information dazu (die Darstellungsart) wird in den Daten, der Kataloggruppe zugeordnet. Wie diese Darstellungsart letztendlich interpretiert wird, das heißt, wie diese Kataloggruppe im Katalog tatsächlich erscheint, wird durch das beim Drucken zugeordnete Design bestimmt.
Im Berichtsdesigner können Sie beliebig viele Designs selbst entwickeln und nach Bedarf beim Drucken den Katalogdaten zuordnen. Somit lassen sich zum Beispiel die gleichen Katalogdaten wahlweise als Bildkatalog mit und ohne Preise oder auch nur als einfache Preisliste drucken.

Wir unterscheiden daher die Katalogerstellung d.h. die Datenzusammenstellung und das eigentliche Drucken der Katalogdaten.

Kataloggestaltung beim Erstellen der Katalogdaten

Automatisierte Katalogerstellung

· Neuerstellung aus externen Daten Datenimport

· Neuerstellung aus interner Artikeldatei Datenimport

· Neuerstellung aus bestehenden Katalogdaten

· Kopieren eines vorhandenen Kataloges mit Nachbearbeiten
"Selektiertes / gefiltertes" Kopieren eines vorhandenen Kataloges mit Nachbearbeiten

Manuelle Katalogerstellung

· Ohne Zugriff auf interne Artikelstammdaten

· Mit Zugriff auf interne Artikelstammdaten

· Mit Zugriff auf interne Artikelstammdaten unter Berücksichtigung von Sonderkonditionen

Kataloggestaltung beim Drucken

Zusammenführen einzelner Kataloge in einem Sammelkatalog

· Selektives Drucken eines Kataloges oder eines Sammelkataloges

· Zusammenführen einzelner Kataloge in einem Sammelkatalog

· Zusammenführen einzelner Katalogteile in einem Sammelkatalog

Kataloggestaltung beim Erstellen der Katalogdaten

Automatisierte Katalogerstellung

Neuerstellung aus externen Daten / Datenimport

Es werden externe Daten in den Katalogdatenstamm direkt aus fremden Schnittstellen eingelesen.
Standardmäßig unterstützt wird hier das CSV-Format wie es z.B. EXCEL oder verschiedene Warenwirtschaftssysteme bereitstellen. Details hierzu finden Sie im Kapitel "Der Datenimport"

Neuerstellung aus interner Artikeldatei / Datenimport

Es werden externe Daten in den Artikelstamm von KL-Katgen direkt aus fremden Schnittstellen eingelesen. Unterstütztes Format ist hier ebenfalls das CSV-Format wie es z.B. EXCEL oder verschiedene Warenwirtschaftssysteme bereitstellen.
Natürlich ist es auch möglich, die Artikeldaten manuell in einem Stammdatenprogramm zu erfassen
Anschließend kann KL-Katgen (im Menüpunkt "Datenimport") aus den bestehenden Artikeldaten automatisiert Kataloge erstellen.

Neuerstellung aus bestehenden Katalogdaten

Es werden fertige Kataloge oder Teile von Katalogen (z.B. über Filterselektion) als neuer Katalog abgespeichert. Anschließend kann der neue Katalog angepasst oder unverändert erstellt werden.

Details hierzu finden Sie im Kapitel "Automatische Katalogerstellung

Manuelle Katalogerstellung

Ohne Zugriff auf interne Artikelstammdaten.

Kataloge werden direkt, ohne vorheriges Erfassen bzw. Vorhandensein von Artikelstammdaten manuell erfasst. Weitere Details hierzu finden Sie im Kapitel "Katalogerstellung ohne Verwendung von Artikelstammdaten"

Mit Zugriff auf interne Artikelstammdaten

Kataloge werden aus der KL-Katgen internen Artikeldatei, die entweder manuell oder per Datenimport gefüllt wurde, manuell zusammengefügt. Grundlegende Inhalte wie Preise, Bezeichnungen, Bilder etc. werden, sofern diese im Artikelstamm vorhanden sind, in die Katalogdatei automatisch übernommen.

Weitere Details hierzu finden Sie im Kapitel "Katalogerstellung unter Verwendung von Artikelstammdaten".

Mit Zugriff auf interne Artikelstammdaten unter Berücksichtigung von Sonderkonditionen

Kataloge werden aus der KL-Katgen internen Artikeldatei, die entweder manuell oder per Datenimport gefüllt wurde, manuell zusammengefügt. Grundlegende Inhalte wie Preise, Bezeichnungen, Bilder werden, sofern diese im Artikelstamm vorhanden sind, in die Katalogdatei automatisch übernommen.

Zur Preisfindung werden die Konditionen eines Kunden herangezogen.

Details hierzu finden Sie im Kapitel "Aktions-/Sonderpreiskatalogerfassung "

Kopieren eines vorhandenen Kataloges mit Nachbearbeiten

Speichern Sie den aktuellen Katalog unter anderem Namen (immer im KL-KatGen Arbeitsverzeichnis). Wählen Sie den so neu entstandenen Katalog (Katalogdaten) zum weiteren Bearbeiten und Drucken aus ("Kataloge und Daten verwalten"à "Datei öffnen"). Löschen und ergänzen Sie nun Kataloggruppen und Positionen.

"Selektiertes / gefiltertes" Kopieren eines vorhandenen Kataloges mit Nachbearbeiten

Kennzeichnen Sie die gewünschten (oder nicht gewünschten) Kataloggruppen einzeln oder "von-bis" und speichern Sie nach Aktivierung des "Filters" die gekennzeichneten Daten in einem neuen Katalog unter neuem Namen. (Details unter "Die Kataloggruppenselektion / Kataloggruppen filtern").

Kataloggestaltung beim Drucken

Um aus vorhandenen Katalogdaten einen Teilkatalog zu drucken, stehen die nachfolgend beschriebenen Möglichkeiten zur Verfügung. Je nach Verwendung ist im Einzelfall zu prüfen welche Variante am geeignetsten ist. Soll der Katalog auch zukünftig in der gewählten Form mehrfach zum Einsatz kommen, sollen Teilbereiche je nach Zielgruppe in einem Sammeldruck unterschiedlich kombiniert werden oder ist lediglich ein Aktionsflyer zusammen zu stellen, KL-KatGen bietet entsprechende Wege.

Zusammenführen einzelner Kataloge in einem Sammelkatalog

Definieren Sie Teilkataloge, indem Sie Einträge mit Katalognummer von/bis aus einem oder mehreren verschiedenen Katalogen vornehmen. Zum Sammeldruck können Sie diese dann einzeln auswählen und zusammenführen. Sie können natürlich auch komplette Kataloge und Spezialseiten wie Deckblatt, Zwischenblatt, diverse Register etc. in dem Sammeldruck zusammenführen.

Selektives Drucken eines Kataloges oder eines Sammelkataloges

Selektives Drucken aus einem vorhandenen Katalog (Katalogdaten)

Drucken eines einzelnen Teilbereichs
In der Grundmaske von "Kataloge - Druck und Design" können, zusätzlich zu der Angabe aus welchen Katalogdaten (in Verbindung mit welchem Design) der Katalog zu Drucken ist, mit einer "von-bis Eingabe" die zu druckenden Kataloggruppen ausgewählt werden. Ist zu erwarten, dass diese Selektion zukünftig wiederholt vorkommen wird, sollte diese "Kombination" in die Auswahlliste übernommen werden (Taste "eintragen").

Drucken mehrerer Teilbereiche aus einem Katalog (Katalogdaten)
"Tragen" Sie, wie im vorigen Absatz beschrieben, die zu druckenden Teilbereiche in die Auswahlliste der Grundmaske von " Kataloge - Druck und Design " ein. Kombinieren Sie anschließend diese "Teilkataloge" in der von Ihnen gewünschten Reihenfolge mit der Funktion "Sammeldruck" zu einem zu druckenden "Gesamtwerk" und speichern diese Kombination mit neuem Namen ab. Künftig steht dieser "Sammeldruck" zum sofortigen Druck in der Auswahlliste zu Verfügung.

Filtern einzelner Kataloggruppen
Sind viele kleinere Teilbereiche (Kataloggruppen von-bis) und /oder einzelne Kataloggruppen aus einem Gesamtkatalog in der Reihenfolge des Gesamtkataloges zu drucken, ist die "Filtermethode" zu empfehlen. Dabei werden die gewünschten (oder nicht gewünschten) Kataloggruppen einzeln oder "von-bis" gekennzeichnet und "gefiltert" gedruckt. Soll ein solches "Werk" erhalten bleiben, können die "gefilterten Daten" als neuer Katalog unter neuem Namen gespeichert werden.

Katalogdruck gesteuert über Sonderkonditionen
(optionale Zusatzfunktion, nicht im Basisprogramm enthalten)

Mit Auswahl der Option "Drucke nur Sonderkonditionsartikel" ("Kataloge - Druck und Design " Register "Preisoptionen") werden nur die Artikel gedruckt, die in der Sonderkonditionsdatei für den in Preisoptionen ausgewählten Kunden/Aktion spezifiziert wurden. Es werden dabei nur Artikel- / Artikelgruppen-Konditionen die für Kunden / Kundengruppen hinterlegt wurden, berücksichtigt. Unbeachtet bleiben reine Artikel/Artikelgruppen Konditionen ohne Kundenbezug. Mit dieser Option können auf einfache Art kundenspezifische bzw. zielgruppenorientierte Preislisten aus einem (Haupt-/Gesamt-)Katalog in der Reihenfolge des Gesamtkataloges erzeugt werden. Z.B. werden durch Erfassen einer "Sonderkondition" für den Kunden/Aktion und der entsprechenden Artikelgruppe ohne Preis-/Rabattangabe alle Artikel der angesprochenen Artikelgruppe gedruckt.

1 Die ersten Schritte

1.1 Vorbereitende Überlegungen und Informationen

- Artikel (auch ein einzelner Artikel) werden in Kataloggruppen abgebildet.

- Die Nummer der Kataloggruppe bestimmt die Reihenfolge und somit die Platzierung im Katalog.

- Zu jeder Kataloggruppe können bis zu 5 Abbildungen, zusätzliche Bezeichnungen und erläuternde Texte zugefügt werden.

- Zu jeder Position (der/die Artikel) einer Artikelgruppe können 2 Abbildungen, zusätzliche Bezeichnungen und erläuternde Texte zugefügt werden

Beispiel für eine Kataloggruppe im gedruckten Katalog

- Innerhalb des Kataloges können Zwischenüberschriften mit Bild für Kataloggruppen-Bereiche zugeordnet werden.

- Überlegen Sie wo, wie und in welcher Reihenfolge Ihre Artikel gedruckt werden sollen.

- Sollen es ein- oder zweispaltige Preislisten oder ein Bildkatalog werden?

- (Lesen Sie dazu auch "Begriffe und Darstellungsarten").

Beispiel für eine Kataloggruppe in der Erfassungsmaske der "Arbeitsansicht"

1.2 Begriffe und Darstellungsarten

KL-KatGen bietet die Möglichkeit, Kataloge und Preislisten weitgehendst individuell zu gestalten.
Anhand der nachfolgenden Abbildung, basierend auf dem Katalogdesign "Standard01", sollen die unterschiedlichen Begriffe erläutert werden. Selbstverständlich können Positionierung, Farbe, Größe usw. der einzelnen Elemente, der mit dem Basisprogramm mitgelieferten Musterkataloge, im "Katalog-Designer" auf firmenspezifische Anforderungen hin, individuell angepasst werden.

Weitere Details für zusätzliches, individuelles Gestalten der Kataloge finden Sie im Kapitel "Der Katalog-Designer".

· Katalogdesign "FORMULAR01"

Kataloggruppe Eine Kataloggruppe ist die Zusammenfassung von Katalogartikel, die unter einer Beschreibung, ergänzt mit einem oder mehreren Bildern dargestellt werden sollen (z.B. ein Artikel in verschiedenen Größen oder Farben, ein Set oder ein Produkt mit Zubehör-/Ersatzteilen .

Der Begriff "Kataloggruppe" hat nichts mit Artikelgruppe oder Warengruppe zu tun.

Kopfzeile fix Firmenbezeichnung, Firmen-Logo, Telefon, Fax usw. sind fest im Design zu hinterlegen.

Seiten-Logo z.B. Logo des Lieferanten der aktuellen Seite. Die Zuordnung erfolgt über die Kataloggruppen-Nummer in der Programmfunktion "Überschriften".

Seiten-

Überschriften Bis zu vier Überschriften à 50 Stellen können auf einer Seite im Seitenkopf gedruckt werden. Die Zuordnung erfolgt über die Kataloggruppen-Nummer in der Programmfunktion "Überschriften".

Texte

Seiten-Überschriften Zwei Texte mit bis zu 64.000 Zeichen können auf einer Seite gedruckt werden. Die Zuordnung erfolgt über die Kataloggruppen-Nummer in der Programmfunktion "Überschriften".

Überschriften

aus Vorlauf Direkt vor dem Drucken eines Kataloges kann zusätzlich ein individueller Text mit bis zu 50 Zeichen erfasst werden, welcher in der Kopfzeile angedruckt wird (z.B. "Preisliste gültig ab 01.07.2012").

Zwischen –

Überschriften Bis zu vier Überschriften à 60 Stellen können vor einzelnen Kataloggruppen gedruckt werden. Die Zuordnung erfolgt über die Kataloggruppen-Nummer in der Programmfunktion "Überschriften".

Texte Zwischen-

Überschriften Zwei Texte mit bis zu 64.000 Zeichen können vor einzelnen Kataloggruppen gedruckt werden. Die Zuordnung erfolgt über die Kataloggruppen-Nummer in der Programmfunktion "Überschriften".

Zwischen-

Überschriften Logo Jede Zwischenüberschrift kann mit einer Abbildung (z. B. Logo des Lieferanten ) ergänzt werden. Die Zuordnung erfolgt über die Kataloggruppen-Nummer in der Programmfunktion "Überschriften".

Katalog-Gruppen-

Bezeichnung (1 + 2) Die für die entsprechenden Kataloggruppen hinterlegten Bezeichnungen (1 + 2, je 50 Stellen).

Katalog-Gruppen-

Abbildung Die für die entsprechenden Kataloggruppen zugeordnete Abbildung.

Katalog-Gruppen-

Nummer Nummer der Kataloggruppe (alphanumerisch, bestimmt die Reihenfolge im Katalog).

Text Katalog-

Gruppen- Zusatzbeschreibung der entsprechenden Kataloggruppen (bis 64.000 Zeichen).

Katalog-Gruppen-

Positionen / Artikel Die einer Kataloggruppe zugeordneten Artikel.

Katalog-Gruppen-

Positionen Zusatztext Den einzelnen Positionen einer Kataloggruppe können bis zu 64.000 Zeichen zusätzlicher Text zugeordnet werden.

Zusatz-Grafik Beliebige Grafik, die für einzelne Kataloggruppen aktiviert werden kann.

Fußzeilen Seite Fest im Katalog-Designer zu hinterlegender Text (z.B. "Es gelten unsere allgemeinen Geschäftsbedingungen").

So haben die bereits mit der Basis-Lösung mitgelieferten Beispiele unterschiedliche Schwerpunkte. Es können mit dem Design "FORMULAR01" (siehe Abbildung zuvor) Bilder, erläuternde Texte, Zwischenüberschriften usw. gedruckt werden. Die Designs "FORMLAR02" und "FORMULAR03" hingegen sind für einfachere Drucke vorgesehen (hier Preislisten ein- und zweispaltig mit Zwischenüberschriften).

1.3 Schritt für Schritt zum ersten Katalog

1. Programmstart

Nach Programmaufruf erscheint das Startfenster

KL-KatGen unterscheidet zwischen zwei Arbeitsmodi:

Anwender-/Normalmodus, dieser Modus ist für den "Normal-Anwender" gedacht. Es stehen nicht alle Programmfunktionen zur Verfügung.

VIP-Modus, in diesem Modus stehen alle Programmfunktionen zur Verfügung (erweitertes Menü).

In welchem Modus der Nutzer arbeiten darf, wird über die Zugangsberechtigung beim Programmstart gesteuert. (Details dazu finden Sie im Menü Programmverwaltung à "Passcode Verwaltung").

Im Demo-/Auslieferungszustand gelangen Sie im VIP-Modus in das Programm, indem Sie in den Eingabefeldern die Ihnen zugewiesenen Zugangsdaten verwenden.

Nach Eingabe des "User-Namens" und des "Passcodes" gelangt man in die Arbeitsansicht.

2. Anlegen eines neuen, leeren Kataloges
Legen Sie einen neuen, leeren Katalog an. (Details dazu unter "Anlegen eines neuen Kataloges").

3. Bereitstellen von Zusatzdaten

Bilddateien:
Kopieren Sie die zu verwendenden Bilddateien (Format BMP, JPG, GIF) in das voreingestellte Verzeichnis "IMAGES1" bzw. weisen Sie das Verzeichnis zu, in dem sich Ihre Bilddateien befinden (siehe Kapitel " Pfad Bilddateien").

Artikeldaten: Verfügt Ihr Warenwirtschaftssystem über geeignete Schnittstellen zum Exportieren der Artikeldaten, so können Sie diese Daten bereits beim Erstellen der Kataloge nutzen und sich so einen wesentlichen Teil der Erfassungsarbeiten ersparen. (Details dazu unter "Der Datenimport")

4. Erfassen der Kataloggruppen

Erfassen Sie die einzelnen Kataloggruppen mit den entsprechenden Artikelpositionen. (Details dazu unter "Anlegen der Kataloggruppen"). Je nach Anforderung können Artikel auch mit "Direktimport" in die Kataloge übernommen werden. (Details dazu finden Sie unter " Der Datenimport" und "Zwei Wege zum eigenen Katalog").

5. Hinzufügen von Überschriften

Definieren Sie gegebenenfalls anschließend, ab welcher Kataloggruppe Seitenüberschriften, Zwischenüberschriften, die entsprechenden "Zusatztexte" und "Logos“ zu den Überschriften im Katalog erscheinen sollen. Lesen Sie dazu "Begriffe und Darstellungsarten". Details für das Erfassen, Verwalten und Zuordnen von Überschriften finden Sie unter "Verwalten Seiten- und Zwischenüberschriften".
6. Drucken des Kataloges

Durch Klicken auf die Schaltfläche "Katalog Drucken" gelangen Sie in die Maske "Katalog – Druck und Design".

Hier können sie mittels Klick auf "Anzeige" bzw. "Druck" den aktuellen Katalog am Bildschirm ansehen bzw. auf einen Drucker ausgeben.

Zu beachten ist, dass bei der Demoversion die Funktion "Drucken" nicht erlaubt ist.

Sollen verschiedene Kataloge oder Teilkataloge zu einem Katalog beim Drucken zusammenführt werden, lässt sich dies in den Druckoptionen ebenso bestimmen, wie die Möglichkeit die Katalogpositionen vor dem Druck mit den Daten der Artikeldatei zu aktualisieren. Auch kann hier festgelegt werden, ob ein Deckblatt, ein Inhaltsverzeichnis und ein Rückblatt gedruckt werden soll.

7. Anpassen des Designs (Druckbild des Kataloges)

Sollte keines der implementierten Designs mit Ihren Vorstellungen übereinstimmen, so können sie nun eines der Musterdesigns (eines das Ihren Vorstellungen am nächsten kommt), auf Ihre spezifischen Belange hin anpassen.
Ersetzen Sie Firmenname, Firmenlogo und ergänzen Sie gegebenenfalls das Design noch im Kopf- und Fußbereich mit Daten wie Telefonnummer, Hinweis auf AGB´s usw.
Selbstverständlich können Sie auch ein komplett neues Design erstellen.

Weitere Details dazu finden Sie hierzu unter "Der Katalog-Designer".

Da ein Katalog in der Regel nicht nur aus dem (Artikel-/) Datenbereich besteht, sondern eventuell auch ein Deckblatt, ein Inhaltsverzeichnis, ein Vorwort, ein Inhaltsregister, Zwischenblätter, AGB´s und eventuell auch ein Bestellformular enthalten soll, können Sie solche "Bausteine" mit dem Katalog-Designer individuell gestalten und mit der Funktion "Sammeldruck" einen "Komplett-Katalog" ausdrucken.

1.4 Die Wege zu Ihrem Katalog

Die Abbildung zuvor zeigt die verschiedenen Wege zur Erzeugung der für den Katalogdruck notwendigen Daten:

- Manuelle Eingabe der Katalogdaten (blaue Linie rechts).

- Manuelles Erfassen mit Auswahl und Übernahme der KL-KatGen eigenen Artikelstammdaten. Die Artikel Daten wurden zuvor manuell erfasst (blaue Linie links) bzw. mit der Datenimportfunktion automatisiert in die Artikeldatei übernommen (grüne Linie) .

- Automatische Katalogerstellung aus einem externen Datenbestand (grüne Linien) oder aus den der KL-KatGen eigenen Artikelstammdaten (orange Linien).

- Nach Erstellung der Katalogdaten können zukünftig, direkt beim Drucken der Kataloge, die Preise mit den Werten der Artikeldatei aktualisiert werden.

2 Der Katalogdaten-Manager

Wie bereits aufgezeigt, verfügt KL-KatGen über zwei leistungsstarke Grundfunktionen, den "Katalogdaten-Manager" und den "Katalog-Designer".

Mit dem Katalogdaten-Manager (die eigentliche Arbeitsansicht) bestimmen Sie, welche Artikel und Leistungen, in welcher Form im Katalog erscheinen sollen. Sie ordnen die Reihenfolge der Artikel, legen fest welche Artikel eventuell zu Kataloggruppen zusammengefasst werden, generieren automatisch Kataloge und Preislisten aus Ihrem Warenwirtschaftssystem oder aus den Daten Ihrer Lieferanten und ergänzen diese mit Bildern und zusätzlichen Texten. Die so erfassten Daten können zukünftig in wenigen Minuten mit den Preisen aus Ihrem Warenwirtschaftssystem aktualisiert werden.

Das endgültige Design, Farbe, Buchstabengröße, Platzierung von Bildern usw. definieren Sie im "Katalog-Designer". Sie können beliebig viele Designs erstellen und im System verwalten. Beim Drucken bestimmen Sie mit welchem Design der Ausdruck erfolgen soll. Sowohl der schöne Bildkatalog mit detailliertem Text als auch die einfache Preisliste mit Artikelnummer, Bezeichnung und Preis lassen sich so unmittelbar aus dem gleichen Datenbestand drucken.

2.1 Zwei Wege zum eigenen Katalog

2.1.1 Automatische Katalogerstellung

Unter der Voraussetzung, dass Artikeldaten (z.B. aus einem Warenwirtschaftssystem) in der für den zu erstellenden Katalog gewünschten Sortierfolge vorliegen, kann KL-KatGen weitgehendst automatisiert eine Preisliste bzw. einen Katalog ohne größere Vorarbeiten erzeugen.

Aus den aus Ihrem Warenwirtschaftssystem exportierten Artikelinformationen, aus den Daten Ihres Lieferanten oder aus MS-Excel usw. (z.B. Artikelnummer, Bezeichnung, Preise, Bildname) werden automatisiert die für den Katalog-Druck notwendigen Daten erzeugt.

Die Reihenfolge der Artikel im Katalog wird dabei durch die "Export-Reihenfolge" der Artikeldaten aus dem Warenwirtschaftssystem bestimmt.

Details hierzu finden Sie unter "Der Datenimport".

2.1.2 Manuelle Katalogerstellung

Wünschen Sie jedoch einen individuell gestalteten Aufbau des Kataloges (Druckreihenfolge, Zusammenfassung bestimmter Artikel, Hinzufügen von Abbildungen usw.) sind gewisse Vorarbeiten unumgänglich. KL-KatGen unterstützt Sie bei diesen Arbeiten.

In der Regel liegen verfügbare Artikeldaten nicht in der für einen Katalog gewünschten Sortierfolge vor.

Das heißt, die Festlegung der Druckreihenfolge und das Zusammenfassen von Artikeln zu einzelnen Kataloggruppen (z.B. gleicher Artikel in unterschiedlichen Größen oder Farben (materialwirtschaftlich können diese unter unterschiedlichen Artikelnummern gespeichert sein)) ist manuell durchzuführen.

- Überlegen Sie, wo, wie und in welcher Reihenfolge Ihre Artikel gedruckt werden sollen.

- Artikel (auch ein einzelner Artikel) werden in Kataloggruppen abgebildet.

- Legen Sie die gewünschten Kataloggruppen an, wobei die Kataloggruppen-Nummer die Reihenfolge und somit die Platzierung im Katalog bestimmt.

- Zu jeder Kataloggruppe können bis zu 5 Abbildungen, Bezeichnung, erläuternder Text und ein entsprechender Eintrag für das Index-Register hinzugefügt werden.

- Die aus Ihrem Warenwirtschaftssystem nach KL-KatGen übernommenen Artikelinformationen (z.B. Artikelnummer, Bezeichnung, Preise (aus Datenimport der exportierten Daten)) können angezeigt und durch "Anklicken" einer Katalog-Gruppe zugeordnet werden.

- Zukünftig können Preisänderungen nach automatisiertem Artikeldatenimport automatisch in die entsprechenden Katalogpositionen übernommen werden.

· D.h., zukünftig steht ein aktualisierter Katalog in Minuten zur Verfügung.

Weitere Details dazu finden Sie im Kapitel "Der Katalogdaten-Manager".

2.2 Die Arbeitsansicht (der Katalogdaten-Manager)

Nach dem Programmstart und der Eingabe des entsprechenden Passcodes gelangen Sie in die Arbeitsansicht (den Katalog-Datenmanager).

Je nach Berechtigung, erhalten Sie das vollständige (einschl. Menügruppe Programmverwaltung) oder das eingeschränkte Menü (ohne Menügruppe Programmverwaltung) zur Auswahl (siehe Passcodeverwaltung).

Die Arbeitsansicht gliedert sich im Wesentlichen in 5 Bereiche (siehe dazu "Begriffe und Darstellungsarten"):

- Menü-Bereich (1) Haupt-Menü und "erweitertes Menü"

- Kopf-Bereich (2) Daten, Abbildung, Texte und Darstellungsart der Kataloggruppen

- Funktions-Tasten (3) Über die Funktionstasten haben Sie die für die Preislisten- / Katalogerstellung wesentlichen Funktionen im direkten Zugriff.

- Positions-Bereich (4) Zuordnung der Artikel-Nummer(n), -Text(e), -Preis(e) zu den Kataloggruppen

- Navigations-Tasten (5) Verwaltungs-/Navigationstasten für Kataloggruppen und Katalogpositionen

Mit der "Zoom-Taste" und der "Zoom-Regelung" können Sie die Größe der Darstellung entsprechend dem Bildschirm anpassen.

2.2.1 Kataloggruppen-Zusätze

Weitere Steuerungen und Ergänzungen zu den Kataloggruppen sind über den Button "Zusätze“ der Hauptmaske aktivierbar. Es erscheint die unten abgebildete Maske.

Hier können Sie je Kataloggruppe weitere Texte (T1 bis T6), Texte für zwei Preiseinheiten, Inhalte für drei Steuerfelder sowie die Kategoriezugehörigkeit (vgl. Kapitel "Kategorienermittlung" bzw. "Kategorien-Verwaltung") der aktuellen Kataloggruppe erfassen.

Mit Klick auf den Button "Kopieren" wird der gesamte Maskeninhalt gemerkt, durch Klick auf den Button "Einfügen" wird der zuletzt gemerkte Maskeninhalt in die aktuelle Maske eingefügt.

Mit Klick auf den Button "leeren" wird der gesamte Maskeninhalt geleert.

Mit Klick auf den Button "Neu" wird eine neue Kataloggruppe angelegt.

Mit Klick auf den Button "Beenden" wird die Maske "Kataloggruppen-Zusätze" verlassen.

2.2.2 Kataloggruppen-Zusatzdaten / Artikel-Zusatzdaten

Weitere Texte können nach Aufruf im Fenster Kataloggruppen-Zusatzdaten manuell erfasst und verwaltet werden.

Werden Positionsdaten aus der Artikeldatei übernommen, werden bei Erfassung der jeweils ersten Position einer Kataloggruppe, der in der Artikeldatei hinterlegte Text automatisiert in den Kataloggruppenzusatztext übertragen.

(Wegen der Gefahr eines ungewollten "Überschreibens der Daten", siehe dazu auch " Datenaktualisierung beim Datenimport / Katalogerstellung".)

Diese Texte können sowohl, zeilenweise (linke Abbildung) oder als ein editierbares Textfenster (rechte Abbildung) genutzt werden.

Sie können durch Klicken auf den L-Button im unteren rechten Maskenbereich zwischen diesen beiden Modi umschalten. Die Grundeinstellung erfolgt im Key "fazusatzkz" durch Eintragen der Ziffer 1 im Feld "Text1" an der dritten Stelle.

Mit Klick auf den Button "Kopieren" wird der gesamte Maskeninhalt gemerkt, durch Klick auf den Button "Einfügen" wird der zuletzt gemerkte Maskeninhalt in die aktuelle Maske eingefügt.

Mit Klick auf den Button "leeren" wird der gesamte Maskeninhalt geleert.

Mit Klick auf den Button "Neu" wird eine neue Kataloggruppe angelegt.

Mit Klick auf den Button "Beenden" wird die Maske "Kataloggruppen-Zusätze" verlassen.

Über den "L-Button" können die Bezeichnungen der jeweiligen Zeilen hinterlegt werden.

2.3 Der schnelle Einstieg: In Minuten zum eigenen Katalog

Erstellen Sie unter Verwendung unserer Standarddesigns in wenigen Minuten Ihren ersten eigenen Katalog.

2.3.1 Katalogerstellung ohne Verwendung von Artikelstammdaten

1. Starten Sie KL-KatGen

2. Legen Sie einen neuen, leeren Katalog an

Um einen neuen Katalog zu erstellen, wählen Sie im Hauptmenü, unter "Kataloge und Daten verwalten" den Menüpunkt "Katalog neu".

Vergeben Sie einen beliebigen, neuen Namen für den zu erstellenden Katalog, z.B. "PREISE0708".
Die zwingend notwendige Endung ".PRL" wird vom Programm automatisch angefügt.
Drücken Sie anschließend die Taste "Erstellen". Das Programm legt nun einen "leeren Katalog" an und erwartet die Eingabe der ersten Kataloggruppen-Nummer.

3. Erfassen der Kataloggruppen

Eine Kataloggruppe ist die Position im Katalog, in der ein oder mehrere Artikel erscheinen sollen. Für jede Kataloggruppe können Sie bis zu 5 Bilder, zwei Überschriften und eine entsprechende Beschreibung mit bis zu 64.000 Zeichen erfassen und die gewünschten Artikel zuordnen. Darüber hinaus haben Sie die Möglichkeit ein Stichwort für das Index-Register im Feld "Register" der Kataloggruppe zuzuordnen. Bleibt dieses Feld leer, wird automatisch die Bezeichnung der ersten Kataloggruppenposition übernommen. Zusätzliche Registereinträge können in der Spalte Register den Katalogpositionen und in einem Zusatzfenster "Erweitertes Register Kataloggruppe" (Z-Taste) der Kataloggruppe zugeordnet werden.

Die Reihenfolge (d.h. die Position) im Katalog wird durch die Kataloggruppen-Nummer bestimmt.
Die Kataloggruppen-Nummer ist alphanumerisch, d.h. Sie können auch Buchstaben verwenden.
Beachten Sie, dass bei einer alphanumerischen Sortierfolge der Vergleich von links nach rechts erfolgt (z.B. "100" ist kleiner "20" jedoch "020" ist kleiner "100". Die Kataloggruppen-Nummer kann später problemlos geändert werden.

Ordnen Sie nun eines oder mehrere Bilder der Kataloggruppe zu und ergänzen Sie Bezeichnung und Beschreibung nach Bedarf. Standardmäßig erwartet KL-KatGen hinzuzufügende Abbildungen (BMP, JPG) im Verzeichnis "x:\KL-KatGen8\Images1". Befinden sich diese in einem anderen Verzeichnis, so ist der entsprechende Pfadname in der "Programmverwaltung" im Menüpunkt "Pfad Bilddateien“ zu hinterlegen.

Bestimmen Sie, ob die Kataloggruppe von einer automatischen Preiskorrektur ausgeschlossen wird und wie die Darstellung der Kataloggruppe im Katalog sein soll (siehe Darstellungsarten).
Nach Eingabe der Kataloggruppen-Nummer und Drücken der Entertaste verlangt das System die Eingabe der Artikelnummer im Positionsbereich.

4. Eingabe der Artikeldaten / Katalogpositionen

Erfassen Sie nun die gewünschten Artikeldaten.

Artikelnummer
Beim Verlassen des Feldes "Artikelnummer" prüft das Programm, ob dieser Artikel in der Artikeldatei verfügbar ist und bringt gegebenenfalls eine Fehlermeldung. Für die aktuelle Sitzung können Sie diese Verfügbarkeitsprüfung ausschalten.

"Artikelbezeichnung im Katalog"
Diese Eingabe wird automatisch in die Kataloggruppen-Bezeichnung und in das Feld Register der Kataloggruppe und der Katalogposition (soweit diese noch "leer" sind) übernommen.

"Preis 1", "Preis 2" und gegebenenfalls Artikelzusatztext usw.
Artikel können von einer automatischen Preiskorrektur ausgeschlossen werden (Häkchen im Feld "Sperre S"). Sollen noch weitere Artikel dieser Kataloggruppe zugeordnet werden, drücken Sie die Taste "Neue-Position" oder gehen Sie mit der ê (Pfeil-Taste) in die nächste Positionszeile.

Die Erfassungsfelder der Katalogpositionen (Spalten) können entsprechend den Anforderungen in die gewünschte Reihenfolge gebracht und mit der gewünschten Überschrift benannt werden (Details dazu finden Sie unter "Verwalten Spalten-Anzeige" im Menü "Programmverwaltung").

5. Erfassen Sie weitere Kataloggruppen mit den entsprechenden Artikeldaten.

6. Seiten und Zwischenüberschriften.

Je nach Bedarf können Sie den Katalog mit Überschriften, Bildern, Zusatztexten für Seiten- oder Zwischenüberschriften ergänzen.

7. Katalog drucken

Sie können nun den fertigen Katalog drucken (Schaltfläche "Katalog Drucken"). Es empfiehlt sich jedoch zuvor in der "Druckansicht" das Ergebnis zu prüfen und gegebenenfalls entsprechende Korrekturen vorzunehmen (Seitenwechsel, Zeilenvorschub usw.).

2.3.2 Schneller geht es mit HOT-KEYs

Unter Verwendung der in der Applikation implementierten HOT-KEYs können Sie weitaus schneller, ohne Einsatz der "Maus", die zuvor beschriebenen Aktionen durchführen.

Nachfolgend haben wir die relevanten HOT-KEYs in der möglichen Ablauf-Folge aufgeführt. Mit dem HOT-KEY
"ALT + N" kann von beliebiger Stelle nach Punkt 1 zum Anlegen einer neuen Kataloggruppe zurück gesprungen werden. Zum besseren Verständnis empfehlen wir diesen Ablauf der Reihe nach einmal durchzuspielen.

Eingabe-Feld

Taste:

Funktion

1.

beliebig

ALT + N

Eine neue Kataloggruppe wird angelegt

2.

Einstellbar evtl. auch direkt nach Pkt. 3

Eingabe der Kataloggruppen-Nummer

ENTER

springt auf Artikel-Position

3.

Eingabe der Artikel-Nummer

ENTER

Prüft, ob Artikel vorhanden

4.

4a.

4b

Eingabe der Positions-/Artikeldaten

beliebig

beliebig

ENTER oder TAB

ALT + P

ALT + Ö

durchläuft die Felder der Pos.-Zeile

weitere Artikel-Position

löscht die markierte Artikel-Position

5.

5a.

5b.

5c.

beliebig

Bild-Auswahl / Dateiname

Bild-Auswahl

oder Bilddatei Name erfassen

ALT + S

Shift+TAB

Cursor-Tasten

ENTER

öffnet Bild-Auswahl

springt in die Auswahl " Bild-Datei“

Auswahl des gewünschten Bildes

übernimmt Bild /springt auf Schaltfläche "Suchen“

6.

Suchen-Taste (Bild)

Shift-TAB

springt auf Bild-Name

7.

Bild-Name

Shift-TAB

springt auf Zusatz-Text

8.

Zusatz-Text

Shift-TAB

springt auf Kataloggruppen-Bezeichnung

9.

Suchen-Taste (Bild)

TAB

springt auf Preis-Einheit 1

10.

Preis-Einheit 1

TAB

springt auf Preis-Einheit 2

11.

Preis-Einheit 2

TAB

springt auf Steuerung

12.

Steuerung

TAB

springt kein Preis-Update

13.

kein Preis-Update

TAB

springt auf das jeweils nächste Feld

(TAB / Shift-TAB springt vor- / rückwärts)

2.4 Katalogerstellung

2.4.1 Anlegen eines neuen Kataloges

Unter dem Menüpunkt "Katalogdaten verwalten" im Hauptmenü, sind die wesentlichen Programmfunktionen für das Verwalten der Kataloge zusammengefasst.

Wählen Sie den Menüpunkt "Katalogdaten Neu". Es öffnet sich das Standard-Auswahl / -Eingabe Fenster. Das Programm erwartet die Eingabe eines frei wählbaren Katalog-(Datei)-Namens, die Endung ".prl" wird vom Programm automatisch angefügt. Nach Bestätigung mit der Taste "Erstellen" wird ein neuer, leerer Katalog angelegt.

2.4.2 Anlegen der Kataloggruppen

Wie aufgezeigt, werden Artikel (auch ein einzelner Artikel) in Kataloggruppen als Kataloggruppenpositionen abgebildet.

Eine Kataloggruppe ist somit die "Zusammenfassung" von Katalogartikel (auch ein einzelner Artikel), die unter einer Beschreibung, ergänzt mit einem oder mehreren Bildern dargestellt werden sollen (z.B. ein Artikel in verschiedenen Größen oder Farben, ein Set oder ein Produkt mit Zubehör-/Ersatzteilen .

Eine Kataloggruppe ist keine Artikelgruppe und keine Warengruppe.

Die Nummer der Kataloggruppe bestimmt dabei die Reihenfolge und somit die Platzierung im Katalog. Beachten Sie, die Sortierfolge ist alphanumerisch, d.h. der Vergleich erfolgt von links nach rechts, so erscheint z.B. "100" vor "20".

KL-KatGen bietet die Möglichkeit Kataloggruppen automatisiert oder manuell anzulegen.

2.4.2.1 Automatische Katalog-Erstellung (Direkt-Import von Artikeldaten)

Unter der Voraussetzung, dass Artikeldaten (z.B. aus einem Warenwirtschaftssystem) in der für den zu erstellenden Katalog gewünschten Sortierfolge vorliegen, kann KL-KatGen weitgehendst automatisiert eine Preisliste bzw. einen Katalog ohne größere Vorarbeiten erzeugen.

Folgende vorbereitende Maßnahmen sind durchzuführen:

1. Die aus dem Warenwirtschaftssystem zu importierenden Artikeldaten sind als CSV-Datei bereitzustellen (z.B. Artikelnummer, Bezeichnung, Preis usw.).

2. Die Importschnittstelle von KL-KatGen ist entsprechend dieser CSV-Datei anzupassen.
Details unter "Der Datenimport".

3. Beim Datenimport besteht die Möglichkeit automatisiert direkt aus einer externen Schnittstellendatei (CSV-Datei) einen Katalog zu erstellen. Alternativ (auch gleichzeitig) können die CSV-Daten in die KL-Katgen eigene Artikeldatei importiert werden, um daraus (eventuell nach Korrektur/Ergänzung) den Katalog zu erzeugen. Weiterführende Details und Bedienungshinweise finden Sie im Kapitel "Der Datenimport" ausführlich beschrieben.
Nach Start des Datenimports mit "automatischer Katalogerstellung" erstellt KL-KatGen automatisiert Kataloggruppen und übernimmt die Artikeldaten in die entsprechenden Kataloggruppenpositionen.

4. Mit der Schaltfläche "Katalog Drucken" wird das Fenster " Kataloge - Druck und Design " angewählt. Nach Eingabe der gewünschten Parameter kann der Katalogdruck erfolgen. Wahlweise können dabei auch zuvor die Preise aus der Artikeldatei in die Katalogdaten übernommen werden oder diese lediglich anstelle der in den Katalogpositionen hinterlegten Preise angedruckt werden. Bei Anwahl der automatischen Preisaktualisierung können einzelne Kataloggruppen bzw. Kataloggruppenpositionen gesperrt werden. Weitere Details und Steuerungsmöglichkeiten finden Sie unter "Der Datenimport".

2.4.2.2 Manuelles Anlegen der Kataloggruppen

Wie aufgezeigt, werden Artikel (auch ein einzelner Artikel) in Kataloggruppen abgebildet. Die Nummer der Kataloggruppe bestimmt dabei die Reihenfolge und somit die Platzierung im Katalog. Beachten Sie, die Sortierfolge ist alphanumerisch, d.h. der Vergleich erfolgt von links nach rechts, so erscheint z.B. "100" vor "20".

Zum Anlegen einer neuen Kataloggruppe drücken Sie die Taste "Neu".
Das Programm legt einen neuen, leeren Kataloggruppen-Datensatz an.

Je nach Anforderung können die nachfolgenden Programmablaufalternativen in der Programmverwaltung (siehe Menüpunkt "Verwalten Steuerung Kataloggruppen-Nummern" im Menü "Programmverwaltung") hinterlegt werden:

1. Der Cursor springt in das "Key-Feld".
Das Programm erwartet nun die Eingabe einer neuen Kataloggruppen-Nummer bzw. bei automatischer Nummervergabe kann die vom System vorgegebene Nummer modifiziert/ergänzt werden.

2. Das Programm legt automatisch den ersten (leeren) Positionssatz der Kataloggruppe an, positioniert den Cursor in das Eingabefeld "Artikelnummer" der Positionszeile und erwartet die Eingabe einer Artikelnummer (siehe oben "Katalogerstellung ohne Verwendung von Artikelstammdaten

3. Das Programm ermöglicht nun die Erfassung weiterer artikelspezifischer Positionsdaten wie Bezeichnung, Preise, erläuternder Text usw.

Die Kataloggruppen-Nummer kann bis zu 12 Stellen und sowohl Zahlen als auch Buchstaben beinhalten.

Erfassen Sie anschließend die entsprechenden Kopfdaten (Bezeichnung, Zusatztext, Preiseinheit), ordnen Sie ggf. eine oder mehrere Abbildungen zu, bestimmen Sie die Darstellungsart und legen Sie fest, ob diese Kataloggruppe zwingend auf einer neue Seite beginnen soll und wie viel Zeilenabstand eventuell zusätzlich zur nächsten Kataloggruppe sein soll.

2.4.3 Darstellungsarten

Mit dem in KL-KatGen integrierten Katalog-Designer können die Ausdrucke (Designs) individuell angepasst werden. Sowohl einfache Preislisten, als auch aufwendige Bildkataloge ergänzt mit Seiten-, Zwischenüberschriften, Firmenlogo usw. lassen sich damit problemlos erstellen. Verschiedene Musterberichte werden bereits mit der Basisversion mitgeliefert.

Im Normalfall wird bei KL-KatGen das Design nicht seitenweise sondern je Kataloggruppe definiert Damit ist die Möglichkeit gegeben, aus einem externen Datenbestand (z.B. Excel, Warenwirtschaftsprogramm, Online-Shopsystem usw.) automatisch Kataloge mit produktspezifischer Darstellung zu erstellen. Eine Kataloggruppe besteht in der Regel aus einem Bild* (auch mehrere Bilder), der Produktbezeichnung und einem oder mehreren Artikeln (meist Varianten des Produktes, z.B. unterschiedliche Größen). Somit können auf einer Katalogseite automatisiert unterschiedliche Darstellungen (für jede Kataloggruppe) erzeugt werden.

* Der Begriff 'Bild' ist nur zur besseren Erläuterung, gemeint ist nicht zwingend ein Bild sondern der für die gesamte Kataloggruppe gültige Teil (Kopf, Überschrift).

Bei den nachfolgend beschriebenen Darstellungsarten handelt es sich um Darstellungsmöglichkeiten der einzelnen Kataloggruppen des Artikel-/Datenbereichs innerhalb eines Kataloges. Da ein Katalog in der Regel nicht nur aus dem reinen Artikel-/Datenbereich besteht, sondern auch Deckblatt, Inhaltsverzeichnis diverse Zwischenblätter usw. enthalten kann, bietet KL-KatGen die Möglichkeit auch solche Seiten individuell zu gestalten und mit der Funktion "Sammeldruck" in einem "Komplett-Katalog" zu drucken. Details dazu finden Sie unter Punkt 4 ff "Designverwaltung" und "Sammeldruck".

Aber nicht nur diese artikelübergreifenden Elemente können im Design modifiziert werden, auch die Darstellung einzelner Kataloggruppen lässt sich individuell über die Darstellungsarten gestalten. Darstellungsarten sind frei wählbare 4-stellige Kennzeichnungen einzelner Kataloggruppen, die den Druck im Katalog steuern.

Aufgrund der Zielsetzung von KL-KatGen, Kataloge weitgehendst automatisiert ohne größere Nachbearbeitung zu erstellen und dennoch dabei einzelne Artikel ihren individuellen Merkmalen entsprechend zu präsentieren, können die Kataloggruppen und Artikel unterschiedlich dargestellt werden. Die Steuerung dafür erfolgt durch Zuweisung einer Darstellungsart in der einzelnen Kataloggruppe und weiteren Kennzeichnungen (in Kataloggruppe und Positionen) die beim Druck (Designer) abgefragt werden können.

Um Kataloge vollautomatisch erstellen und pflegen zu können und dabei trotzdem weitgehend freie Gestaltungsmöglichkeiten zu haben, wird in der Regel der Katalog nicht seitenweise "designt" sondern die unterschiedlichen Darstellungsanforderungen werden je Kataloggruppe definiert. Somit besteht unter Anderem auch bereits beim Datenimport die Möglichkeit die entsprechenden Informationen mitzugeben die bei der Kataloggenerierung und im Designer berücksichtigt werden.

Grundsätzlich sind die Darstellungsarten der Kataloggruppen mit Ausnahme der unter "Vordefinierte Darstellungsarten" aufgeführten frei definierbar (siehe folgende Seiten), d.h. Sie können einen vier-stelligen "Code" festlegen, den Sie im Designer in den einzelnen Objekten (den Feldern die Sie drucken wollen) in den Druckbedingungen ("drucken wenn") abfragen können.

Erfordern die Artikel (Kataloggruppen) Ihres Kataloges unterschiedliche Darstellung (Spalten, Mengen-, Preisangaben) sollten Sie sich, um unnötig komplexe Designs zu vermeiden, bereits im Vorfeld Gedanken machen in wie weit diese zu vereinheitlichen sind.

ACHTUNG: In den mitgelieferten Beispielen werden nur die Objekte angedruckt, bei denen in den Druckbedingungen, in dem jeweiligen Design, eine entsprechende übereinstimmende Darstellungsart definiert wurde.

z.B. Der Zusatztext der Kataloggruppe "Katgruppe.zustext" wird nur dann in diesem Design (Report) gedruckt, wenn die Darstellungsart der Kataloggruppe (Kurzform der Variablen = "drv") übereinstimmt mit der Darstellungsart, die in dem zu druckenden Objekt (Platzhalter für das zu druckende Feld (hier "Zustext") für diesen Report vorgesehen ist (hier in der Variablen "vergl_drv1" hinterlegt (z.B. = "08S6" d.h. 8 Positionsspalten (Matrix) wobei bereits 6 Zeilen für diese Positionsdarstellung neben dem Bild vorgesehen sind).

Im Berichtsdesigner ist das Drucken der entsprechenden Objekte (Bilder, Text usw.) in Abhängigkeit dieser Darstellungsarten zu steuern. Das heißt, das zu druckende Objekt wird nur dann (überhaupt bzw. an dieser Stelle) gedruckt, wenn die Darstellungsart des Objektes mit der Darstellungsart der Kataloggruppe übereinstimmt. Um dies zu erreichen ist im Berichtsdesigner in den Druckoptionen des Objektes zu hinterlegen, unter welchen Voraussetzung (hier bei Übereinstimmung der Darstellungsart) dies gedruckt werden soll (weitere Details dazu finden Sie auf der nächsten Seite bzw. im Kapitel "Der Katalog-Designer").

Kataloge mit Kataloggruppen in unterschiedlichen Darstellungsarten

Unterschiedliche Produkte benötigen unterschiedliche Darstellung im Katalog. Auch sollen gerade und ungerade (rechte und linke) Katalogseiten eventuell anders dargestellt werden (z.B. Bild immer außen).

Zum Beispiel Im Katalog sollen die zu einer Kataloggruppe gehörenden Artikel aufgrund des erhöhten Informationsbedarfs je Artikel, unterhalb des Bildes erscheinen (z.B. Darstellungsart "xxxx".

Für andere Artikel hingegen reicht die Darstellung in einer Matrix, wobei die Positionszeilen sogar bereits neben und unterhalb dem Bild stehen können (z.B. hier Darstellungsart "08S6" (8 Artikel horizontal, 6 Positionen neben dem Bild).

Um dies realisieren zu können, werden, wie zuvor beschrieben, die für eine Darstellungsart zu druckenden Objekte abhängig von der 'Darstellungsart' der jeweiligen Kataloggruppe gedruckt.

Diese Felder/Objekte sind im Designer definiert zu hinterlegen.
Die Felder/Objekte der 'anders" darzustellenden Kataloggruppe sind entsprechend zu behandeln und ebenfalls im Designer zu hinterlegen. Sollen diese an gleicher Stelle (Zeile) gedruckt werden, sind die Felder der "zweiten Kataloggruppe" über die der "ersten" zu platzieren. Weitere Darstellungsarten werden in gleicher Weise behandelt.

Das heißt, es ist für jede im Katalog vorkommende Darstellungsart eine "Ebene" zu erstellen und diese werden im Designer übereinander gelegt. Sollen auch rechte und linke Katalogseiten unterschiedlich dargestellt werden, sind dafür weitere "Ebenen" zu erstellen, die dann, abhängig von der Platzierung auf einer geraden bzw. ungeraden Seite angesprochen werden, Dazu ist die Funktion 'gerade()' bzw. 'ungerade()' in den Druckbedingungen (gegebenenfalls zusätzlich zu der Darstellungsart-Abfrage zu hinterlegen.

Nur drucken wenn: "Katgruppe.darstellungsart= '08S0' and gerade()"
oder Kurzform "drv =' 08S0' and gerade()"

oder mit Vergleichvariable "drv =vergl_drv1 and gerade()" (siehe dazu Vergleichsvariable)

Um dabei den Überblick nicht zu verlieren, empfehlen wir, für jede Darstellungsart, die zu druckenden Objekte stets alle separat (d.h. für jede Darstellungsart alle Felder extra) zu definieren und zu gruppieren, damit diese "als eine Einheit" problemlos übereinander gelegt werden können.
(Menüpunkt im Berichtsdesigner ' Format' -> 'Gruppieren') .
Die gruppierten Objekte einer einzelnen Darstellungsart können so einfach ausgewählt, 'entgruppiert' und erneut bearbeitet werden. Nach erneutem Gruppieren sind diese wieder zu platzieren

Grundsätzlich unterscheiden wir bei den Darstellungsarten zwischen

- Darstellungsarten ohne Funktionen

Bei solchen Darstellungsarten handelt es sich um einen frei zu vergebenden, vierstelligen, vorerst funktionslosen Schlüssel. Erst im Berichtsdesigner wird dieser Schlüssel, wie zuvor beschrieben, als steuerndes Element genutzt, indem einzelne Objekte (Platzhalter für das zu druckende Feld (z.B. der "Preis")) nur bei Übereinstimmung der Darstellungsart des Objektes mit der Darstellungsart der Kataloggruppe, gedruckt werden. Die entsprechenden Abfragen bzw. Bedingungen sind vom Anwender im Berichtsdesigner in den jeweiligen Objekten zu hinterlegen.

Diese Darstellungsarten erlauben lediglich Positionen (Artikel, Varianten) unterhalb dem Kataloggruppenkopf zu drucken. Die erste Position kann auch neben dem Bild stehen.

- Darstellungsarten mit integrierten Funktionen

Bei den "Darstellungsarten mit integrierten Funktionen" wird die Darstellungsart ebenfalls im Berichtsdesigner als steuerndes Element genutzt. Im Gegensatz zu den zuvor beschriebenen "funktionslosen Darstellungsarten", werden jedoch unmittelbar vor dem eigentlichen Druckvorgang die Daten aufbereitet (generiert).

Damit sind weitere Darstellungsmöglichkeiten gegeben:

- Positionen / Artikel unterhalb des Kataloggruppenbildes*

- Positionen / Artikel neben dem Kataloggruppenbild

- Positionen / Artikel einer Kataloggruppen in mehreren Spalten

- Mehrere Kataloggruppen nebeneinander

- Darstellungsarten zur Steuerung von Seiten-/ und Zwischenüberschriften

- Darstellungsarten für spezielle Funktionen z.B. Angebotserstellung

Grundsätzlich ist die auf vier alphanumerische Stellen begrenzte Bezeichnung (Verschlüsselung) einer Darstellungsart frei wählbar. Aufgrund automatisch ablaufender Funktionen (siehe dazu "vordefinierte Darstellungsarten") sind folgende Restriktionen bei der Benennung von eigenen Darstellungsarten zu beachten:

maximal vier Stellen alphanumerisch

nur Ziffern in der ersten Stellen verwenden (z.B. "1234")

in der 3. Stelle der Bezeichnung kein "S", "s", "G", "N" oder, "W" verwenden (z.B. "06N0" = fehlerhaft)

Übersicht der Darstellungsarten

Darstellungsarten ohne integrierte Funktionen

Bei den "Darstellungsarten ohne integrierte Funktionen" werden in der Regel der Kataloggruppenkopf und darunter die dazugehörenden (Artikel)-Positionen (meist Produktvarianten) je Zeile ein Artikel gedruckt.
In der einfachsten Form werden die Artikel auch ohne Gruppenkopf gelistet.

Basisdesign

Katalogpositionen gruppiert
je Kataloggruppe gelistet f

Katalogpositionen einzeln mit Bild
(ein Artikel je Kataloggruppe)

Katalogpositionen (Artikel) einfach gelistet f

Format 9zZz

"9" = numerisches Zeichen (0 bis 9 oder " " )

"z" = beliebiges alphanumerisches Zeichen oder " "

"Z" = beliebiges alphanumerisches Zeichen oder " " jedoch kein "S", "s", "G", "N" oder, "W"

Mehrspaltiges Design seitenorientiert

Im Gegensatz zur kataloggruppenorientierten Darstellungsart , handelt es sich in der Regel bei der "mehrspaltigen einfachen Darstellung", um eine seitenorientierte Darstellung, die meist für Preislisten und Inhaltsregister Anwendung findet.
Dazu ist unter "Seiteneinrichten" die Spaltenanzahl und die "Laufrichtung" (horizontal Zeile für Zeile oder vertikal Spalte für Spalte) zu bestimmen.

Katalogposition(en ) (Artikel) mehreren Spalten (gruppiert je Kataloggruppe) gelistet

Katalogpositionen in(Artikel) mehreren Spalten gelistet

Katalogpositionen in(Artikel)
mehreren Spalten gruppiert
je Kataloggruppe gelistet

Darstellungsarten mit integrierten Funktionen

Primäre Darstellungsarten mit integrierten Funktionen:

Mehrere Kataloggruppen nebeneinander (maximal 4 Kataloggruppen)

Kataloggruppenpositionen
(Artikel) unterhalb
dem Gruppenkopf

Kataloggruppenpositionen
(teilweise) neben
dem Gruppenkopf

Format S atp

"t" = Aufteilung der Zeile für bis zu 4 Kataloggruppen nebeneinander z.B. 4 x 1/4

"a" = Anteile die eine Kataloggruppe innerhalb einer Zeile belegt
"p" = Anzahl Positionszeilen neben dem Bild

Kataloggruppenpositionen (Artikel) nebeneinander (Artikelmatrix bis 99 Spalten)

Kataloggruppenpositionen
(Artikel) unterhalb
dem Gruppenkopf

Kataloggruppenpositionen
(Artikel) unterhalb
dem Gruppenkopf

Format ss S p

"s" = Positionsspalten innerhalb einer Kataloggruppe
(Positionen/Artikel einer Kataloggruppe - in Matrix-Darstellung)

"t" = Aufteilung der Zeile für bis zu 4 Kataloggruppen nebeneinander z.B. 4 x 1/4

"a" = Anteile die eine Kataloggruppe innerhalb einer Zeile belegt
"p" = Anzahl Positionszeilen neben dem Bild

Darstellungsarten "SK ", "BK ", "SL " und "BL " Kataloggruppen nebeneinander

Diese Darstellungsarten sind aus Kompatibilitätsgründen noch verfügbar, verwenden Sie stattdessen die zuvor beschriebenen Darstellungsarten "Snn ".

Mit den bildorientierten Darstellungsarten "SK ", "BK ", "SL " und "BL " können bis zu 4 Kataloggruppen mit Bild in einer Zeile dargestellt werden:

Darstellung: "SK " "BK " "SL " "BL "

schmal / kurz breit / kurz schmal / lang breit / lang

je Zeile je Zeile je Zeile je Zeile

bis zu 4 Artikel mit Bild bis zu 4 Artikel mit Bild bis zu 4 Artikel mit Bild bis zu 4 Artikel mit Bild

Spezielle Darstellungsarten mit integrierten Funktionen:

Darstellungsart " ppNa"

Wie Darstellungsart S atp jedoch bis 99 Positionen neben einen Bild auch maximal 4 Kataloggruppen nebeneinander jedoch mit fester Aufteilung der Zeile (4 x ein Viertel).

Format S atp

"a" = Anteile die eine Kataloggruppe innerhalb einer Zeile belegt (a x Viertel)
"p" = Anzahl Positionszeilen neben dem Bild

Darstellungsart " xxG" und " xxW"

Bei den Darstellungsarten "nnG" und "nnW" (auch "06 ", "11 " und "22 ") handelt es sich um Darstellungsarten, bei denen das Programm zur Laufzeit, ausgehend von einem Basispreis, weitere (nn) Preise errechnet und druckt (z.B. bei tagesabhängigen Metallnotierungen für Kupfer, Zink, Feinzink etc.).

Details dazu unter "Darstellungsarten für automatische Preisermittlung bei kursabhängigen Preisen"

Darstellungsart SUEB" Seitenüberschrift und "ZUEB" Zwischenüberschrift

Die Darstellungsarten "SUEB" und "ZUEB" dienen zur Steuerung von Zwischen- und Seitenüberschriften.

Details dazu finden Sie auf den Folgeseiten.

Tabellarische Übersicht der Darstellungsarten

Formate für spezielle

Darstellungsarten

der Kataloggruppen

Beispiel

Kataloggruppen

In einer "Zeile" nebeneinander

Positionsspalten
innerhalb einer Kataloggruppe

Positionszeilen neben dem Bild bzw. neben dem Langtext einer Kataloggruppe

Bsp.= hier Beispielhaft

9zZz

0001

ss S p

08 S 0

max. 1

Bsp. 08 max. 99

Bsp. 0 (max. 9)

08 S 6

max . 1

Bsp. 08 max. 99

Bsp. 08 max. 99

ss S p

01 S 0

max. 1

Bsp. 01 max. 99

Bsp. 0 (max. 9)

01 S 6

max. 1

Bsp. 01 max. 99

Bsp. 6 (max. 9)

S atp

S 140

Bsp. 1 (max. 4)

-

Bsp. 0 (max. 9)

S 146

Bsp. 1 (max. 4)

-

Bsp. 6 (max. 9)

pp N a

06 N 0

1 (max. 4)

-

Bsp. 06 (max. 99)

06 N 1

1 (max. 4)

-

Bsp. 06 (max. 99)

xx G

06 G

1

-

-

xx W

06 W

1

-

-

SUEB *

ZUEB *

"9" = numerisches Zeichen (0 bis 9 oder " " )

"z" = beliebiges alphanumerisches Zeichen oder " "

"Z" = beliebiges alphanumerisches Zeichen oder " " jedoch kein "S", "s", "G", "N" oder, "W"

"p" = Anzahl Positionszeilen neben dem Bild

"s" = Positionsspalten innerhalb einer Kataloggruppe (Positionen/Artikel einer Kataloggruppe - in Matrix-Darstellung)

"t" = Aufteilung der Zeile für bis zu 4 Kataloggruppen nebeneinander z.B. 4 x 1/4

"a" = Anteile die eine Kataloggruppe innerhalb einer Zeile belegt
z.B. 'S 240' Kataloggruppe belegt 2/4l von 4 . Bei Darstellungsart 'pp N a' wird von einer von einer festen "Vierteilung" ausgegangen (z.B. 20 N 3 = 20 Zeilen neben Bild belegen ¾ der Zeile, d.h. es könnte noch eine Kataloggruppe die ¼ belegt in die gleiche Zeile).

X = Anzahl Preisspalten für Preise ermittelt aufgrund unterschiedlicher Kurse /Notierungen

Nachfolgende Darstellungsarten stehen aus Kompatibilitätsgründen noch zur Verfügung.
Sie sollten jedoch stattdessen dafür neu entwickelten Darstellungsarten verwenden.

11 (dafür neu 06G / 06W)

22 (dafür neu 06G / 06W)

BK (dafür neu Satp)

BL (dafür neu Satp)

SL (dafür neu Satp)

SK (dafür neu S atp)

2.4.3.1 Darstellungsarten ohne integrierte Funktionen

Format "9zZz"

"9" = numerisches Zeichen (0 bis 9 oder " " )

"z" = beliebiges alphanumerisches Zeichen oder " "

"Z" = beliebiges alphanumerisches Zeichen oder " " jedoch kein "S", "s", "G", "N" oder, "W"

Bei den "Darstellungsarten ohne integrierte Funktionen" werden in der Regel der Kataloggruppenkopf (siehe Abbildung Punkt 3) und darunter die dazugehörenden (Artikel)-Positionen (meist Produktvarianten) gedruckt.

Einfache Preisliste ohne Bild

Die einfachste Darstellung von Artikel ist in einer Liste ohne Bild und irgendwelcher Gruppierungen.

In der nachfolgenden Abbildung sehen Sie bereits eine anspruchsvollere Darstellung, bei der zusammen gehörende Artikel (Varianten eines Artikel (4)), die in den Katalogdaten jeweils in einer Kataloggruppe zusammengeführt wurden, unter der gemeinsamen Kataloggruppenbezeichnung (3 "Holzschraube SD1") gelistet werden.

Beachten Sie in KL-KatGen wird auch ein Artikel als Kataloggruppe dargestellt.

Zusammengehörende Kataloggruppen erhalten eine Zwischenüberschrift (2 "Holzschraube SD") und die "Artikelbereiche" die entsprechende Seitenüberschriften (1 "Schrauben und Nägel") auf denen Sie gedruckt werden. Hier belegt jeder Artikel eine komplette Zeile unter den Kataloggruppeninformationen

Beispiel für eine 1-spaltige Preisliste ohne Bilder (1-spaltig = eine Artikel-/Katalogposition je Zeile)

1 = Seitenüberschrift

2 = Zwischenüberschrift

3 = Kataloggruppen Bezeichnung (hier als Überschrift)

4 = Positionen der Kataloggruppe

Einfache Bildpreisliste ohne Artikelvarianten

Die einfachste Darstellung der Artikel in einem Bildkatalog ist für jeden einzelnen Artikel z.B. ein Bild, die Artikelnummer, die Artikelbezeichnung, evtl. die Produktbeschreibung und einen Preis zu drucken (siehe Abbildung).

Bildpreisliste mit Artikelvarianten

Eine Kataloggruppen je 'Zeile', Positionen unterhalb dem Bild

Gehören zu einer Kataloggruppe mehrere Artikelpositionen (meist Varianten) lassen die sich mit diesen "einfachen Darstellungsarten" wie nachfolgend gezeigt drucken.

Hier stehen die Artikelpositionen unterhalb des Bildes und der für alle gemeinsamen Beschreibung. In der Regel handelt es sich bei solchen Kataloggruppen um Varianten eines Produktes oder um ein zusammengehörendes Set oder Sortiment.

Mehrspaltige, einfache Darstellung (seiten orientierte Darstellung)

Im Gegensatz zur kataloggruppenorientierten Darstellungsart , handelt es sich in der Regel bei der "mehrspaltigen einfachen Darstellung", um eine seitenorientierte Darstellung, die meist für Preislisten und Inhaltsregister Anwendung findet.

D. h. es wird die Anzahl der Spalten (und damit auch der Spaltenbreite) unter "Seite einrichten" definiert.

Alle Kataloggruppen und Artikel werden einheitlich, fortlaufend untereinander bzw. nebeneinander, Spalte für Spalte gedruckt.

Trotz Allem können mit dieser Darstellungsart schnell und einfach auch attraktive Katalogseiten erzeugt werden, jedoch ist eine breitere Darstellung einer einzelnen Kataloggruppe (z.B. über die ganze Zeile) im gleichen Design (Report) nicht möglich.

Beispiel für eine 2-spaltige Preisliste ohne Bilder:

Beispiel für eine 2-spaltige Preisliste mit Bildern:

2.4.3.2 Vordefinierte Darstellungsarten

Grundsätzlich sind die Darstellungsarten der Kataloggruppen mit Ausnahme der in der nachfolgenden Tabelle aufgeführten frei definierbar, d.h. Sie können einen vierstelligen "Code" festlegen den Sie im Designer in den einzelnen Objekten (den Feldern, die Sie drucken wollen) in den Druckbedingungen ("drucken wenn") abfragen können. Die optische Gestaltung dieser Darstellungsarten können Sie dennoch entsprechend Ihren individuellen Anforderungen anpassen:

2.4.3.2.1 Primäre Darstellungsarten mit integrierten Funktionen:

Darstellungsart "ssSp"

("S" an der 3. Stelle)

Die Positionen einer Kataloggruppe können in bis zu 99 Spalten je Positionszeile dargestellt werden.
(Siehe Darstellungsart "ss s p" ( bzw. kleines "s" an der 3. Stelle) für automatischen Zeilenumbruch).

"s" = Positionsspalten innerhalb einer Kataloggruppe (Positionen/Artikel einer
Kataloggruppe in Matrix-Darstellung)

"p" = Anzahl der Positionszeilen (maximal 9) neben dem Bild

Eine Kataloggruppen je 'Zeile', Positionen mehrspaltig unter dem Bild

Darstellungsart " ssSp"

Eine Kataloggruppen je 'Zeile', Positionen mehrspaltig neben dem Bild

In dem Beispiel hier, werden die Artikel (Artikelnummer und Preis) mit der Darstellungsart '08S6" in 8 Positionsspalten neben dem Bild angedruckt. Die Längenangaben werden horizontal als Überschrift, die unterschiedlichen Stärken vertikal in der ersten Spalte angezeigt.

Benötigen Sie mehr Platz in den einzelnen Positionszeilen oder ist der Platzbedarf für die Produktbeschreibung der Kataloggruppe größer, ist eine Darstellung zu wählen bei der die Positionen (hier eine Positionsmatrix) unterhalb des Bildes stehen.

Darstellungsart "Satp"

( "S" an der 1. Stelle )

Mehre Kataloggruppen nebeneinander

Benötigen Sie weniger Platz in der einzelnen Positionszeilen und für den Kataloggruppentext, so dass mehrere Kataloggruppen nebeneinander stehen können, kann dies mit der Darstellungsart 'S140" gesteuert werden.

Bis zu 4 Kataloggruppen können nebeneinander dargestellt werden.

"a" = Die Anteile die eine Kataloggruppe innerhalb einer Zeile belegt (max. 4)

"t" = Aufteilung der Zeile für bis zu 4 Kataloggruppen nebeneinander (max. 4)
z.B. t = 4, die Zeile ist in 4 x ¼ aufgeteilt

"p" = Anzahl der Positionszeilen (maximal 9) neben dem Bild (siehe auch "ppNa")

Beispiel Darstellungsart "S 140"

Bei dieser Darstellungsart stehen keine Positionen (0) neben dem Bild, d.h. die Positionen der Kataloggruppe werden unterhalb dem Bild angedruckt. Wobei für die einzelne Kataloggruppen 1-Viertel der Zeilenbreite (Seitenbreite) von den 4-Viertel vorgesehen wurden.

Mehrere Kataloggruppen nebeneinander, Positionen neben dem Bild

Beispiel Darstellungsart "S246"

Im Gegensatz zu der zuvor aufgeführten Darstellungsart "S140" können hier bis zu 6 Positionen neben dem Bild stehen. Wobei für die Kataloggruppen 2-Viertel der Zeilenbreite (Seitenbreite) Im Beispiel zuvor 1-Viertel) vorgesehen wurden.

Das gleiche Ergebnis könnte auch mit der Darstellungsart "06 N 2" erreicht werden. (Die Kataloggruppe (hier 2 mit gleicher Darstellungsart) belegt 2 Anteile der Zeile mit 6 Positionen neben dem Bild).

"ppNa" bietet gegenüber " Satp " den Vorteil mehr als 9 (theoretisch bis 99 Positionen ) (pp) neben dem Bild zu drucken. Jedoch bei fester "Zeilenteilung" 4 x ein Viertel d.h. maximal 4 Kataloggruppen nebeneinander, die jeweils a-Viertel belegen.

2.4.3.2.2 Spezielle Darstellungsarten mit integrierten Funktionen:

Hierbei handelt es sich um Darstellungsarten mit erweitertem und speziellen Funktionsumfang

Darstellungsart "pp N a"

"N" an der 3. Stelle der Darstellungsart = Diese Darstellungsart entspricht der Darstellungsart "Satp" jedoch können hier bis zu 99 Positionszeilen neben dem Kataloggruppenkopf ( Bild) und bis zu 4 Kataloggruppen nebeneinander dargestellt werden.

"p" = Anzahl der Positionszeilen (maximal 9) neben dem Bild.

"a" = Die Anteile die eine Kataloggruppe innerhalb einer Zeile belegt (max. 4 x 1/4)

Sollen Artikelpositionen neben der Abbildung der Kataloggruppe gedruckt werden (und evtl. weitere darunter), so ist dafür die Darstellungsart "nnN" vordefiniert. "nn" steht für die Anzahl möglicher Positionen neben der Abbildung. Maximal sind 30 Positionen neben der Abbildung möglich ( "01 N "bis "30 N ").

Beispiel: Mit der Darstellungsart "06N" können bis zu 6 Positionen neben der Abbildung der Kataloggruppe und weitere Positionen darunter angedruckt werden.

Beispiel für Darstellungsart "06N2"
( bis 6 Positionen neben dem Bild, 2 Kataloggruppen nebeneinander die jeweils 2/4 der Zeile belegen)

Das gleiche Ergebnis könnte auch mit der Darstellungsart "S 246" erreicht werden. (Die Kataloggruppe (hier 2 mit gleicher Darstellungsart) belegt 2 Anteile der Zeile mit 6 Positionen neben dem Bild).

"ppNa" bietet gegenüber " Satp " den Vorteil mehr als 9 (theoretisch bis 99 Positionen ) (pp) neben dem Bild zu drucken. Jedoch bei fester "Zeilenteilung" 4 x ein Viertel d.h. maximal 4 Kataloggruppen nebeneinander, die jeweils a-Viertel belegen.

Bei "Satp" können maximal nur 9 Positionen (p) neben dem Bild gedruckt werden, jedoch lassen sich hier beliebige Zeilenaufteilungen (t) (nicht nur Viertel) der Zeile definieren (z.B. "S236", die zu druckende Kataloggruppe belegt 2-Drittel der Zeile mit 6 Positionen neben dem Bild . Maximal passt in diesem Fall nur noch eine Kataloggruppe die gleich oder weniger als ein Drittel belegt in die gleiche Zeile (z.B. S136).

Darstellungsarten für automatische Preisermittlung bei kursabhängigen Preisen

Darstellungsart " xxG"

Bei den Darstellungsarten "nnG" und "nnW" (auch "06 ", "11 " und "22 ") handelt es sich um Darstellungsarten, bei denen das Programm zur Laufzeit, ausgehend von einem Basispreis, weitere (nn) Preise errechnet und druckt (z.B. bei tagesabhängigen Metallnotierungen für Kupfer, Zink, Feinzink etc.).

Darstellungsart " xxW"

Bei den Darstellungsarten "nnG" und "nnW" (auch "06 ", "11 " und "22 ") handelt es sich um Darstellungsarten, bei denen das Programm zur Laufzeit, ausgehend von einem Basispreis, weitere (nn) Preise errechnet und druckt (z.B. bei tagesabhängigen Metallnotierungen für Kupfer, Zink, Feinzink etc.).

Bei den Darstellungsarten "nnG" und "nnW" (auch "06 ", "11 " und "22 ") handelt es sich um Darstellungsarten, bei denen das Programm zur Laufzeit, ausgehend von einem Basispreis, weitere (nn) Preise errechnet und druckt (z.B. bei tagesabhängigen Metallnotierungen für Kupfer, Zink, Feinzink etc.).

.

von nnG.

Das Programm erwartet dazu in der Artikeldatei die Informationen: Basispreis, Schrittweite und Zuschlag.

Zum Beispiel:

Artikelnummer : "XYZ-4711"

Grundpreis : 100

Basiskurs : 150

aktueller Kurs : 400

Schrittweite : 10

Zuschlag : € 1,00 je 10 Punkte Kursschwankung

Im Katalog sollen 20 Preise ab einem möglichen Kurs von 350 gezeigt werden, wobei die ersten 10 Preise auf der linken, die restlichen 10 Preise auf der rechten, gegenüberliegenden Seite gedruckt werden sollen.

In der Artikeldatei müssen dazu folgende Daten für die einzelnen Artikel vorhanden sein (z.B. aus Datenimport oder manuell erfasst).

Art (bis zu 4 unterschiedliche Kursermittlungen sind möglich)

Basis-Notierung

Schrittweite

Zuschlag

Mit der Darstellungsart "10G" werden automatisch folgende Werte ermittelt

Kurse von-

bis

Artikel-Nummer

350-359

360-369

370-379

380-389

390-399

400-409

410-419

420-429

430-439

440-449

XYZ-4711

120

121

122

123

124

125

126

127

128

129

XYZ-4712

130

131

132

133

134

135

136

137

138

139

XYZ-4713

...

..

..

..

..

Mit der Darstellungsart "10W" werden folgende Werte ermittelt (Fortsetzung von "10G"

Kurse von-

bis

Artikel-Nummer

450-459

460-469

470-479

480-489

490-499

500-509

510-519

520-529

530-539

540-549

XYZ-4711

130

131

132

133

134

135

136

137

138

139

XYZ-4712

140

141

142

143

144

145

146

147

148

149

XYZ-4713

...

..

..

..

..

Gedruckt werden diese nun sowohl untereinander, als auch auf gegenüberliegenden Seiten nebeneinander, bzw. auf Folgeseiten in gleicher Höhe. Ob und wo (links oder rechts) die Artikelnummer usw. gedruckt werden, ist im "Katalog-Designer" festzulegen.

Darstellungsart "SUEB" Seitenüberschrift

Durch Einfügen einer "Pseudo-Kataloggruppe" mit der Darstellungsart "SUEB", stehen für die Verwendung im Seitenüberschriftenbereich, ab der entsprechenden Kataloggruppe, alle Datenfelder (Namen und Inhalte) dieser Kataloggruppe zur Verfügung. Im Berichtsdesigner werden diese mit der vorgestellten Buchstabenfolge "SUEB." angesprochen.

Beispiel: Der Inhalt aus dem Datenfeld "T1" der Kataloggruppe soll ab dieser Kataloggruppe als Seiten Überschrift gedruckt werden, so wird dieses im Textobjekt des Designers mit "SUEB.T1" angesprochen.

Somit können bereits bei der automatischen Katalogerstellung aus einer Importdatei, Überschriften ab einer gewünschten Katalogstelle automatisiert eingefügt werden, indem ein entsprechender "Pseudoartikel" mit der Darstellungsart "SUEB" in der Importdatei eingefügt wird.

Darstellungsart "ZUEB" Zwischenüberschrift

Durch Einfügen einer "Pseudo-Kataloggruppe" mit der Darstellungsart "ZUEB", stehen für die Verwendung im Seitenüberschriftenbereich, ab der entsprechenden Kataloggruppe, alle Datenfelder (Namen und Inhalte) dieser Kataloggruppe zur Verfügung. Im Berichtsdesigner werden diese mit der vorgestellten Buchstabenfolge "ZUEB." angesprochen.

Beispiel: Der Inhalt aus dem Datenfeld "T1" der Kataloggruppe soll ab dieser Kataloggruppe als Seiten-Überschrift gedruckt werden, so wird dieses im Textobjekt des Designers mit "ZUEB.T1" angesprochen.

Somit können bereits bei der automatischen Katalogerstellung aus einer Importdatei, Überschriften ab einer gewünschten Katalogstelle automatisiert eingefügt werden, indem ein entsprechender "Pseudoartikel" mit der Darstellungsart "ZUEB" in die Importdatei eingefügt wird.

2.4.3.3 Drucksteuerung mit unterschiedlichen Darstellungsarten

In dem nachfolgenden Beispiel sollen im Design "Buero01" die Bilder einer bestimmten Kataloggruppe an eine bestimmte Stelle gedruckt werden (hier immer rechts außen). Wir haben dafür willkürlich festgelegt, dass dies die Kataloggruppen-Darstellungsart "01 " (="katgruppe.darstell" (steht für Druckvariante)) sein soll.

Im obersten Fenster des Formulars ("Objekt drucken") wurde dazu in der Bedingung "nur drucken wenn Ausdruck wahr ist" die Bedingung "BildKG0Da() and katgruppe.darstell = "06N " eingegeben. Die Funktion "BildKG0Da()" liefert "JA", wenn die Bilddatei (der Name steht in der Kataloggruppe) vom Programm gefunden wurde. Wenn zusätzlich die Darstellungsart der Kataloggruppe (katgruppe.darstell) gleich "01 " ist, wird das Bild gedruckt.

2.4.3.3.1 PRL-Listen

Kataloge mit Darstellungsarten mit integrierten Funktionen (z.B. Positionen mehrspaltig, Positionen neben Bild usw. ) können ohne Änderung der Darstellungsart in den einzelnen Kataloggruppen. auch als "einfache Listen" gedruckt werden. So lässt sich problemlos aus den Daten eines vorhandenen Kataloges eine dazu passende Liste (z.B. separate Preisliste) erstellen.

Dazu ist lediglich als Name für das zu erstellende Design mit der Zeichenfolge "-PRL" am Ende zu wählen (Z.B. "Standard01-PRL") . Das Programm erkennt diese Zeichenfolge und neutralisiert beim Drucken die unterschiedlichen Darstellungsarten in den einzelnen Kataloggruppen (d.h. es generiert die Arbeitsdatei mit Darstellungsart " " anstelle der in der Kataloggruppe vorgegebenen).

Die ursprüngliche Darstellungsart bleibt dabei erhalten.

2.4.4 Erfassen der Katalogpositionen (Artikeldaten)

Artikeldaten können auf verschiedene Art den Kataloggruppen zugewiesen werden:

1. Freies Erfassen von Artikeldaten durch direkte Eingabe der Artikelnummer ohne Prüfung.

2. Erfassen von Artikeldaten durch direkte Eingabe der Artikelnummer mit Prüfung und Datenübernahme. Vor der Verwendung dieser Funktion sind die entsprechenden Artikeldaten zu importieren. Details dazu finden sie unter der Rubrik "Der DatenImport" "

3. Übernahme / Auswahl von Artikeldaten aus einem vorhandenen Warenwirtschaftssystem oder aus einer beliebigen anderen ASCII-Datei (z.B. Artikeldaten eines Lieferanten). Vor der Verwendung dieser Funktion sind die entsprechenden Artikeldaten zu importieren. Details dazu finden sie unter der Rubrik "Der Datenimport".

2.4.5 Katalogerstellung unter Verwendung von Artikelstammdaten

Die Vorgehensweise ist weitgehendst wie unter "Katalogerstellung ohne Verwendung von Artikelstammdaten" beschrieben. Zusätzlich können hier, die aus Ihrem Warenwirtschaftssystem oder aus Lieferantendaten importierten Artikeldaten bereits bei der Erstellung der Kataloge arbeitsersparend genutzt werden.

Den weitaus größeren Nutzen jedoch ziehen Sie aus der Möglichkeit, zukünftig den einmal erstellten Katalog automatisiert mit den neuesten Preisen aus dem Warenwirtschaftssystem zu aktualisieren (siehe dazu "Der Datenimport").

Folgende vorbereitende Maßnahmen sind durchzuführen:

1. Die aus dem Warenwirtschaftssystem zu importierenden Artikeldaten sind als CSV-Datei (z.B. aus MS-EXCEL) bereitzustellen (z.B. Artikelnummer, Bezeichnung, Preis, usw.).
Es besteht natürlich auch die Möglichkeit Artikelstammdaten manuell zu erfassen
(vgl Kapitel "Artikeldaten verwalten")

2. Die Importschnittstelle von KL-KatGen ist entsprechend dieser CSV-Datei anzupassen.
Details finden Sie unter "Der Datenimport".

3. Im Menüpunkt "Der Datenimport" besteht die Möglichkeit, aus einer externen Schnittstellendatei Artikeldaten in die KL-KatGen eigene Artikelstammdatei einzulesen.
Die Option "Daten in Artikeldatei übernehmen" aktivieren.

Nicht Vergessen: Die Option "automatische Kataloggruppen-Anlage" deaktivieren.

Nicht Vergessen: Prüfung der Update-Steuerung "Artikel" und "Katalog"

Die einzelnen Optionen und Bedienungshinweise zu diesem Programmteil sind im Kapitel "Der Datenimport " ausführlich beschrieben.

4. Öffnen Sie nun die Artikelauswahl (Schaltfläche "Artikel-Auswahl" auf der Hauptmaske). In einem Auswahlfenster stehen nun die Artikeldaten zur Verfügung und können per "Knopfdruck" (Schaltfläche "Erfassen") oder durch "Doppelklick" auf die Artikelnummer in die jeweilige Position übertragen werden.

5. Mit der Schaltfläche "Katalog Drucken" gelangen Sie in den Programmzweig "Kataloge – Druck und Design".
Hier können Sie Designs zuweisen, Designs erstellen und ändern, Kataloge anzeigen bzw. Drucken.

2.4.6 Katalog Preis-Aktualisierung unter Verwendung von Artikelstammdaten

Wie bereits aufgezeigt, können Sie mit KL-KatGen in wenigen Minuten Ihre einmal erstellten Kataloge mit den neuesten Preisen aus Ihrem Warenwirtschaftssystem oder mit Preisen von Ihrem Lieferanten aktualisieren.

Entsprechend der Vorgehensweise der Katalogerstellung sind folgende vorbereitende Maßnahmen durchzuführen:

1. Die aus dem Warenwirtschaftssystem zu importierenden Artikeldaten sind als Datei im CSV-Format (siehe dazu MS-EXCEL ) bereitzustellen (z.B. Artikelnummer, Bezeichnung, Preis usw.). Es besteht natürlich auch die Möglichkeit Artikelstammdaten manuell zu erfassen
(vgl Kapitel "Artikelstammdaten verwalten")

2. Die Importschnittstelle von KL-KatGen ist ggf. entsprechend dieser CSV-Datei anzupassen (in der Regel ist dies bereits bei der Erstellung erfolgt).

3. Wählen Sie ggf. den zu aktualisierenden Katalog (Schaltfläche "Katalog-Wechsel").

4. Im Menüpunkt "Datenimport" besteht die Möglichkeit aus einer externen Schnittstellendatei Artikeldaten in die KL-KatGen eigene Artikelstammdatei einzulesen.
Die Option "Daten in Artikeldatei übernehmen/aktualisieren" aktivieren.
Die Option "automatische Kataloggruppen-Anlage" aktivieren.
Die Option "einschließlich aktualisieren vorhandener Kataloggruppen/Positionen" aktivieren.

Nicht Vergessen: Prüfung der Update-Steuerung "Artikel" und "Katalog"

Die einzelnen Optionen und Bedienungshinweise zu diesem Modul sind im Kapitel "Der Datenimport" ausführlich beschrieben.

5. Mit der Schaltfläche "Katalog Drucken" gelangen Sie in den Programmzweig "Kataloge – Druck und Design".
Hier können Sie Designs zuweisen, Designs erstellen und ändern, Kataloge anzeigen bzw. Drucken.

2.4.7 Manuelles Erfassen von Artikeldaten ohne Prüfung und Datenübernahme

Um einen Artikel der Kataloggruppe zuzuordnen, drücken Sie Taste "Neue Position". Sie können nun in der gewünschten Zeile, in der Spalte "Artikel-Nummer" eine Artikel-Nummer erfassen.

Das Programm prüft beim Verlassen des Eingabefeldes, ob ein entsprechender Artikel in der Artikeldatei vorhanden ist. Wird der Artikel nicht gefunden, erfolgt eine Fehlermeldung und die Abfrage, ob weiterhin fehlende Artikel gemeldet werden sollen.

Wird dies verneint, können beliebige Artikeldaten ohne weitere Prüfung erfasst werden.

Dies ist insbesondere dann sinnvoll, wenn Kataloge frei, d.h., ohne Bezug auf eine Artikeldatei erstellt werden sollen.

2.4.8 Manuelles Erfassen von Artikeldaten mit Prüfung und Datenübernahme

Um einen Artikel der Kataloggruppe zuzuordnen, drücken Sie die Taste "Neue Position". Sie können nun in der gewünschten Zeile, in die Spalte "Artikel-Nummer" eine Artikelnummer erfassen.

Das Programm prüft beim Verlassen des Eingabefeldes, ob ein entsprechender Artikel in der Artikeldatei von KL-KatGen vorhanden ist und überträgt Preis und Artikelbezeichnung sowie weitere Informationen.

Wird der Artikel nicht gefunden, erfolgt eine Fehlermeldung. Wahlweise kann die Eingabe wiederholt, abgebrochen oder die Prüfung ausgeschaltet werden (siehe zuvor).

2.4.9 Ändern der Reihenfolge der Positions-/Artikeldaten

Die Reihenfolge der erfassten Positionsdaten kann problemlos durch Überschreiben der Positionsnummer geändert werden. Das Programm sortiert die Positionen nach Verlassen des Eingabefeldes sofort neu (in Zehner-Schritten).

2.4.10 Ändern der Position (Reihenfolge) einzelner Kataloggruppen im Katalog

Durch Überschreiben der Kataloggruppen-Nummer kann die Position der Kataloggruppe (Reihenfolge) jederzeit geändert werden. Beachten Sie jedoch, dass dadurch Überschriften ebenfalls eventuell neu platziert werden müssen.

2.4.11 Kopieren von Kataloggruppen

Es besteht die Möglichkeit vorhandene Kataloggruppen zu kopieren bzw. auszuschneiden und diese an einer anderen Stelle des Kataloges einzufügen.
Öffnen Sie hierzu das Kopierfenster, mit klick auf den "Z" Button am unteren rechten Rand der Hauptmaske.
Es erscheint die hier abgebildete Maske mit den entsprechenden Buttons "Kopieren", "Ausschneiden" und "Einfügen". Klicken Sie auf den "Kopieren-Button" bzw. den "Ausschneiden-Button", damit wird die aktuell in der Hauptmaske angezeigte Kataloggruppe in den Zwischenspeicher von KL-Katgen geladen.

Blättern Sie nun an die Stelle des Kataloges, wo die Kataloggruppe eingefügt werden soll.

(Sie können natürlich auch durch Eingabe der Kataloggruppennummer in der Hauptmaske an die gewünschte Stelle gelangen).
Mit Klick auf den "Einfügen-Button" wird die zu kopierende Kataloggruppe nach der am Bildschirm angezeigten Kataloggruppe eingefügt.

Der Button "Reorganisation" öffnet das Modul Verwaltung "Katalogsortierung nach Kataloggruppen"

2.4.12 Verwenden importierter Artikeldaten für die Katalogerstellung

Vor der Verwendung dieser Funktion sind die entsprechenden Artikeldaten zu importieren. Details dazu finden Sie unter Punkt "Der Datenimport" .

Nach Drücken der Taste "Artikel-Auswahl" öffnet sich das "Artikelauswahlfenster".

Sie können nun den gewünschten Artikel auswählen (markieren) und durch Drücken der Taste "Erfassen" in die vorgesehene Kataloggruppe übernehmen. Automatisch "springt" dabei der Cursor sowohl in der Grundmaske, als auch im Artikelauswahlfenster in die nächste Position.

Durch Doppel-Klick auf die Artikelnummer im Artikelauswahlfenster können die Daten ebenfalls übertragen werden.

Filtersuchfunktion

Suchen von Artikel in der Artikelstammdatei und Übernahme in den Katalog

Erlaubt auch die Artikelneuanlage, die Änderung einzelner Datenfelder und das sofortige Löschen von Artikeldaten in der Artikelstammdatei.

Artikel-Suche im Katalog

Auf der rechten Seite des Artikelauswahlfensters werden die Kataloggruppen in der sich der angezeigte Artikel befindet, angezeigt. Mit Doppel-Klick auf die gewünschte Kataloggruppen-Nummer wird die entsprechende Kataloggruppe in der Arbeitsansicht angezeigt.

2.4.13 Artikel-Suchfilter

Zum schnellen Auffinden der Artikeldaten kann die Artikelstammdatei "gefiltert" werden.

Geben Sie dazu die Artikelnummer bzw. den in der Artikelbezeichnung 1 oder 2 zu suchenden Text in das "Textfilterfeld" ein und "klicken" Sie in das "Artikelauswahlfeld". Es werden nun nur noch die Artikel angezeigt, bei denen der entsprechende Text in der Bezeichnung 1 oder 2 enthalten ist.

Zur Prüfung, ob der Artikel bereits übernommen ist, oder um zu sehen, welche noch nicht übernommen wurden, kann die entsprechende "Filtertaste" ("Alle", "Verteilt", usw.) gedrückt werden. In der Spalte "Verteilt" wird die Häufigkeit der Übertragung angezeigt

2.4.14 Verwalten Seiten- und Zwischenüberschriften

Aus Kompatibilitätsgründen ist diese Funktion noch verfügbar, verwenden Sie stattdessen die Überschriftensteuerung mit den Darstellungsarten "SUEB" und "ZUEB"..

Seiten- und Zwischenüberschriften und -texte und -bilder werden über die Funktion "Überschriften" den einzelnen Kataloggruppen zugeordnet. D.h., man bestimmt, ab welcher Kataloggruppe die entsprechende Seitenüberschrift im Seitenkopf oder innerhalb der Seite, vor welcher Kataloggruppe, die entsprechende Zwischenüberschrift erscheinen soll.

Lesen Sie hierzu auch "Automatische Überschriftenerzeugung" im Kapitel "Datenimport""

Mit Maus-Klick auf die Schaltfläche "Überschriften" öffnet sich das Fenster.

Bis zu vier Seitenüberschriften á 60 Zeichen (S1 bis S4), zwei Seitentexte bis jeweils 64.000 Zeichen und eine Abbildung (für die Seitenüberschrift) können festgelegt werden.

Bis zu vier Positionsüberschriften á 60 Zeichen (S1 bis S4), zwei Positionstexte bis jeweils 64.000 Zeichen und eine Abbildung (für die Seitenüberschrift) können festgelegt werden.

Festgelegt bedeutet, ab welcher Kataloggruppe die entsprechenden Daten gedruckt werden sollen.

Die Zuordnung kann direkt durch Eingabe der entsprechenden, korrekten (vollständigen) Kataloggruppen-Nummer oder einer davor liegenden, kleineren Nummer erfolgen. Zum Beispiel wird die Überschrift mit der Ziffernfolge "B1" erfasst, so erfolgt die Umsetzung ab der Kataloggruppe "B1", d.h. falls keine Kataloggruppe "B1" vorhanden ist mit der nächst höheren Ziffernfolge z.B. "B1ABC" oder "C1".

2.5 Spaltensteuerung / Spaltenüberschriften der Kataloggruppen

Überschriften, Reihenfolge und die Breite von Spalten der Kataloggruppen-Positionen können für jede Kataloggruppe individuell hinterlegt werden. Durch diese Zuordnung werden die Daten in der Grundmaske entsprechend strukturiert angezeigt und beim Katalogdruck stehen die unterschiedlichen Überschriftentexte zur Verfügung.

Im folgenden Kapitel erfahren Sie, wie Sie den einzelnen Kataloggruppen vordefinierte Spaltensteuerungen zuordnen können.

Die Defaulteinstellung greift immer auf Spaltensteuerung Blank also "leer" zu.

Wenn Sie eine andere definierte Steuerung zuweisen möchten, blättern Sie mit den Navigationstasten (den Pfeilen) vor bzw. zurück (Die Anzeige der Kataloggruppe auf der Hauptmaske ändert sich dynamisch mit), bis die gewünschte Spaltensteuerung aktiviert ist.

Durch Klicken auf die Schaltfläche "Übernahme" wird die Spaltensteuerung für die aktuelle Kataloggruppe wirksam.

Durch Klick auf die Schaltfläche " A " öffnet sich auch in diesem Programmzweig die Maske "Verwalten Spalten-Anzeige". Die detaillierte Beschreibung, wie Sie eigene Spaltensteuerungen anlegen bzw. vorhandene abändern können, finden Sie im Kapitel "Verwalten Spalten-Anzeige".
2.6 Die Kataloggruppenselektion

Teilkataloge erstellen mittels setzen von Filtern

Für die weitere Verarbeitung können Kataloggruppen durch Setzen des Selektionskennzeichen ausgewählt und durch Aktivieren des Selektionsfilters selektiert werden. So können auf einfache Art Teilbereiche aus einem Katalog (Katalogdaten) ausgewählt und gedruckt oder durch Speichern unter einem neuen Namen ein neuer Katalog gebildet werden. Diese Funktion ist insbesondere sinnvoll für das Erstellen von Aktionskatalogen, Flyer oder Artikelübersichten als Ergänzung für ein Angebot aber auch für das schnelle Erstellen eines Kataloges oder einer Preisliste in dem einzelne Artikel/ Kataloggruppen nicht erscheinen sollen.

Alternativ können Kataloge auch selektiv gedruckt werden, in dem die Druckbereiche (Kataloggruppe von-bis) unmittelbar beim Drucken vorgegeben werden. Weitere Details dazu finden Sie unter " Kataloge Drucken und Design verwalten "

2.6.1 Filter ja/nein

Mit "Klick" auf die Schaltfläche "Filter ja/nein" werden gekennzeichnete (bzw. nach "Klick" auf die Schaltfläche "Selektion umkehren" die nicht gekennzeichneten) Kataloggruppen "gefiltert", d.h. lediglich die mit einem Selektionskennzeichen markierten (bzw. nicht markierten) Kataloggruppen stehen nun für das Weiterverarbeiten zur Verfügung.

Bei aktivem Filter wechselt die Hintergrundfarbe des Kataloggruppenselektionsfensters von "blau" nach "rot". Wird das Fenster geschlossen, ist die Filterfunktion deaktiviert.

2.6.2 Die Kataloggruppen Einzelselektion

Wahlweise kann im Datenfeld "von" oder "bis" durch Eingabe der Kataloggruppennummer die gewünschte Kataloggruppe ausgewählt werden.

Mit "Klick" auf die Taste "KatGr. Einzel-Selektion" wird das Selektionskennzeichen für die angezeigte Kataloggruppe (rote Schrift im Datenfeld "von" oder "bis") gesetzt. Das Programm springt automatisch eine Kataloggruppe weiter.

Durch erneutes "Klicken" auf die Taste "KatGr. Einzel-Selektion" (auf den gleichen Kataloggruppensatz) kann das Selektionsmerkmal zurückgenommen werden.

Mit den "Pfeil-Buttons" kann ohne Setzen des Selektionsmerkmals weiter "geblättert" werden.

2.6.3 Selektieren Von Bis

Mit "Klick" auf den Button "von-bis setzen" wird das Selektionskennzeichen für alle Kataloggruppen entsprechend der Anzeige "von" oder "bis" gesetzt. Analog dazu kann das Selektionskennzeichen mit "Klick" auf den Button "von-bis löschen" zurückgenommen werden.

2.6.4 Alle löschen

Mit "Klick" auf den Button "alle löschen" wird das Selektionskennzeichen für alle Kataloggruppen des Kataloges zurückgenommen.

2.6.5 Selektion umkehren

Mit "Klick" auf die Taste "Selektion umkehren" werden die n i c h t gekennzeichneten Kataloggruppen "gefiltert".

2.6.6 Anzeige

Mit "gesetztem Filter" prüfen Sie in einem "Anzeigefenster" welche Kataloggruppenpositionen selektiert / gefiltert wurden.

Mit "deaktivierten Filter" können Sie alle Kataloggruppen des Kataloges anzeigen und die gewünschte Auswählen.

2.7 Positionszusätze und Positionsdetails

Durch Klick auf den Button "Positionsdetails" öffnet sich die abgebildete Maske. Hier können die Positionsfelder Feldweise "klassisch" erfasst und gepflegt werden.
Außerdem können Sie hier Fußnoten in der Fußnotentabelle (Button mit drei Punkten anklicken) erfassen und einzelnen Positionen zuweisen.

Es öffnet sich das hier abgebildete Fenster. Hier können Sie die entsprechenden Fußnotentexte durch Klick auf das Memo-Feld der Fußnotennummer editieren
Anlage eines neuen Fußnotensatzes erfolgt mit der Tastenkombination Strg + T

Achtung: Beachten Sie die Grundeinstellung im Menüpunkt "Programmeinstellung" in der 7.Zeile:
0=benutzt Fußnotennummer wie erfasst; 1=zählt Fußnotennummer je Seite von 1 ab hoch.

2.8 Katalogverwaltung

Achtung: Bei den Funktionen "Speichern unter" oder "Öffnen" auf KL-Katgen-interne Dateien und Designs, auf die sofort oder später wieder zugegriffen werden soll, muss das KL-Katgen Installationsverzeichnis als Speicherort gewählt werden.

2.8.1 Speichern des fertigen Kataloges

Da KL-KatGen die Daten im ausgewählten Katalog sofort aktualisiert, ist ein Speichern des Kataloges nicht erforderlich. Sie haben jedoch die Möglichkeit beliebig viele Kataloge/Preislisten mit unterschiedlicher Darstellung und unterschiedlichen Inhalten zu erstellen und zu verwalten.

Mit dem Menüpunkt "Katalog Speichern unter" zu finden im Menü "Katalogdaten verwalten", öffnet sich ein Fenster und Sie können den bearbeiteten Katalog unter neuem Namen speichern.

Achtung!!! KL-KatGen aktualisiert die Daten sofort im ausgewählten Katalog. Legen Sie gegebenenfalls eine Sicherungskopie an, indem Sie den Katalog unter einem anderen Namen speichern.

2.8.2 Katalog unter anderem Namen speichern

Funktion "Katalog Speichern unter" (Hauptmenü à Kataloge und Daten Verwalten à Katalog Speichern unter)

Es öffnet sich das Standardauswahl/-eingabe Fenster. Das Programm erwartet die Eingabe eines frei wählbaren Katalog-(Datei)-Namens, die Endung ".prl" wird vom Programm automatisch angefügt.

2.8.3 Bearbeiten eines vorhandenen Kataloges

Zum Bearbeiten eines bereits gespeicherten Kataloges ist der gewünschte Katalog über das Hauptmenü unter (Hauptmenü à Kataloge und Daten verwalten à Katalog Öffnen) .

Es öffnet sich das Standardauswahl/-eingabe Fenster. Das Programm erwartet die Auswahl eines der angezeigten Kataloge.

Ebenso können im Fenster "Kataloge - Druck und Design" (siehe im Kapitel " Kataloge Drucken und Design verwalten") andere Kataloge ausgewählt werden.

2.8.4 Katalog Daten Löschen (Datei leeren)

Diese Programmfunktion löscht, nach Bestätigung ob Sie sicher sind, die Daten aus dem aktuellen Katalog. Gelöscht werden Kataloggruppen einschl. der zugeordneten Positionen. Die leere Katalogdatei bleibt für die Bearbeitung erhalten. Artikeldatei und die für diesen Katalog erfassten Überschriften bleiben erhalten.

2.8.5 Katalog Dateien Löschen

Funktion "Katalog Datei Löschen " (Hauptmenü à Kataloge und Daten Verwalten à Katalog Datei Löschen)

Die archivierten Preislisten /Kataloge werden in einem Auswahlfenster angezeigt ("xxx.prl Dateien"). Der gewünschte Katalog kann ausgewählt und gelöscht werden. Gelöscht wird, nach Bestätigung, dass Sie sicher sind, der komplette Katalog (Dateien). Die Artikeldatei und die für diesen Katalog erfassten Überschriften bleiben erhalten.

Der aktuell im Zugriff befindliche Katalog kann nicht gelöscht werden.

2.9 Zusatzmodul SK (Option, nicht in der Basislösung)

Mit dem Zusatzmodul "SK" erzeugen Sie kundenindividuelle oder aktionsbezogene Kataloge und Preislisten aus bereits vorhandenen Katalogdaten. Bestimmen Sie, welche Artikel, Artikelgruppen zu welchen Preisen aus diesen Daten gedruckt werden. Hinterlegen oder importieren Sie dazu die individuelle Preisfindungsalgorithmen wie Kundengrundrabatt, Kundengruppenkonditionen bis hin zu Artikeleinzelpreise. Legen Sie Aktionszeiträume für einzelne Artikel, Artikelgruppen und Kundengruppen fest und drucken Sie Kataloge und Preislisten aus den vorhandenen Katalogdaten ohne diese ändern zu müssen.

Individualkataloge, Kunden- / Aktionskataloge aus bestehenden Katalogen (Katalogdaten) erstellen.
Ist der Kunde einer bestimmten Kundengruppe zugeordnet, oder sollen bestimmte Artikel / Artikelgruppen nicht in "seinem Katalog" erscheinen, können Sie dies mit KL-KatGen schnell und einfach aus Ihrem bestehenden "Standard Katalog" realisieren.

Flyer, Sonderkataloge und Angebotsergänzungen manuell mit "Spezialpreisen" neu erstellen.
Aber auch bei der manuellen Neuerstellung eines Kataloges kann die individuelle Preisermittlung genutzt werden. Räumen Sie Ihrem Kunden für eine Artikelgruppe einen Rabatt ein, weil er einer bestimmten Kundengruppe angehört oder gibt es zur Zeit einen Aktionspreis für einen einzelnen Artikel. So kann dies bei der Erfassung eines neuen Kataloges, Preisblattes oder eines Aktionsflyers entsprechend automatisiert errechnet werden.

Automatische Preisänderungen in den Katalogdaten unter Berücksichtigung der hinterlegten Preisfindungsalgorithmen.
Die Preise in den Katalogdaten können automatisiert modifiziert werden. Die Neuberechnung kann dabei sowohl aus den Preisen der Artikelstammdaten, als auch aus den Preisen in den Katalogdaten erfolgen.

KL-KatGen ermittelt Aktions- / Kundenpreise wie folgt:

Ausgehend von einem Basispreis, bestimmt durch die zugeordnete Preisgruppe im Kunden-/Aktionsstammsatz ( leer bzw. 0 = 1 ) wird der neue Preis ermittelt. Diese zugeordnete Preisgruppe kann in den einzelnen Sonderkonditionen für einzelne Artikel/Artikelgruppen oder Kundengruppen übersteuert werden.
Nach folgender Reihenfolge prüft das Programm die Sonderkonditionen, wobei die jeweils letzte Kondition die vorherige übersteuert. Für die Neuberechnung wird immer vom Basispreis oder vom vorgegebenen Einzelpreis (=SK-Artikelpreis) ausgegangen:

Kondition für

1.

Kunden-/ Aktionsgrundrabatt

Basispreis abzüglich Kunden-/Aktionsgrundrabatt
(aus Kunden-/Aktionsstammsatz)

2.

Artikelgruppe

Basispreis abzüglich Artikelgruppenrabatt

3.

Kundengruppe / Artikelgruppe Artikelgruppe

Basispreis abzüglich Kundengruppen-Artikelgruppenrabatt

4.

Kunde / Artikelgruppe

Basispreis abzüglich Kunden-Artikelgruppenrabatt

5.

Artikel

SK-Artikelpreis oder Basispreis abz. Artikelrabatt

6.

Kundengruppe / Artikel

SK-Artikelpreis oder Basispreis abz. Kundengruppenartikelrabatt

7.

Kunde / Artikel

SK-Artikelpreis oder Basispreis abz. Artikelrabatt

Weitere detaillierte Informationen zur Anlage und Pflege von Sonderkonditionen entnehmen Sie bitte den Kapiteln "Kundenstamm / Aktionsstamm verwalten" bzw. "Sonderkonditionen verwalten" sowie "Kundengruppen verwalten" bzw. "Artikelgruppen verwalten"

2.9.1 Individualkataloge, Kunden- / Aktionskataloge aus bestehenden Katalogen (Katalogdaten) erstellen

Im Register "Preisoptionen" im Programmteil "Druck und Design" stehen verschiedene Optionen für den Katalogdruck und für die automatische Preisermittlung zur Verfügung.

2.9.1.1 Gesamtkatalog mit Sonderkonditionen

Aus den aktuellen Katalogdaten wird ein Katalog mit allen Artikeln des Kataloges* mit den individuellen Preisen eines Kunden oder einer Aktion erstellt. Die notwendigen Preisinformationen sind in den "Sonderkonditionen" zu hinterlegen.

Das Hinterlegen der Sonderkonditionen wird nachfolgend unter "Verwalten der Kunden-/ Lieferanten-/Aktionskonditionen" im Detail beschrieben

* nicht einbezogen in die Verarbeitung sind Katalogpositionen, die selektiert und "ausgefiltert" wurden oder durch Eingrenzung "Kataloggruppe von – bis" nicht angesprochen werden. Details dazu finden Sie unter "Drucken von Teilbereichen eines Kataloges" (unter "Druck und Design") und unter "Kataloggruppenselektion / Kataloggruppen filtern".

2.9.1.2 Kunden- / Aktionskatalog mit Sonderkonditionen

.

Aus den aktuellen Katalogdaten wird ein Katalog mit den für einen Kunden bzw. für eine Aktion vorgesehenen Artikel* / Artikelgruppen unter Berücksichtigung der individuellen Preise erstellt.

Mit dieser Option können auf einfache Art kundenspezifische bzw. zielgruppenorientierte Preislisten aus einem (Haupt-/Gesamt-)Katalog erzeugt werden

Welche Artikel / Artikelgruppen gedruckt werden sollen, ist in den "Sonderkonditionen" zu hinterlegen (auch ohne Preise oder Rabatte). Sind in den Sonderkonditionsdaten Preise und Rabatte hinterlegt finden diese Berücksichtigung.

Das heißt, es werden nur die Artikel des aktuellen Kataloges berücksichtigt, die in den Artikel- / Artikelgruppen-Konditionen, die für den Kunden bzw. der entsprechenden Kundengruppen des Kunden hinterlegt wurden. Z.B. werden durch Erfassen einer "Sonderkondition" für den Kunden und der entsprechenden Artikelgruppe ohne Preis-/Rabattangaben alle Artikel der angesprochenen Artikelgruppe gedruckt.

Unbeachtet bleiben reine Artikel/Artikelgruppen Konditionen ohne Kundenbezug.

2.9.1.3 Kunden- / Aktionskatalog mit Listenpreisen

Aus den aktuellen Katalogdaten wird ein Katalog mit den für einen Kunden bzw. für eine Aktion vorgesehenen Artikel* / Artikelgruppen erstellt. Über die Preisauswahl ist der anzudruckende Preis "Preis 1" bis "Preis 5" bzw. "Wert 1" bis "Wert 5" aus der Artikelstammdatei zu bestimmen. Mit Auswahl der Option "Prgr" berücksichtigt das Programm die Preisgruppenzuordnung im Kunden-/Aktionsstammsatz bzw. in den entsprechenden Sonderkonditionen (Preisauswahl aus Artikelstamm aufgrund der "gefundenen" Preisgruppe).

Welche Artikel / Artikelgruppen gedruckt werden sollen, ist in den "Sonderkonditionen" zu hinterlegen (auch ohne Preise oder Rabatte). Sind in den Sonderkonditionsdaten Preise und Rabatte hinterlegt finden diese keine Berücksichtigung.

2.9.1.4 Katalog mit den Artikeln eines oder mehrerer bestimmter Lieferanten

Analog zu den zuvor beschriebenen Varianten können auch Kataloge mit Artikeln bestimmter Lieferanten aus einem Gesamtkatalog erzeugt werden. Dazu ist ein "Pseudo Kunden-Aktionsstammsatz" mit den entsprechenden Konditionssätzen anzulegen.

"Drucke nur Sonderkonditionsartikel"

Mit Auswahl dieser Option werden nur die Artikel gedruckt, die in der Sonderkonditionsdatei für den in Preisoptionen ausgewählten Kunden spezifiziert wurden und wo der ermittelte Sonderkonditionspreis vom Basispreis (Preis entsprechend der Preisgruppe) abweicht. Unberücksicht bleibt dabei ein eventueller Kundengrundrabatt.

Aktionszeitraum von-bis

Hier wird der Zeitraum definiert, in dem die Preise einer Aktion, einer Preisliste oder eines Kataloges gültig sein sollen. Mit der Option "Preise müssen im gesamten Zeitraum gültig sein" legen Sie zusätzlich fest ob es ausreichend ist, wenn lediglich Beginn oder Ende einer zeitlich begrenzten Sonderkondition in den Aktionszeitraum fällt oder ob der "Sonderpreis" über den gesamten Aktionszeitraum gültig sein muss.

Treffen die gewählten Bedingungen nicht zu, kommt der Basispreis (Preis entsprechend der Preisgruppe) unter Berücksichtigung eines eventuellen Kundengrundrabatts zum Tragen.

2.9.2 Automatische Preisänderung über Sonderkonditionen

2.9.2.1 Katalogdatenaktualisierung

Die aktuellen Preise der Artikeldatei können unmittelbar vor (beim) Drucken in die Katalogpositionen übernommen werden.

ACHTUNG:

Beachten Sie, dass durch Anwahl dieser Option nicht nur die Preise sondern auch weitere Datenfelder in den Katalogpositionen automatisiert geändert werden können.

Prüfen Sie daher in der "Update-Steuerung" welche Felder aktualisiert werden .

In Verbindung mit der "autom. Preisermittlung / Kunden / Aktionskataloge" besteht zusätzlich die Möglichkeit die Preise für einzelne Artikel oder Artikelgruppen automatisiert neu zu berechnen und diese Preise dauerhaft in die Katalogpositionen zu übernehmen.

Die Preise in der Artikeldatei bleiben dabei unverändert.

Anzeige Preisprotokoll, Druck Preisprotokoll

Vor dem Katalogdruck bzw. vor der Preisaktualisierung können in einem Protokoll die Werte und deren Herkunft nochmals überprüft werden.

Angezeigt / gedruckt werden folgende Informationen:

Kataloggruppenummer

Artikelnummer

Artikelbezeichnung

der "neue" Preis

der Basispreis

die Preisherkunft (über Sonderkonditionen)

GR Kunden-Grundrabatt

AG Artikelgruppenkondition

AR Artikel

KG/AR Kundengruppen- / Artikelkondition

KD/AG Kunden-/Artikelgruppenkondition

KG/AR Kundengruppen-/Artikelkondition

KD/ AR Kunden-/Artikelkondition

Welcher Preis wurde als Basispreis herangezogen:

S Preis ermittelt über Sonderkonditionen

A Preis aus Artikel

P Preis aus Katalogposition

AP Preis aus Katalogposition da kein Artikelstammsatz vorhanden

K0 bis 5 abweichende Preisgruppe 0 bis 5 (gewählt über Sonderkonditionen)

ACHTUNG:

Beim Druck / bzw. bei Übernahme mit Preisen aus der Artikeldatei werden, wenn der in der Katalogposition angegebene Artikel nicht in der Artikeldatei vorhanden ist, der Preis der Positionsdatei für die Bearbeitung zu Grunde gelegt. Im Protokoll sind fehlende Artikel in der letzten Spalte mit rot "PA" gekennzeichnet.

2.9.2.2 Automatische Preisermittlung bei der manuellen Erfassung eines Kataloges

Flyer, Sonderkataloge und Angebotsergänzungen manuell mit "Spezialpreisen" neu erstellen

KL-KatGen bietet die Möglichkeit Kataloge unter Berücksichtigung der Sonderkonditionen manuell zu erfassen. Diese Variante ist insbesondere interessant um schnell Kataloge und Flyer mit einer geringeren Anzahl von Positionen in einem neuen Katalog zusammenzustellen, wobei KL-KatGen automatisiert im Hintergrund die gewünschten Preise ermittelt oder heranzieht.

1. Erfassen Sie einen Kunden-/ Aktionsstammsatz (=Pseudokunde in der Kundenstammdatei)

und ordnen Sie diesem die gewünschten Konditionen / Preise zu (Details unter "Kundenstamm" und " Sonderkonditionen") zu.
Zusätzlich können Sie auch weitere Sonderkonditionen und Preise artikel- und kundengruppenbezogen unter "Sonderkonditionen verwalten" erfassen. (Achtung diese nicht kunden-/aktionsspezifischen Konditionen sind auch für andere Kunden-/Aktionen gültig !!! )

2. Eröffnen Sie einen neuen Katalog ("Kataloge und Daten verwalten").

3. Aktivieren Sie im Menü "Extras" die "Aktions-/Sonderpreiskatalogerfassung"

und wählen Sie die gewünschte "Aktion" / den Kunden.

4. Erfassen Sie nun die gewünschten Kataloggruppen und Positionen

Das Programm berücksichtigt nun bei der manuellen Erfassung der Katalogposition die hinterlegten Konditionen.

ACHTUNG:

Die automatische Preisermittlung erfolgt nur solange das Fenster "Aktions-/Sonderpreiserfassung" geöffnet ist.

2.9.3 Automatische Preisänderungen in den Katalogdaten unter Berücksichtigung der hinterlegten Preisfindungsalgorithmen.

Die Preise in den Katalogdaten können automatisiert modifiziert werden. Die Neuberechnung kann dabei sowohl aus den Preisen der Artikelstammdaten, als auch aus den Preisen in den Katalogdaten erfolgen.

Preisauswahl
Welche Preise sollen in den aktuellen Katalog übernommen werden.
- Preise aus der KL-KatGen-Artikeldatei oder
- Preise aus der Katalog-Positionsdatei

automatische Preisermittlung / Kunden-/Aktionskataloge
Wählen Sie
- Gesamtkatalog mit Sonderkonditionen und
- einen Kunden bzw. eine Aktion
- den Gültigkeitszeitraum

Updatesteuerung
Prüfen Sie in der Updatesteuerung welche Felder aktualisiert werden sollen

Anzeige / Druck des Preisprotokoll
Vor der Aktualisierung der Katalogdaten sollten die neuen Preise und der Preisfindungsweg geprüft werden.

Katalogdatenaktualisierung
Wählen Sie
- Katalogdaten werden aktualisiert

2.10 Der Datenimport

Schaffen Sie Voraussetzungen in Ihrem Warenwirtschaftssystem

Das "Ideal", die vollautomatische Katalogerstellung

Primäres Ziel von KL-KatGen, ist das weitgehendst automatisierte Erstellen und Pflegen von Printkatalogen. Daten dafür sollten möglichst zentral erfasst und verwaltet werden. Insbesondere wenn es um die Aktualität des Datenbestandes und hier in erster Linie der Preise geht, bietet sich in der Regel das hausinterne Warenwirtschaftssystem als Datenquelle mit den entsprechenden Artikelstammdaten an.

In den meisten Fällen jedoch verfügen Warenwirtschaftssysteme über "gewachsene Strukturen", und somit über kein einheitliches Nummernsystem.

Vorausgesetzt die Möglichkeit besteht, sollte daher geprüft werden, in wie weit sich der einmalige Aufwand lohnt, entsprechende Informationen bereits in den Artikelstammdaten des Warenwirtschaftssystems, ggflls.in einem separaten Datenfeld bzw. in mehreren Datenfeldern zu hinterlegen, die es erlauben, zukünftig Kataloge immer vollautomatisch, komplett neu, ohne dass ein Nachbearbeiten notwendig wird, mit KL-KatGen zu erstellen.
Je mehr und detaillierter die zur Verfügung stehenden Daten sind, um so besser und aussagefähiger kann KL-KatGen automatisiert Kataloge erzeugen
Aber auch "halbautomatisch" kommen Sie schnell zum Ziel

Lassen sich in Ihrem Warenwirtschaftssystem nicht die "idealen" Voraussetzungen für eine vollautomatische Katalogerstellung schaffen, wird Ihnen KL-KatGen dennoch bei der Erstellung und Pflege Ihrer Kataloge eine wesentliche Hilfe sein.

Importieren Sie Ihre Katalogdaten in die KL-KatGen eigene Artikelstammdatei und "Klicken" Sie von dort Ihren Katalog einfach und schnell zusammen. Einmal erstellt, müssen Sie danach nur noch eventuelle neue Artikeldaten ergänzen. Auf Wunsch aktualisieren sich die Preise dann zukünftig von selbst.

2.10.1 Der Datenimport im Überblick

KL-KatGen verfügt über leistungsstarke Datenimportfunktionen, die es Ihnen erlauben, schnell und einfach Artikeldaten aus einem oder mehreren Fremdsystemen zu importieren. Zu unterscheiden sind hierbei die unterschiedlichen Zielsetzungen bei der Verwendung der Importdaten.

Datenimport zur Erstellung eines neuen Kataloges

Datenimport zur Aktualisierung vorhandener Katalogdaten

Datenimport zur Aktualisierung / Erzeugung der Artikelstammdaten in KL-KatGen

Die Importfunktionen im Überblick

Die Abbildung auf der Seite zuvor zeigt die verschiedenen Wege zur Erzeugung der für den Katalogdruck notwendigen Daten. Zielsetzung von KL-KatGen ist es, den Aufwand für das Erstellen und Pflegen von Katalogen und Preislisten weitgehendst zu automatisieren und im Idealfall vollautomatisch zu realisieren. Auch wenn Letzteres nicht immer sofort und erst nach einer "Bereinigung / Ergänzung der Ursprungsdaten" (z.B. der Daten in Ihrem Warenwirtschaftssystem) zu erreichen ist, können durch den Einsatz von KL-KatGen, unabhängig von der Arbeitsweise, Aufwand und Kosten für die Katalogerstellung minimiert werden.

Manuelles Erfassen der Katalogdaten

Bei dieser Vorgehensweise werden die Kataloggruppen und Katalogpositionen direkt in der KL-KatGen Grundmaske manuell erfasst. Es erfolgt kein Zugriff auf bereits hinterlegte Daten.

Dieses Verfahren ist nur dann sinnvoll, wenn sich die Artikeldaten eines Kataloges zukünftig nicht mehr ändern oder diese nur einmalig benötigt werden, oder um schnell einen kleinen Katalog oder eine Preisliste zu erstellen.

Manuelles Erfassen der Katalogdaten mit Zugriff auf KL-KatGen Artikelstammdaten

Bei dieser Vorgehensweise werden die Kataloggruppen und Katalogpositionen ebenfalls direkt in der KL-KatGen Grundmaske manuell erfasst. Hier jedoch kann der Anwender die in KL-KatGen (zuvor erfassten bzw. importierten) vorhandenen Artikelstammdaten nutzen.
Beim Erfassen der Katalogdaten werden die gewünschten Artikelinformationen nach Eingabe der Artikelnummer bzw. nach Auswahl in der Artikelanzeige direkt in die Katalogposition übernommen.

Voraussetzung ist, dass entsprechende Artikelstammdaten in KL-KatGen manuell erfasst oder durch Datenimport erzeugt wurden.

Wesentliche Vorteile dieser Arbeitsweise sind die Mehrfachnutzung der Artikelstammdaten, das schnelle Erstellen kleiner Kataloge und Flyer und vor Allem die Möglichkeit der automatisierten Preisaktualisierung beim Drucken.

Datenimportfunktionen

Mit der Programmfunktion "DatenImport" werden im Wesentlichen drei Aufgaben abgedeckt:

· Automatische Katalogerstellung mit Daten direkt aus einer externen Importdatei

· Datenimport nach der Artikelstammdatei aus einer externen Importdatei

· Automatische .Katalogerstellung mit Daten aus der KL.KatGen-Artikelstammdatei

Beim Datenimport erlaubt KL-KatGen sowohl die Katalogdaten, als auch die KL-KatGen-Artikelstammdatei mit Daten aus einer Importdatei (z.B. bereitgestellt aus Ihrem Warenwirtschaftssystem) automatisch zu erstellen bzw. zu aktualisieren.

Ob die automatische Katalogerstellung sinnvoll möglich ist, hängt im Wesentlichen von den Anforderungen des Kataloges und von der Güte der bereitgestellten Daten ab. Meistens können mit geringen Korrekturen (z.B. Ergänzungen der Artikelstammdaten in Ihrem Warenwirtschaftssystem) die Importdaten soweit "verbessert" werden, dass mit "diesem" einmaligen Aufwand Kataloge zukünftig immer vollautomatisiert "in Minuten" erzeugt werden können. Damit dieses Ziel erreicht werden kann, stehen zahlreiche Funktionen (Textkonvertierung, Zufallsüberschriften, Datensortierung und Gruppierung usw.) zur Verfügung.
Diese können beim Datenimport genutzt werden und im Hintergrund ablaufen.
Eine detaillierte Beschreibung dieser Funktionen finden Sie auf den nachfolgenden Seiten

Die Tabelle "FaArtikel"

Nur die Importdaten, die in die Katalogdatei und/oder in die Artikelstammdatei übernommen werden, können in KL-KatGen nachbearbeitet werden.

Zusätzlich erzeugt KL-KatGen beim Import die Tabelle "FaArtikel", die alle Daten der Importdatei (d.h. die Datenfelder Ihrer Importdatei) "KL-KatGen verarbeitbar" beinhaltet. Diese Daten stehen beim Katalogdruck (verknüpft über die Artikelnummer) zusätzlich zu den KL-KatGen Daten zur Verfügung und können im Designer mit "FaArtikel.xxx" (xxx steht für Name des Tabellenfeldes) angesprochen werden.
Somit können Sie alle benötigten Daten aus "Ihrer Datei" auch im Berichtsdesigner und somit beim Katalogdruck verwenden.

Die Namen der entsprechenden Tabellenfelder können Sie in der Strukturverwaltung, in der Spalte "Feldnamen" ersehen und abändern.

2.10.2 Der Datenimport Schritt für Schritt

(Kurzbeschreibung)

Für den "Standard-Datenimport" sind nur wenige einfache Kenntnisse und Eingaben erforderlich. Zum besseren Verständnis haben wir uns daher an dieser Stelle darauf beschränkt. KL-KatGen verfügt jedoch über eine Vielzahl von Zusatzfunktionen die beim Datenimport genutzt werden können.

Die detaillierte Beschreibung dieser Funktionen und Arbeitsweisen finden Sie weiter unten im Kapitel "Der Datenimport im Detail".

Der Datenimport Schritt für Schritt

1. Sicherungskopie des zu ändernden Kataloges und der Artikeldatei erstellen

2. Einrichten der Importschnittstelle (Struktur festlegen)

3. Abstimmen / Prüfung der Datenaktualisierung (Update-Steuerung)

4. Sichtprüfung mittels Importtest

5. Starten des Datenimports (Ausführen)

2.10.2.1 Sicherungskopie des zu ändernden Kataloges und der Artikeldatei erstellen

Sicherungskopie der Katalog- und Artikeldaten erstellen

Aufgrund der komplexen Import-Steuerungsmöglichkeiten von KL-KatGen empfehlen wir zur Vermeidung ungewollter Ergebnisse, vor der Bearbeitung mit der Funktion "Katalog speichern unter" eine Sicherungskopie des Kataloges anzulegen.

Das Aktualisieren der Katalogdaten kann außer beim Direktimport auch beim Drucken bzw. bei der Druckanzeige der Kataloge erfolgen. Eventuelle manuelle Korrekturen in den Katalogdaten können daher auch dabei durch ungewolltes Überschreiben verloren gehen.
Überprüfen Sie daher immer die entsprechenden "Update-Einstellungen".

Alternativ können Katalog- und Artikeldaten temporär gesichert werden:

Wählen Sie zum temporären Sichern des Kataloges

im Hauptmenü à Kataloge und Daten verwalten à Katalog speichern unter

Wählen Sie zum temporären Sichern der KL-Katgen internen Artikeldatei

Im Hauptmenü à Kataloge und Daten verwalten à Artikeldatei sichern.

Empfohlene Vorgehensweise beim ersten Katalog:

Sollten Sie noch keinen eigenen Katalog erzeugt bzw. erfasst haben, das heißt, bei dem aktuellen Katalog handelt es sich um einen bei der Programminstallation mitgelieferten Beispielkataloge, empfehlen wir über die Funktion im Hauptmenü à Kataloge und Daten verwalten à Katalog neu einen neuen Katalog unter einem aussagefähigen Namen ihrer Wahl anzulegen.

Der nächste Schritt wäre, die Artikeldatei mit den Demo-Daten unter einem anderen Namen zu speichern, um diese nicht mit Ihren Artikeldaten zu mischen und um auch später auf diese Demodaten zugreifen zu können, um eventuell etwas nachsehen bzw. nachvollziehen zu können.

Wir empfehlen hierzu folgende Vorgehensweise:

Im Hauptmenü à Kataloge und Daten verwalten à Artikeldatei speichern unter

vergeben Sie hier einen Namen wie z.B. "Artikel-Demo" um auch später zu erkennen, dass es sich hierbei um Test- oder Demodaten handelt.

Achtung: Bei Funktion "Speichern unter" oder "Öffnen" auf KL-Katgen-interne Dateien, auf die sofort oder später wieder zugegriffen werden soll, darf das KL-Katgen Installationsverzeichnis nicht verlassen werden.

Anschließend wählen Sie im Hauptmenü à Kataloge und Daten verwalten à Artikeldatei löschen (Datei leeren).

Für einen späteren Zugriff auf die originalen Demodaten wählen Sie im Hauptmenü à Kataloge und Daten verwalten à Artikeldatei wechseln.

Hier können sie mit der Dateiauswahl die gespeicherte Artikeldatei (in unserem Beispiel "Artikel-Demo") auswählen und somit zuweisen.

2.10.2.2 Aufruf der Funktion "Daten-Import“

Wählen Sie dazu den Punkt "Datenimport" aus dem Menü "Kataloge und Daten verwalten“. Es öffnet sich das Fenster "Daten-Import". Wählen Sie hier die gewünschten Optionen.

Was wollen Sie tun ?

Daten in die Artikeldatei übernehmen / aktualisieren

Wählen Sie diese Option, wenn die Daten nur bzw. auch in die Artikelstammdatei übernommen werden sollen.

Katalogdaten/ aktualisieren

Wählen Sie diese Option, wenn Sie die vorhandenen Daten im Katalog lediglich aktualisieren wollen.
Z.B. neue Preis, es werden keine neuen Positionen gebildet.

Automatische Katalogerstellung

Wählen Sie diese Option, wenn (auch) ein Katalog automatisch erstellt werden soll.

Aus Sicherheitsgründen sind diese beiden Optionen beim Programmstart deaktiviert und es wird bei Auswahl jeweils (einmalig je Datensitzung) das entsprechende "Selektionsfenster" zur Bestimmung der zu aktualisierenden Datenfelder angezeigt. (siehe dazu "Update-Steuerung Steuerung der Datenaktualisierung"). Mit Klick auf die Tasten "Artikel-Update-Steuerung" bzw. "Katalog-Update-Steuerung" können diese Masken manuell aufgerufen werden.

Woher kommen die Daten ?

Aus einer Importdatei

Sollen die Daten aus einer Importdatei (ASCII, CSV-Format) übernommen werden, müssen Pfadnamen und Datenstruktur bekannt sein. In der Strukturverwaltung können diese Definitionen hinterlegt werden, die dann dauerhaft zur Auswahl zur Verfügung stehen.

Aus der KL-KatGen Artikeldatei

Wählen Sie diese Option, wenn ein Katalog aus den Daten der KL-KatGen Artikelstammdatei erstellt werden soll.

2.10.2.3 Die Importstruktur, Konfigurieren der Import-Schnittstelle

(Kurzbeschreibung)

Mit "Klick" auf den Button "Strukturverwaltung" in der Import-Grundmaske" öffnet sich das Fenster "Verwalten der Importschnittstellen" (Importstruktur) (siehe Abbildung).

Hier werden die für den Import einer externen Datei notwendigen Informationen, wie Pfadname der Importdatei, Feldtrennzeichen, Code-Page (=Computer-Zeichensatz) usw. hinterlegt und verwaltet. Es können beliebig viele solcher Definitionen erstellt, dauerhaft im System hinterlegt und wiederholt genutzt werden.

So empfiehlt es sich eventuell für eine Katalogneuerstellung alle Datenfelder und für spätere Preisaktualisierungen lediglich Artikelnummer und Preise in separaten Strukturen anzulegen. Durchaus sinnvoll ist das Anlegen einer separaten Importstruktur auch für Artikeldaten, die Ihnen Ihre Lieferanten zur Verfügung stellen.

Anlegen einer neuen Importstruktur:

Neue Import-Struktur definieren

Um eine neue Schnittstelle (Importstruktur) zu definieren klicken Sie auf den Button "Neue Import-Struktur definieren".

Name der Importstruktur

Erfassen im Feld "Name Importstruktur" einen eigenen aussagefähigen Namen für Ihre Schnittstelle/Struktur.

Auswahl der Importdatei

Wählen Sie die Importdatei aus. Klicken Sie dazu mit der Maus auf den Button mit den drei Punkten hinter dem Eingabefeld um die gewünschte Datei auf Ihrem System zu suchen.

CODE-Page, Feld-, Text- und Dezimaltrennzeichen

Spezifizieren Sie nun, mit welchen Feld- und Texttrennzeichen, mit welchem Dezimaltrennzeichen und mit welcher Code-Page die Datenfelder in Ihrer Exportdatei abgestellt wurden.

Text-Feld-Trenner In der Regel leer oder " (Anführungszeichen)

Feld-Trenner " ; " (Semikolon)

Code-Page 1252 für ANSI.Format (Windows-Format)

850 für ASCII-Format (MS-Dos)

CR im Text (nur beim Import von Textfeldern mit Zeilenschaltungen notwendig)

Befinden sich Zeilenschaltungen (CR = carriage return) in den zu importierenden Textfeldern, ist dies zu kennzeichnen und die Anzahl der Importdatenfelder eines Datensatzes anzugeben.

Zeilenschaltungen befinden sich meistens in längeren Beschreibungsfeldern, und resultieren daraus, dass bei der Erfassung des Textes (z.B. in MS-EXCEL) die Enter-Taste gedrückt wurde.

Die Importfunktion würde den jeweiligen Datensatz nur bis zur ersten Zeilenschaltung importieren und insgesamt ein falsches Ergebnis liefern.

Struktur einlesen

Mit der Taste "Struktur einlesen", werden Ihnen in der zweiten Spalte unter "Feldinhalt" die Inhalte der Datenfelder des ersten Datensatzes der Importdatei angezeigt. Diese Anzeige soll Ihnen helfen die einzelnen Felder zu benennen. Je nach dem, wie die Importdatei erzeugt wurde (z.B. aus MS-EXCEL oder aus einem Warenwirtschaftssystem) können die Feldnamen auch bereits im ersten Datensatz der Importdatei abgestellt worden sein. In diesen Fällen kann Ihnen KL-KatGen nach Wahl der Option "Feldnamen im ersten Datensatz" die Namen in der dritten Spalte "Feldname" anbieten. Wenn nicht alle Feldnamen den KL-KatGen Konventionen entsprechen, werden diese automatisch angepasst bzw. ersetzt.

· Die Spalte " Feldname"

Die von KL-KatGen übernommenen bzw. erzeugten Feldnamen können bei Bedarf umbenannt werden. Unter diesem Namen können die entsprechenden Daten später im Berichtsdesigner angesprochen und gedruckt werden. Datenfelder denen Sie keine Referenz zuweisen (siehe nächsten Punkt), werden dabei nicht direkt in die Katalogdaten übernommen, sondern stehen Ihnen lediglich in der Tabelle "FaArtikel" verknüpft über die Artikelnummer zur Verfügung. Angesprochen werden diese Datenfelder im Berichtsdesigner mit "FaArtikel.xxx" (xxx=Feldname). Bei Namensvergabe sind bestimmte Konventionen zu beachten, Details dazu finden Sie unter Punkt "Der Datenimport im Detail"

· Die Spalte "Referenz"

Bestimmen Sie nun, in welche Datenfelder von KL-KatGen und somit in die Katalogdaten und ggflls. Artikeldatei die einzelnen Feldinhalte der Importdatei zu übernehmen sind.

Durch "Maus-Klick" in die Spalte "Referenz", der relevanten Zeile, können Sie aus dem sich öffnenden Auswahlfenster das entsprechende "KL-KatGen-Datenfeld" (und somit die Feldbezeichnung) zuordnen.

In dem abgebildeten Beispiel wurde z.B. unter der laufenden Nummer 2 die Bezeichnung aus dem ersten Importdatensatz "BEZEICHNUNG" angeboten. Über das Referenz-Auswahlfenster wurde mit dem Begriff "Artikelbezeichnung 1" der KL-KatGen-interne Feldname "artbez1" diesem Datenfeld zugewiesen.

Das einzige Feld das zugewiesen werden muss ist die "Artikelnummer".

Für Ihren ersten Test empfehlen wir entsprechend unserem Beispiel die Felder "Artikelnummer", "Artikelbezeichnung 1", "Artikelbezeichnung 2" und "Preis 1" den Importdaten (vorausgesetzt dass diese dort verfügbar sind) zuzuordnen und diese in Ihren "ersten Katalog" zu übernehmen.

2.10.2.4 Sortierung / Gruppierung

Ermöglicht sortierten Artikelimport mit Gruppierungsmöglichkeit. Durch Angabe eines oder mehrerer Datenfelder kann die Sortierung der Schnittstellendaten bei der Kataloganlage beeinflusst werden. Zum Beispiel kann eine Sortierung nach Artikelgruppe und Artikelnummer sinnvoll sein.

Eine Gruppierung könnte nach einem Teil (z. B. den ersten 5 Stellen) der Artikelnummer erfolgen, um die automatische Kataloggruppenanlage zu erleichtern.

In der Abbildung oben ist eine Gruppierung nach Bildnamen vorgesehen, d.h. alle Artikel mit dem gleichen Bild werden in eine Kataloggruppe importiert.

Weiterführende, detaillierte Informationen über Steuerungsmöglichkeiten, Sortierung, Gruppierung und integrierte automatische Funktionen beim Datenimport finden Sie im Kapitel "Der Datenimport im Detail".

2.10.2.5 Importstruktur (Erweiterungen)

· Konvertiervariante
Auswahl eventueller kundenindividueller Importlösungen (kein Standard)

· Import von Zusatzüberschriften und Zusatztexten
Details siehe " Datenimport im Detail" -> "Automatische Überschriftenerzeugung"

· EOF-Satz

Fügt einen leeren Datensatz EOF() an die Importdatei an.

· Konvertierzusatzbefehle

Hier können Befehle hinterlegt werden, die bei dem Datenimport ausgeführt werden.
Details siehe Folgeseiten

· Werte Textkonvertierung

Automatisierte Änderung und Ergänzung der Importdaten.

· Erweitert

Automatisierte Korrektur der Nachkommastellen der Wertfelder bei bestimmten Datenformaten..

· Anzeige CSV-Datei

Kontrollanzeige der Importdaten (Quelle)

Weiterführende, detaillierte Informationen über Steuerungsmöglichkeiten, Sortierung, Gruppierung und integrierte automatische Funktionen beim Datenimport finden Sie im Kapitel "Der Datenimport im Detail".

2.10.2.6 Datenaktualisierung beim Datenimport (Update-Steuerung)
(Kurzbeschreibung)

Mit "Maus-Klick" auf die Tasten "Artikel-Update-Steuerung" bzw. "Katalog-Update-Steuerung" öffnen sich die entsprechenden Fenster.

(Aus Sicherheitsgründen, um ein versehentliches Überschreiben von Daten zu verhindern, öffnen sich diese Fenster auch bei der Anwahl der Funktionen " Daten in die Artikeldatei übernehmen / aktualisieren" bzw. " Automatische Katalogerstellung" automatisch, einmalig je Datensitzung.)

ACHTUNG: Vor dem Starten des Datenimports sollte immer geprüft werden, welche Datenfelder automatisiert aktualisiert werden.

In der Updatesteuerung wird festgelegt, welche Daten beim Datenimport zu aktualisieren sind.

Datenimport in die Katalogdaten

Beim Datenimport in die Katalogdaten (Katalogerstellung-/Aktualisierung) aus einer externen Importdatei werden grundsätzlich nur die in der Importstruktur per Referenz zugewiesenen Datenfelder aktualisiert.

Beim Datenimport in die Katalogdaten (Katalogerstellung-/Aktualisierung) aus der KL-KatGen Artikelstammdatei hingegen, werden alle Werte aktualisiert.

Datenimport in die Artikelstammdatei

Beim Datenimport in die Artikelstammdatei werden grundsätzlich nur die in der Importstruktur per Referenz zugewiesenen Datenfelder aktualisiert.

In den Bildschirmmasken (siehe unten) kann die zuvor beschriebene grundsätzliche Arbeitsweise übersteuert werden. Markieren Sie die Datenfelder, die aktualisiert werden sollen, und löschen Sie Markierungen bei den Datenfeldern deren Inhalt erhalten bleiben soll.

Weiterführende, detaillierte Informationen finden Sie Kapitel "Der Datenimport im Detail".

2.10.2.7 Sichtprüfung mittels Importtest

Vor dem eigentlichen Daten-Import sollte das zu erwartende "Import-Ergebnis" nochmals geprüft werden.

Mit Maus-Klick auf die Schaltfläche "Testen" werden dafür die für die Übernahme aufbereiteten Daten in einem "Browse-Fenster" angezeigt.

Prüfen Sie insbesondere

Feldinhalte hinsichtlich
Vollständigkeit (-> Importstruktur ->Feldlängen)
Nachkommastellen bei numerischen Werten (->Importstruktur ->Erweitert ->Nachkommastellen)
Korrekte Schreibweise der Umlaute und Sonderzeichen (-> Importstruktur ->Codepage).

2.10.2.8 Starten des Datenimports (Ausführen)

Liefert die "Sichtprüfung" ein Ihrer Meinung nach befriedigendes Ergebnis, starten Sie den eigentlichen Datenimport mit "Maus-Klick" auf den Button "Ausführen".

Je nach Anzahl der zu übernehmenden Datensätze und der im Hintergrund ablaufenden Prozesse (Textkonvertierungen, Datenwandlung, -verdichtung usw.) kann dieser Vorgang mehrere Minuten dauern. Die einzelnen Arbeitsschritte werden daher der Transparenz wegen am Bildschirm angezeigt.

Nach Beendigung des Datenimports erhalten Sie in einem Anzeigefenster Informationen über die Anzahl der importierten Datensätze, Gruppierungen, Fehler usw.

anzahl sätze usw

Wurde die Option "Anzeige fehlerhafte Importsätze" gewählt, werden während der Verarbeitung Unstimmigkeiten angezeigt.

In der Regel handelt es sich dabei um Fehler durch "Zeilenschaltungen" (CR) oder "Semikolon" in Textfeldern (;).

Dies kann bedeuten, Sie haben, obwohl "Zeilenschaltungen" in Textfeldern vorhanden sind, nicht die Option "CR im Text" angewählt bzw. es wurde die Anzahl der Importfelder je Datensatz fehlerhaft angegeben.

Eine weitere häufige Ursache für auftretende Fehler beim Import kann sein, wenn das in der "Importschnittstelle" definierte Zeichen für Text-Feld-Trenner (meist "Semikolon") in Textfeldern einzelner Datensätze vorhanden ist.

Oft wird auch der letzte Datensatz der Importdatei als fehlerhaft angezeigt, Dabei handelt es sich in der Regel um den leeren "EOF-Satz" (End off File), was man ignorieren kann.

2.10.3 Der Datenimport im Detail
2.10.3.1 Aufruf der Funktion "Daten-Import“

Wählen Sie die Funktion "Datenimport" aus dem Menü "Kataloge und Daten verwalten“. Es öffnet sich das Fenster "Daten-Import". Wählen Sie hier die gewünschten Funktionen.

'

Was wollen Sie tun ?

Daten in die Artikeldatei übernehmen / aktualisieren

Wählen Sie diese Option, wenn die Daten nur bzw. auch in die Artikelstammdatei übernommen werden sollen.

Katalogdaten/ aktualisieren

Wählen Sie diese Option, wenn Sie die vorhandenen Daten im Katalog lediglich aktualisieren wollen.
Z.B. neue Preis, es werden keine neuen Positionen gebildet.

Automatische Katalogerstellung

Wählen Sie diese Option, wenn (auch) ein Katalog automatisch erstellt werden soll.

Woher kommen die Daten ?

Aus einer Importdatei

Sollen die Daten aus einer Importdatei (ASCII, CSV-Format) übernommen werden, müssen Pfadnamen und Datenstruktur bekannt sein. In der Strukturverwaltung können diese Definitionen hinterlegt werden, die dann dauerhaft zur Auswahl zur Verfügung stehen.

Aus der KL-KatGen Artikeldatei

Wählen Sie diese Option, wenn ein Katalog aus den Daten der KL-KatGen Artikelstammdatei erstellt werden soll.

2.10.3.2 Konfigurieren der Import-Schnittstelle Strukturverwaltung

(Detailbeschreibung)

Mit "Klick" auf den Button "Strukturverwaltung" in der Import-Grundmaske" öffnet sich das Fenster "Verwalten der Importschnittstellen" (Importstruktur) (siehe Abbildung).

Hier werden die für den Import aus einer externen Datei notwendigen Informationen, wie Pfadname der Importdatei, Feldtrennzeichen, Sprachcode usw. hinterlegt und verwaltet. Es können beliebig viele solcher Definitionen erstellt, dauerhaft im System hinterlegt und wiederholt genutzt werden.

So empfiehlt es sich eventuell für eine Katalogneuerstellung alle Datenfelder und für spätere Preisaktualisierungen lediglich Artikelnummer und Preise in separaten Strukturen anzulegen. Durchaus sinnvoll ist dies auch für Artikeldaten, die Ihnen Ihre Lieferanten zur Verfügung stellen.

2.10.3.2.1 Verwalten der Importschnittstellen
"Grundmaske / Schnittstellenbeschreibung"

Anlegen einer neuen Importstruktur: (Importschnittstelle)

Rufen Sie dazu die "Strukturverwaltung" auf. Es erscheint die unten abgebildete Maske.

Um eine neue Schnittstelle zu definieren klicken Sie auf den Button "Neue Import-Struktur definieren".

Neue Import-Struktur definieren

Um eine neue Schnittstelle (Importstruktur) zu definieren klicken Sie auf den Button "Neue Import-Struktur definieren".

Name der Importstruktur

Erfassen Sie im Feld "Name Importstruktur" einen eigenen aussagefähigen Namen für Ihre Schnittstelle/Struktur.

Auswahl der Importdatei

Wählen Sie die Importdatei aus. Klicken Sie dazu auf den Button mit den drei Punkten hinter dem Eingabefeld um die gewünschte Datei auf Ihrem System zu suchen.

CODE-Page, Feld-, Text- und Dezimaltrennzeichen

Spezifizieren Sie nun, mit welchen Feld- und Texttrennzeichen, mit welchem Dezimaltrennzeichen und mit welcher Code-Page die Datenfelder in Ihrer Exportdatei abgestellt wurden.

Text-Feld-Trenner In der Regel leer oder " (Anführungszeichen)

Feld-Trenner " ; " (Semikolon)

Code-Page 1252 für ANSI.Format (Windows-Format)

850 für ASCII-Format (MS-Dos)

Struktur einlesen

Mit der Taste "Struktur einlesen", werden Ihnen in der zweiten Spalte unter "Feldinhalt" die Inhalte der Datenfelder des ersten Datensatzes der Importdatei angezeigt. Diese Anzeige soll Ihnen helfen, die einzelnen Felder zu benennen. Je nach dem, wie die Importdatei erzeugt wurde (z.B. aus MS-EXCEL oder aus einem Warenwirtschaftssystem) können die Feldnamen auch bereits im ersten Datensatz der Importdatei abgestellt worden sein. In diesen Fällen kann Ihnen KL-KatGen nach Wahl der Option "Feldnamen im ersten Datensatz" die Namen in der dritten Spalte "Feldname" anbieten. Da nicht alle Name den KL-KatGen Konventionen entsprechen werden dies eventuell automatisch angepasst.

· Die Spalte " Feldname"

Die von KL-KatGen übernommenen bzw. erzeugten Feldnamen können bei Bedarf umbenannt werden. Unter diesem Namen können die entsprechenden Daten im Berichtsdesigner angesprochen und gedruckt werden. Datenfelder denen Sie keine Referenz zuweisen (siehe nächsten Punkt), werden dabei nicht direkt in die Katalogdaten übernommen, sondern stehen Ihnen lediglich in der Tabelle "FaArtikel" verknüpft über die Artikelnummer zur Verfügung. Angesprochen werden diese Datenfelder im Berichtsdesigner mit "FaArtikel.xxx" (xxx=Feldname).

Bei Namensvergabe sind bestimmte Konventionen zu beachten

maximal 10 Zeichen,

keine Leerstellen, kein Bindestrich im Namen

Name darf nicht mehrfach vorkommen.

Erstes Zeichen muss ein Buchstabe sein

Feldnamen die den o.g. Konventionen nicht entsprechen, werden vom Programm wie folgt behandelt.

Feldnamen mit unerlaubten Zeichen werden nach dem Schema "Feld" plus "Unterstrich" plus "laufende Nummer" belegt. Beispiel: steht über der zweiten Spalte in der Importdatei der Text "Artbez-1" (also ein unerlaubter Bindestrich) so generiert das Programm hieraus den Feldnamen "Feld_2".

Feldnamen, die zu lang sind, werden nach Möglichkeit abgeschnitten und wenn doppelte Namen entstehen in den letzten beiden Stellen hochnummeriert.
Beispiel: Steht über der zweiten Spalte in der Importdatei der Text "Artikelbezeichnung1" und über der dritten Spalte in der Importdatei der Text "Artikelbezeichnung2" (also zu lange Namen UND bis Stelle 10 doppelte Namen) so generiert das Programm hieraus die Feldnamen "Artikelbez" und "Feld_03"

Ist die Feldnamen-Automatik "Feldnamen im ersten Datensatz" nicht aktiviert, generiert das Programm Feldnamen nach dem Schema "Feld" plus "laufende Nummer" , also Feld1, Feld2, Feld3 .... Feld11 usw.

Nach dem Einlesen der Importstruktur, (Button "Struktur einlesen") wird die Tabelle mit den Spalten "lfd.Nr." "Feldinhalt", "Feldname", "Typ", "Dez.St." und "Referenz" mit dem Inhalt des ersten Satzes Ihrer Datei gefüllt.

Feldnamen im ersten Datensatz

Die Option "Feldnamen im ersten Datensatz" bewirkt, dass das Programm beim Einlesen der Struktur (siehe Button "Struktur (erneut) einlesen" am unteren Maskenbereich), die Feldnamen aus "Ihrer" Datei zur Verwendung anbietet.

· Die Spalte "Referenz"

Bestimmen Sie nun, in welche Datenfelder von KL-KatGen und somit in die Katalogdaten und ggflls. Artikeldatei die einzelnen Felder der Importdatei zu übernehmen sind.

Durch "Maus-Klick" in die Spalte "Referenz", der relevanten Zeile, können Sie aus dem sich öffnenden Auswahlfenster das entsprechende "KL-KatGen-Datenfeld" (und somit die Feldbezeichnung) zuordnen.

In dem abgebildeten Beispiel wurde z.B. unter der laufenden Nummer 2 die Bezeichnung aus dem ersten Importdatensatz "BEZEICHNUNG" angeboten. Über das Referenz-Auswahlfenster wurde mit dem Begriff "Artikelbezeichnung 1" der KL-KatGen-interne Feldname "artbez1" diesem Datenfeld zugewiesen.

Das einzige Feld, das zugewiesen werden muss ist die "Artikelnummer".

Für Ihren ersten Test empfehlen wir entsprechend unserem Beispiel die Felder "Artikelnummer", "Artikelbezeichnung 1", "Artikelbezeichnung 2" und "Preis 1" den Importdaten (vorausgesetzt dass diese dort verfügbar sind) zuzuordnen und diese in Ihren "ersten Katalog" zu übernehmen.

Weiterführende Details zu den Referenzfeldern finden Sie nachfolgend unter "Referenzfelder beim Datenimport".

· Schaltflächen "Feld löschen" und "Feld einfügen"

Hiermit können Sie einzelne Felder in der Strukturbeschreibung entfernen bzw. hinzufügen.
Die Funktion "Feld löschen" bezieht sich auf die aktuelle Zeile (eingefärbt).
Die Funktion "Feld einfügen" fügt eine Zeile nach der aktuellen Zeile ein.

Referenzfelder beim Datenimport

Durch Klicken in der Spalte "Referenz" und Auswahl des angezeigten Datenfeldes können Sie bestimmen, in welche Datenfelder von KL-KatGen und somit in die Katalogdaten und ggflls. Artikeldatei die einzelnen Felder der Importdatei zu übernehmen sind.

Das einzige Feld das hierbei zugewiesen werden muss ist die "Artikelnummer". Alle anderen Felder aus der Importdatei können nach dem Import bei Bedarf im Katalog-Designer über den in der Spalte "Feldname" spezifizierten Namen aus der Tabelle "FaArtikel" angesprochen werden (z.B. "FaArtikel.arbez1").

KL-KatGen erzeugt beim Datenimport zusätzlich die "FaArtikel-Tabelle". Die Inhalte dieser Tabelle entsprechen der Import-Datei in "KL-KatGen verarbeitungsfähiger Form", d.h. verknüpft über die Artikelnummer stehen beim Katalogdruck (Designer) alle Datenfelder der "gewandelten" Importdatei zusätzlich zu den "normalen" KL-KatGen-Daten zur Verfügung.

Es ist dennoch zu empfehlen, möglichst viele Felder in die Katalogdaten und Artikelstammdatei zu importieren. Dies hat den Vorteil, dass im KL-Katgen-Verwaltungsprogramm die Kataloggruppen und Positionen zur besseren Kontrolle angezeigt und gegebenenfalls auch manuell nachgepflegt werden können. Dies gilt insbesondere auch beim Import in die Artikelstammdatei. Hier sollten, da auch beim Drucken eine Datenaktualisierung (nur aus der Artikeldatei) gewählt werden kann, die notwendigen Daten übernommen werden (z.B. Preise).

Ihnen fällt vielleicht auf, wenn Sie in der Referenzspalte ein Feld auswählen, dass in der Spalte "Feldname" ein bestimmter, meist kürzerer Name eingestellt wird. Sie wählen z. B. das Feld "preis 1" aus, so erscheint in der Spalte "Feldname" die Bezeichnung "vkbasis" in der Spalte "Typ" "Numerisch" sowie in der Spalte "Dez.St." die Ziffer 3. Dies ist der Programminterne Name, mit dem das Feld im Katalogdesigner angesprochen wird.

Referenzfelder

Feldbezeichnung Feldbezeichnung intern Typ /Länge NK Bemerkung

Artikelbezeichnung 1 artbez1 C 120 a

Artikelbezeichnung 2 artbez2 C 120 a

Artikelgruppe 1 artgr1 C 4

Artikelgruppe 2 artgr2 C 10

Artikelnummer artnr C 30

Bilddatei 1 Name Bild C 60

Bilddatei 2 Name Bild2 C 60 s

Bilddatei 3 Name Bild3 C 60 s

Bilddatei 4 Name Bild4 C 60 s

Bilddatei 5 Name Bild5 C 60 s

Bild 1 Position BildPos C 30 s

Bild 2 Position BildPos2 C 30 s

Bildsteuerung 1 Bild1st C 4 s

Bildsteuerung 2 Bild2st C 4 s

Bildsteuerung 3 Bild3st C 4 s

Bildsteuerung 4 Bild4st C 4 s

Bildsteuerung 5 Bild5st C 4 s

Darstellung darstell C 4 b

Frei 1 F1 C 1

Frei 2 F2 C 1

Frei 3 F3 C 1

Frei 4 F4 C 1

Frei 5 F5 C 1

Frei 6 F6 C 1

Gesperrt bei Import gesperrt C 1 c

Gewicht gewicht N 10 3

Gleiche Kataloggruppe gleicheGrp C 30 d

Gleiche Zeile gleicheZei C 30 d

Kategorie Kategorie C 10 e

Kategoriebezeichnung kategortx C 100 e

KatGruppe KatGruppe C 12 f

KatGruppe-Position KatPosnr C 4 g

KatGruppe-Bez1 separat KGrBez1 C 120 h

KatGruppe-Bez2 separat KGrBez2 C 120 i

KatGruppe-Register sep. KGrRegist C 50 j

KatGruppe-Zusatztext1 KGrZusTx M r

KatGruppe-Zusatztext2 KGrZusTx2 M r

Kataloggruppen Vor-Nr. KatGrVorNr C 3 k1

KatPos-Register separat KPosRegist C 50 k2

Langtext 1 zustext M l

Langtext 2 zustext2 M

Listung 1 listung1 C 10

Listung 2 listung2 C 10

Master 1 master1 C 10 m

Master 1 Bezeichnung mastertx1 C 100 m

Master 2 master2 C 10 m

Master 2 Bezeichnung mastertx2 C 100 m

Master 3 master3 C 10 m

Master 3 Bezeichnung mastertx3 C 100 m

Master 4 master4 C 10 m

Master 4 Bezeichnung mastertx4 C 100 m

Master 5 master5 C 10 m

Master 5 Bezeichnung mastertx5 C 100 m

Master 6 master6 C 10 m

Master 6 Bezeichnung mastertx6 C 100 m

Mehrwertsteuer % mwst N 5 2

Preis 1 vkbasis N 10 3

Preis 2 p2 N 10 3

Preis 3 p3 N 10 3

Preis 4 p4 N 10 3

Preis 5 p5 N 10 3

Preiseinh. 1 preiseinh C 20

Preiseinh. 2 preiseinh2 C 20

Preiseinh. 3 preiseinh3 C 20

Preisgruppe preisgr C 10

Sortierung sortierung C 30 n

SpaltenBedarf apaltenbed N 3 o

Text-Feld 1 t1 C 250

Text-Feld 2 t2 C 250

Text-Feld 3 t3 C 250

Text-Feld 4 t4 C 250

Text-Feld 5 t5 C 250

Text-Feld 1 (254) infotext1 C 254 p

Text-Feld 2 (254) infotext2 C 254 p

Text-Feld 3 (254) infotext3 C 254 p

Text-Feld 4 (254) infotext4 C 254 p

Wert-Feld 1 N1 N 10 3

Wert-Feld 2 N2 N 10 3

Wert-Feld 3 N3 N 10 3

Wert-Feld 4 N4 N 10 3

Wert-Feld 5 N5 N 10 3

Zusatzsteuerung steuerung C 10 q

Steuerfeld1 stf1 C 4

Steuerfeld2 stf2 C 4

Steuerfeld3 stf3 C 4

notierung 1 Basis mnbasis1 N 6 2 r

notierung Mn1 mN1 C 1 r

notierung Schrittweite 1 sw1 N 6 2 r

notierung Zuschlag 1 zu1 N 4 2 r

notierung 2 Basis mnbasis2 N 6 2 r

notierung Mn2 mN2 C 1 r

notierung Schrittweite 2 sw2 N 6 2 r

notierung Zuschlag 2 zu2 N 4 2 r

Erklärung Daten-Typ:

C = Character (also alphanumerisch)

N = Numerisch

M = Memofeld (alphanumerisches Textfeld – Kapazität 64.000 Zeichen)

Beachten Sie, dass numerische Datenfelder keine alphanumerischen Inhalte (keine Buchstaben, Satz- oder Sonderzeichen) aufnehmen können.

Bei alphanumerischen Datenfeldern ist zu bedenken, dass eine eventuelle Sortierung/Reihenfolge über ein solches Feld von links nach rechts erfolgt.

Das heißt beispielsweise, wenn Sie die Kataloggruppe aus einer Schnittstelle verwenden möchten, dass die "10" vor der "2" erscheint. Um Dieses zu umgehen, müssen Sie die Kataloggruppe mit entsprechend vielen Vorlaufnullen in Ihrer Schnittstelle abspeichern.

Beispiel: 000002 erscheint in der Reihenfolge vor 000010

Erläuterung der Referenzfelder mit Zusatzfunktionen beim Import und Druck

Beachten Sie in diesem Zusammenhang, dass jeweils der erste Positionssatz einer Kataloggruppe für die Voreinstellung verschiedener Datenfelder der Kataloggruppe genutzt wird (z.B. Darstellung, Bezeichnung usw.)

a Artikelbezeichnung 1

Artikelbezeichnung 2
Erzeugt das Feld Artikelbezeichnung im Katalog (Positionen)
Erzeugt das Feld Register (Kataloggruppe)

b Darstellung
Die Darstellungsart der Kataloggruppe

c Gesperrt bei Import
Ein Wert in diesem Datenfeld verhindert den Import des kompletten Datensatzes

d Gleiche Kataloggruppe
Aufeinanderfolgende Importdatensätze mit gleichem Inhalt in diesem Datenfeld werden in einer Kataloggruppe zusammengeführt

d Gleiche Zeile
Nur in Verbindung mit Darstellungsart "nnS" (Matrixdarstellung). Aufeinanderfolgende Importdatensätze mit gleichem Inhalt in diesem Datenfeld sollen in einer Zeile in mehreren Spalten dargestellt werden. Das System ermittelt automatisch die Anzahl der Spalten.

e Kategorie

Kategoriebezeichnung
erzeugt beim Import zusätzlich die Kategorietabelle (weitere Details in den Kapiteln "Kategorienermittlung" bzw. "Kategorien-Verwaltung")

f KatGruppe

Die Kataloggruppe bestimmt die Position (Reihenfolge) im Katalog. Wahlweise kann diese beim Import automatisch erzeugt oder in der Importdatei vorgegeben werden.

g KatGruppe-Position

Die Kataloggruppenpositionsnummer bestimmt die Reihenfolge im Katalog. Wahlweise kann diese beim Import automatisch erzeugt oder in der Importdatei vorgegeben werden.

h KatGruppe-Bez1 separat

Ist dieses Feld in der Importdatei vorhanden, wird dessen Inhalt in die Kataloggruppenbezeichnung1 übernommen.

i KatGruppe-Bez2 separat

Ist dieses Feld in der Importdatei vorhanden, wird dessen Inhalt in die Kataloggruppenbezeichnung2 übernommen.

j KatGruppe-Register sep.

Ist dieses Feld in der Importdatei vorhanden, wird dessen Inhalt in den Registerbegriff der Kataloggruppe übernommen.

k1 KatGrVorNr –Katalog-Vornummer

Ein Inhaltswechsel in diesem Importfeld bewirkt einen 1000-Sprung (sonst 10 Schritte) bei der automatischen Kataloggruppen-Nummerierung beim Import.

K2 KatPos-Register separat

Ist dieses Feld in der Importdatei vorhanden, wird dessen Inhalt in den Registerbegriff der Kataloggruppenposition übernommen.

l Langtext 1 und 2

Ist das Feld "Langtext 1" in der Importdatei vorhanden, wird dessen Inhalt in das Feld "Zusatztext" in der Kataloggruppe übernommen.
Das Feld "Langtext 2" würde in die "Katalog-Gruppen-Zusatz-Daten" übernommen.

m Master 1

Master 1 Bezeichnung

Master 2

Master 2 Bezeichnung

Master 3

Master 3 Bezeichnung

Master 4

Master 4 Bezeichnung

Master 5

Master 5 Bezeichnung

Master 6

Master 6 Bezeichnung

erzeugt beim Import zusätzlich die Kategorientabelle (weitere Details in den Kapiteln "Kategorienermittlung" bzw. "Kategorien-Verwaltung")

n Sortierung

o Spalten Bedarf

In Verbindung mit der Darstellungsart "Spaltenmatrix" "02S" bis "30S" kann ein automatischer Spaltenumbruch erfolgen. Details finden Sie unter "automatische Kataloggruppennummern" à "Spaltenbedarf"

p Text-Feld 1 (254)

Text-Feld 2 (254)

Text-Feld 3 (254)

Text-Feld 4 (254)

Übernimmt die vier Datenfelder in das (MEMO-)Feld "Zusatztext" in der "Artikelstammdatei" und / oder der Katalogpositionsdatei und / oder der Kataloggruppendatei

q Zusatzsteuerung

r Notierunng 1 Basis

Notierung Mn1

Notierung Schrittweite 1

Notierung Zuschlag 1

Notierung 2 Basis

Notierung Mn2

Notierung Schrittweite 2

Notierung Zuschlag 2

Beim Druck der Preisliste bzw. dem Katalog werden ausgehend von einer Basisnotierung (Basis), aufgrund der aktuellen Notierung (Mn1. Metallnotierung) unter Berücksichtung von Zuschlägen und Schrittweiten bis zu 22 Preise für die jeweilige Notierung ermittelt.

r KatGruppe-Zusatztext1

KatGruppe-Zusatztext2

Beim Druck der Preisliste bzw. dem Katalog werden ausgehend von einer Basisnotierung (Basis), aufgrund der aktuellen Notierung (Mn1. Metallnotierung) unter Berücksichtung von Zuschlägen und Schrittweiten bis zu

s Bilddatei-Name, Bildsteuerung, Bild1 und Bild2 der Kataloggruppen-Position

Bilddatei-Name 1 bis 5

Bis zu 5 Bilder können je Kataloggruppe hinterlegt werden. In der Bildsteuerung können zusätzliche Parameter erfasst werden, die im Berichtdesigner abgefragt werden können (z.B. Drucke das Bild mit der recheckiger Form, wenn im Steuerfeld "1" steht, quadratisch wenn ein "2" steht.

Bild1 + Bild2 der Kataloggruppe-Position

Bis zu 2 Bilder lassen sich jeder Kataloggruppenposition zuordnen. Werden diese Übergabefelder beim Import genutzt, übernimmt das Programm die Werte (Dateinamen) aus den Feldern "Bilddateiname 1 bis 5" in die Kataloggruppe und die Werte der "Bild1 + Bild2 der Kataloggruppe-Position" in die jeweiligen Positionen.

2.10.3.2.2 Sortierfolgen beim Datenimport

Grundsätzlich wird ein Katalog beim Datenimport, d.h. die Reihenfolge der Kataloggruppen, analog der Reihenfolge der Datensätze der Importdatei aufgebaut.

Davon abweichend kann die Sortierfolge über entsprechende Parameter individuell gesteuert werden.

So kann der Import beispielsweise nach (Teilen) der Artikelbezeichnungen oder der Artikelnummer oder nach Werten anderer Datenfelder oder aus Kombinationen verschiedener Datenfelder sortiert erfolgen.

Sortierfolge nach einem Importfeld

Der gewünschte Sortierbegriff, "Name eines Feldes der Importdatei" (Spalte Feldinhalt) ist im Feld "Sortierbegriff" in der Maske "Verwaltung der Importschnittstellen" zu erfassen (hier z.B. "artbez1").

Sortierfolge nach Kategorie

KL-KatGen bietet die Möglichkeit Kataloge automatisch entsprechend einer von Ihnen vorgegebenen Kategoriestruktur zu erstellen.
Eine entsprechender "Kategoriebaum" kann dabei automatisch aus den Artikel-Importdaten ermittelt.
Alternativ können Sie den "Kategoriebaum " auch manuell erfassen oder separat aus einer ASCII-Datei (CSV) importieren.

Aus folgenden Sortierungsvarianten kann gewählt werden:

- Kategorienummer

- Kategoriebezeichnung

- Kategoriesortiernummer

Detaillierte Informationen finden Sie nachfolgend unter "Automatische Kategorienermittlung",
Darüber hinaus gehende spezielle Informationen für Ihre Anforderungen, erhalten Sie von der KL-KatGen Hotline.

2.10.3.2.3 Automatische Kataloggruppenbildung beim Datenimport

Beim Datenimport können automatisiert Kataloggruppen mit den entsprechenden Kataloggruppenpositionen gebildet werden.Werden die Kataloggruppennummern nicht in der Schnittstellendatei mitgeliefert, vergibt KL-KatGen die Kataloggruppennummern, ausgehend von einem hinterlegten Wert (Zähler, siehe "Verwalten Steuerung Katalog-Gruppen-Nummern" unter "Programmverwaltung") in 10er-Schritten automatisch.

In Verbindung mit einer entsprechenden Sortierfolge der Importdatei, kann KL-KatGen, gesteuert über Parameter, automatisiert aus Werten einzelner Datenfelder oder aus Kombinationen verschiedener Datenfelder der Importdatei, automatisch Kataloggruppen bilden und so Katalogpositionen gleicher Kataloggruppen zuordnen.

Werden in der Definition der Importstruktur der Schnittstellendatei die Felder Katalog-Gruppe und Katalog-Gruppenposition nicht definiert und wurde die Option "Katalog-Gruppen-Nummer automatisch bilden" gewählt, wird für jeden Datensatz eine separate Katalog-Gruppe mit jeweils einer Position angelegt. Die Reihenfolge entspricht dabei der Reihenfolge der Datensätze der Importdatei.

2.10.3.2.4 Bereitstellen der Kataloggruppennummer in der Importdatei

Die für die Kataloggruppe relevanten Parameter werden bei der Erstellung der Kataloggruppe aus dem ersten Positionssatz der jeweiligen Kataloggruppe in die Datenfelder der Kataloggruppe übernommen.

Wird die Kataloggruppen-Nummer im Importsatz "mitgeliefert", kann damit die Position der Kataloggruppe im Katalog bestimmt werden (siehe dazu auch Punkt "Katalog-Gruppen-Nummern automatisch bilden"). Gehören zu einer Kataloggruppe mehrere Positionen (Artikel), kann die Platzierung der Position innerhalb der Kataloggruppe durch Verfügbarkeit einer Positionsnummer im Feld Kataloggruppen-Positionsnummer der Schnittstellendatei gesteuert werden.
Bleibt das Feld "Kataloggruppen-Positionsnummer" leer, werden die Positionen entsprechend der Datensatzfolge der entsprechenden Kataloggruppe zugeordnet.

Nachfolgend ein Beispiel mit den Gruppierungsinformationen in der Schnittstellendatei:

Artikel-Nr.

Artikel-Bezeichnung1

Artikelbezeichnung 2

VK-Preis

Evtl. weitere Datenfelder

Katalog-Gruppe

Katalog-Gruppen-Positionsnummer

4711;

USB-DatenKabel 1;

100 cm ;

2.50;

xxxxx;

10

1

4712;

USB-DatenKabel 2;

150 cm ;

3.50;

xxxxx;

10

2

4713;

USB-DatenKabel 3;

200 cml;

4.50;

xxxxx;

10

3

4811;

Serielles Datenkabel;

100 cm;

12.50;

xxxxx;

20

1

4812;

Serielles Datenkabel;

150cm;

13.50;

xxxxx;

20

1

4912;

Paralleles Datenkabel;

150 cm;

6.50;

xxxxx;

30

1
KL-KatGen erzeugt beim Import mit den Optionen "automatische Katalogerstellung" und "Kataloggruppen-Nummer aus der Import-/Artikeldatei verwenden" folgende Kataloggruppen:

Kataloggruppe Position Artikel Preis

000010 00010 4711 USB-Datenkabel 1 2,50

00020 4712 USB-Datenkabel 2 3,50

00030 4713 USB-Datenkabel 3 4,50

Kataloggruppe Position Artikel Preis

000020 00010 4811 Serielles-Datenkabel 1 12,50

00020 4812 Serielles-Datenkabel 2 13,50

Kataloggruppe Position Artikel Preis

000030 00010 4912 Paralleles -Datenkabel 1 6,50

Automatisch Kataloggruppen aus den Importdaten erzeugen

· Gruppierungsbegriff kann direkt aus Artikeldaten abgeleitet werden

Verfügen die Artikel-Importdaten über Merkmale, die es erlauben, diese automatisiert in einzelnen Kataloggruppen zusammenzuführen, so können die entsprechenden Werte im Feld "Gruppierung" der Import-Grundmaske "Verwalten der Importschnittstellen" angegeben werden. Voraussetzung dafür ist jedoch, dass die "Aussage" dieses "Gruppierungsfeldes" für alle Datensätze der Importdatei gültig ist.

In einer Kataloggruppe werden aufeinanderfolgende Importdatensätze mit gleichem Feldinhalt zusammengeführt. Diese sind daher entsprechend sortiert bereitzustellen bzw. zu verarbeiten.

Z.B. Durchgängig über alle Artikel wurden "sprechende" 10-stellige Artikelnummern vergeben.

Aufbau der Artikelnummer:
 01                 = Artikelgruppe "Gürtel"
4711 = Modelbezeichnung "Gürtel Monza"
           10       = Längenkennzeichen  "10" für 100 cm
              02    = Farbkennziffer
Artikel-Nr.

Artikel-Bezeichnung1

Artikel-bezeichnung 2

VK-Preis

Evtl. weitere
Datenfelder

01 4711 00 01;

Gürtel Monza 100 cm braun;

100 cm ;

12.50;

xxxxx;

01 4711 10 02;

Gürtel Monza 110 cm braun

110 cm ;

13.50;

xxxxx;

01 4711 15 01;

Gürtel Monza 115 cm braun;

115 cml;

14.50;

xxxxx;

01 4712 00 02;

Gürtel Verona 100 cm braun

100 cm;

12.50;

xxxxx;

01 4712 10 01;

Gürtel Verona 110 cm braun

110 cm;

13.50;

xxxxx;

01 4713 00 02;

Gürtel Padua 100 cm braun

100 cm;

16.50;

xxxxx;
Hier könnten zum Beispiel Artikel mit gleicher Ziffernfolge in den Stellen eins bis sechs der Artikelnummer, jeweils in einer Kataloggruppe zusammengeführt werden.

Dazu ist im Feld Gruppierung "left(artnr,6)" (bedeutet die ersten 6 Stellen der Artikelnummer von links) einzugeben.

KL-KatGen erzeugt beim Import mit den Optionen "automatische Katalogerstellung" und "Kataloggruppen-Nummer automatisch bilden" und im Feld Gruppierung "left(artnr,6)" folgende Kataloggruppen:

Kataloggruppe Position Artikel Preis

000010 00010 01 4711 00 01 Gürtel Monza 100 cm 12,50

00020 01 4711 10 02 Gürtel Monza 110 cm 13,50

00030 01 4711 15 01 Gürtel Monza 115 cm 14,50

Kataloggruppe Position Artikel Preis

000010 00010 01 4712 00 01 Gürtel Verona 100 cm 12,50

00020 01 4712 10 02 Gürtel Verona 110 cm 13,50

Kataloggruppe Position Artikel Preis

000010 00010 01 4713 00 01 Gürtel Padua 100 cm 16,50

· Gruppierungsbegriff kann nicht direkt aus Artikeldaten abgeleitet werden

Alternativ besteht die Möglichkeit gezielt im Datenfeld "gleicheGrp" (Zuweisung per Referenz), die für die Gruppierung von Positionen notwendigen Informationen in der Importdatei mitzugeben.

2.10.3.3 Verwalten der Importschnittstellen "Register Erweiterungen"

Zusätzliche Funktionen beim Datenimport stehen zur Verfügung und können im Register Erweiterungen definiert und angewählt werden.

Auf den Folgeseiten werden die in KL-KatGen integrierten erweiterten Zusatzfunktionen beim Datenimport beschrieben. Zum Teil wurden diese Funktionen auch bereits auf den Seiten zuvor angesprochen.

· Konvertiervariante
Auswahl eventueller kundenindividueller Importlösungen (kein Standard)

· Import von Zusatzüberschriften und Zusatztexten
Details siehe Folgeseiten "Automatische Überschriftenerzeugung"

· EOF-Satz

Fügt einen leeren Datensatz EOF() an die Importdatei an.

· Konvertierzusatzbefehle

Hier können Befehle hinterlegt werden, die bei dem Datenimport ausgeführt werden.
Details siehe Folgeseiten

· Werte Textkonvertierung

Automatisierte Änderung und Ergänzung der Importdaten.

· Erweitert

Automatisierte Korrektur der Nachkommastellen der Wertfelder bei bestimmten Datenformaten..

· Anzeige CSV-Datei

Kontrollanzeige der Importdaten (Quelle)

2.10.3.4 Automatische Überschriftenerzeugung

automatisch artikelbezogene Überschriften übernehmen

Es können artikelbezogene Überschriften (Bild, Text ) bereitgestellt werden, die automatisiert in die Katalogdaten vor die entsprechenden Artikel übernommen werden.

Folgende Datenfelder sind in einer CSV-Datei bereitzustellen (aktuell 5 Importfelder fix definiert).

Ueberschrift 1

Textfeld1

Textfeld2

Pfad Bild 1

Pfad Bild 2

2.10.3.5 Überschriften Zufall / Überschriften Artikel

I
m KL-Katgen besteht die Möglichkeit beim Daten Import automatisiert artikel- und zufallsbezogene Zwischenüberschriften und Texte in einen Katalog einfließen zu lassen. Diese Daten können ebenfalls aus einer ASCII Datei übernommen oder manuell erfasst werden.
Für die manuelle Erfassung klicken Sie auf die Buttons "Überschriften Zufall" bzw. "Überschriften Artikel". Stehen die Daten in einer ASCII Datei (CSV) zur Verfügung, können diese auch direkt mit (vor) dem eigentlichen Katalogdatenimport automatisiert eingelesen und verarbeitet werden. Dazu sind die nachfolgend beschriebenen Eingaben zu machen.

Anzahl der Importfelder der Überschriftendateien

Die Zahl in diesem Feld muss identisch sein mit der Anzahl der Datenfelder in der Importdatei für Überschriften (zur Zeit auf 5 festgelegt).

Überschriftentext auf neue Seite

(Kundenvariante nicht aktiviert)

Pfadname der Importdatei mit Artikelbezogenen Zwischenüberschriften

Hier kann der Pfadname der o.g. Importdatei eingegeben bzw. ausgewählt werden.

Pfadname der Importdatei mit zufallsabhängigen Zwischenüberschriften

Hier kann der Pfadname der o.g. Importdatei eingegeben bzw. ausgewählt werden.

Zufall min./Zufall max.: Hier wird spezifiziert nach wie viel Kataloggruppen das Konvertiertool eine Zufallsüberschrift einfügen soll.

EOF-Satz

Fügt leeren Datensatz an das Ende der Importdatei an.

2.10.3.6 Konvertierzusatzbefehle

Konvertierzusatzbefehle: Durch klick auf diese Schaltfläche, öffnet sich ein Textfenster in dem Befehle hinterlegt werden können, die beim Datenimport ausgeführt werden sollen.

Unmittelbar beim Datenimport (d.h. nach dem Einlesen der Daten, vor der Übernahme in den Katalog bzw. in die Artikelstammdatei) können so die einzelne Datensätze automatisiert geändert oder ergänzt werden ( z.B. Bildnamen aus der Artikelnummer erzeugen und diesen in einem separaten Datenfeld des Datensatzes speichern Artikelnummer "4711" à Bildname "Bild4711.jpg").

Zusätzlich zur Textkonvertierung ermöglicht der Importkonverter die Importdaten beim Import zu verändern. So können zum Beispiel einzelne Artikelgruppen für die Übernahme gesperrt werden oder für bestimmte Kataloggruppen spezielle Darstellungsarten ausgewählt werden.

Befehle werden mittels einem vorangestellten "BEF" kodiert

Beispiele:

BEF replace all artbez1 with "Twix" for artbez1 = "Raider"

Es werden alle "Raider" in "Twix" gewandelt

BEF replace all gesperrt with "1" for artbez1 = "Mars"

Es werden alle "Mars" gesperrt und somit nicht in den Katalog übernommen.

BEF replace all darstell with "04S" for artgr2 = "Socken"

Es werden alle Artikel der Gruppe "Socken" mit der Darstellungsart "04S" (=Vierermatrix) vorbelegt.

Für die Beantwortung von Detailfragen wenden sie sich bitte an die Sevice-Hotline.

Benennen Sie das Datenfeld der Artikel-/Katalogpositionsdaten worauf sich der Zugriff bezieht (in der Regel Artikelnummer).

2.10.3.7 Importkonverter

Der Importkonverter ermöglicht beim Datenimport Texte und Daten der Importdatei vor Übernahme in die Katalogdaten bzw. Artikelstammdaten zu verändern.

Textkonvertierung

Der Importkonverter ermöglicht beliebige Zeichenfolgen des zu importierenden Textes zu wandeln. So können zum Beispiel HTML-Zeichenfolgen, Namen, Leerzeilen usw. entfernt, ergänzt, gewandelt oder eingefügt werden
Aufruf Menü --> Programmverwaltung --à Verwalten Textkonvertierung
Mit "KON Name" werden die zu konvertierenden Felder bestimmt (hier Feld "Name")

Um darstellbare Zeichen zu tauschen, muss nur das alte und das neue Zeichen mit einem "=" getrennt in eine Zeile eingegeben und mit einem Semikolon abgeschlossen werden. Nachfolgend ein paar Beispiele:
HTML=; Mit diesem Kommando werden alle in spitzen Klammern begrenzte Texte (=HTML-Befehle) eliminiert

Beispiel:
Aus:" ...<body><span style="font-family: Calibri;">Magnesium f&uuml;r unterwegs.</span></body>"

wird: "Magnesium für unterwegs."

Otto=Karlheinz;     Aus "Otto" wird "Karlheinz"

</b>=;              HTML-Zeilenschaltungen werden eliminiert. Um ein Zeichen oder eine Zeichenfolge komplett zu eliminieren ist das Semikolon direkt hinter dem Gleichheitszeichen anzugeben.

chr(13)+chr(10)= ;  Zeilenschaltungen aus Text durch Leerstelle ersetzen

*=chr(13)           "Stern" wird durch Zeilenschaltung ersetzt

Achtung: Befehlsendezeichen (Semikolon bzw. wie in der Abbildung oben: Doppelpunkt) am Ende der Befehls-Zeile nicht vergessen!

Problemlösung bei Semikolon in zu ersetzendem Text

Bei Dateien im XML-Format oder HTML-Format kann das Semikolon Bestandteil der zu ersetzenden Zeichenfolge sein. So sind Umlaute, zum Beispiel das Zeichen "Ä" in HTML-Dateien gewöhnlich als "&Auml;" codiert.

Um bei der Datenkonvertierung in KL-Katgen, die Zeichen korrekt übernehmen zu können, müsste also folgendes definiert werden: &Auml;=Ä;

Sie sehen, dass ein Semikolon im zu ersetzenden Zeichen steht, das Programm würde dies als Befehlsabschlusszeichen definieren, und unerwünschte Ergebnisse bei der Konvertierung hervorbringen.
Um Dieses zu umgehen ist es möglich eine Variable "endebefzeile" zu definieren und diese mit einem "unverdächtigen" Zeichen (evtl. Doppelpunkt) zu belegen.
Unverdächtig bedeutet in diesem Zusammenhang, dass das gewählte Zeichen weder in einer ersetzenden noch in einer zu ersetzenden Zeichen/Zeichenkette vorkommt.

Die Hinterlegung in unserem Beispiel (XML/HTML mit Doppelpunkt als Befehlsabschluss) wäre nun folgendermaßen zu machen:

1. einmalig die Definition der Variable "endebefzeile" BEF endebefzeile=":"

2. einmalig die Definition der zu "behandelnden" Datenfelder KON zustext

3. danach je zu ersetzender Zeichenkette (Beispiel Ä) &Auml;=Ä:

2.10.3.8 automatisch zufallsabhängig Überschriften übernehmen

Es können hinterlegte Überschriften (Bild, Text ) automatisiert nach dem Zufallsprinzip in die Katalogdaten übernommen werden (z.B. Werbetexte, Telefonnummer usw.).

Definieren Sie hier, nach wie viel Kataloggruppen frühestens (Zufall min) und spätestens (Zufall max) die nächste Überschrift gedruckt werden soll. Die Reihenfolge der Überschriften ist entsprechend der Reihefolge der Importdatei.

2.10.3.8.1 Integrierte Nachkommastellen (Button "Erweitert")

Verschiedene Anwendungen stellen (exportieren) numerische Werte ohne Dezimaltrennzeichen in die Schnittstellendatei zur Verfügung (Z.B, "12,34" wird als "1234" in die Datei abgestellt).

Um auch solche Werte korrekt in die KL-KatGen Katalogdaten übernehmen zu können, sind für jede Schnittstellendatei den einzelnen Importfeldern die entsprechenden Nachkommastellen zuzuordnen.

Zum Verwalten öffnen Sie mit dem Button "Erweitert" das entsprechende Fenster.

2.10.3.8.2 Der Import-Test

Aufgrund der komplexen Import-Steuerungsmöglichkeiten von KL-KatGen empfiehlt es sich, die gewählten Optionen genau zu verifizieren, und vor der Datenübernahme die Sichtprüfung mittels “Import-Test“ durchzuführen.

Mit Maus-Klick auf die Taste "Testen" werden dafür die für die Übernahme aufbereiteten Daten in einem "Browse-Fenster" angezeigt.

Stimmen die Feldinhalte, Nachkommastellen, Korrekte Schreibweise der Umlaute und Sonderzeichen usw., kann der Import gestartet werden.

2.10.3.9 Import Ausführen

2.10.3.10 Verwalten der Import-Strukturen (ändern, löschen, kopieren)

Zum Verwalten (Ändern, Löschen, Kopieren) bereits vorhandener Importstrukturen öffnen Sie das Fenster "Verwalten der Importschnittstellen" mit "Klick" auf den "Button Strukturverwaltung" im Fenster "Daten Import".
Weitere Details finden Sie zuvor im unter "Anlegen einer neuen Importstruktur" im Kapitel "Importschnittstelle"
2.10.3.11 Die Updatesteuerung beim Datenimport

In der Updatesteuerung wird festgelegt, welche Daten beim Datenimport zu aktualisieren sind.

Datenimport in die Katalogdaten

Beim Datenimport in die Katalogdaten (Katalogerstellung-/Aktualisierung) aus einer externen Importdatei werden grundsätzlich nur die in der Importstruktur per Referenz zugewiesenen Datenfelder aktualisiert.

Beim Datenimport in die Katalogdaten (Katalogerstellung-/Aktualisierung) aus der KL-KatGen Artikelstammdatei dagegen, werden alle Werte aktualisiert.

Datenimport in die Artikelstammdatei

Beim Datenimport in die Artikelstammdatei werden grundsätzlich nur die in der Importstruktur per Referenz zugewiesenen Datenfelder aktualisiert.

In den Bildschirmmasken (siehe unten) kann die zuvor beschriebene grundsätzliche Arbeitsweise übersteuert werden. Markieren Sie die Datenfelder, die aktualisiert werden sollen und löschen Sie Markierungen bei den Datenfeldern, deren Inhalt erhalten bleiben soll.

2.10.3.11.1 Datenaktualisierung beim Datenimport / Artikeldatei übernehmen / aktualisieren

Nach Anwahl der Funktion "Datenimport in die Artikelstammdatei" öffnet sich automatisch das Fenster zur Bestimmung, welche Datenfelder in der KL-KatGen Artikelstammdatei übernommen / aktualisiert werden sollen.

(Aus Sicherheitsgründen, um ein versehentliches Überschreiben von Daten zu Verhindern, öffnet sich dieses Fenster auch bei Anwahl der Funktion " Daten in die Artikeldatei übernehmen / aktualisieren" automatisch, einmalig je Datensitzung.)

Beachten Sie, es werden nur die Felder aktualisiert, die auch in der Importstruktur zugewiesen wurden. Die Tabelle "FAArtikel" (Abbild der Importdatei in für KL-Katgen verarbeitungsfähigem Format) hingegen wird grundsätzlich immer neu erstellt.

Bevor Sie diese Fenster verlassen, können Sie noch festlegen, ob Sie die ausgewählten Optionen nur für die aktuelle Sitzung gelten sollen oder Ihnen als "Standard" erhalten bleiben sollen.

Bestimmen Sie nun noch im "Daten-Import-Fenster":

zuvor Artikeldatei leeren
Diese Abfrage bewirkt, das Löschen der KL-KatGen Artikeldatei vor dem Ausführen des Imports.

zuvor Kategorietabelle leeren
Diese Abfrage bewirkt, das Löschen der Kategorietabelle vor dem Ausführen des Imports. (Details nachfolgend)

Button "Artikel-Update-Steuerung"

Öffnet das Fenster Artikel-Update-Steuerung (Details nachfolgend)

2.10.3.11.2 Datenaktualisierung beim Datenimport / Katalogerstellung

Nach Anwahl der Funktion "Automatische Katalogerstellung" öffnet sich automatisch das Fenster zur Bestimmung welche Daten in der KL-KatGen Katalogdatei (Kataloggruppen Kopf- / -Positionsdaten) aktualisiert werden sollen.

(Aus Sicherheitsgründen, um ein versehentliches Überschreiben von Daten zu Verhindern, öffnet sich dieses Fenster auch beim Anwahl der Funktionen " Daten in die Artikeldatei übernehmen / aktualisieren" bzw. " Automatische Katalogerstellung" automatisch, einmalig je Datensitzung.)

Beachten Sie, es werden nur die Felder aktualisiert, die auch in der Importstruktur zugewiesen und hier ausgewählt (markiert) wurden.

2.10.3.11.3 Aktualisierungssteuerung bei manueller Erfassung

Definieren Sie, ob die Datenaktualisierung auch bei der manuellen "Katalogpositionserfassung" gültig sein soll (Erfassung / Aktualisierung von Artikeln aus der KL-KatGen Artikeldatei).

2.10.3.11.4 Darstellungsart automatisch ergänzen

Wird keine Darstellungsart für einzelne Kataloggruppen in der Schnittstellendatei mitgegeben, kann KL-KatGen diese automatisch zuordnen. Wählen Sie dazu aus, welche Darstellungsart der jeweiligen Kataloggruppe automatisch zugewiesen werden soll, wenn nur eine Position oder wenn mehrere Positionen in einer Kataloggruppe vorhanden sind.

Lesen Sie dazu auch Punkt "Integrierte erweiterte Funktionen des Datenimports"

2.10.3.11.5 Unterdrückung identischer Bezeichnungen

KL-KatGen kann automatisiert gleiche Artikelbezeichnungen in den Positionen entfernen und gleichzeitig die "normal entstehende" Kataloggruppenbezeichnung korrigieren.

Nachfolgend Beispiele für die unterschiedlichen Verarbeitungsweisen:

2.10.3.11.6 "Normal-Import": (= ohne Unterdrücken identischer Bezeichnungen)

aus der "Artikelbezeichnung 1" und "Artikelbezeichnung 2" wird durch Aneinanderhängen dieser Felder (Leerstelle dazwischen) das Feld "Artikelbezeichnung-im-Katalog". Dieser Wert wird auch in die "Bezeichnung 1" der Kataloggruppe und in das Feld "Inhaltsregister" der Kataloggruppe übernommen.

Z.B.

Artikelbezeichnung 1: "FISCHER Wanddübel"

Artikelbezeichnung 2: "6 mm"

KL-KatGen erzeugt beim Import automatisch daraus:

Für die Kataloggruppe (wird aus der ersten Artikelposition der jeweiligen Kataloggruppe erstellt) :

Kataloggruppenbezeichnung: "FISCHER Wanddübel 6mm"

Kataloggruppe-Registereintrag: "FISCHER Wanddübel 6mm"

Für die Katalogposition :

Artikelbezeichnung 1: "FISCHER Wanddübel"

Artikelbezeichnung 2: "6 mm"

Artikelbezeichnung im Katalog : "FISCHER Wanddübel 6mm"

Können in der Importschnittstelle die Felder Kataloggruppenbezeichnung1 (und -2) und / Register zugewiesen werden, so werden diese Werte direkt in die Kataloggruppenbezeichnung bzw. Register übernommen. Ein Nachbearbeiten ist dann nicht mehr notwendig.

(Feldzuordnung / Referenz: Katgruppe-Bez1 separat = Kgrbez1, Katgruppe-Bez2 separat = Kgrbez2, Katgruppe-Register separat =KatgrRegist (Details im Kapitel "Referenzfelder beim Datenimport")).

2.10.3.11.7 Import mit Unterdrücken identischer Bezeichnungen

KL-KatGen bietet die Möglichkeit beim Import automatisch gleiche Bezeichnungen der Positionen zu unterdrücken.

2a. Variante: in der Schnittstellendatei wird die "Kataloggruppenbezeichnung" mitgeliefert

Wird in der Schnittstellendatei die "Kataloggruppenbezeichnung" mitgegeben und zugewiesen, wird dieser Wert in die Kataloggruppenbezeichnung übernommen.

Die "Artikelbezeichnung-im-Katalog" in den Katalogpositionen wird auch hier durch Aneinanderhängen der "Artikelbezeichnung 1" und "Artikelbezeichnung 2" gefüllt (Leerstelle dazwischen). Es wird jedoch nun der mit der Kataloggruppenbezeichnung übereinstimmende Bezeichnungsteil in den Positionen automatisch entfernt.

Z.B. "mitgelieferter" Text für die Kataloggruppenbezeichnung = "FISCHER Wanddübel"

der Text der Katalogpositionen "FISCHER Wanddübel 6 mm", "FISCHER Wanddübel 8 mm" usw. wird auf "6 mm" bzw. "8mm" usw. gekürzt.

Für die Kataloggruppe (wird aus der ersten Artikelposition der jeweiligen Kataloggruppe erstellt) :

Kataloggruppenbezeichnung: "FISCHER Wanddübel"

Für die Katalogposition :

Artikelbezeichnung 1: "FISCHER Wanddübel"

Artikelbezeichnung 2: "6 mm"

Artikelbezeichnung im Katalog: "6mm"

2b. Variante: in der Schnittstellendatei wird die "Kataloggruppenbezeichnung" n i c h t mitgeliefert

Wird in der Schnittstellendatei die "Kataloggruppenbezeichnung" n i c h t mitgegeben und wurde die Option "Unterdrücken identischer Bezeichnungen" ausgewählt, ermittelt KL-Katgen übereinstimmende Textteile und korrigiert automatisch die Kataloggruppenbezeichnung und die "Artikelbezeichnung-im-Katalog".

KL-KatGen prüft dabei auf gleiche Textteile und entfernt diese aus der sich automatisch gebildeten Bezeichnung der Kataloggruppe (hinterer Teil) und entsprechend in der "Artikelbezeichnung-im-Katalog" der Katalogposition (vorderer Teil).

z.B. so ergeben sich folgende Bezeichnungen:

Für die Kataloggruppe

"FISCHER Wanddübel 6mm"

Für die Katalogpositionen:

"FISCHER Wanddübel 6 mm",

"FISCHER Wanddübel 8 mm",

"FISCHER Spezial Wanddübel 8 mm"

usw. gebildet.

Das Programm prüft nun die Positionen aufsteigend auf gleiche Textbestandteile und wird nach der 2. Position in die Kataloggruppenbezeichnung die Bezeichnung "FISCHER Wanddübel" und in die Position1 und 2 die Bezeichnung "6 mm" bzw. "8mm" erhalten.

Für die Kataloggruppe

"FISCHER Wanddübel "

Für die Katalogpositionen:

" 6 mm",

" 8 mm",

In unserm Beispiel jedoch folgt noch die 3. Position mit dem Text "FISCHER Spezial Wanddübel 8 mm", so dass lediglich nur noch der gemeinsame Text "FISCHER" verbleibt. So ergeben sich folgende Bezeichnungen:

Für die Kataloggruppe

"FISCHER"

Für die Katalogpositionen:

"Wanddübel 6 mm",

"Wanddübel 8 mm",

"Spezial Wanddübel 8 mm"

Erkennt das Programm auf absolute Übereinstimmung der Texte in der Gruppe und in den Positionen, so bleiben diese erhalten. Dies gilt insbesondere, wenn nur eine Position in der Kataloggruppe vorkommt (da sonst keine Bezeichnung mehr vorhanden wäre).

Wurde das Registerfeld der Kataloggruppe nicht extra in der Schnittstellendatei mitgegeben und zugewiesen, wird der Inhalt der Kataloggruppenbezeichnung übernommen.

Werte als Standard übernehmen

Bevor Sie dieses Fenster verlassen, können Sie noch festlegen, ob die ausgewählten "Aktualisierungs-Optionen" nur für die aktuelle Sitzung gelten sollen oder Ihnen als "Standard" erhalten bleiben sollen.

Mit den Daten aus der Import-Datei

Diese Auswahl bewirkt, dass das Programm direkt aus der Importdatei die Katalogdaten erstellt (d.h. Kataloggruppen bildet).

Mit den Daten aus der Artikeldatei

Diese Option bewirkt, dass Katalog-Gruppen aus der KL-KatGen Artikelstammdatei gebildet werden.

Schaltfläche: Artikel-Selektion

Durch Klicken auf diesen Button öffnet sich ein Fenster, in dem Artikel-Selektionen für die Kataloganlage getroffen werden können (vgl. Abbildung).

Die gewählte Artikel-Selektion wird wirksam, wenn Sie auf den Button "Filter aktivieren“ klicken (Farbe der Maske ändert sich).

Vor einer Übernahme in den Katalog besteht mit der Funktion "Kontrolle" die Möglichkeit, die selektierten Artikelsätze anzeigen zu lassen.
Durch Schließen der Artikel-Selektions-Maske werden alle Filter zurückgesetzt, das heißt, die Maske muss beim Ausführen aktiv sein, wenn eine Selektion wirksam sein soll.

Katalog-Gruppen-Nummern automatisch bilden

Diese Option bewirkt, dass das Programm, automatisch neue Kataloggruppennummern beim Datenimport erzeugt. (Siehe dazu "Sortierfolge und automatische Kataloggruppenbildung beim Import")

Katalog-Gruppen-Nummern aus der Import-/Artikeldatei verwenden

Dazu ist die entsprechender Kataloggruppennummer in einem Datenfeld der Importdatei bereitzustellen und das Feld "Kataloggruppe“ in der Schnittstellenbeschreibung zuzuweisen.

Wenn Sie Kataloggruppenbildung aus der Artikeldatei gewählt haben (vgl. " Daten-Import“), sollten die Felder Kataloggruppe und Kataloggruppenposition in der Artikeldatei (Menüpunkt "Kataloge und Daten verwalten“, "Artikeldaten verwalten“) gefüllt sein. Ist kein Wert für die Kataloggruppenposition vorgegeben, bestimmt die Importreihenfolge die Positionsnummer.

zuvor Katalog-Gruppen-Nummer zurücksetzen

Diese Option bewirkt, dass das Programm vor dem Ausführen des nächsten Imports das mittlere Segment der am Bildschirm dargestellten Matrix "Letzte Katalog-Gruppen-Nummer“ auf Null zurücksetzt. Neu zu bildende Kataloggruppen mit automatischer Nummernvergabe (vgl. "Verwalten Steuerung Katalog-Gruppen-Nummern") beginnen nun mit der Nummer 00010.

zuvor Katalog leeren

Diese Option bewirkt, dass das Programm vor dem Ausführen des nächsten Imports alle Kataloggruppen und Positionen aus dem aktuellen Katalog entfernt.

letzte Katalog-Gruppen-Nummer

Dies ist ein Eingabefeld in dem die Gruppennummernvergabe-Matrix angezeigt wird und gegebenenfalls verändert werden kann. Die Nummervergabe erfolgt in 10er-Schritten. Durch Ergänzung der sich automatisch bildendenen Nummer in den ersten drei Stellen kann die Positionierung der Kataloggruppen innerhalb des Kataloges zusätzlich gesteuert werden.

Beispiel:

Die in der Maske dargestellte Einstellung bewirkt bei einer automatisierten Neuanlage von Kataloggruppen, dass die Nummern "BEF000060 “, "BEF00070 “, "BEF00080 “ usw. weitergeführt werden.

Die zu importierenden Artikel (hier Befestigungsmaterial) werden im Katalog nach der Kataloggruppe

"BEE9999999zz" eingeordnet (bzw. wenn nicht vorhanden nach einer kleineren Kataloggruppennummer).

zuvor Katalogüberschriften löschen

Diese Option bewirkt, dass das Programm vor dem Ausführen des nächsten Imports alle Überschriftentexte und Überschriftenbilder aus dem aktuellen Katalog entfernt.

zuvor Kategorietabelle leeren

Diese Option bewirkt, das Löschen der Kategorietabelle vor dem Ausführen des Imports.

· einschließlich Aktualisieren vorhandener Katalog-Gruppen/-Positionen

Diese Option bewirkt, dass das Programm versucht, Datenfelder in Kataloggruppen und Katalogpositionen zu aktualisieren. Dies ist allerdings nur möglich, wenn die oben beschriebenen Einstellungen (Kataloggruppennummer, Positionen) genau mit dem des aktuellen Katalogs übereinstimmen. Die Suche des Programms nach zu aktualisierenden Datensätzen geschieht hier nach Übereinstimmung von Kataloggruppennummer und Artikelnummer. Sollte die aus den Einstellungen ermittelte Kataloggruppennummer im Katalog nicht vorhanden sein, wird vom Programm eine neue gebildet.

· generelle Neuanlage der importierten Katalog-Gruppen/-Positionen

Diese Option bewirkt, dass das Programm generell aus den entsprechenden Daten neue Kataloggruppen bildet. Sollte es zu Duplikaten bei Kataloggruppen-Nummern kommen, so werden diese durch Hochzählen des dritten Segments umgangen.
Beispiel: Kataloggruppe "00050-A“ ist bereits vorhanden, so wandelt das Programm das dritte Segment in einen numerischen Zähler und versucht 00050-10 00050-11 00050-12 usw. zu bilden.

· Anzeige fehlerhafter Importsätze

Fehlerhaft erkannte Importdatensätze (z.B. keine Artikelnummer, Anzahl Felder stimmt nicht mit der Strukturdefinition überein) können während der Verarbeitung (Import) angezeigt werden.

2.10.3.12 Import ausführen

Scheint nach der "Sichtprüfung" (empfohlen) soweit "alles in Ordnung", starten Sie den eigentlichen Datenimport mit "Maus-Klick" auf den Button "Ausführen" mit den aktuell auf der Bildschirmmaske erfassten Optionen.

Je nach Anzahl der zu übernehmenden Datensätze und der im Hintergrund ablaufenden Prozesse (Textkonvertierungen, Datenwandlung, -verdichtung usw.) kann dieser Vorgang mehrere Minuten dauern. Der Programmfortschritt wird daher am Bildschirm angezeigt.

Nach Beendigung des Datenimports erhalten Sie in einem Anzeigefenster Informationen über die Anzahl der importierten Datensätze.

Wurde die Option "Anzeige fehlerhafte Importsätze" gewählt, werden während der Verarbeitung eventuelle Unstimmigkeiten angezeigt. In der Regel handelt es sich dabei um Fehler durch "Zeilenschaltungen" (CR) oder "Semikolon" in Textfeldern (CR).

Dies kann bedeuten, Sie haben, obwohl "Zeilenschaltungen" in Textfeldern vorhanden sind, nicht die Option "CR im Text" angewählt bzw. es wurde die Anzahl der Importfelder je Datensatz fehlerhaft angegeben.

Eine weitere häufige Ursache für auftretende Fehler beim Import kann sein, wenn das in der "Importschnittstelle" definierte Zeichen für Text-Feld-Trenner (meist "Semikolon") innerhalb von Textfeldern einzelner Datensätze vorhanden ist. Eine Problemlösung hierzu finden Sie im Kapitel "Importkonverter".

Oft wird der letzte Datensatz der Importdatei als fehlerhaft angezeigt, Dabei handelt es sich in der Regel um den leeren "EOF-Satz" (End off File), was man ignorieren kann.

2.10.3.13 Automatische Kategorienermittlung

Wurde das Feld "Kategorie" in der Strukturverwaltung einem Datenfeld der Importdatei per Referenz zugewiesen (z.B. der Artikelgruppe (nicht Kataloggruppe) ), erstellt KL-KatGen beim Import einen entsprechenden Datensatz in der Kategorietabelle. Wurde in einem weiteren Feld auch noch die Bezeichnung mitgeliefert, wird diese auch übernommen.

Wird darüber hinaus auch noch die übergeordnete Kategorie/Gruppe im gleichen Datensatz "mitgeliefert" (die Zuweisung /Referenz ist "Master1" und "MasterTx1") erzeugt KL-KatGen einen "Mastersatz" ("Parentsatz") und vermerkt die Zuordnung zu dieser Gruppe im untergeordneten Datensatz ("Slave"-/"SonSatz"). Wird dem "Master" ebenfalls ein "Master" zugewiesen, verfährt KL-KatGen entsprechend. KL-KatGen kann auf diese Weise eine entsprechende Tabelle mit bis zu 6 Stufen ("master , slave" bzw. "parent son") erstellen.

Beispiel:

Die Artikel werden in einem Unternehmen wie folgt gruppiert:

Soll ein Register entsprechend dieser Struktur erstellt werden, sind die Felder in der entsprechenden Reihenfolge in der Importdatei zuzuweisen.

· Zur Verdeutlichung:

Die Zuweisung beginnt mit der untersten Stufe (hier Geldbörse, Herrengürtel, Kopfbedeckungen, Krawatten etc.).

Diese Stufe muss den Referenzfeldern "Kategorie" und "KategorieTx" zugewiesen werden.

Die nächste Stufe (hier Accessoires, Anzüge, Hemden etc.) muss den Referenzfeldern "Master1" und "MasterTx1" zugewiesen werden.

Die nächste Stufe (hier Herrenmode bzw. Damenmode) muss den Referenzfeldern "Master2" und "MasterTx2" zugewiesen werden.

Die letzte Stufe in unserem Beispiel (Bekleidung) muss den Referenzfeldern "Master3" und "MasterTx3" zugewiesen werden.

KL-KatGen bereitet beim Drucken des Kataloges die Daten für den Druck eines nach Kategorien alphabetisch, sortierten Inhaltsregisters und eines nach "Katalogaufbau" sortierten Inhaltsverzeichnisses auf. Weitere Details zu "Inhaltsregister" und "Inhaltsverzeichnis" finden Sie unter "Katalog drucken".

Unabhängig von der hier beschriebenen Möglichkeit die Kategorietabellen beim Datenimport automatisiert zu erzeugen, können diese auch zu einem späteren Zeitpunkt manuell erstellt werden. Details dazu finden Sie unter "Kategorien-Verwaltung"

In der Importdatei werden in unserem Beispiel die Daten entsprechend nachfolgender Tabelle bereitgestellt:

Artikel Nummer

Artikelbezeichnung

Preis

Kategorie

Kategoriebezeichnung

Master 1

Master 1

Bezeichnung

Master 2

Master 2

Bezeichung

4711 01

Ledergürtel Verona

12,50

1111

Herrengürtel

1110

Accessoires

1100

Herrenmode

4711 02

Ledergürtel Padua

13,70

1111

Herrengürtel

1110

Accessoires

1100

Herrenmode

Beim Datenimport erzeugt KL-KatGen, mit Ausnahme der Kategorie "1000 Bekleidung" (rot dargestellt) daraus folgende Kategorietabellensätze

Kategorie

Kategoriebezeichnung

Master

1000

Bekleidung

1100

Herrenmode

1000

1110

Bekleidung

1100

1111

Herrengürtel

1110

Es müssen nicht zwangsläufig alle Master in der Importdatei mitgeliefert werden. So wurde in dem obigen Beispiel die Kategorie "1000" nicht in der Importdatei "mitgeliefert", sondern wurde manuell hinzugefügt. KL-KatGen stellt zum Ändern / Ergänzen der Kategorietabelle im Hauptmenü unter Programmverwaltung die Funktion "Kategorien-Verwaltung" zur Verfügung.

2.10.3.14 Automatischer Umbruch bei Spaltendarstellung

Spaltenbedarf (nur in Verbindung mit der Darstellungsart "01S " bis "30S"

Übersteigt bei einer Kataloggruppe in der Matrix-/Spaltendarstellung "Darstellungsart "01S " bis "30S" der Spaltenbedarf die Anzahl, der aus der Darstellungsart vorgegebenen Spaltenanzahl (z.B. "07S"= 7 Spalten), ermittelt KL-KatGen den entsprechenden Spaltenumbruch und erzeugt eine oder mehrere "Fortsetzungskataloggruppe(n)" unter folgenden Voraussetzungen:
1. In der Importschnittstelle wird in einem Datenfeld die Anzahl der benötigten Spalten "mitgeliefert" (Feldzuweisung "spaltenbed"="Spaltenbedarf").
oder

2. Die Anzahl der benötigten Spalten wird von KL-Katgen automatisch ermittelt, wenn die in einer "Zeile" zu druckenden Positionen in einem Datenfeld der Importdatei die gleiche Kennung erhalten haben und diesem Feld in der Definition der Importstruktur die Referenz "gleiche Zeile"="GleicheZei" zugewiesen wurde. Das Programm ermittelt beim Import den Spaltenbedarf durch Zählen der Datensätze einer Kataloggruppe mit gleichem Inhalt in diesem Datenfeld. Voraussetzung dazu ist, dass diese Positionen sortiert d.h. aufeinanderfolgend aus der Importdatei eingelesen werden. Bleibt das Importfeld "gleicheZei" leer, erfolgt kein automatischer Umbruch.

3. Die "Sortierung" in der Maske "Importstrukturen" ist mit "autogrp" zu ergänzen z.B. "artnr"+"autogrp".
Beispiel:
Die Preise von vier Artikeln (Gürtel Modelle "Monza", "Pisa", "Verona", "Padua" ) in jeweils 18 Längen (= 64 Artikel) sollen in einer Matrix dargestellt werden.
Es sollen maximal die Preise von 7 Längen in eine Zeile gedruckt werden. Es wurde somit die Darstellungsart "07S" gewählt.

Da jedoch 18 Spalten zu drucken sind, bildet das System beim Datenimport automatisch eine zweite Kataloggruppe mit den nächsten 7 Längen und eine dritte Kataloggruppe mit den restlichen 4 Längen.
Die nun wie folgt gedruckt werden können (Design und anzudruckende Felder sind im Designer individuell zu gestalten).
Bezeichnung

60 cm

65 cm

70 cm

75 cm

80 cm

85 cm

90 cm
4711 01
Gürtel Monza

10,00

11,00

12,00

13,00

14,00

15,00

16.00

4711 02

Gürtel Pisa

10,10

11,10

12,10

13,10

14,10

15,10

16,10

4711 03

Gürtel Verona

10.20

11,20

12,20

13,20

14,20

15,20

16,20

4711 04

Gürtel Padua

10,30

11,30

12,30

13,30

14,30

15,30

16,30

Bezeichnung

95 cm

100 cm

105 cm

110 cm

115 cm

120 cm

125 cm

4711 01

Gürtel Monza

10,40

11,00

12,00

13,00

14,00

15,00

16.00

4711 02

Gürtel Pisa

10,50

11,10

12,10

13,10

14,10

15,10

16,10

4711 03

Gürtel Verona

10.60

11,20

12,20

13,20

14,20

15,20

16,20

4711 04

Gürtel Padua

10,70

11,30

12,30

13,30

14,30

15,30

16,30

Bezeichnung

130 cm

135 cm

140 cm

145 cm

4711 01

Gürtel Monza

10,80

11,80

12,80

13,80

4711 02

Gürtel Pisa

10,90

11,90

12,90

13,90

4711 03

Gürtel Verona

11.20

12,20

13,20

14,20

4711 04

Gürtel Padua

11,30

12,30

13,30

14,30
Beim Drucken kann das Programm aus den jeweils ersten (hier) sieben Positionssätzen, die für die Spaltenüberschriften der Kataloggruppe notwendigen Bezeichnungen (hier die "cm"-Größen) andrucken. (Entsprechend bei der zweiten Kataloggruppe aus den ersten sieben und bei der dritten aus den ersten vier Positionssätzen). Voraussetzung für das Andrucken der Spaltenüberschriften ist das Hinterlegen der entsprechenden Information in einem Datenfeld der Importschnittstelle. (Hier zum Beispiel im Datenfeld "T1" siehe Beispielsdarstellungen der Schnittstelldateien auf der Folgeseite).
Variante 1, der Spaltenbedarf ist bekannt und wird in der Schnittstelle "mitgeliefert":
Der Spaltenbedarf (hier 18) wird in der Importschnittstelle in dem Feld "Spaltenbedarf"= "spaltenbed" definiert.
 Artikelnummerf
 Artikelbezeichnung
T1
Darstell
Preis
Spaltenbedf
4711 01 01
Gürtel Monza rot
60 cm
07S
12,00
18
4711 01 02
Gürtel Monza gelb
65 cm
07S
12,00
18
…
usw.
4711 01 17
Gürtel Monza rosa
140 cm
07S
12,00
18
4711 01 18
Gürtel Monza lila
145 cm
07S
12,00
18
4711 02 01
Gürtel Pisa rot
60 cm
07S
12,00
18
4711 02 02
Gürtel Pisa gelb
65 cm
07S
12,00
18
…
usw.
4711 02 17
Gürtel Pisa rosa
140 cm
07S
12,00
18
4711 02 18
Gürtel Pisa lila
145 cm
07S
12,00
18
4711 03 01
Gürtel Verona rot
60 cm
07S
12,00
18
4711 03 02
Gürtel Verona gelb
65 cm
07S
12,00
18
…
usw.
Beispiel Schnittstellendatei
Variante 2, der Spaltenbedarf wird vom Programm automatisch ermittelt:
Alternativ kann der Spaltenbedarf vom Programm automatisch ermittelt werden. Voraussetzung hierfür ist, dass ein Datenfeld in der Schnittstellendatei bereitgestellt wird, welches bei Artikeln die in einer Zeile gedruckt werden sollen, einen identischen Inhalt hat. Diesem Datenfeld ist die Referenz "gleicheZei" (=Gleiche Zeile) in der Schnittstellenbeschreibung (Importstruktur) zuzuweisen.

In diesem Beispiel verwenden wir zur Ermittlung des Spaltenbedarfs (da diese optimal gestaltet ist) die Artikelnummer oder besser gesagt Teile der Artikelnummer. Selbstverständlich könnten die notwendigen Informationen auch aus einem anderen Datenfeld oder einem speziell dafür im Artikelstamm oder der Importschnittstelle eingerichteten Feld genutzt werden.
Der Aufbau der Artikelnummer: Stelle 1-4 Basis-Nr., hier 4711
Stelle 5-6 Qualität, hier 01 bis 04
Stelle 7-8 Grösse, hier 01 bis 18

Dieses muss beim Daten-Import der Referenz "gleiche Zeile"="GleicheZei" zugewiesen werden.

Generelle Voraussetzung hier: Die Daten sind nach Artikelnummer, Qualität und Größe beim Import sortiert.
Artikelnummerf
Artikelbezeichnung
T1
Darstell
Preis
gleicheZei
4711 01 01
Gürtel Monza rot
60 cm
07S
12,00
4711 01
4711 01 02
Gürtel Monza gelb
65 cm
07S
12,00
4711 01
usw-
usw.
4711 01 17
Gürtel Monza rosa
140 cm
07S
12,00
4711 01
4711 01 18
Gürtel Monza lila
145 cm
07S
12,00
4711 01
4711 02 01
Gürtel Pisa rot
60 cm
07S
12,00
4711 02
4711 02 02
Gürtel Pisa gelb
65 cm
07S
12,00
4711 02
usw-
usw.
4711 02 17
Gürtel Pisa rosa
140 cm
07S
12,00
4711 02
4711 02 18
Gürtel Pisa lila
145 cm
07S
12,00
4711 02
4711 03 01
Gürtel Verona rot
60 cm
07S
12,00
4711 03
4711 03 02
Gürtel Verona gelb
65 cm
07S
12,00
4711 03
usw-
usw.
Beispiel Schnittstellendatei
2.10.3.15 Individuelle Schnittstellenlösungen

Für die Realisierung individueller Schnittstellen-Lösungen, z.B. die direkte Datenübernahme aus vorhandenen Warenwirtschaftssystemen oder aus einem vorhandenen Internetshop, wenden Sie sich bitte direkt an die KL-KatGen-Hotline.

2.10.3.16 Einlesen exportierter Artikeldaten in KL-KatGen zur Katalogaktualisierung

Zum Einlesen der aus Ihrem Warenwirtschaftssystem exportierten Artikeldaten oder aus von Ihrem Lieferanten zur Verfügung gestellten Daten z.B. aus MS-EXCEL Tabellen, wählen Sie den Menüpunkt "Datenimport" (Hauptmenü à Kataloge und Daten verwalten à Datenimport).

Im Vergleich zur Katalog-Erstellung werden in der Regel für die Aktualisierung der Katalogdaten weniger Daten
(-Felder) benötigt. So reichen für eine Preisaktualisierung unter Umständen "Artikel-Nummer" und "Artikel-Preis" in der Schnittstellendatei aus. Da beim Datenimport lediglich die Daten des Kataloges überschrieben werden, die in der Schnittstellendatei vorhanden (definiert) sind, empfehlen wir dafür eine entsprechende (weitere) vereinfachte Schnittstellenstruktur anzulegen. Weitere Details finden Sie unter "Datenimport".

2.10.3.17 Preisaktualisierung beim Katalogdruck bzw. der Kataloganzeige

Das Aktualisieren der Katalogdaten kann außer beim Datenimport auch beim Drucken bzw. bei der Anzeige der Kataloge erfolgen. Das Programm prüft vor dem Druck, bzw. der Anzeige des Kataloges, ob der entsprechende Artikel der Katalogdatei in der (KL-KatGen)-Artikeldatei vorhanden ist und übernimmt entsprechend den "Update-Schaltungen" die gewünschten Daten (in der Regel die Preise).

In dem Register "Preisoptionen" im Vorlauf-Fenster "Kataloge - Druck und Design" kann festgelegt werden, welche Daten in den Katalogpositionen beim Drucken oder Anzeigen der Kataloge aktualisiert werden.

Durch Markieren des Optionsfeldes "Katalog-Daten werden n i c h t aktualisiert" (siehe Abbildung). Wird das Aktualisieren der Katalogdaten beim Drucken oder Anzeigen komplett unterbunden.

Ist diese Option deaktiviert, können die Katalogdaten aktualisiert werden. Welche Datenfelder übertragen werden sollen, ist nach "Klick" auf den nun verfügbaren Button "Update-Steuerung" in dem sich öffnenden Fenster "Datenaktualisierung beim Drucken" auszuwählen.
Siehe Abbildung: Aktualisiert werden hier in unserem Beispiel die Preise 1 bis 5 .
Bei Katalog-Gruppen-Positionen ohne entsprechenden Artikel in der Artikeldatei bleiben die in der Kataloggruppe vorhandenen Daten erhalten.

ACHTUNG !!! Eventuelle manuelle Korrekturen in den Katalogdaten können durch ungewolltes Überschreiben verloren gehen. Überprüfen Sie daher die entsprechenden "Update-Schaltungen". Um ungewollte Ergebnisse rückgängig machen zu können, sollten Sie vor Durchführung mit der Funktion "Katalog speichern unter" eine Sicherungskopie des Kataloges anlegen.

3 Der Katalog-Designer

Im Generierungslauf beim Drucken bzw. bei der Druckanzeige stellt KL-KatGen die für den Katalogdruck notwendigen Daten bereit. Sie können nun mit einem der mitgelieferten "Katalogdesigns" Ihren ersten Katalog drucken.

KL-KatGen verfügt daher bereits in der Basisversion über einen integrierten Katalog-Designer. Passen Sie damit die mitgelieferten Designbeispiele auf Ihre Belange hin an oder erstellen Sie neue Versionen.

3.1 Starten des Katalog-Designers

Um das Design des voreingestellten Kataloges zu ändern, wählen Sie in der Programmverwaltung den Menü-Punkt "Preisliste-/Katalog Design".

In der Regel jedoch, werden Sie den Designer über die Funktionstaste "Drucken" à "aktuelles Design bearbeiten" aufrufen. Denn hier haben Sie die Möglichkeiten zwischen verschiedenen Designs zu wählen, neue zu erstellen und diese zugleich den entsprechenden Katalogdaten zuzuordnen. Details dazu finden Sie unter "Kataloge Drucken".
Das in der obigen Abbildung, im Katalog-Designer dargestellte Design, wird in der Basisversion von KL-KatGen als erläuterndes Beispiel "MUSTER02" mitgeliefert.

Dieses Beispieldesign soll Ihnen, ebenso wie die Beispieldesigns MUSTER01 und MUSTER03, lediglich die Arbeitsweise mit dem Katalog-Designer verdeutlichen. Sie erheben nicht den Anspruch auf Vollständigkeit.

3.2 Die Werkzeuge und Funktionen des Katalog-Designers

Siehe dazu die Abbildung zuvor.

Es öffnet sich der Katalog-Designer mit dem entsprechenden "Katalog" und zeigt das Menü "Bericht" und unter "Ansicht" die Werkzeuge zum Bearbeiten des Katalog-Designs:

- "Symbol-Leiste für Bericht-Steuerelemente"

- "Layout-Symbol-Leiste"

- "Symbolleiste für Farbpalette".

Zusätzlich stehen nun noch weitere Funktionen unter den einzelnen Hauptmenü-Punkten zur Verfügung, die je nach Arbeitsschritt aktiviert oder deaktiviert sind.

- Seite einrichten (à Datei)

- Format (Extra Menüpunkt)
- usw.

Aus dem Menü Ansichten können Sie die für das Ändern/Erstellen notwendigen "Werkzeuge" auswählen.

3.3 Grundeinstellungen des Katalog-Designs
(Seiteneinstellungen)

Die Seiteneinstellungen des Kataloges können Sie unter à "Datei" à "Seite einrichten" anpassen.

Bestimmen Sie dort bei Bedarf:

- Seitenränder

- Seitenbreite

- die Anzahl der zu druckenden Spalten

- Sortierfolge (wird in der Regel nicht geändert).

Beachten Sie das die Druckbereiche je nach Druckertreiber variieren können und dies zu unterschiedlichen Darstellungen der Daten führen kann. Um den Druckbereich auf die druckerspezifischen Vorgaben zu reduzieren wählen Sie Option "Druckbereich/Druckränder beachten".

3.4 Die Katalogbereiche

Im Katalog-Designer werden die unterschiedlichen Katalogbereiche durch die horizontal verlaufenden "grauen Balken" gekennzeichnet.

Zum besserem Verständnis ein paar Informationen vorab.

Kernstück des Katalogdrucks sind die Kataloggruppen-Positionen. Daraus erzeugt KL-KatGen beim Kataloggenerieren (automatisiert beim Druck bzw. Anzeige), aufgrund der vom Anwender erfassten Ergänzungen die zu druckenden Datensätze.

Design "MUSTER01":

In der einfachsten Form benötigt man in dem Katalogdesign lediglich die Bereiche Seitenkopf, Seitenfuß und den Detailbereich (siehe Design "MUSTER01").

Design "MUSTER02":

Beinhaltet eine Kataloggruppe mehrere Positionen, und wünschen Sie für jede Kataloggruppe zusätzliche Information anzudrucken (z.B. Bild, Bezeichnung, Texte ), so ist der Gruppenwechsel "Katalognr" mit den entsprechenden zu druckenden Feldern einzufügen (siehe Design "MUSTER02").

Zusätzlich ist in diesem Musterdesign auch der gesteuerte Seitenwechsel eingearbeitet. (Gruppenwechsel "SV", zu aktivieren durch Markieren der Kataloggruppe in der Arbeitsansicht im Feld "SV").

Design "MUSTER03":

Wollen Sie beispielsweise zusätzlich Zwischenüberschriften, -Texte im Kopf- und Positionsbereich andrucken, so ist im Design der Gruppenwechsel "NUEB" (=neue Überschrift) einzufügen. Dieser Bereich wird automatisch angedruckt, sobald Sie in der Arbeitsansicht einer Kataloggruppe die Kennzeichnung "Pos.Üb." markieren, d.h. wenn Sie eine entsprechende Zwischenüberschrift vor der Kataloggruppe wünschen (à Überschriften)

(siehe Design "MUSTER03").

Sollen mit dem gleichen Katalogdesign auch mehrspaltig Positionen angedruckt werden (maximal vier Spalten), so ist die Kataloggruppe "HGR = Wechsel auf mehrspaltige Darstellung" einzufügen. Dieser Bereich wird automatisch angesteuert, sobald in der Arbeitsansicht einer Kataloggruppe eine der Darstellungsarten "SL ", "SK ", "BK " oder ="BL" zugeordnet wird.

Jeder Katalogbereich besteht aus einem "Kopf-" und einem "Fußbereich".

Zu unterscheiden sind nachfolgende Bereiche / Gruppenwechsel:

Titel Erscheint nur (einmal, bei Bedarf) am Anfang des Kataloges.

Seitenkopf Firmenbezeichnung, Kataloggültigkeit, Seitenüberschriften, Seitentexte, Seitenzahl, Datum usw., eigenes Firmen-Logo, Logo der Artikel-/Kataloggruppe

Gruppenkopf In einem Katalogdesign können mehrere Gruppierungen bestimmt werden. Für jede Gruppe sind die zu druckenden Elemente wie Zwischenüberschriften, Zwischentexte, Logo der Artikel-/Kataloggruppe festzulegen.
Primär werden hier auch die Bilder, Texte, Bezeichnungen einer Kataloggruppe definiert.

KL-KatGen verfügt bereits über verschiedene "Standard Gruppen (Wechsel)".

Katalognr + SA Sonderfunktion (z.Z. nur in Verbindung mit Darstellungsart "22").
Bereich für Überschriften, wenn mehr als 11 Preise je Kataloggruppenposition benötigt werden. Dieser Bereich wird automatisch angedruckt, sobald in der Arbeitsansicht einer Kataloggruppe die Darstellungsart "22 " zugewiesen wurde.

Katalognr Bereich für Überschriften, Bild, Texte für die zu einer Kataloggruppe zusammengefassten Kataloggruppen-Positionen.
Dieser Bereich wird automatisch angedruckt, sobald die Kataloggruppe wechselt.

NUEB neue Positions-/Zwischenüberschrift.
Dieser Bereich wird automatisch angedruckt, sobald Sie in der Arbeitsansicht einer Kataloggruppe die Kennzeichnung "Pos.Üb." markieren, d.h. wenn Sie eine entsprechende Zwischenüberschrift vor der Kataloggruppe wünschen (à Überschriften).

HGR Wechsel auf mehrspaltige Darstellung
Dieser Bereich wird automatisch angedruckt, sobald in der Arbeitsansicht einer Katalog-Gruppe eine der Darstellungsarten "SL ", "SK ", "BK " oder "BL " zugewiesen wurde.

UGR Sonderfunktion.
Dieser Bereich wird automatisch angedruckt, sobald Sie ein Wechsel "mehrspaltige Darstellung und unterschiedliche hohe Bilddarstellung", in der Arbeitsansicht einer Kataloggruppe in der Darstellungsart zugewiesen wurde (Details auf Anfrage).

Detailbereich Der Detailbereich enthält die eigentlich zu druckenden Daten der Katalogpositionen, die in der Datei "Preisarti", nach dem Generieren zur Verfügung gestellt werden.

Gruppenfuß Erscheint am Ende jeder Gruppierung (z.B. Trennlinie oder Zeilenabstand zur nächsten Gruppe).

Seitenfuß Erscheint auf jeder Seite am unteren Rand (z.B. Seitenzahl, Firmendaten, Kataloggültigkeit, Hinweise auf AGB, Brutto-/Nettopreise usw.

Zusammenfassung Katalog-Abschluss-Seite

Eigene Bereiche / Gruppenwechsel erstellen:

Entsprechend Ihren Anforderungen können Sie (weitere) eigene Gruppierungen definieren. Die kann insbesondere bei der vollautomatisierten Katalogerstellung z.B. für das automatische Erstellen von Zwischenüberschriften genutzt werden.

Beispiel:

Sie wollen einen Katalog mit Befestigungsmaterialen erstellen. In einem Datenfeld der Importdatei, wird Ihnen zu jedem Artikel die entsprechende Gruppe wie "Schrauben", "Nägel", "Dübel" usw. übergeben. Das Einlesen der Artikel erfolgt sortiert nach diesen Gruppierungen. Die Zuordnung / Übernahme (siehe "Importschnittstelle") dieses Datenfeldes erfolgt z.B. in das Feld "T1". Definiert man im Designer einen entsprechenden Gruppenwechsel (hier für Feld T11), können beim Wechsel des Inhaltes dieses Feldes (z.B. "Dübel" à "Nägel"), sowohl die Inhalte dieses Feldes, als auch weitere damit in Verbindung stehende Werte angedruckt werden bzw. kann dies (zusätzlich) Auslöser für Aktionen wie Seitenwechsel, Druck eines Bildes usw. sein.

3.5 Die Katalog-Steuerelemente

Für die Darstellung der Daten stellt KL-KatGen nachfolgende Katalog-Steuerelementtypen zur Verfügung.

Bei aktivem Katalog-Designer finden Sie die entsprechenden Werkzeuge unter Hauptmenüà Ansicht à Symbolleiste für Bericht-Steuerelemente.

Beschriftungen Mit dem Steuerelement "Beschriftungen" "A-Feld" bezeichnen Sie die Inhalte der zu druckenden, variablen Textfelder (Spaltenüberschriften, Feldbezeichnungen).
Klicken Sie dazu auf das "A-Symbol", positionieren Sie im Design mit "Klick" und schreiben Sie über die Tastatur den gewünschten Text.

Für eine nachträgliche Änderung des Textes zuerst auf das "A-Symbol" und dann auf das zu ändernde Feld klicken.

Textfelder Textfelder beinhalten die eigentlichen Informationen des Kataloges. Klicken Sie auf das "AB-Feld" im Fenster "Bericht-Steuerelemente" und anschließend auf die gewünschte Position im Design. Es öffnet sich das Berichtsausdrucksfenster und erwartet die Eingabe des Namens des zu druckenden Datenfeldes (manuelle Eingabe oder Auswahl), einschl. der Formatierung und der Druckbedingungen.
Eine Übersicht der zur Verfügung stehenden Datenfelder finden Sie auf den Folgeseiten unter "Datenfelder und Funktionen für den Druck"

Rechtecke, Linien

und Kreise Diese Steuerelemente verwenden Sie um Rechtecke, Linien und Kreise in Ihrem Katalog darzustellen.
Klicken Sie dazu das gewünschte Symbol in der Symbolleiste für Bericht-Steuerelemente an, positionieren Sie im Design und legen Sie mit gedrückter Maus-Taste die Größe des Elementes fest.

OLE-Felder /

Abbildungen Mit dem Steuerelement "OLE" werden die Bild-Steuerelemente ausgewählt.

3.6 Datenfelder und Funktionen für den Druck

Aus dem generierten Datenbestand, den Stammdaten und den Zusatzinformationen stellt KL-KatGen
die nachfolgenden Datenfelder, Funktionen und Zusatzinformationen für den Katalogdruck zur Verfügung.

3.6.1 Datenfelder für den Druck

Daten aus den folgenden Dateien / Tabellen können im Berichtsdesigner angesprochen und gedruckt werden.

Beachten Sie bitte, dass u.U. nicht immer alle Dateien in allen Designs notwendig sind und daher auch nicht alle Datenfelder verfügbar sein müssen. Im Bedarfsfall wenden Sie sich bitte an de KL-KatGen Hotline.

ACHTUNG: Es stehen nicht in allen Designs alle Tabellen zur Verfügung

3.6.1.1 Tabellen und Datenfelder für den Druck der Kataloghauptdaten (Positionen und Artikel)

Beachten Sie die neue Druckfunktion drucke("wasdrucken", subZ ,subP), die die eine vereinfachte, einheitliche Arbeitsweise erlaubt und die direkte Verwendung der Datenfelder der "Preisarti" und "Katpos" ersetzt.

KatStandard01

KatStandard02

KatStandard-Profi

Prlstandard01

Prlstandard02

Katgruppe

X

X

X

X

X

Katgruppe2,3,4 ²

X

Katpos

X

X

X

X

X

Katpos2,3,4 ²

X

Preisarti

X

X

X

X

X

Artikel

X

X

X

X

X

Artikel2,3,4 ²

X

FaArtikel

X

X

X

X

X

FaArtikel2,3,4 ²

X

Register

X

X

X

X

X

Spaueb

X

X

X

X

Ueberschriften

X

X

X

X

² Voraussetzung für Darstellungsarten S13, S14; S23 S24, siehe dazu das Kapitel "Kataloggruppen nebeneinander"

3.6.1.1.1 Tabellen und Datenfelder für den Druck der Katalogdaten (Artikel, Artikelgruppen)

Katgruppe Synonym / programminterne Bezeichnung für die Tabelle mit den Kopfdaten der Kataloggruppe. Die eigentlich genutzte Tabelle hat die Bezeichnung "KATALOGNAME.PRL" ( z.B. "Buero01.prl"). Bei den mehrspaltigen Darstellungsarten wie SK, BK, SL,BL und S01 bis S49 wird diese Tabelle mit "Katgruppe1", "Katgruppe2" usw. in Abhängigkeit der jeweiligen Spalte angesprochen.

Katpos Synonym / programminterne Bezeichnung für die Tabelle mit den Positionsdaten der Kataloggruppe (Artikel). Die eigentlich genutzte Tabelle hat die Bezeichnung "KATALOGNAME_:PRL" ( z.B. "Buero01.prl"). Bei den mehrspaltigen Darstellungsarten wie SK, BK, SL,BL und S01 bis S49 wird diese Tabelle mit "Katgruppe1", "Katgruppe2" usw. in Abhängigkeit der jeweiligen Spalte angesprochen.

Preisarti Synonym / programminterne Bezeichnung für die Tabelle mit den Positionsdaten der Kataloggruppe (Artikel). Die eigentlich genutzte Tabelle hat die Bezeichnung "KATALOGNAME_:PRL" ( z.B. "Buero01.prl").

Artikel Programminterne Artikel-Tabelle mit den manuell erfassten bzw. mit den beim Datenimport erzeugten / aktualisierten Artikeldaten.

FaArtikel Synonym / programminterne Bezeichnung für die Tabelle mit den beim Datenimport erzeugten Artikeldaten. Die Inhalte dieser Tabelle (die einzelnen Datenfelder) Feldbezeichnungen und Feldtyp entsprechen den beim Datenimport übernommen Werten (siehe Importstruktur beim Datenimport)
Die eigentlich genutzte Tabelle hat die Bezeichnung "FaKATALOGNAME:DBF" ( z.B. "FaBuero01.dbf").

3.6.1.2 Tabellen und Datenfelder für den Druck Katalogergänzungsdaten
(Inhaltsregister, Deckblätter, Zwischenblätter)

regstandard

regastandard

regkstandard

registandard

regVstandard

regVstandardV

Kategorien

X

X

X

X

Register

X

X

X

X

Reftab1

Reftab2

Reftab3

Registerkat

X

RegisterKatV

X

x

Katgruppe

X

X

X

X

Artikel

Faartikel

X

X

Katpos

X

X

3.6.1.2.1 Tabellen und Datenfelder für den Druck der Katalogdaten (Artikel, Artikelgruppen)

Register Temporär, bei Katalog-Druck bzw. Katalog-Anzeige erstellte Datei mit den entsprechenden Inhalten aus den Registerfeldern sowie Kategoriebezogenen Vorsortierungen.
Hieraus werden beim "Einzeldruck" die diversen Registerarten und Inhaltsverzeichnisse gespeist.

Kategorien Hier erwartet das Programm die entsprechende Kategorienhierarchie die Sie entweder manuell angelegt oder automatisiert per Schnittstelle eingelesen haben.
Weitere Details finden Sie in den Kapiteln "Kategorienermittlung" bzw. "Kategorien-Verwaltung".

3.6.1.3 Datenfelder für den Druck

Datei Preisarti (generiert aus den Katalogpositionen)

Beachten Sie die neue Druckfunktion drucke("wasdrucken", subZ ,subP), die die eine vereinfachte, einheitliche Arbeitsweise erlaubt und die direkte Verwendung der Datenfelder der "Preisarti" und "Katpos" ersetzt.

Preisarti.Katalognr Katalognummer

Preisarti.Katalognr2 Katalognummer bei Darstellungsarten BK,SK,BL,SL Spalte 2

Preisarti.Katalognr3 Katalognummer bei Darstellungsarten BK,SK,BL,SL Spalte 3

Preisarti.Katalognr4 Katalognummer bei Darstellungsarten BK,SK,BL,SL Spalte 4

Preisarti.Drv Druckvariante, Darstellungsart

Preisarti.Sv Seitenvorschub

Preisarti.Spv Spaltenvorschub / Neue Spalte (nur bei mehrspaltigem Katalog)

Preisarti.Nueb Neue Überschrift

Preisarti.artnr Artikelnummer

Preisarti.preis01 Preisfelder 01 bis 12

Preisarti.b11, ..b12 Artikelbezeichnung 1 und 2

Preisarti.b21, ..b22 Artikelbezeichnung 1 und 2 bei Darstellungsarten BK,SK,BL,SL Spalte 2

Preisarti.b31, ..b32 Artikelbezeichnung 1 und 2 bei Darstellungsarten BK,SK,BL,SL Spalte 3

Preisarti.b41, ..b42 Artikelbezeichnung 1 und 2 bei Darstellungsarten BK,SK,BL,SL Spalte 3

Preisarti.artbezkat Artikelbezeichnung im Katalog 1

Preisarti.artbezkat2 Artikelbezeichnung im Katalog bei Darstellungsarten BK,SK,BL,SL Spalte 2

Preisarti.artbezkat3 Artikelbezeichnung im Katalog bei Darstellungsarten BK,SK,BL,SL Spalte 3

Preisarti.artbezkat4 Artikelbezeichnung im Katalog bei Darstellungsarten BK,SK,BL,SL Spalte 4

Preisarti.artbezm Zusatztext

Preisarti.menge1 Menge 1 z.B. für Staffelpreise

Preisarti.menge2 Menge 2 z.B. für Staffelpreise

Preisarti.menge3 Menge 3 z.B. für Staffelpreise

Preisarti.menge4 Menge 4 z.B. für Staffelpreise

Preisarti.menge5 Menge 5 z.B. für Staffelpreise

Preisarti.stf1 frei belegbares Steuerfeld 1 (Erfassung in der Arbeitsansicht)

Preisarti.stf2 Steuerfeld 2 (noch nicht aktiviert)

Preisarti.stf3 Steuerfeld 3 (noch nicht aktiviert)

Preisarti.artnr Artikel-Nummer

Preisarti.artnr2 Artikel-Nummer bei Darstellungsarten BK,SK,BL,SL Spalte 2

Preisarti.artnr3 Artikel-Nummer bei Darstellungsarten BK,SK,BL,SL Spalte 3

Preisarti.artnr4 Artikel-Nummer bei Darstellungsarten BK,SK,BL,SL Spalte 4

Preisarti.t1,t2,t3,t4,t5 Zusatz-Textfeld 1,2,3,4,5

Preisarti.t11 Zusatz-Textfeld 1,2,3,4,5

..t12, .. t13,...t14, ..t15

Preisarti.t21 dto. bei Darstellungsarten BK,SK,BL,SL Spalte 2

..t22, .. t23,...t24, ..t25

Preisarti.t31 dto. bei Darstellungsarten BK,SK,BL,SL Spalte 3

..t32, .. t33,...t34, ..t35

Preisarti.t41 dto. bei Darstellungsarten BK,SK,BL,SL Spalte 4

..t42, .. t43,...t44, ..t45

Preisarti.n11 Zusatz-Wertfeld 1,2,3,4,5

..n12, .. n13,...n14, ..n15

Preisarti.n21 dto. bei Darstellungsarten BK,SK,BL,SL Spalte 2

..n22, .. n23,...n24, ..n25

Preisarti.n31 dto. bei Darstellungsarten BK,SK,BL,SL Spalte 3

..n32, .. n33,...n34, ..n35

Preisarti.n41 dto. bei Darstellungsarten BK,SK,BL,SL Spalte 4

..n42, .. n43,...n44, ..n45

Preisarti.Preis01 bis Preis05 Preise 1 bis 5

Preisarti.Preis06 bis Preis12 Preise 6 bis 12

Preisarti.Preis201 bis Preis205 Preise 1 bis 5 bei Darstellungsarten BK,SK,BL,SL (Spalte 2)

Preisarti.Preis301 bis Preis305 Preise 1 bis 5 bei Darstellungsarten BK,SK,BL,SL (Spalte 3)

Preisarti.Preis401 bis Preis405 Preise 1 bis 5 bei Darstellungsarten BK,SK,BL,SL (Spalte 4)

Preisarti.f1 bis f5 Freifeld 1 bis 5

Preisarti.f11 bis f15 Freifeld 1 bis 5 bei Darstellungsarten BK,SK,BL,SL (Spalte 1)

Preisarti.f21 bis f25 Freifeld 1 bis 5 bei Darstellungsarten BK,SK,BL,SL (Spalte 2)

Preisarti.f31 bis f35 Freifeld 1 bis 5 bei Darstellungsarten BK,SK,BL,SL (Spalte 3)

Preisarti.f41 bis f45 Freifeld 1 bis 5 bei Darstellungsarten BK,SK,BL,SL (Spalte 4)

Datei Katgruppe

Katgruppe.Bez1 Kataloggruppen Bezeichnung 1 50 Stellen

Katgruppe.Bez2 Kataloggruppen Bezeichnung 2 50 Stellen

Katgruppe.Zustext Kataloggruppen Zusatz-Text Memo

Katgruppe.Bild Dateiname Kataloggruppen Bild 60 Stellen

Katgruppe.Darstell Darstellungsart der Kataloggruppe 4 Stellen

Katgruppe.Preiseinh1 Preiseinheiten 1 20 Stellen

Katgruppe.Preiseinh2 Preiseinheiten 2 20 Stellen

Katgruppe.Preiseinh3 Preiseinheiten 3 20 Stellen

Katgruppe.Stf1 Steuerfeld 1 4 Stellen

Katgruppe.Stf2 Steuerfeld 2 4 Stellen

Katgruppe.Stf3 Steuerfeld 3 4 Stellen

Katgruppe.T1 Textfeld 1 frei verwendbar 250 Stellen

Katgruppe.T2 Textfeld 2 frei verwendbar 250 Stellen

Katgruppe.T3 Textfeld 3 frei verwendbar 250 Stellen

Katgruppe.T4 Textfeld 4 frei verwendbar 250 Stellen

Katgruppe.T5 Textfeld 5 frei verwendbar 250 Stellen

Katgruppe.T6 Textfeld 6 frei verwendbar 250 Stellen

Katgruppe.Sv Seitenvorschub Anzahl Zeilen

Katgruppe.Nueb neue Überschrift ja/nein

Katgruppe.Updsperre Updatesperre für gesamte Kataloggruppe

Katgruppe.vpe1n Verpackungseinheit 1 Menge

Katgruppe.vpe1t Verpackungseinheit 1 20 Stellen

Katgruppe.vpe2n Verpackungseinheit 2 Menge

Katgruppe.vpe2t Verpackungseinheit 2 20 Stellen

Katgruppe.vpe3n Verpackungseinheit 3 Menge

Katgruppe.vpe3t Verpackungseinheit 3 20 Stellen

Katgruppe.Zv Zeilenvorschub

Katgruppe.Bild2 Dateiname Kataloggruppen Bild 2 60 Stellen

Katgruppe.Bild3 Dateiname Kataloggruppen Bild 3 60 Stellen

Katgruppe.Bild4 Dateiname Kataloggruppen Bild 4 60 Stellen

Katgruppe.Bild5 Dateiname Kataloggruppen Bild 5 60 Stellen

Katgruppe.Bild1st Steuerfeld zu erstem Bild 4 Stellen

Katgruppe.Bild2st Steuerfeld zu Bild 2 4 Stellen

Katgruppe.Bild3st Steuerfeld zu Bild 3 4 Stellen

Katgruppe.Bild4st Steuerfeld zu Bild 4 4 Stellen

Katgruppe.Bild5st Steuerfeld zu Bild 5 4 Stellen

zt11 bis zt201 Felder aus Maske "Zusatzdaten" zeilenweise.

Datei KatPos (Katalog-Artikelpositionen)

Beachten Sie die neue Druckfunktion drucke("wasdrucken", subZ ,subP), die die eine vereinfachte, einheitliche Arbeitsweise erlaubt und die direkte Verwendung der Datenfelder der "Preisarti" und "Katpos" ersetzt.

KatPos.ArtBez1 Artikelbezeichnung 1 50 Stellen

KatPos.ArtBez1 Artikelbezeichnung 2 50 Stellen

KatPos.ArtBezKat Artikelbezeichnung im Katalog 100 Stellen

KatPos.ArtGr Artikelgruppe 10 Stellen

KatPos.KatalogNr Katalog-Gruppennummer 12 Stellen

KatPos.PosNr Katalog-Positionsnummer 5 Stellen

KatPos.ListenNr frei 10 Stellen

KatPos.n1 Wertfeld 1

KatPos.n2 Wertfeld 2

KatPos.n3 Wertfeld 3

KatPos.n4 Wertfeld 4

KatPos.n5 Wertfeld 5

KatPos.Preis Preis 1

KatPos.Preis2 Preis 2

KatPos.Preis3 Preis 3

KatPos.Preis4 Preis 4

KatPos.Preis5 Preis 5 Alle Wert- und Preisfelder 999999,999

KatPos.register Registereintrag Index 50 Stellen

KatPos.Steuerung Kataloggruppen Bezeichnung 1 10 Stellen

KatPos.t1 Textfeld 1 50 Stellen

KatPos.t2 Textfeld 2 50 Stellen

KatPos.t3 Textfeld 3 50 Stellen

KatPos.t4 Textfeld 4 50 Stellen

KatPos.t5 Textfeld 5 50 Stellen

KatPos.updSperre Updatesperre 1 Stelle

KatPos.zustext Zusatztext Memo

KatPos.zustext2 Zusatztext2 Memo

KatPos.Bild Dateiname Bild 60 Stellen

KatPos.Bild2 Dateiname Bild 2 60 Stellen

KatPos Bild3 Dateiname Bild 3 60 Stellen

KatPos.Bild4 Dateiname Bild 4 60 Stellen

KatPos.Bild5 Dateiname Bild 5 60 Stellen

KatPos.Bild1st Steuerfeld zu erstem Bild 4 Stellen

KatPos.Bild2st Steuerfeld zu Bild 2 4 Stellen

KatPos.Bild3st Steuerfeld zu Bild 3 4 Stellen

KatPos.Bild4st Steuerfeld zu Bild 4 4 Stellen

KatPos.Bild5st Steuerfeld zu Bild 5 4 Stellen

Datei Artikel

Artikel.Artbez1 Artikelbezeichnung 1 50 Stellen

Artikel.Artbez2 Artikelbezeichnung 2 50 Stellen

Artikel.Artgr1 Artikelgruppe 1 4 Stellen

Artikel.Artgr2 Artikelgruppe 2 10 Stellen

Artikel.artnr Artikelnummer

Artikel.Zustext Artikelzusatztext Memo

Artikel.Bild Dateiname Bild 60 Stellen

Artikel.darst Darstellungsart 4 Stellen

Artikel.Gewicht Gewicht

Artikel.Infotext1 Infotext 1 254 Stellen Text1 bis 4 wird beim Import autom. In den

Artikel.Infotext2 Infotext 2 254 Stellen Zusatztext übernommen

Artikel.Infotext3 Infotext 3 254 Stellen

Artikel.Infotext4 Infotext 4 254 Stellen

Artikel.Katgruppe Kataloggruppe 12 Stellen für autom. Katalogerstellung

Artikel.KatPosNr Kataloggruppenpositionsnummer 5 Stellen für autom. Katalogerstellung

Artikel.Listung1 Listung 1 10 Stellen

Artikel.Listung2 Listung 2 10 Stellen

Artikel.Match Matchcode 20 Stellen

Artikel.mwst Mehrwertsteuersatz

Artikel.n1 Wertfeld 1

Artikel.n2 Wertfeld 2

Artikel.n3 Wertfeld 3

Artikel.n4 Wertfeld 4

Artikel.n5 Wertfeld 5 Wertfelder 999999,999

Artikel.neu Artikelgruppe 1 2 Stellen

Artikel.vkbasis Preis 1

Artikel.p2 Preis 2

Artikel.p3 Preis 3

Artikel.p4 Preis 4

Artikel.p5 Preis 5 Preisfelder 999999,999

Artikel.sortierung

Artikel.t1 Textfeld 1 60 Stellen

Artikel.t2 Textfeld 2 60 Stellen

Artikel.t3 Textfeld 3 60 Stellen

Artikel.t4 Textfeld 4 60 Stellen

Artikel.t5 Textfeld 5 60 Stellen

Artikel.vpe1n Verpackungseinheit 1 Menge

Artikel.vpe1t Verpackungseinheit 1 Text 20

Artikel.vpe2n Verpackungseinheit 2 Menge

Artikel.vpe2t Verpackungseinheit 2 Text 20

Artikel.vpe3n Verpackungseinheit 3 Menge

Artikel.vpe3t Verpackungseinheit 3 Text 20

Artikel.Bild2 Dateiname Bild 2 60 Stellen

Artikel.Bild3 Dateiname Bild 3 60 Stellen

Artikel.Bild4 Dateiname Bild 4 60 Stellen

Artikel.Bild5 Dateiname Bild 5 60 Stellen

Artikel.Bild1st Steuerfeld zu erstem Bild 4 Stellen

Artikel.Bild2st Steuerfeld zu Bild 2 4 Stellen

Artikel.Bild3st Steuerfeld zu Bild 3 4 Stellen

Artikel.Bild4st Steuerfeld zu Bild 4 4 Stellen

Artikel.Bild5st Steuerfeld zu Bild 5 4 Stellen

Nachfolgende Felder sind für kursabhängige Preisgenerierung

Artikel.mn1 Notierung 1

Artikel.mnbasis1 Basiskurs 1

Artikel.sw1 Schrittweite 1

Artikel.zu1 Zuschlag 1

Artikel.mnbasis2 Basiskurs 2

Artikel.mn2 Notierung 2

Artikel.sw2 Schrittweite

Artikel.zu2 Zuschlag 2

Sonstige Variablen

verwenden Sie die neuen Funktionen für Überschriften über Pseudo-Kataloggruppen.

Details unter "spezielle Darstellungsarten mit integrierter Funktion"

Sueberschrift Seitenüberschrift 1

Sueberschrift1 Seitenüberschrift 1

Sueberschrift2 Seitenüberschrift 2

Sueberschrift3 Seitenüberschrift 3"

Sueberschrift4 Seitenüberschrift 4

SueberschriftBild Dateiname des Bildes für Seitenüberschrift

Suebtext1 Seitenüberschrift 1 Zusatztext

Suebtext2 Seitenüberschrift 2 Zusatztext

Pueberschrift Zwischenüberschrift 1

Pueberschrift1 Zwischenüberschrift 1

Pueberschrift2 Zwischenüberschrift 2

Pueberschrift3 Zwischenüberschrift 3

Pueberschrift4 Zwischenüberschrift 4

PueberschriftBild Dateiname des Bildes für Zwischenüberschrift

Puebtext1 Zwischenüberschrift 1 Zusatztext

Puebtext2 Zwischenüberschrift 2 Zusatztext

preisListenNummer der im Vorlauf des Katalogdrucks erfassbare Text

(z.B. "Preisliste gültig ab")

faName Firmen-Name aus dem Firmenstamm

faStraße Straßenname aus dem Firmenstamm

faPlzOrt Postleitzahl und Ort aus dem Firmenstamm "

faWerbeName Firmen- (Werbe-)Name aus dem Firmenstamm

faWerbeText Werbe-Text aus dem Firmenstamm

faLogo Pfadname des Firmen-Logos

zeilenvorschub Anzahl

_pageno laufende Seitennummer

leer Leerfeld zur Unterdrückung von Leerräumen

Spezielle Variablen für das Auftragswesen (Briefe, Angebote etc.)

a_nummer Angebotsnummer

a_kundennr Kundennummer

a_ansprechpartner Ansprechpartner (eigener)

a_name1 bis a_name3 Name des Kunden (Zeile 1 bis 3)

a_plz PLZ des Kundenortes

a_ort PLZ des Kunden

a_betreff Betreff des Dokuments (nicht bei Briefen)

a_kopftext Kopftext des Dokuments

briefbetreff Betreff des Dokuments (nur bei Briefen)

briefinhalt Briefinhalt (Fliesstext) des Dokuments (nur bei Briefen)

a_manamekd Sachbearbeiter beim Kunden

a_anfragedatum Anfragedatum

a_bestellnrKD Bestellnummer beim Kunden

katpos.n5 Menge

possumme Summe einer Position

zwsumme Nettobetrag

mwst1 Mwst-Satz1

mwst2 Mwst-Satz2

mw1sum Mwst-Basis1

mw2sum Mwst-Basis2

mw2sum*(mwst1/100) Mwst-Betrag1

mw2sum*(mwst2/100) Mwst-Betrag2

zwsumme+(mw1sum*(mwst1/100))+mw2sum*(mwst2/100)
Bruttosumme (Endbetrag)

a_lieferbed Lieferbedingung

a_zahlungsbed Zahlungsbedingung

a_fusstext Fusstext

3.6.1.4 Funktionen für den Druck

KL-KatGen verfügt über eine Vielzahl interner Funktionen, die beim Drucken die Verarbeitung im Hintergrund steuern und zusätzlich zu den zu den im Anschnitt zuvor aufgeführten Tabellen und Datenfeldern Informationen bereitstellen und automatisiert Daten erzeugen. Im Berichtsdesigner an entsprechender Stelle hinterlegt liefern diese zum Beispiel den Pfadnamen der Abbildung eines Artikels (und somit das Bild), die aktuelle Seitenzahl oder die Information ob der Druck im Moment auf einer geradzahligen oder ungeradzahligen Seite stattfindet.
Zusätzlich werden im Hintergrund die Daten für Inhaltsverzeichnis und Inhaltsregister gesammelt.

3.6.1.5 Haupt-Steuerfunktionen

Wie bereits beschrieben sind die zu druckenden Daten im Berichtsdesigner zu bestimmen und die "steuernden Informationen" zu hinterlegen. Betrachten wir dazu den grundsätzlichen Aufbau des Berichtsdesigners anhand eines Beispiels in der nachfolgenden Abbildung:

Um die neuen Druckfunktionen (ab Programm-Release 10) nutzen können, sind nachfolgende Hauptfunktionen im Berichtsdesigner zu hinterlegen (Doppel-Klick auf die jeweilige "Leiste")

Titelleiste, Seitenkopf, Gruppenkopf 1 +2 (rote Pfeile)

nkgr9(katgruppe.katalognr,_pageno) .

Detailleiste (blauer Pfeil)

npos9(katgruppe.katalognr,_pageno)

Ein Doppel-Klick auf die "graue Zeile" des entsprechenden Gruppenwechselbereiches öffnet das jeweilige "Gruppenkopf-Fenster" (siehe Abbildung).

Veraltete Steuerungen:

Die nachfolgenden Funktionen sind aus Kompatibilitätsgründen weiterhin verfügbar.

Zur Ausnutzung der vollen Funktionalität sind die oben aufgeführten neuen Funktionen zu verwenden.

nueb(katgruppe.katalognr,_pageno) steuert Überschriften.

Diese Funktion ist jeweils in dem Eingabefeld "bei Start" (s. Abb. unten) im Titelbereich, im Seitenkopfbereich und Bereich "Nueb" einzutragen. (Doppelklick auf "graue Zeile").

nkgr(katgruppe.katalognr,_pageno) steuert Druckablauf. (gültig ab Rel. 5.20Z).

Diese Funktion ist jeweils in dem Eingabefeld "bei Start" (s. Abb. unten) im Gruppenkopf n "katalonr" einzutragen. (Doppelklick auf "graue Zeile").

Npos(katgruppe.katalognr,_pageno) steuert Druckablauf. (gültig ab Rel. 5.20Z).

Diese Funktion ist jeweils in dem Eingabefeld "bei Start" (s. Abb. unten) im Detailbereich einzutragen. (Doppelklick auf "graue Zeile").

nueberschrift(katgruppe.katalognr,_pageno) entsprechend "nueb".

nkatgruppe(katgruppe.katalognr,_pageno) ientsprechend "nkgr".

gwkatgruppe(katgruppe.katalognr,_pageno) (gilt für Release bis 5.00)

initial() ermittelt ersten Buchstaben aus einem Datenfeld und liefert diesen als Großbuchstaben zurück (ä,ö,ü werden in A,O,U gewandelt). Funktion kann für die Gruppenwechselsteuerung genutzt werden (z.B. Überschriftenbuchstabe in alphabetischem Register mit Einsortierung der Umlaute in Register A, O, U)

Unter Objekt-Drucken (Klick auf die entsprechende Taste) fügen Sie in das Feld "nur Drucken wenn Ausdruck wahr ist" die Bedingung leer > " " ein und markieren "Zeile entfernen wenn leer".

mline(Memodatenfeld,Zeile) ermöglicht das Andrucken einer bestimmten Zeile aus einem Memofeld

Beispiel: mline(Katgruppe.zustext2,1) druckt die erste Zeile des Memofeldes "zustext2"

Auf folgende Felder kann hiermit zugegriffen werden:

Zustext1 bis 5

Zustext6 bis 10 (Label)

Für die Kataloggruppe (katgruppe.zustext1 bis zustext5)

Für die Katalogpositionen (katpos.zustext1 bis zustext5)

Für die Artikeldatei (Artikel.zustext1 bis zustext5)

Die Labelzuordnung ist folgendermaßen festgelegt:

Label Inhalt

Zustext6 Zustext1
Zustext7 Zustext2
Zustext8 Zustext3
Zustext9 Zustext4
Zustext10 Zustext5

Lesen Sie hierzu auch das Kapitel "Label setzen für formatierte Textfelder".für den Artikelstamm.
Sonstige Funktionen für den Druck

Sonstige Funktionen

gerade() wahrer Ausdruck bei gerader Seitenzahl

ungerade() wahrer Ausdruck bei ungerader Seitenzahl

posgerade() wahrer Ausdruck bei gerader Positionszahl

posungerade() wahrer Ausdruck bei ungerader Positionszahl

(z. B. abwechselnd graue/weiße(=ohne) Unterlegung von Positionen)

faLogo() Liefert den Pfadnamen des Firmen-Logos (für Bild-Objekt)

faLogoDa() liefert ".T." true (Wahr) zurück wenn Datei vorhanden

testmodus Objekte, die nur zum Testen angezeigt bzw. gedruckt werden sollen.

In der Druckoption "Objekt drucken" unter der Rubrik "Nur drucken, wenn Ausdruck wahr ist" den Eintrag "testmodus=1" definieren.
Der Testmodus wird aktiviert mit rechter Maustaste auf "Anzeige" oder "Druck".

BildV(Feldname) Liefert den Pfadnamen einer Abbildung. z.B."katpos.bild"

BildVDa(Feldname) liefert ".T." true (Wahr) zurück wenn Bild-Datei vorhanden "

BildKG0() Liefert den Pfadnamen einer Abbildung für die Kataloggruppe

BildKG0DA() liefert ".T." true (Wahr) zurück wenn Bild-Datei vorhanden

BildKG1() Liefert den Pfadnamen einer Abbildung für die Kataloggruppe 1
bei Darstellungsarten BK,SK,BL,SL Spalte 1.

BildKG1DA() liefert ".T." true (Wahr) zurück wenn Bild-Datei vorhanden

BildKG2() Liefert den Pfadnamen einer Abbildung für die Kataloggruppe 2
bei Darstellungsarten BK,SK,BL,SL Spalte 2

BildKG2DA() liefert ".T." true (Wahr) zurück wenn Bild-Datei vorhanden

BildKG3() Liefert den Pfadnamen einer Abbildung für die Kataloggruppe 3
bei Darstellungsarten BK,SK,BL,SL Spalte 3.

BildKG3DA() liefert ".T." true (Wahr) zurück wenn Bild-Datei vorhanden

BildKG4() Liefert den Pfadnamen einer Abbildung für die Kataloggruppe 4
bei Darstellungsarten BK,SK,BL,SL Spalte 4

BildKG4DA() liefert ".T." true (Wahr) zurück wenn Bild-Datei vorhanden

initial() ermittelt ersten Buchstaben aus einem Datenfeld und liefert diesen als Großbuchstaben zurück (ä,ö,ü werden in A,O,U gewandelt). Funktion kann für die Gruppenwechselsteuerung genutzt werden (z.B. Überschriftenbuchstabe in alphabetischem Register mit Einsortierung der Umlaute in Register A, O, U)

Seitenzahl() Voreinstellung der Seitenzahl aus Druckvorlauf.

Kombidruck

Kombidruck("v1","v2","v3".. Druck bis zu 5 Druckfelder getrennt durch Zeilenschaltung

Beispiel: kombidruck ("b1","b2","artbezm","t3") gibt die Felder Bezeichnung1, Bezeichnung2, Zusatztext und das Textfeld3 auf dem Formular aus.
Vorangestelltes "#" je Variable unterdrückt die Zeilenschaltung. z.B. ("#b1","#b2","#artbezm","#t3")

Vorangestelltes "~" je Variable bewirkt Prüfung und Zeilenunterdrückung, wenn der Inhalt einer Variable leer ist.

à siehe auch Funktion "drucke" z.B. drucke("kombidruck("~artbez1","~artbez2","#zustext")",1,1)

textbaustein("Baustein-Name") Voreinstellung der Seitenzahl aus Druckvorlauf.

liest einen hinterlegten Text, wobei "Baustein-Name " die Kennung des Textes ist. Details finden Sie unter "Verwalten Textvariable"

textholen("xxx") liest einen hinterlegten Text, wobei "xxx" die Kennung des Textes ist.
Details finden Sie unter "Verwalten Textvariable" (Programmverwaltung)

Verwenden Sie die neue Funktion textbaustein("Baustein-Name")

artikelholen("ARTNR") bewirkt Anlesen eines Artikels, die Daten stehen anschließend zur Verfügung

katgruppeholen ("1232321") bewirkt Anlesen einer Kataloggruppe, die Daten stehen anschließend zur Verfügung

katposholen("123123") bewirkt Anlesen einer Katalogposition, die Daten stehen anschließend zur Verfügung

drucke("wasdrucken", subZ ,subP)

Diese Funktion wurde entwickelt um eine vereinfachte, einheitliche Arbeitsweise bei unterschiedlichen Darstellungsarten zu ermöglichen. Sie kann im Designer sowohl im Gruppenbereich als auch im Detailbereich eingesetzt werden, um Positionsdaten zu drucken. (Daten aus der Datei "KatPos" und "Preisarti".

Funktion Ausschließlich für Daten aus der Datei "katpos" und der Datei "preisarti".

"wasdrucken" = Name des zu druckenden Datenfeldes in Anführungszeichen.

subZ = Anzahl Positionszeilen neben dem Bild

subP = Positionsspalte (z.B. Matrix)

spezielle Steuerung:

wenn subZ = 0 Platzhalter im Detailbereich

wenn subZ = "spu" Platzhalter für Spaltenüberschrift

Es gibt auch die Möglichkeit der gekürzten Eingabe

drucke("wasdrucken") = wasdrucken im Detailbereich, einspaltig

drucke("wasdrucken", subZ) = wenn subZ = 0 -> wasdrucken im Detailbereich,

einspaltig

= wenn subZ > 0 Anzahl subZ Zeilen neben Bild

einspaltig

Beispiel:
Bei einer Darstellungsart der Kataloggruppe "08S6"
(= 8 Spalten 6 Zeilen á 8 Positionen neben dem Bild)

wird mit der Funktion "drucke("Preis01",4,2)" (im Designer)

der "Preis01" der 26. Katalogposition der Kataloggruppe in die 4 Zeile neben das Bild, und dort in die 2 Position (Spalte) gedruckt.
Warum die 26. Position (Artikel) der Kataloggruppe ?
Das Programm ordnet die Positionen entsprechend der, in der Kataloggruppen erfassten Reihenfolge wie folgt zu: . 3 (ganze Zeilen) x 8 + 2 (Positionen in der 4 Zeile) = 26

à siehe auch Funktion "kombidruck" z.B. drucke('kombidruck("~artbez1","~artbez2","#zustext")',1,1)

drucke("wasdrucken", spu ,subP)

Mit dieser Funktion können variable Spaltenüberschriften bei Matrix-Darstellung erzeugt werden. Entsprechend der sich aus der Darstellungsart der Kataloggruppe ergebenden Anzahl Positionsspalten werden aus den ersten (Anzahl) Positionsdatensätzen die gewünschten Werte gedruckt.

"wasdrucken" = Name des zu druckenden Datenfeldes in Anführungszeichen.

spu = Fix "spu" (ohne Anführungszeichen)

subP = Positionsspalte

Beispiel

Bei einer Darstellungsart der Kataloggruppe "08S6"

(= 8 Spalten 6 Zeilen á 8 Positionen neben dem Bild)

drucke("T1",spu,2) Das Textfeld "T1" wird als Überschrift der Spalte 2 gedruckt

Das Wert "T1" (hier "12") aus der 2. Positionen der Kataloggruppe wird als Spaltenüberschrift gedruckt.

fussnoten_drucken()
Diese Funktion bewirkt den dynamischen Andruck der definierten Fußnotentexte je Seite.

Vgl. Kapitel "Positionsdetails"

Überschriftsbilder

Verwenden Sie die neue Überschriften-Funktion über Pseudo-Kataloggruppen.

Details unter " Spezielle Darstellungsarten mit integrierten Funktionen"

bildS() Liefert den Pfadnamen einer Abbildung für Seitenüberschriften.

bildSDa() liefert ".T." true (Wahr) zurück wenn Datei vorhanden

bildZ() Liefert den Pfadnamen einer Abbildung für die Zwischenüberschrift

bildZDa() liefert ".T." true (Wahr) zurück wenn Datei vorhanden

bildSueb() Liefert den Pfadnamen einer Abbildung für Seitenüberschriften

bildSuebDa() liefert ".T." true (Wahr) zurück wenn Datei vorhanden

bildZueb() Liefert den Pfadnamen einer Abbildung für die Zwischenüberschrift.

bildZuebDa() liefert ".T." true (Wahr) zurück wenn Datei vorhanden.

Verwenden Sie für die nachfolgenden Funktionen und Variablen nur noch entsprechende aus obiger Übersicht.

Aus Kompatibilitätsgründen sind nachfolgende jedoch weiterhin verfügbar:

SUebBild("") Liefert den Pfadnamen des Überschriften-Bildes (für Bild-Objekt)

PuebBild("") Liefert den Pfadnamen des Zwischenüberschriften-Bildes (für Bild-Objekt)

GetBildPfad("") Liefert den Pfadnamen des Katalog-Gruppen-Bildes (für Bild-Objekt)

getdetailBild("1") dto. Darstellungsarten BK,SK,BL,SL Spalte 1

getdetailBild("2") dto. Darstellungsarten BK,SK,BL,SL Spalte 2

getdetailBild("3") dto. Darstellungsarten BK,SK,BL,SL Spalte 3

getdetailBild("4") dto. Darstellungsarten BK,SK,BL,SL Spalte 4

Berichtsvariable:

Einer beliebig zu benennenden Variablen hier: Vergl_drv1

Wird ein Wert zugewiesen hier "08S0" der bei der Druckabfrage verglichen wird

Nur drucken wenn "drv = Vergl_drv1" drv =Druckvariante = Darstellungsart der Kataloggruppe

Verhindern wiederholtes Andrucken gleicher Datenfeldinhalte im Detailbereich.
Um zu verhindern dass gleiche Inhalte (z.B. gleiche Artikel-Bezeichnungen) im Detailbereich mehrfach gedruckt werden, kann die Funktion "keinwdhdruck" genutzt werden.

Hierzu muss im Detailbereich (grauer Balken, in der Option "bei Ende" der Eintrag 'keinwdhdruck()' gemacht werden.

Die entsprechende Definition wird im Menü "Programmverwaltung" unter dem Menüpunkt "Kein Wiederholdruck" angelegt.

In diesem Satz muss eine Hilfsvariable definiert werden.

Beispiel Numerisch public Preis1_vgl

defn Preis1_vgl

Preis1_vgl=preisarti.vkbasis

(Verhindert Andruck gleicher Preise in einer Kataloggruppe)

Beispiel Alphanum. public Artbez1_vgl

defa Artbez1_vgl

Artbez1_vgl=Preisarti.Artbezkat

(Verhindert Andruck gleicher Bezeichnungen in einer Kataloggruppe)

Im Designer, im anzudruckenden Objekt (in unserem Beispiel Preisarti.Artbez1) ist bei "Nur Drucken wenn Ausdruck wahr" folgendes zu definieren: preisarti.artbez1 <> Artbez1_vgl

Zulassen wiederholter Andruck gleicher Datenfeldinhalte im Detailbereich.

Im Menüpunkt "Doch Wiederholdruck" kann definiert werden, wenn es Ausnahmen von dieser Konstellation geben soll. Beispielsweise, wenn sich eine Kataloggruppe über mehrere Seiten verteilt, und eine sich wiederholende Bezeichnung in der ersten Position jeder Seite angedruckt werden soll.

Hierzu muss im entsprechenden Bereich im Designer (Seitenkopf, grauer Balken, in der Option "bei Ende" der Eintrag 'dochwdhdruck()' gemacht werden.

Die entsprechende Definition wird im Menü "Programmverwaltung" unter dem Menüpunkt "Doch Wiederholdruck" angelegt.

In diesem Satz wird die Hilfsvariable, die im Satz "keinwdhdruck" definiert wurde, gewissermaßen geleert bzw. mit einem Phantasiewert belegt (hier 999999999,99 bzw. "xxx")..

Beispiel Numerisch Preis1_vgl=999999999,99

Beispiel Alphanum. Artbez1_vgl="xxx"

3.6.1.5.1 Vergleichsvariable

Nutzen Sie die Funktion Vergleichsvariable um schneller die Designs/Reports ändern zu können.

Objekte werden wie zuvor beschrieben, in Abhängigkeit verschiedener Faktoren gedruckt. Soll z.B. ein Sonderpreis "Fett" gedruckt werden, kann eine entsprechende Kennzeichnung in der Position hinterlegt werden, die in den Druckoptionen (Berichtsdesigner) abgefragt wird.

Entsprechendes wird auch mit der Darstellungsart der Kataloggruppe gesteuert. So können einzelne Felder zusätzlich angedruckt werden, wegfallen oder an anderer Position gewünscht werden.

Da diese Druckoptionen in allen Objekten einzeln zu hinterlegen sind und eine spätere Umstellung die Korrektur in jedem einzelnen Objekte erfordert (z.B. wenn die Positionen nicht mehr neben dem Bild sonder unterhalb angedruckt werden sollen). empfehlen wir den entsprechend abzufragenden Wert in einer Variablen für das jeweilige Design zu hinterlegen. Damit ist die Möglichkeit gegeben die Druckoption für alle betroffenen Objekte durch einfaches Ändern der Variablen anzupassen.

Zum Hinterlegen einer Variablen, wählen Sie im entsprechenden Berichtsdesigner unter dem Menüpunkt "Bericht" -à Variablen.

Im "Folgefenster" können Sie eine Variable mit beliebigen Namen (hier z.B. "vergl_drv1" ) erfassen und den Vergleichswert (hier "08S6") hinterlegen. Die Abfrage erfolgt wie zuvor beschrieben in den Druckoptionen des jeweiligen Objektes (Nur drucken wenn Ausdruck wahr ist").

3.6.1.5.2 Leerraumoptimierer

Insbesondere bei der Verwendung mehrerer Darstellungsarten für Kataloggruppen in einem Katalog, können unter Umständen ungewollte Leerräume entstehen.

Um solche Leerräume zu unterdrücken, können im Berichtsdesigner "Leerraumoptimierer" in dem jeweiligen Design hinzugefügt werden (hier grün und durch Pfeile markiert).

Dies sind inhaltslose "Feld-Variable" (im Ausdruck "leer"), die in Abhängigkeit der Darstellungsart gedruckt werden. Genauer es wird ein Leerraum nur bei der entsprechenden Darstellungsart "gedruckt"

z.B. Nur Drucken, wenn Ausdruck wahr ist: vergl_drv1=drv . ( = Kataloggruppe.darstell="01S6")

Einfügen der Feldvariablen (Menüpunkt Ansicht -> Bericht-Steuerelemente -> ab (siehe Pfeil)

Es ist darauf zu achten, dass die "Leerraumoptimierer" exakt den zu optimierenden Zwischenraum in der Höhe abdecken und keine anderen Objekte überschneiden. Die Feldbreite und horizontale Positionierung ist dabei st dabei zu vernachlässigen.

3.6.1.5.3 PRL-Listen

Kataloge mit Darstellungsarten mit integrierten Funktionen (z.B. Positionen mehrspaltig, Positionen neben Bild usw. ) können ohne Änderung der Darstellungsart in den einzelnen Kataloggruppen. auch als "einfache Listen" gedruckt werden. So lässt sich problemlos aus den Daten eines vorhandenen Kataloges eine dazu passende Liste (z.B. separate Preisliste) erstellen.

Dazu ist lediglich als Name für das zu erstellende Design mit der Zeichenfolge "-PRL" am Ende zu wählen (Z.B. "Standard01-PRL") . Das Programm erkennt diese Zeichenfolge und neutralisiert beim Drucken die unterschiedlichen Darstellungsarten in den einzelnen Kataloggruppen (d.h. es generiert die Arbeitsdatei mit Darstellungsart " " anstelle der in der Kataloggruppe vorgegebenen).

Die ursprüngliche Darstellungsart bleibt dabei erhalten.

3.7 Formatieren von Feld-Steuerelementen in einem Bericht

Nach dem Einfügen eines Feld-Steuerelements können Datentyp und Druckformat des Steuerelements geändert werden. Der Datentyp kann "Zeichen", "Numerisch" oder "Datum" sein. Jeder Datentyp verfügt über eigene Formatoptionen. Das Format bestimmt, wie das Feld im Katalog gedruckt wird. Formatfunktionen können Sie entweder in das Feld "Ausdruck" des Dialogfeldes "Berichtsausdruck" eingeben oder als Optionen aus dem Dialogfeld
"Format" auswählen.

3.7.1 Formatieren von Feld-Steuerelement

1. Markieren Sie das Feld-Steuerelement.

2. Wählen Sie im Dialogfeld Berichtsausdruck die Schaltfläche mit den drei Punkten neben dem Feld "Format".

3. Wählen Sie im Dialogfeld "Format" den Datentyp für das Feld aus: "Zeichen", "Numerisch" oder "Datum". Im Bereich "Bearbeitungsoptionen" werden die für den Datentyp verfügbaren Formatierungsoptionen angezeigt.

4. Wählen Sie die gewünschten Ausrichtungs- und Formatoptionen aus.

Abhängig vom ausgewählten Datentyp werden im Dialogfeld "Format" verschiedene Optionen angezeigt. Sie können eine Formatvorlage auch erstellen, indem Sie im Feld "Format" Zeichen eingeben.

3.7.2 Ändern von Schriftarten

Sie können die Schriftart und den Schriftgrad für den Text in jedem Feld- oder Beschriftungs-Steuerelement ändern.

Ändern Bericht Schriftart und -grad

Wählen Sie das Steuerelement durch Anklicken aus.

Wählen Sie aus dem Menü "Format" den Menüpunkt "Schriftart".
Das Dialogfeld "Schriftart" wird angezeigt.

Wählen Sie die gewünschte Schriftart und Punktgröße (Grad) aus, und wählen Sie anschließend OK.

Ausrichten von Text in einem Feld.

Sie können den Inhalt eines Feldes im Steuerelement auf zwei Arten ausrichten. Diese Einstellung verändert nicht die Position des Steuerelements auf dem Bericht, sondern nur den Inhalt im Bereich des Steuerelements.

Ausrichten von Text in einem Feld-Steuerelement

1. Wählen Sie die Steuerelemente aus, die Sie ändern möchten.

2. Wählen Sie aus dem Menü Format den Befehl Textausrichtung.

3. Wählen Sie aus dem Untermenü den entsprechenden Befehl.

Ausrichten von Text in einem Feld

1. Markieren Sie das Feld-Steuerelement.

2. Wählen Sie im Dialogfeld "Berichtsausdruck" die Schaltfläche mit den drei Punkten neben dem Feld "Format".

3. Wählen Sie im Dialogfeld "Format" den Datentyp für das Feld aus: "Zeichen", "Numerisch" oder "Datum".

4. Wählen Sie die gewünschten Ausrichtungs- und Formatoptionen aus.
3.7.3 Ändern der Farbe von Bericht-Steuerelementen

Sie können die Farbe von Feldern, Beschriftungen, Linien oder Rechtecken ändern.

1. Wählen Sie die zu ändernden Steuerelemente aus.

2. Wählen Sie in der Symbolleiste für die Farbpalette Vordergrundfarbe oder Hintergrundfarbe.

3. Wählen Sie die gewünschte Farbe aus.

3.7.4 Ändern der Größe eines Steuerelements

Wählen Sie das Steuerelement aus und ziehen Sie es mit gedrückter linker Maus-Taste auf die gewünschte Größe.

3.7.5 Mehrere Steuerelemente auf die gleiche Größe anpassen

1. Wählen Sie die Steuerelemente aus, deren Größe identisch sein sollen.

2. Wählen Sie aus dem Menü "Format" den Befehl Größe.

3. Wählen Sie die entsprechende Option, um Breite, Höhe oder Größe abzustimmen.

Die Größe der Steuerelemente ändert sich entsprechend der von Ihnen gewählten Option.
3.7.6 Formatieren eines Bildes

Das eingefügte Bild passt nicht in den Rahmen, den Sie beim Erstellen gezeichnet haben. Standardmäßig behält das Bild oder Objekt seine Originalgröße. Sie können es aber beschneiden oder maßstäblich anpassen, damit es in den Rahmen passt. Wenn das Bild größer ist als der im Berichts-Designer erstellte Rahmen, wird im Rahmen nur ein Teil des originalen Bildes oder Objekts angezeigt.

3.7.7 Einpassen des Bildes in den Rahmen

1. Erstellen Sie im Katalog-Designer ein OLE/Grafik-gebundenes Steuerelement.

2. Aktivieren Sie im Dialogfeld Berichtsbild die Option "Bild skalieren" "Form beibehalten".

Das gesamte Bild wird angezeigt und füllt den Rahmen so vollständig wie möglich aus, wobei die relativen Proportionen beibehalten werden.
3.7.8 Ausfüllen des Rahmens mit dem Bild

1. Erstellen Sie im Berichts-Designer ein OLE/Grafik-gebundenes Steuerelement.

2. Aktivieren Sie im Dialogfeld "Berichtsbild" die Option "Bild skalieren - Rahmen ausfüllen".

Das gesamte Bild wird so in der Größe geändert, dass es den Rahmen ausfüllt.

3.7.9 Zentrieren eines Bildes
Die in einem Objektfeld enthaltenen OLE-Objekte können in Form und Größe variieren. Wenn das Objekt im Feld kleiner ist als der Rahmen, wird es in der linken oberen Ecke des Rahmens angezeigt. Sie sollten daher das Objekt in seiner Ursprungsdatei (z.B. "xxx,.jpg") mit einem geeigneten Bildbearbeitungsprogramm zentrieren und für eine optimale Darstellung die Proportionen entsprechend der endgültigen Druckdarstellung wählen. Variieren die Bilder stark, können unterschiedliche Bildformate (z.B. rechteckig oder quadratisch, groß oder klein, senkrecht oder waagrechtes Format) mit der Bildsteuerung unterschiedlich selektiert werden (z.B. Bild im recheckigen Rahmen drucken wenn im Steuerfeld1 "1" steht, sonst im quadratischen Rahmen).

3.7.10 Gruppieren von Steuerelementen

1. Wählen Sie die Steuerelemente durch Anklicken aus, die Sie als Gruppe behandeln möchten.

2. Wählen Sie aus dem Menü "Format" den Befehl "Gruppieren".

Sie können nun die Gruppe von Steuerelementen als eine Einheit behandeln.

Dies ist zum Beispiel dann sinnvoll, wenn Sie Überschriftzeilen und Datenfelder des Detailbereichs im Katalogdesigner übereinander legen müssen (z.B. aufgrund unterschiedlicher Spaltenaufteilungen für einzelne Kataloggruppen oder wenn ein Rahmen um ein Textfeld "mitwachsen" soll.

3.7.11 Aufheben der Gruppierung von Steuerelementen

1. Wählen Sie die Gruppe der Steuerelemente durch Anklicken aus.

2. Wählen Sie aus dem Menü "Format" den Befehl "Gruppierung aufheben".

3.7.12 Ausrichten von Steuerelementen

Sie können Steuerelemente entweder zueinander ausrichten, oder diese entsprechend an dem vom Katalog-Designer zur Verfügung gestellten Raster ausrichten.

3.7.13 Steuerelemente zueinander ausrichten

1. Wählen Sie die auszurichtenden Steuerelemente durch Anklicken aus.

2. Wählen Sie aus dem Menü "Format" den Befehl Ausrichten.

3. Wählen Sie aus dem Untermenü die gewünschte Ausrichtungsoption.

KL-KatGen verwendet das Steuerelement als Verankerung, dessen Rand der Richtung, die zum Ausrichten ausgewählt wurde, am nächsten liegt. Sie können Steuerelemente auch mit Hilfe der "Layout-Symbolleiste" ausrichten.

3.7.14 Zentrieren von Steuerelementen in einem Bereich

1. Wählen Sie die auszurichtenden Steuerelemente durch Anklicken aus.

2. Wählen Sie aus dem Menü "Format" den Befehl "Ausrichten".

3. Wählen Sie aus dem Untermenü die Option "Horizontal zentrieren" oder "Vertikal zentrieren".

Die Steuerelemente werden zum horizontalen bzw. vertikalen Mittelpunkt ihres Bereichs verschoben.

3.7.15 Platzierung von Steuerelementen mit der Statusleiste oder dem Raster

Mit der Statusleiste oder dem Raster können Sie ein Steuerelement auf der Berichtsseite platzieren. Standardmäßig wird die Position der Steuerelemente entsprechend an dem Raster ausgerichtet. Sie können wahlweise die automatische Ausrichtung deaktivieren und die Rasterlinien ein- und ausblenden. Rasterlinien helfen Ihnen beim Positionieren der Steuerelemente im Layout.

3.7.16 Anordnen von Steuerelementen auf eine bestimmte Position

1. Wählen Sie aus dem Menü "Ansicht" den Menüpunkt "Position anzeigen".

2. Wählen Sie das Steuerelement durch Anklicken aus, und verschieben Sie dieses anschließend mit Hilfe der Positionsangaben in der Statusleiste.

3.7.17 Anzeigen von Rasterlinien

Wählen Sie aus dem Menü "Ansicht" den Befehl "Rasterlinien".

Im Berichtsbereich wird ein Raster angezeigt.

3.7.18 Ändern der Abmessungen des Rasters

1. Wählen Sie aus dem Menü "Format" den Menüpunkt "Rastermaßstab setzen".

2. Geben Sie im Dialogfeld "Rastereigenschaften einstellen" die Anzahl der Pixel für die Breite und Höhe der Quadrate im Raster an.
3.7.19 Text in einem Feld-Steuerelement ausrichten

1. Wählen Sie die Steuerelemente, die Sie ändern möchten durch Anklicken aus.

2. Wählen Sie aus dem Menü "Format" den Befehl "Textausrichtung".

3. Wählen Sie aus dem Untermenü die gewünschte Option.

3.7.20 Text in einem Feld ausrichten

1. Markieren Sie das Feld-Steuerelement.

2. Wählen Sie im Dialogfeld Berichtsausdruck die Schaltfläche mit den drei Punkten neben dem Feld "Format".

3. Wählen Sie im Dialogfeld "Format" den Datentyp für das Feld aus: "Zeichen", "Numerisch" oder "Datum".

4. Wählen Sie die gewünschten Ausrichtungs- und Formatoptionen aus.

3.8 Einstellen der Druckoptionen für Steuerelemente

Das allgemeine Layout und die Bereichsposition der Steuerelemente legen fest, wann und wo diese gedruckt werden. Außerdem können Sie für jedes Steuerelement genau festgelegte Druckoptionen bestimmen. Jedes Steuerelement besitzt eine Standardgröße, die entweder auf seinem Wert (Felder und Bezeichnungen) oder auf der von Ihnen erstellten Größe (Linien, Rechtecke und Bilder) basiert. Die Länge der Steuerelemente auf dem Layout legt die Anzeigebreite des Steuerelements fest. Da der Wert einiger Steuerelemente von Datensatz zu Datensatz variiert, können Sie die Höhe des Steuerelements so setzen, dass es nach unten vergrößert wird, um den gesamten Wert anzuzeigen. Andernfalls wird der Wert in der Anzeigebreite gekürzt. Mit Ausnahme der Bezeichnungs-Steuerelemente können Sie alle Steuerelemente in der Größe ändern.

3.8.1 Drucken von Steuerelementen mit Werten variabler Länge

Wenn ein Steuerelement nur den Platz verwenden soll, der von seinem Wert benötigt wird, können Sie dieses so einstellen, dass es vergrößert wird. Beispielsweise können die Werte in einem Ausdruck von Datensatz zu Datensatz variieren. Anstatt in dem Bericht dem Steuerelement einen Platz mit fester Größe für den längsten Wert zuzuweisen, können Sie das Steuerelement so einstellen, dass es nach unten vergrößert wird, um den gesamten Wert anzuzeigen. Steuerelemente unterhalb des vergrößerten Steuerelements können Sie so einstellen, dass sie auf der Seite relativ zum vergrößerten Steuerelement nach unten verschoben werden.

Die Option zum Vergrößern steht für Felder, vertikale Linien, Rechtecke und abgerundete Rechtecke zur Verfügung.

3.8.2 Festlegen, dass ein Feld mit seinem Wert vergrößert wird

Doppelklicken Sie auf das Feld-Steuerelement, um das zugehörige Dialogfeld anzuzeigen.
Aktivieren Sie "Bei Überlauf vergrößern".

3.8.3 Festlegen, dass ein Feld verschiebbar wird

1. Doppelklicken Sie auf das Steuerelement, um das zugehörige Dialogfeld anzuzeigen.

2. Aktivieren Sie im Dialogfeld des Steuerelements die Option "Frei anordnen".

3.8.4 Festlegen, dass Linien und Rechtecke vergrößert werden können

1. Doppelklicken Sie auf das Steuerelement, um das zugehörige Dialogfeld anzuzeigen.

2. Aktivieren Sie im Bereich "Nach unten vergrößern" eine Option.

3.8.5 Druck vergrößerbarer Steuerelemente in einem Rahmen
1. Ziehen Sie ein Rechteck um die vergrößerbaren Steuerelemente.

2. Doppelklicken Sie auf das Rechteck, um das Dialogfeld Rechteck/Linie anzuzeigen.

3. Aktivieren Sie im Bereich "Nach unten vergrößern" die Option "Relativ zu größtem Objekt in der Gruppe vergrößern".

4. Wählen Sie OK.

5. Ziehen Sie ein Auswahlfeld um das Rechteck.

6. Wählen Sie aus dem Menü "Format" den Menüpunkt "Gruppieren".

Von nun an können Sie alle Steuerelemente als eine Einheit behandeln. Das Rechteck wird zusammen mit dem vergrößerbaren Feld vergrößert. Unabhängig davon, wie weit sich der Wert im Feld nach unten erstreckt, behält das Rechteck seinen Rahmen um das Feld bei. Sie können zwei dieser Gruppen im Layout nebeneinander platzieren, ohne dass eine durch das Vergrößern der anderen beeinflusst wird.

3.8.6 Druck vergrößerbarer Steuerelemente untereinander

1. Fügen Sie die beiden Steuerelemente im Layout untereinander ein.

2. Doppelklicken Sie auf das obere Steuerelement, um das zugehörige Dialogfeld anzuzeigen.

3. Aktivieren Sie im Bereich Feldposition die Option Relativ zu oberem Bereichsrand ausrichten, und wählen Sie anschließend OK.

4. Doppelklicken Sie auf das untere Steuerelement, um das zugehörige Dialogfeld anzuzeigen.

5. Aktivieren Sie im Bereich "Feldposition" die Option "Frei anordnen", und wählen Sie anschließend OK.

Die beiden Datensatzwerte werden vollständig gedruckt und überschreiben sich nicht gegenseitig.

3.8.7 Festlegung der Bedingungen ob ein Bericht-Steuerelement gedruckt werden soll

Eine der wichtigsten Funktionen des Katalog-Designers ist die Möglichkeit zu bestimmen, unter welchen Bedingungen das Bericht-Steuerelement gedruckt werden soll.

Im Fenster "Objekt drucken" sind dazu die entsprechenden Bedingungen zu hinterlegen.

1. Öffnen Sie mit Doppel-Klick auf das gewünschte Steuerelement das Fenster "Berichtsausdruck"
.

2. Mit Klick auf das Feld "Objekt Drucken" öffnet sich das entsprechende Fenster.

3. Erfassen Sie im Eingabefeld "Nur drucken, wenn Ausdruck wahr ist" die gewünschte Bedingung.

In dem nachfolgend dargestellten Beispiel (siehe Abbildung nächste Seite) soll der Druck nur dann erfolgen, wenn in dem Datenfeld "katgruppe.darstell" ein Wert kleiner "A" steht.

Das heißt: gedruckt wird nur das entsprechende Datenfeld aus Kataloggruppen mit Darstellungsart von " " bis "999".
Ist diese Bedingung nicht erfüllt, erfolgt kein Druck dieses Steuerelementes. Zusätzlich wurde durch Markieren der Option "Zeile entfernen wenn leer" festgelegt, dass das Drucken der Zeile unterdrückt werden soll, wenn diese ansonsten keine zu druckenden Felder beinhaltet.

Wurde eine Bedingung erfasst, sind die sonst zur Verfügung stehenden Optionen deaktiviert.

Im obersten Fenster des Formulars ("Objekt drucken") wurde dazu in der Bedingung "nur drucken wenn Ausdruck wahr ist" die Bedingung "BildKG0Da() and drv = "01 " eingegeben. Die Funktion "BildKG0Da()" liefert "JA", wenn die Bilddatei (der Name steht in Kataloggruppe) vom Programm gefunden wurde.

Wenn zusätzlich die Darstellungsart der Kataloggruppe (drv) gleich "01 " wird das Bild gedruckt..

Mit "Klick" auf die Schaltfläche mit den drei Punkten öffnet sich der Ausdruckgenerator, der Sie bei der Erstellung der Bedingungsausdrücke unterstützt.

3.9 Einstellen der Druckoptionen für Gruppen

Sie können steuern, wo, wie und unter welchen Bedingungen Gruppen in einem Bericht gedruckt werden.

3.9.1 Festlegen von Seitenumbrüchen für Gruppen

Neben der Auswahl des zu gruppierenden Feldes oder Ausdrucks können Sie im Dialogfeld Datengruppierung Seitenumbruchoptionen für Gruppen angeben.

3.9.2 Auswählen einer Gruppenkopfoption

Vielleicht möchten Sie, dass die Gruppen bei Berichten mit mehreren Spalten in der nächsten Spalte angezeigt werden, oder bei Designs auf einer neuen Seite oder auf einer mit "1" nummerierten neuen Seite. Das Dialogfeld Datengruppierung bietet hierzu vier Möglichkeiten. Dabei haben Sie folgende Möglichkeiten:

- Starten jeder Gruppe in einer neuen Spalte

- Starten jeder Gruppe auf einer neuen Seite

- Zurücksetzen der Seitennummer auf "1" für jede Gruppe

- Erneutes Drucken des Gruppenkopfes auf jeder Seite

Nach dem Eingeben eines Ausdrucks können Sie im Bereich "Gruppeneigenschaften" diese Optionen aktivieren.

3.9.3 Vermeiden von allein stehenden Gruppenköpfen

Gelegentlich wird ein Teil einer Gruppe auf der einen und der andere Teil auf der nächsten Seite gedruckt. Um zu verhindern, dass der Gruppenkopf am unteren Rand der Seite und die Mehrheit der Datensätze auf der nächsten Seite gedruckt wird, können Sie den Mindestabstand angeben, mit dem ein Gruppenkopf zum unteren Rand gedruckt wird. Wenn der Kopf näher zum unteren Rand der Seite positioniert würde, als der in Zoll oder Zentimetern eingegebene Abstand beträgt, druckt KL-KatGen den Kopf auf einer neuen Seite.

3.9.4 Verhindern von allein stehenden Gruppenköpfen

1. Wählen Sie aus dem Menü "Bericht" den Befehl "Datengruppierung".

2. Wählen Sie im Feld "Gruppe auf neuer Seite beginnen, wenn weniger als" des Dialogfeldes "Datengruppierung" einen Wert aus, oder geben Sie einen Wert ein.

3.9.5 Drucken unterdrückter Werte beim Gruppenwechsel

Wenn wiederholte Werte unterdrückt werden, möchten Sie diese vielleicht drucken, wenn sich eine bestimmte Gruppe ändert.

3.9.6 Wiederholte Werte drucken, wenn sich die Gruppe ändert

1. Doppelklicken Sie auf das Steuerelement, um das zugehörige Dialogfeld anzuzeigen.

2. Wählen Sie die Schaltfläche "Objekt drucken", um das Dialogfeld "Objekt drucken" anzuzeigen.

3. Wählen Sie Bei Änderung dieser Gruppe.
Die für den Bericht definierten Gruppen werden im Feld angezeigt.

4. Wählen Sie im Feld eine Gruppe aus, und wählen Sie anschließend OK.

3.9.7 Wiederholen von Gruppenköpfen

Wenn eine Gruppe auf der nächsten Seite fortgesetzt wird, haben Sie die Möglichkeit, den Gruppenkopf zu Beginn der fortgesetzten Daten zu wiederholen. Wenn sich in dem Bericht mehrere Datengruppen befinden, stammt der Kopf der folgenden Seiten aus der letzten Gruppe in der Gruppenliste. Platzieren Sie alle im Gruppenkopf zu druckenden Steuerelemente im Kopfbereich der letzten Gruppe in der Liste.

3.9.8 Wiederholen des Gruppenkopfs auf der nächsten Seite

1. Wählen Sie im Dialogfeld "Datengruppierung" die zu wiederholende Gruppe aus.

2. Aktivieren Sie das Kontrollkästchen "Gruppenkopf auf jeder Seite drucken".

3. Deaktivieren Sie dieses Kontrollkästchen, wenn Sie den Gruppenkopf nicht wiederholen möchten.

3.9.9 Grundeinstellungen für Standardfunktionen in der Hauptmaske

Um die Funktionalität der folgenden Standardfunktionen

- Zwischenüberschrift (ZW-Über),

- SW (Seitenwechsel)

- SpW (Spaltenwechsel) (nur bei mehrspaltigem Design)

richtig nutzen zu können, müssen im Design unter dem Menüpunkt Bericht -> Datengruppierung die folgenden Einstellungen vorgenommen werden.

4 Kataloge Drucken und Design verwalten

Das Drucken der Kataloge erfolgt im Programmzweig "Kataloge - Druck und Design".

Durch "Klick" auf die Funktionstaste "Katalog Drucken" öffnet sich das entsprechende Fenster (siehe Abbildung).

(Alternativ: Menü-Punkt "Katalog Drucken" im Hauptmenü "Kataloge und Daten verwalten").

Über das reine Drucken der Kataloge hinaus stehen in diesem Programmzweig noch weitere Funktionen zur Verfügung:

2. Drucken und Anzeigen der Kataloge

3. Erfassen und Verwalten der Katalogdesigns

4. Verwalten der Katalog-/ Designauswahlübersicht

5. Katalogsammeldruck

6. Festlegung der Druckoptionen

7. Festlegung der Datenaktualisierung

8. Druck diverse Registerarten (Standard, Kategorien, Artikelnummern, Inhalt)

Sie können einzelne Kombinationen hier mehrfach eintragen, sinnvoll um auf verschiedene Teilkataloge auf einen Klick zugreifen zu können.

Beispiel: Sie erhalten des öfteren die Anforderung einen Katalog erstellen zu müssen mit der Artikelgruppe Speichermedien" und "Druckerzubehör". Die Speichermedien befinden sich in Ihrem Gesamtkatalog im Kataloggruppenbereich "000010" bis "000500", das Druckerzubehör im Bereich "001000" bis "001920".
Also definieren Sie einen Eintrag mit Katalog "GESAMT" mit "ab Kataloggruppe "000010" und "bis Kataloggruppe "000500" und schreiben in das Infofeld (Button "Info") als Kommentar "Druck Teilkatalog Speichermedien".

Definieren Sie nun einen weiteren Eintrag mit Katalog "GESAMT" mit "ab Kataloggruppe "0001000" und "bis Kataloggruppe "0001920"und schreiben in das Infofeld (Button "Info") als Kommentar "Druck Teilkatalog Druckerzubehör"

Sie können ab jetzt diese beiden Teilkataloge jeweils einzeln oder in einem Sammeldruck (mit Deckblatt, Rückblatt, Register etc.) drucken lassen

In der Kopfzeile wird der aktuell zu bearbeitende Katalog (hier "KATALOG-MIX") und das aktuelle Design (hier "DESIGN-MIX") angezeigt.

Im Fenster mit der Aufschrift "Information Druck und Design" können Sie einen eigenen Kommentar zu der entsprechenden Kombination erfassen.
Das Fenster lässt sich mit Klick auf die Schaltfläche "Info" aktivieren bzw. deaktivieren.

4.1 Kataloge Drucken

Mit "KLICK" auf den Button "Katalog drucken" wird der voreingestellte Katalog mit dem ausgewählten Design und den voreingestellten Optionen (siehe Punkt nachfolgend "Optionen bei Katalogdruck"), nach Abfrage auf welchem Drucker die Ausgabe erfolgen soll, gedruckt.

Wählen Sie gegebenenfalls zuvor ein anders Design. Mit der Funktion "Anzeigen" sollten Sie in der Druckansicht vor dem Drucken das Ergebnis überprüfen.

Da KL-KatGen auf den Windows-Standarddrucker zugreift, beachten Sie, dass Sie beim Sammeldruck bzw. beim Katalogdruck mit Deck-/Rückblatt oder Inhaltsregister (zusammengesetzt aus einzelnen "Drucken") den entsprechenden Drucker vorher auswählen und konfigurieren. Es erscheint einmalig folgende Meldung:

4.2 Kataloge am Bildschirm anzeigen

Durch Drücken der Taste "Anzeigen" kann die Ausgabe vor dem Drucken am Bildschirm geprüft werden.

Über Navigationstasten kann innerhalb des Kataloges geblättert und die Anzeige "gezoomt" werden.

Beachten Sie, dass beim Anzeigen lediglich der Datenbereich des aktuellen Kataloges gezeigt wird. Deckblatt, Rückblatt und Inhaltsregister sind in diesem Modus nicht ersichtlich, können jedoch durch direkte "Designauswahl" einzeln angezeigt werden.

4.3 Design ändern

Mit der Taste " Design bearbeiten" gelangen Sie in den Katalogdesigner um gegebenenfalls das Design zu modifizieren oder ein Neues zu erstellen. Weitere Details dazu finden Sie unter "Der Katalog-Designer". Die gleiche Funktion kann auch über das Hauptmenü aufgerufen werden (Hauptmenü à Programmverwaltung à Preis-Liste/Katalog Design).

Die detaillierte Beschreibung für die Gestaltung des Katalogdesigns finden Sie in dem Kapitel "Der Katalog-Designer".

4.4 Katalog-Design Auswahlarchiv

Über die Auswahlfelder "Katalog" und "Design" besteht die Möglichkeit, Kataloge mit dem gewünschten Design auszuwählen, anzuzeigen und zu drucken. Der ausgewählte Katalog kann im Katalogdaten-Manager, das gewählte Design im "Katalog-Designer" modifiziert werden.

Mit der Funktionstaste "Katalog/Design eintragen", können Sie die gewählte Kombination in das Auswahlarchiv übernehmen. Ergänzt mit erläuternden Informationen im Datenfeld "Beschreibung" über Inhalt und Design, steht diese für künftige Verwendung im Auswahlfenster bereit.

Insbesondere beim "Sammeldruck" lassen sich so schnell und einfach neue Kataloge aus verschiedenen Katalogen (Teilkatalogen) auswählen und drucken.

Mit "Klick" auf den Button "Eintrag Löschen" wird der Eintrag aus dem Auswahlfenster gelöscht. Katalogdaten und Design bleiben erhalten.

4.5 Drucken von Teilbereichen eines Kataloges

KL-KatGen erlaubt Teilbereiche aus einem Gesamtkatalog durch Auswahl der Kataloggruppennummer "von – bis" zu Drucken. (siehe dazu auch "Die Kataloggruppenselektion / Kataloggruppen filtern".

Mit Klick auf die Taste "eintragen" können Kombinationen "Katalogdaten kombiniert mit den verschiedenen Designs" in ein Auswahlfenster übertragen werden und stehen dort künftig für eine schnelle Auswahl zur Verfügung.

Dieses Eintragen ist nicht zwingend notwendig da Katalogdaten und Design auch einzeln ausgesucht und gedruckt werden können (Eingabefelder im Fenster rechts oben). Sollen jedoch ein Katalog als Sammeldruck aus mehreren Katalogen (Daten) oder Datenbereichen eines Kataloges (Kataloggruppen aus einen Katalog) erstellt werden, sind die Eintragungen der zusammenzuführenden Bereiche unumgänglich um diese bei der Erstellung des Sammeldrucks einzeln auswählen zu können (Details siehe Sammeldruck).

Zur besseren Übersicht kann über ein Selektionsfeld die Auswahl gefiltert werden:

A = alle Einträge

M = verschiedene mitgelieferten Musterkataloge und Musterdesigns einschließlich der vereinfachten Beispiele

B = nur die mitgelieferten, vereinfachten Beispiele

E = die eigenen, selbsterzeugten Kataloge und Designs

Unabhängig von den hier aufgezeigten Möglichkeiten Kataloge durch Vorgabe der zu Druckenden Bereiche zu erstellen, erlaubt KL-KatGen weitere Selektionen durch integrierte Filterfunktionen. (Siehe dazu "Druckoptionen" und "Kataloggruppenselektion / Kataloggruppen filtern").

4.6 Preisoptionen

4.6.1 Preisauswahl

Unmittelbar vor dem Druck einer Preisliste bzw. eines Kataloges kann bestimmt werden, welche Preise das System andrucken soll:

- Preise aus der KL-KatGen Artikeldatei

- Preise aus den Katalogpositionen

- Preise aus den Sonderkonditionen (eventuell nach Neuberechnung)

(Nur in Verbindung mit dem Zusatzmodul "SK")

ACHTUNG:
wenn kein Artikelstammsatz gefunden wird, druckt KL-KatGen den Preis aus der Katalogposition.

Preisauswahl
Welche Preise sollen in dem aktuellen Katalog dargestellt werden.
- Preise aus der KL-KatGen-Artikeldatei oder
- Preise aus der Katalog-Positionsdatei

automatische Preisermittlung / Kunden-/Aktionskataloge
Wählen Sie
- Gesamtkatalog mit Sonderkonditionen und
- einen Kunden bzw. eine Aktion
- den Gültigkeitszeitraum

Katalogdatenaktualisierung
Vor dem Druck kann festgelegt werden, ob die Katalogdaten (in den Positionen)
aktualisiert werden sollen.
Ist dies der Fall so wählen Sie dazu
- Katalogdaten werden aktualisiert

Updatesteuerung (nur bei "mit Katalogdatenaktualisierung")
Prüfen Sie in der Updatesteuerung welche Felder aktualisiert werden sollen

Anzeige / Druck des Preisprotokoll
Vor der Aktualisierung der Katalogdaten sollten die neuen Preise und der Preisfindungsweg geprüft werden.

ACHTUNG:

Beachten Sie, dass durch Anwahl dieser Option nicht nur die Preise sondern auch weitere Datenfelder in den Katalogpositionen automatisiert geändert werden können. Prüfen Sie daher in der "Update-Steuerung" welche Felder aktualisiert werden.

Die Preise in der Artikeldatei bleiben dabei unverändert.

4.6.2 Automatische Preisermittlung / Kunden- / Aktionskataloge
(Zusatzmodul nicht in der Basislösung)

In Verbindung mit der "autom.Preisermittlung / Kunden / Aktionskataloge" besteht zusätzlich die Möglichkeit die Preise für einzelne Artikel oder Artikelgruppen automatisiert neu zu berechnen und diese Preise dauerhaft in die Katalogpositionen zu übernehmen.

Drucken Sie aus dem Gesamtkatalog einen Katalog für spezielle Kunden oder Aktionen mit automatisch über hinterlegten (oder Importierten) Sonderkonditionen ermittelten Preisen.

Oder lassen Sie die Preise im Katalog neu errechnen. Details dazu finden Sie unter "Automatische Preisermittlung":

Anzeige Preisprotokoll, Druck Preisprotokoll

Vor dem Katalogdruck bzw. vor der Preisaktualisierung können in einem Protokoll die Werte nochmals überprüft werden.

Angezeigt / gedruckt werden Artikelnummer, Artikelbezeichnung und Preisherkunft.

Datum, Seitenzahl fortlaufend.

ACHTUNG beim Druck / bzw. bei Übernahme mit Preisen aus der Artikeldatei werden, sofern der in der Katalogposition angegebene Artikel nicht in der Artikeldatei vorhanden ist, der Preis der Positionsdatei für die Bearbeitung zu Grunde gelegt. Im Protokoll sind fehlende Artikel in der letzten Spalte mit rot "AP" gekennzeichnet.

Datum, Seitenzahl fortlaufend.

4.7 Optionen beim Katalogdruck

In den Registern "Optionen" und "erweitert" können verschiedene ergänzende Funktionen für den Druck ausgewählt werden:

Katalog-Gruppe von/bis Selektiver Druck des aktuellen Kataloges.
Eingegrenzt über zusammenliegenden Bereich von Kataloggruppennummern.

Selektion aktivieren Selektiver Druck des aktuellen Kataloges.
Filter kann in der Hauptmaske (Button "KGR-Selektion") gesetzt werden
Auch umgekehrt (alle nicht selektierten Gruppen)

Seitenseparation Je nach Druckausgabe (Druck als PDF- bzw. JPG-Datei) wird für jede Seite des Kataloges einen einzelnen Datei erzeugt um dies beispielsweise einzeln ansteuerbar (adressierbar) im Internet bereitzustellen.

Ohne Katalogdaten-Aktualisierung: Sowohl für die "Anzeige" als auch für den "Druck" werden die hinterlegten Katalogdaten automatisch im Hintergrund aufbereitet (generiert).

Dies geschieht unmittelbar nach "Klick" auf die entsprechenden Tasten ", vor dem eigentlichen Drucken/Anzeigen. Gleichzeitig können dabei die Preise aus der Artikeldatei in die Katalogpositionsdatei übernommen werden. Soll keine automatische Katalogdaten-Aktualisierung erfolgen, ist diese Funktion zu aktivieren.

Ist diese Funktion deaktiviert (d. h. "mit Datenaktualisierung") besteht die Möglichkeit in der "Update-Steuerung" die zu aktualisierenden Felder zu bestimmen. Weitere Details dazu unter "Preise aktualisieren".

Zusatzüberschrift / Preislistennummer: Soweit im Design hinterlegt (Variable: "preisListenNummer") wird der hier erfasste Text im Katalog angedruckt (z.B. im Überschriftsbereich Texte wie "Preisliste gültig ab ...")

Preise aus der KL-KatGen Angedruckt werden die Preise aus der KL-KatGen-Positionsdatei.

Positionsdatei Verwenden: Findet das Programm keinen entsprechenden Artikel in der Artikeldatei oder wurde die "Update-Sperre" der Kataloggruppe oder Kataloggruppenposition aktiviert, wird der Preis der Katalogpositionsdatei angedruckt.

Deckblatt/ Rückblatt Aus Kompatibilitätsgründen in dieser Maske.

Inhaltsverzeichnis In neueren Releases erweiterte Funktionen im Register "Einzeldruck"

Siehe folgendes Kapitel.

Anzeige- /Druck im Testmodus Es besteht die Möglichkeit, im Katalogdesign Felder zu definieren, die nur in einem sogenannten Testmodus angezeigt bzw. angedruckt werden. Beispielsweise die Kataloggruppennummer oder den Namen der Bilddatei.
Sie aktivieren diesen Testmodus, indem Sie in der Maske "Kataloge – Druck und Design" mit der rechten Maustaste auf den Button Anzeige bzw. Druck klicken.
Das Objekt müssen sie in den Druckoptionen "Objekt drucken" in der Rubrik "Nur drucken, wenn Ausdruck wahr ist" den Eintrag "testmodus=1" definieren.

Seitenzähler beginnend ab Es besteht die Möglichkeit den automatischen Seitenzähler von KL-Katgen mit einem anderen Wert als mit 1 beginnen zu lassen.
Dieses ist sinnvoll, wenn Sie zum Beispiel separate Deckblatt oder Vorwortseiten zum Katalog beilegen möchten, dessen Seitenzahlen bereits integriert sein sollen.

Register vor dem Druck leeren Hier bestimmen Sie, dass das Register vor dem Start geleert werden soll. Verneinen bei Sammeldruck.

4.8 Erstellen und Drucken Inhaltsverzeichnisse und Register

KL-KatGen verfügt über eine leistungsstarke integrierte automatische Erstellung von Inhaltsregistern und InhaltsVerzeichnissen. Beim Drucken/Anzeigen des Kataloges erzeugt KL-KatGen dazu im Hintergrund die notwendigen Daten. Die Kriterien, nach denen sortiert und gruppiert werden kann, sind Kategoriebezeichnung, Kategorienummer sowie Stichwort, Artikelnummer und Artikelbezeichnung.

Beachten Sie: Um ein korrektes, komplettes Inhaltsverzeichnis zu erhalten, ist der komplette Katalog unmittelbar vor dem Drucken des gewünschten Registers zu erzeugen.

· Stichworte

· Stichworte hierfür können hinterlegt/importiert werden:

- Im Feld "Text-Register" in Kataloggruppe (Grundmaske)

- Im Erweiterten Register der Kataloggruppe (Schaltfläche "Z" in Grundmaske)

- Im Registerfeld der Katalogposition

· Kategorien:

· Für die Ermittlung der Kategorien sind Kategorienummer und Kategoriebezeichnung in der Kategorientabelle zu hinterlegen bzw. zu importieren. Bei einer mehrstufigen Struktur ist der jeweilige Master (Parent) dem Slave (Client) zuzuordnen. Weitere Details hierzu finden Sie in den Kapiteln "Kategorienermittlung" bzw. "Kategorien-Verwaltung")

·

· Die Kategorienummer (alpahnum.) ist zu hinterlegen:

- Im Feld "Kategorie" der Kataloggruppe (Maske "Kataloggruppen-Zusätze")

Inhaltsverzeichnisse bzw. Register können sowohl durch Auswahl der entsprechenden Optionen beim Drucken (siehe Abbildung: Register Druckoptionen und Einzeldruck) oder durch Einbinden in einen "Sammeldruck" (siehe Sammeldruck) erstellt werden, als auch nachträglich gezielt durch Einzeldruck abgerufen werden.

Der nachgelagerte Einzel-Druck ist sinnvoll für das gezielte Erzeugen von einzelnen "kategoriesortierten" Registern und für ein Inhaltsverzeichnis, das dem Katalog vorgelagert wird.

Siehe hierzu nachfolgend den Punkt "Erzeugen eines Inhaltsverzeichnisses mit den korrekten Seitenangaben".

4.8.1 Standard-Register im Design des Kataloges erstellen

Für ein einheitliches Katalogdesign können zu jedem Katalog(-Design) die optisch passenden Register gedruckt werden, indem ein Design mit gleichem Namen, wie das Katalogdesign, mit davor stehender Buchstabenfolge im Verzeichnis bereitgestellt wird.

"REGs" für Standardregister

"REGa" für Register Artikelnummer

"REGk" für Register Kategorien

"REGi" für Register Inhaltsverzeichnis

Beispiel: Ihr Katalog heißt "ZUBEHÖR""

Wenn Sie alle vier möglichen Registerarten nutzen möchten und zu jeder ein eigenes Design erstellen wollen, müssten Sie Designs unter folgenden Namen bereitstellen:

für das Standard-Register "REGsZUBEHÖR

für das Artikelnummern-Register "REGaZUBEHÖR

für das Kategorien-Register "REGkZUBEHÖR,

für das Inhaltsverzeichnis-Register "REGiZUBEHÖR,

Findet KL-KatGen kein Design mit entsprechendem Namen, benutzt KL-KatGen das mitgelieferte Standard-Design z.B. "REGsSTANDARD.FRX".

Erzeugen eines Inhaltsverzeichnisses mit den "korrekten" Seitenangaben

Um ein "korrektes" Inhaltsverzeichnis mit den richtigen Seitennummern, dass vor den eigentlichen Katalogdaten erscheinen soll, zu erzeugen ist folgendende Vorgehensweise zwingend:

1. Ermitteln Sie den Platzbedarf für das vorgelagerte Inhaltsverzeichnis durch Drucken (Anzeigen) des gesamten Kataloges und anschließendem Druck des Inhaltsregisters.

2. Drucken Sie danach erneut den Katalog ohne die vorlaufenden Seiten, d.h. den Katalogdatenteil ohne Deckblatt und Inhaltsverzeichnis(se) und geben die Seitenzahl an, mit der der Druck beginnen soll. Zum Beispiel die Anzahl der vorgelagerten Seiten wie Deckblatt, Zwischen- Leerblatt, Vorwort, Inhaltsverzeichnis usw. beträgt 25 Seiten, so ist, um die richtigen Seitenverweise zu erhalten, der Datenteil ab Seite 26 erneut zu Drucken.

3. Sie können nun im Sammeldruck den Katalog zusammenstellen und hintereinander ausdrucken. Bzw. mit einem geeignetem Programm für das Erstellen von PDF-Dateien (PDF-Drucker) die einzelnen Katalogteile in der gewünschten Reihenfolge ausgeben.

4.8.1.1 Alphabetisches Register Standard

Es wird ein herkömmliches alphabetisch sortiertes Stichwortregister erzeugt. Die Stichworte dazu werden aus dem Feld "Register" der Kataloggruppe bzw. der Katalogpositionen (vgl. "Die Arbeitsansicht") entnommen.

Sollten Sie weitere Registereinträge wünschen, steht zusätzlich ein Eingabefenster für die Erfassung weiterer Stichworte je Kataloggruppe zur Verfügung.
                     Beispiel für ein automatisch erstelltes alphabetisches Inhaltsverzeichnis
4.8.1.2 Register alphabetisch sortiert nach Kategorien und Stichwort

Es wird ein alphabetisches Stichwort-Register erstellt, das nach Kategorie-Nummer oder Bezeichnung gruppiert werden kann.

Im Gegensatz zu dem einfachen, alphabetisch sortierten Stichwortregister, kann ein alphabetisch sortiertes, nach Kategorien gruppiertes Inhaltsregister gedruckt werden. Voraussetzung dazu ist, dass die einzelnen Artikel (Katalogpositionen) Kategorien (Haupt-, Zwischenkategorien usw.) zugeordnet wurden.

Was, wie detailliert erscheinen soll, kann auf einfache Art im Berichtsdesigner definiert werden.

Registereinträge nach Kategorien sortiert (einzelne Artikel)

Weitere detaillierte Informationen zum automatischen, halbautomatischen oder manuellen Erstellen eines Registerbaumes entnehmen Sie bitte dem Kapitel "Kategorien-Verwaltung"

4.8.1.3 Register Inhaltsverzeichnis

Im Gegensatz zu dem alphabetisch sortierten Stichwortregister, kann ein Inhaltsverzeichnis nach Reihenfolge des Katalogs gedruckt werden. Unter der Voraussetzung, dass die einzelnen Artikel Kategorien (Haupt-, Zwischenkategorien usw.) zugeordnet wurden, kann der Ausdruck entsprechend verdichtet erfolgen. D.h. es können sämtliche Artikel in der Reihenfolge des Kataloges mit Seitenangabe gedruckt werden (was in der Regel wenig sinnvoll sein dürfte) oder nur die Unter- , Zwischen- und Hauptgruppen (Kategorien). Was, wie detailliert erscheinen soll, kann auf einfache Art im Berichtsdesigner definiert werden.

4.8.1.4 Register nach Artikelnummer

Der Ausdruck erfolgt nach Artikelnummer aufsteigend sortiert.

Die Daten für die Erstellung dieses Inhaltsregisters können für die Weiterverarbeitung exportiert werden.

4.8.1.5 Druck Preisliste / Register nach Seite (Programmoption, nicht im Standard)

Hiermit kann ein Design definiert werden, welches nach Seitennummer aufsteigend die Artikel bzw. Katalogpositionen andruckt. Dies kann zum Beispiel als einfache Preisliste oder als Seitenbezogenes Inhaltsverzeichnis genutzt werden.

4.8.1.6 Individual-Register (Programmoption, nicht im Standard)

Es besteht die Möglichkeit diverse weitere individuelle Register zu definieren und zu entwerfen. Hierbei können die Sortierungen und weitere Optionen (z.B. ignoriere Groß-/Kleinschreibung), sowie der Name des Designs individuell gestaltet werden.

Folgende Sortierungen sind realisierbar:

- nach Kategoriebezeichnungen/Registerbegriffen

- nach Kategorienummern/Registerbegriffen

- nach Kategoriebezeichnungen/Artikelnummern

- nach Kategorienummern/Artikelnummern

- nach Kategoriebezeichnungen/Artikelbezeichnung

- nach Kategorienummern/Artikelbezeichnung

- sortiert nach Artikelnummern

- nach Artikelbezeichnung

- weitere Sortierungen

Bis zu sechs Kategoriestufen kann Kl-KatGen verarbeiten, wobei die Sortierung auch mit einer der Kategorie-Untergruppen beginnen kann

Der Ausdruck eines individuellen Registers wird in der Parameterdatei im Schlüssel "registersteu" gesteuert.
Im Memo-Feld "Info" wird hier ein Text als Kommentar, der Name des Designs (xxx.frx), sowie der Befehl, der die Sortierung steuert hinterlegt.

Bei Fragen zu diesem Thema wenden Sie sich bitte direkt an die KL-KatGen-Hotline.

Die obige Abbildung zeigt ein Register mit Sortierung nach Kategorienstufe 2, 3 und Alphabet.

4.8.2 Erstellen und Drucken des Deckblattes

Unabhängig von der Möglichkeit ein Deckblatt durch Auswahl dieser Optionen zu drucken, können Sie ein Deckblatt auch durch Einbinden in einen "Sammeldruck" (siehe Sammeldruck) drucken.

Im Katalog-Designer kann zu jedem Katalog ein optisch passendes Deckblatt (Design) erstellt werden. Dazu ist ein Design mit gleichem Namen, wie das Katalogdesign, mit davor stehender Buchstabenfolge "DECK" im Verzeichnis bereit zu stellen (z.B. Katalogname = "ZUBEHÖR.PRL" à so muss der Name des Designs für das Inhaltsverzeichnis "DECKZUBEHÖR.FRX" lauten).

Findet KL-KatGen kein Design mit entsprechendem Namen, benutzt KL-KatGen das mitgelieferte Standard-Design "DECKSTANDARD.FRX".

4.8.3 Erstellen und Drucken des Rückblattes

Unabhängig von der Möglichkeit ein Rückblatt durch Auswahl dieser Optionen zu drucken, können Sie ein Rückblatt auch durch Einbinden in einen "Sammeldruck" (siehe Sammeldruck) drucken.

Im Katalog-Designer kann zu jedem Katalog ein optisch passendes Rückblatt (Design) erstellt werden. Dazu ist ein Design mit gleichem Namen, wie das Katalogdesign, mit davor stehender Buchstabenfolge "RUECK" im Verzeichnis bereit zu stellen (z.B. Katalogname = "ZUBEHÖR.PRL" à so muss der Name des Designs für das Inhaltsverzeichnis "RUECKZUBEHÖR.FRX" lauten).

Findet KL-KatGen kein Design mit entsprechendem Namen, benutzt KL-KatGen das mitgelieferte Standard-Design "RUECKSTANDARD.FRX".

4.9 Designverwaltung

Bei den unter Punkt 2 beschriebenen Darstellungsarten handelt es sich um Darstellungsmöglichkeiten der einzelnen Kataloggruppen des Artikel-/Datenbereichs innerhalb eines Kataloges. Da ein Katalog in der Regel nicht nur aus dem reinen Artikel-/Datenbereich besteht, sondern auch Deckblatt, Inhaltsverzeichnis diverse Zwischenblätter usw. enthalten kann, bietet KL-KatGen die Möglichkeit auch solche Seiten individuell zu gestalten und mit der Funktion "Sammeldruck" in einem "Komplett-Katalog" zu drucken.

Inder Designverwaltung können Sie neue Designs erstellen oder nicht mehr gewünschte löschen.

Für die "Neuerstellung" werden Ihnen die unterschiedlichen Standarddesigns als Basis angeboten, die Sie für Ihre eigenen Designs verwenden können.

Basisdesigns:

KL-KatGen unterscheidet folgende Basisdesign-Typen:

Designs für den Druck von Katalogdaten: Katalogdaten
Preisliste einspaltig
Preisliste zweispaltig

Bei diesen Basisdesign sind die für den Druck der Katalogdaten (Artikel) erforderlichen Daten in der Datenumgebung definiert.

Designs für das Drucken von Sonderblätter: Deckblatt
Zwischenblätter
Rückblatt
Leere Seiten

Bei diesen Basisdesigns sind die für den Druck von Textvariablen erforderlichen Daten in der Datenumgebung definiert

Designs für das Drucken eines Registers: Register

Bei diesen Basisdesigns sind die für den Druck des Katalogregisters erforderlichen Daten in der Datenumgebung definiert.
Katalogdaten: Dieses Design beinhaltet alle Datenstrukturen die für das Drucken der Artikeldaten notwendig sind. (Kataloggruppe, Katalogpositionen usw.). Das Design berücksichtig ungerade und gerade Seiten (z.B. Bilder immer außen).

Preisliste einspaltig: Dieses Design beinhaltet alle Datenstrukturen die für das Drucken der Artikeldaten notwendig sind. Der Druck erfolgt einspaltig für jede Position ohne Bilder.

Preisliste Zweispaltig: Dieses Design beinhaltet alle Datenstrukturen die für das Drucken der Artikeldaten notwendig sind. Der Druck erfolgt zweispaltig für jede Position ohne Bilder.

Deckblatt: Es stehen lediglich die Textvariablen zur Verfügung. Kataloggruppen-, Kataloggruppenpositions- und Artikeldaten sind nicht verfügbar.

Register zweispaltig: Es stehen die während des Drucks erzeugten Inhaltsregisterdaten zur Verfügung.

Der Ausdruck erfolgt zweispaltig.

Register dreispaltig: Es stehen die während des Drucks erzeugten Inhaltsregisterdaten zur Verfügung. Der Ausdruck erfolgt zweispaltig.

Rückblatt: Es stehen lediglich die Textvariablen zur Verfügung. Kataloggruppen-, Kataloggruppenpositions- und Artikeldaten sind nicht verfügbar.

Zwischenblatt: Es stehen lediglich die Textvariablen zur Verfügung. In der Regel mit Kopf- und Fußzeilen.

Leere Seite: Es stehen lediglich die Textvariablen zur Verfügung. In der Regel ein vollkommen leeres Blatt, z.B. Rückseite des Deckblattes.

Wählen Sie die gewünschte Basis, z. B . "Deckblatt", wenn Sie ein Deckblatt für Ihren Katalog erstellen wollen. Erfassen Sie einen eindeutigen Namen (z.B. "DeckKatalog01"), verwenden Sie dabei keine Leerstellen oder Sonderzeichen.Nach "Klick" auf die "Ausführen-Taste" öffnet sich der "Katalog-Designer. Passen Sie das Design entsprechend Ihren Anforderungen an und speichern Sie das Ergebnis.

Selbstverständlich können auch neue Designs durch Ändern bereits vorhandener Designs erstellt werden. Wählen Sie dazu das gewünschte Ausgangsdesign, modifizieren Sie dies entsprechend Ihren Wünschen und speichern Sie es unter neuem Namen. Beachten Sie, dass keine Leerstellen im Dateinamen sind und dass das Design entsprechend seinem Ursprung (Basisdesign) mit der richtigen Datenumgebung zu verwenden ist, d.h. z.B. mit einem Deckblatt können Sie aufgrund der fehlenden Datenstruktur keine Artikeldaten drucken.

Im Register "Auswahl Katalog/ Design" Selektion "Eigene" finden Sie nun die von Ihnen erstellten Designs.

Designs für Katalogdaten werden mit dem Katalognamen in Kombination mit dem passenden Design angezeigt.

Sammeldrucke werden hier mit vorlaufenden ">" gekennzeichnet und stehen am Anfang der Auswahl.

Sonderblätter wie Deckblatt, Zwischenblätter usw. werden hier mit vorlaufenden "~" gekennzeichnet und stehen am Ende der Auswahl.

4.9.1 Programmerweiterungen / firmenspezifische Funktionen
(Programmoption, nicht im Standard)

Optional können anwenderspezifische Bewertungen beim Generieren berücksichtigt werden (nicht im Standard).

So werden zum Beispiel mit der nachfolgend abgebildeten Vorlaufmaske, tagesabhängige Kurse (unterschiedliche Metallnotierung) beim Generieren berücksichtigt.

Aktiviert wird diese Variante im Datensatz "fakz" mit dem Eintrag "notierung" im Feld "Text1".

Weitere Details hierzu, erfragen Sie bitte bei der KLKatGen-Hotline..

4.10 Der Sammeldruck

Einmal erstellt, ermöglicht der "Sammeldruck" in einem Arbeitsgang komplette Kataloge zu drucken, d.h. Kataloge vom Deckblatt bis Rückblatt einschließlich Zwischenblätter, Inhaltsverzeichnis, Inhaltsregister usw. Wenn gewünscht, werden dabei automatisch Preise und weitere Daten aktualisiert und ein durchgängiges Inhaltsregister erstellt. Direkt auf dem Drucker ausgegeben, erhalten Sie so einen kompletten Katalog.

In Verbindung mit einem geeigneten "PDF-Programm" können Sie eine PDF-Datei erstellen, die direkt in einem Druckereibetrieb zum Drucken weiterverarbeitet werden kann. Oder Sie stellen Ihren "PDF-Katalog" zum Ansehen, Drucken oder Downloaden im Internet für Kunden und Interessenten bereit.

4.10.1 Sammeldrucke erstellen

Vor Erstellung eines Sammeldrucks sind die notwendigen "Teile" (z.B. Deckblatt, Zwischenblätter, Datenteil(e) usw) vorzubereiten und im "Auswahlfenster Katalog-/Design" zu registrieren (siehe Punkte zuvor).

Mit "Klick" auf den "Sammeldruck-Button", starten Sie die Erfassung eines "Sammeldruckes".

Wählen Sie die zu druckenden Objekte aus dem "Auswahlfenster Katalog-/Design", in der für den Katalogdruck gewünschten Reihenfolge (Doppel-Klick auf die Position im Auswahlfenster oder nach Auswahl Klick auf die "Anfügen-Taste" im Fenster "Sammeldruck" ).

Die ausgewählten Katalog-Teile werden im Fenster "Sammeldruck" angezeigt.

Kombinieren Sie so Deckblatt, Inhaltsverzeichnis, Katalogdaten, Zwischenblätter und Register zu einem Individuellen Gesamtkatalog. Nach Klick auf "Erfassung Beenden" werden Sie nach einem Namen gefragt, unter dem der neu erstellte Sammeldruck (Katalog) gespeichert werden soll.

Der Sammeldruck wird im Auswahlfenster mit vorstehenden ">" gekennzeichnet gelistet und kann nun
ausgewählt, angezeigt und gedruckt werden.

5 Menü Katalogdaten verwalten

Unter dem Menüpunkt "Kataloge und Daten verwalten" im Hauptmenü sind alle Programmfunktionen für das Verwalten der Kataloge zusammengefasst. Die wesentlichen Funktionen sind im Kapitel "Der Katalogdaten-Manager" im Detail beschrieben..
5.1 Katalogdaten Neu

Es öffnet sich das Standard-Auswahl/-Eingabefenster. Das Programm erwartet die Eingabe eines frei wählbaren Katalog-(Datei)-Namens. Die Endung ".prl" wird vom Programm automatisch angefügt. Nach Bestätigung mit der Taste "Erstellen" wird ein neuer, leerer Katalog angelegt. Die Datenerfassung kann beginnen.

5.2 Katalog Speichern unter

Es öffnet sich das Standard-Auswahl/-Eingabefenster. Das Programm erwartet die Eingabe eines frei wählbaren Katalog-(Datei)-Namens, die Endung ".prl" wird vom Programm automatisch angefügt

5.3 Katalogdaten Öffnen

Es öffnet sich das Standard-Auswahl / -Eingabe Fenster. Das Programm erwartet die Auswahl eines Kataloges bzw. die Eingabe eines Katalog-(Datei)-Namens. Nach Bestätigung mit der Taste "Holen" wird der gewünschte Katalog zur weiteren Verwendung angezeigt.

5.4 Artikel in den Positionen tauschen und löschen

Die Wahl dieses Menüpunktes öffnet das abgebildete Fenster, in dem Sie folgende Aktionen einstellen können:

Einen Artikel im gesamten Katalog durch einen anderen Artikel ersetzen:
Hierzu wählen Sie (Doppelklick auf Eingabefeld öffnet Artikelauswahl) im oberen Feld "Artikel" den gewünschten Artikel (Artikel-Nummer) den Sie im aktuellen Katalog ersetzen möchten.

Im unteren Feld "Artikel" wählen Sie den Artikel (Artikel-Nummer) mit dem der oben eingestellte Artikel ersetzt werden soll.
Durch klick auf den Button "im Katalog ersetzen" wird jede Position in der der oben eingestellte Artikel im Katalog vorkommt, durch die Inhalte aus dem Artikelstamm des unten eingestellten Artikels ersetzt.

Einen Artikel im gesamten Katalog löschen:
Hierzu wählen Sie (Doppelklick auf Eingabefeld öffnet Artikelauswahl) im oberen Feld "Artikel" den gewünschten Artikel (Artikel-Nummer) den Sie im aktuellen Katalog löschen möchten.

Durch klick auf den Button "im Katalog löschen" wird jede Position in der der oben eingestellte Artikel im Katalog vorkommt, aus dem Katalog entfernt.

Einen Artikel im gesamten Katalog durch neue Inhalte des gleichen Artikels ersetzen:

Hierzu wählen Sie (Doppelklick auf Eingabefeld öffnet Artikelauswahl) im oberen und im unteren Feld "Artikel" den gewünschten Artikel (Artikel-Nummer) dessen Inhalte Sie im aktuellen Katalog aktualisieren möchten.

Durch klick auf den Button "im Katalog ersetzen" wird jede Position in der der oben eingestellte Artikel im Katalog vorkommt, durch die Inhalte aus dem Artikelstamm des unten eingestellten Artikels ersetzt.
Hierbei können Sie im rechten Teil der Maske "Werte in den Katalog-Positionen aktualisieren" festlegen, welche Datenfelder bei diesem Update berücksichtigt werden sollen.

5.5 Verwalten Kataloggruppen

Sowohl bei der automatisierten, als auch bei der manuellen Katalogerstellung werden die Kataloggruppennummern in 10er-Schritten vergeben. Damit ist die Möglichkeit gegeben, durch einfaches Überschreiben der Kataloggruppennummer eine komplette Kataloggruppe innerhalb des Kataloges neu zu positionieren.

Sollen mehrere bzw, größere "Umstellungen" notwendig werden, können diese mit der Programmfunktion "Verwaltung Katalogsortierung nach Kataloggruppen" durchgeführt werden.

Das Markieren der zu verschiebenden Kataloggruppen geschieht folgendermaßen:

Strg + rechte / linke Maustaste einzelne Gruppe

Shift + rechte / linke Maustaste Bereich von/bis

Alt + rechte / linke Maustaste Bereich von/bis

Das Aufheben einer Markierung funktioniert auf die gleiche Weise.

Das Einfügen der markierten Datensätzen mit Doppelklick auf die gewünschte Kataloggruppe nach der diese eingefügt/einsortiert werden sollen

Oder positionieren Sie auf die Kataloggruppe nach der die gewählten Positionen eingefügt/einsortiert werden sollen sind und "Klicken" Sie auf den Button "verschieben".

Die neuen Positionen der Kataloggruppen werden dargestellt.

Nach Klick auf "Daten übernehmen" werden die Änderungen im Katalog durchgeführt.

Achtung: Beachten Sie die Hinweise unter "Katalognummern neu vergeben" auf der Folgeseite

Katalognummern "Neu vergeben"

Wurden Kataloggruppennummern manuell geändert, verschoben oder Katalogruppen gelöscht kann die Standardnummerierung, Kataloggruppen in 10er-Schritten, erzeugt werden.

Wählen Sie dazu den

- Menüpunkt "Verwaltung Katalogsortierung nach Kataloggruppen" (siehe Abbildung zuvor)

und

- "Klicken" sie auf den Button "Daten Übernehmen".

Achtung: Die Kataloggruppen werden "neu" in 10er-Schritten nummeriert, Wurden Seiten oder Zwischenüberschriften nach dem "alten System" im Katalog behandelt, sind eventuell Korrekturen bei der Überschriftenplatzierung vorzunehmen.

Bei dem "neuen Überschriftensystem ", werden Seiten und Zwischenüberschriften mit Pseudokataloggruppen (Darstellungsart "SUEB" bzw. "ZUEB") an den gewünschten Katalogstellen eingefügt und können somit bereits mit der beschriebenen Programmfunktion (mit)sortiert werden.

5.6 Aktions-/Sonderpreiskatalogerfassung

Hier muss der gewünschte Kunde angewählt werden und die entsprechende Maske geöffnet bleiben.

Auf der Hauptmaske kann nun der entsprechende Katalog mit den gewünschten Artikeln manuell zusammengestellt werden. Die Preisübernahme in die Katalogpositionen geschieht unter Berücksichtigung der Sonderkonditionen des ausgewählten Kunden.

Eine detaillierte Beschreibung finden Sie im Kapitel "Automatische Preisermittlung bei der manuellen Erfassung eines Kataloges"

5.7 Kataloggruppen Selektion

Für die weitere Verarbeitung können Kataloggruppen durch Setzen des Selektionskennzeichen ausgewählt und durch Aktivieren des Selektionsfilters selektiert werden. So können auf einfache Art Teilbereiche aus einem Katalog (Katalogdaten) ausgewählt und gedruckt oder durch Speichern unter einem neuen Namen ein neuer Katalog gebildet werden. Die detaillierte Beschreibung finden Sie unter Kataloge manuell erstellen.

5.8 Überschriften

Seiten- und Zwischenüberschriften und -texte und -bilder werden über die Funktion "Überschriften" den einzelnen Kataloggruppen zugeordnet. D.h., man bestimmt, ab welcher Kataloggruppe die entsprechende Seitenüberschrift im Seitenkopf oder innerhalb der Seite, vor welcher Kataloggruppe, die entsprechende Zwischenüberschrift erscheinen soll.

Aus Kompatibilitätsgründen ist diese Funktion noch verfügbar, verwenden Sie stattdessen die Überschriftensteuerung mit den Darstellungsarten "SUEB" und "ZUEB".

Die detaillierte Beschreibung beider Möglichkeiten finden Sie unter Kataloge manuell erstellen.

5.9 Aktuelle Katalogdaten sichern

Durch Auswahl dieser Menüfunktion wird die Katalogdatei temporär gesichert. Da es sich hier lediglich um eine temporäre Sicherung handelt, die durch einen erneuten Sicherungsvorgang überschrieben wird, empfehlen wir ggflls. mit "Katalog speichern unter" eine Kopie mit modifizierten Namen zu erstellen.

5.10 Katalog zurücksichern

Die letzten temporär gesicherten Katalogdaten werden wieder als aktuelle Katalogdatei zur Verfügung gestellt.

5.11 Katalog Dateien Löschen

Die archivierten Kataloge/ Preislisten /Kataloge werden in einem Auswahl-Fenster angezeigt ("xxx.prl Dateien"). Der gewünschte Katalog kann ausgewählt und gelöscht werden.
Gelöscht wird der komplette Katalog (d.h. die Dateien). Die Artikelstammdatei bleibt erhalten.

5.12 Aktuelle Katalogdatei leeren

Diese Programmfunktion löscht die Daten aus dem aktuellen Katalog. Gelöscht werden Kataloggruppen einschl. der zugeordneten Positionen. Die leere Katalogdatei bleibt für die Bearbeitung erhalten. Die Artikelstammdaten bleiben erhalten.

5.13 Katalog Drucken und Designverwaltung

Die Ausgabe des Kataloges / der Preisliste kann wahlweise direkt auf einen angeschlossenen Drucker oder am Bildschirm angezeigt werden. Diese Funktion kann mit dem Button "Drucken" in der Grundmaske direkt aufgerufen werden. Weitere Details sind unter Punkt 4 "Kataloge drucken" beschrieben.

6 Menü Stammdatenverwaltung

Unter dem Menü-Punkt Stammdatenverwaltung finden sich Programmzweige, die es ermöglichen eigene Stammdaten zur speziellen Weiterverarbeitung in KL-Katgen zu erfassen und zu pflegen.
6.1 Artikeldaten verwalten

6.1.1 Artikel-Basisdaten

Durch Auswahl dieses Menüpunktes öffnet sich die unten abgebildete Maske, in der die Artikelstammdaten verwaltet werden können.
Dies ist dann sinnvoll, wenn Sie Ihre Artikeldaten komplett manuell erfassen oder zumindest teilweise nachpflegen und daraus verschiedene Kataloge erstellen möchten.
Sie können dann immer wieder neue Kataloge erfassen, indem Sie auf die einmal erfassten Artikeldaten zugreifen. Die Datenfelder in der Artikelstammmaske entsprechen weitgehend denen in der Katalogdatei.

Werden beim Katalogdruck oder bei der manuellen Katalogerfassung Positionsdaten aus der Artikeldatei übernommen oder aktualisiert, so übernimmt das Programm beim Bilden bzw. erfassen der jeweils ersten Position einer Kataloggruppe, die in der Artikeldatei hinterlegten Inhalte automatisiert in die entsprechenden Datenfelder der Kataloggruppendatei.

(Wegen der Gefahr eines ungewollten "Überschreibens der Daten", beachten Sie bitte hierzu auch das Kapitel "Die Updatesteuerung beim Datenimport ".)

6.1.2 Artikel Ergänzende Daten

6.1.3 Artikelauswahl mit Filtern

Ist die Artikelnummer eines Artikels nicht bekannt, oder sollen mehrere Artikel mit ähnlichen Bezeichnungen oder Zugehörigkeiteb gefunden werden steht die" Filterfunktion" zur Verfügung.

Nach Eingabe eines Suchbegriffs im Eingabefeld "Suchfilter" öffnet sich ein zusätzliches Fenster in dem Sie bestimmen können in welchen Datenfelder der Artikelstammdatei der gewünschte Begriff gesucht werden soll.

Die Maskenhintergrundfarbe ändert sich bei aktivem Filter auf rot.

6.1.4 Artikel-Zusatzdaten

Weitere Texte können nach Aufruf im Fenster Kataloggruppen-Zusatzdaten manuell erfasst und verwaltet werden.

Werden Positionsdaten aus der Artikeldatei übernommen, werden bei Erfassung der jeweils ersten Position einer Kataloggruppe, der in der Artikeldatei hinterlegte Text automatisiert in den Kataloggruppenzusatztext übertragen.

(Wegen der Gefahr eines ungewollten "Überschreibens der Daten", siehe dazu auch "Datenaktualisierung beim Datenimport / Katalogerstellung".)

Diese Texte können sowohl, zeilenweise (linke Abbildung) oder als ein editierbares Textfenster (rechte Abbildung) genutzt werden.

Sie können durch klicken auf den A-Button im unteren rechten Maskenbereich zwischen diesen beiden Modi umschalten. Die Grundeinstellung erfolgt im Key "fazusatzkz" durch Eintragen der Ziffer 1 im Feld "Text1" an der dritten Stelle.

Bis zu fünf Zusatztexte (jeweils bis 64.000 Zeiche) können für jede Kataloggruppe hinterlegt werden.

In der Fußleiste kann der gewünschte Text 1 bis 5) angewählt und geändert werden.

Gezeigt wird jeweils der (die) Text(e) der aktiven Kataloggruppe.

Sowohl in der Grundmaske als auch in dem Zusatztextfenster können die Kataloggruppen gewechselt (geblättert )werden.

Mit Klick auf den Button "Kopieren" wird der gesamte Maskeninhalt gemerkt, durch Klick auf den Button "Einfügen" wird der zuletzt gemerkte Maskeninhalt in die aktuelle Maske eingefügt.

Mit Klick auf den Button "leeren" wird der gesamte Maskeninhalt geleert.

Mit Klick auf den Button "Neu" wird ein neuer Artikelstammsatz angelegt.

Mit Klick auf den Button "Beenden" wird die Maske "Kataloggruppen-Zusätze" verlassen.

Über den "P-Button" können die Bezeichnungen der jeweiligen Zeilen hinterlegt werden.

6.1.5 Nutzungsvarianten der Zusatztexte

Je nach Anforderung können die Zusatztexte unterschiedlich genutzt werden:

- Zusatztext als ein durchgehender, editierbar Text (Langtext):
lange unformatierte frei editierbare Texte (siehe Abbildung zuvor)

- Aufteilen des Zusatztextes in bis zu 20 Textzeilen bzw. Textblöcke (siehe nachfolgende Abbildung)

Dies erlaubt auf einfach Weise mit einem entsprechenden Design Produktdaten in Tabellenform (siehe Abbildung) zu drucken

6.1.6 Label setzen für formatierte Textfelder

Um zu wissen, welche Werte in welche Zeile zu erfassen sind, können Bezeichnungen für die jeweilige Zeile hinterlegt werden. Klicken Sie die dazu auf die " 'L' Taste".

In der ersten Spalte (gelb unterlegt) können nun die Bezeichner (Label) für die einzelnen Zeilen vorgegeben werden.

ACHTUNG: Diese Struktur gilt einheitlich für alle Kataloggruppen des Kataloges.

Für eine schnellere Erfassung, insbesondere bei nachträglichen Korrekturen (z.B. Zeile einschieben) kann der Editiermodus mit Klick auf die "LS" = Labelerfassung und "TS" = Texterfassung Taste geändert werden. In den einzelnen Feldern (siehe Abbildung "gelb und rosa") können nun Zeilen eingefügt und gelöscht werden.

ACHTUNG: Prüfen Sie durch Wechsel des Editiermodus, dass Bezeichnung und Daten übereinstimmen. Vergleichen Sie das Ergebnis insbesondere auch in Ihren bereits erstellten Katalogdesigns

6.1.7 Kataloggruppenzusatztexte (und Label) Kopieren

Sie können die Label und die Zusatztexte einer Kataloggruppe in andere Kataloggruppen übertragen.

Klicken Sie dazu auf den Button "Merken"

Das Programm übernimmt Texte und Label in den Zwischenspeicher

Wählen Sie nun "Was" Sie übertragen wollen.

- Nur den aktuellen Text (hier Text 1)

- Text1 mit dem entsprechenden Label

- Alle Texte (1-5)

- Alle Texte (1-5) mit den entsprechenden Labels

- Nur die Labels der aktuellen Kataloggruppe von Zusatztext 1

- Alle Labels (1-5) der aktuellen Kataloggruppe

Wählen Sie nun "Wohin" Sie übertragen wollen.

- In eine bestimmte Kataloggruppe

Indem Sie in der Grundmaske oder in dem Kataloggruppenzusatztextfenster (hier) die gewünschte Kataloggruppe wählen (z.B. durch Blättern oder Anwahl)

- In alle Kataloggruppen des Kataloges

Indem Sie auf die entsprechende Auswahltaste "Klicken"

6.1.8 Kataloggruppenzusatztexte und –Label Löschen

Mit "Klick" auf den "Löschen Button" werden die gewählten (siehe Kopieren) Texte und Label der entsprechenden Kataloggruppen gelöscht.

6.2 Artikellisten

Über diesen Menüpunkt stehen Ihnen drei einfache Artikellisten zur Verfügung.

Die Sortierung kann nach Artikel-Nummer, Artikelhauptgruppe oder nach Artikelbezeichnung erfolgen.

6.3 Artikeldatei speichern unter

Die aktuelle Artikeldatei kann unter einem anderen Namen gespeichert werden und zu einem späteren Zeitpunkt erneut genutzt werden.

6.4 Artikeldatei wechseln

Durch Auswahl dieses Menüpunktes, kann eine Artikeldatei, die zu einem früheren Zeitpunkt mit der Funktion "Artikeldatei speichern unter" gespeichert wurde, als aktuelle Artikeldatei ausgewählt werden.

6.5 Artikeldatei sichern

Durch Auswahl dieser Menüfunktion wird die Artikeldatei temporär gesichert. Beachten Sie dass die vorherige temporäre Sicherung dabei überschrieben wird.

6.6 Artikeldatei zurücksichern

Die zuvor temporär gesicherte Artikeldatei wird wieder als aktuelle Artikeldatei zur Verfügung gestellt.

6.7 Aktuelle Datei leeren

Durch Auswahl dieses Menüpunktes wird die aktuelle Artikeldatei geleert.

6.8 Kategorien/Artikelgruppen verwalten

Ab der Version 8.0 verfügt KL-Katgen über die Möglichkeit "Katalog-Kategorien" bzw. "Artikelgruppen" zu verarbeiten. Es besteht somit die Möglichkeit beim Drucken automatisiert die Daten für zusätzliche Inhaltsregister und Verzeichnisse zu erzeugen und die Katalogbereiche mit entsprechenden Überschriften zu versehen.

Die Erfassung und Zuordnung von Artikelgruppen ermöglicht es Ihnen darüber hinaus Artikelgruppenspezifische Sonderkonditionen (Rabatte) zu vergeben. (vgl. Kapitel " Zusatzmodul SK".

Sollten Sie planen, ihre Artikel in Gruppen zuzuweisen oder aus Ihrer Vertriebssoftware vorhandene Artikelgruppenzuweisungen zu aktivieren/übernehmen (d.h. im Artikel steht die Artikelgruppe, Sie müssen nur noch den entsprechenden Artikelgruppenbezeichnung erfassen), um die Möglichkeit zu haben, Sonderkonditionen auf Artikelgruppen zu erfassen, lesen Sie am besten das Kapitel "Manuelle Artikelgruppen/Kategorienverwaltung"

Damit Kategorien verarbeitet werden können, müssen Kategorienummer und Bezeichnung bekannt sein, d.h. diese Informationen müssen in der Tabelle Kategorien zur Verfügung stehen. Ebenso muss bekannt sein in welchen Beziehungen die Kategorien untereinander stehen, d.h. welche Kategorie ist einer anderen über- bzw. untergeordnet ("Master" à "Slave", bzw. "Parent" à "Son").

Je nach Qualität der zur Verfügung stehenden Ursprungsdaten kann diese Tabelle beim eigentlichen Datenimport komplett automatisch erzeugt werden. Sie kann manuell nachbearbeitet bzw. ergänzt werden. Hierzu steht die entsprechende Programmfunktion unter dem Menüpunkt "Stammdaten" zur Verfügung.

1. automatische Ermittlung der Katalogkategorien beim Datenimport

2. automatisierte Ermittlung der Katalogkategorien mit der Programmfunktion
" Erstellen / Verwalten Kategorien"

2a. Ermittlung aus den Kataloggruppen des aktuellen Kataloges

2b. Ermittlung aus der KL-KatrGen-eigenen Artikelstammdatei

2c. Ermittlung aus der Importdatei
2d. Ermittlung aus einer CSV-Datei

3. manuelle Erfassung / Verwaltung Katalogkategorien mit der Programmfunktion
" Erstellen / Verwalten Kategorien"

Abbildung "Erstellen und Verwalten Kategorien / Artikelgruppen

6.8.1 Automatische Kategorienermittlung beim Datenimport

Wurde das Feld "Kategorie" in der Strukturverwaltung einem Datenfeld der Importdatei per Referenz zugewiesen (z.B. der Artikelgruppe (nicht Kataloggruppe) ), erstellt KL-KatGen beim Import einen entsprechenden Datensatz in der Kategorietabelle (siehe in nachfolgender Abbildung "lfd.Nr. 4" folgende).

Wurde in einem weiteren Feld auch noch die Bezeichnung "mitgeliefert", wird diese auch übernommen. Wird darüber hinaus auch noch die übergeordnete Kategorie/Gruppe im gleichen Datensatz "mitgeliefert" (die Zuweisung /Referenz ist "Master1" und "MasterTx1") vermerkt KL-KatGen diese Zuordnung im Feld "Master" und erzeugt, falls noch nicht vorhanden einen "Mastersatz" ("Parentsatz").

Wird dem "Master" ebenfalls ein "Master" zugewiesen, verfährt KL-KatGen entsprechend. KL-KatGen kann auf diese Weise eine Tabelle mit bis zu 6 Stufen ("master, slave" bzw. "parent, son") erstellen.

Beispiel: Die Artikel sind in einem Unternehmen wie folgt gruppiert:

Soll ein Register entsprechend dieser Struktur automatisiert erstellt werden, sind die Felder in der Importdatei bereitzustellen und in der Importstruktur zuzuweisen.

Die Zuweisung beginnt mit der untersten Stufe (hier Geldbörse, Herrengürtel, Kopfbedeckungen, Krawatten etc.).

Diese Stufe muss den Referenzfeldern "Kategorie" und "KategorieTx" zugewiesen werden.

Die nächste Stufe (hier Accessoires, Anzüge, Hemden etc.) muss den Referenzfeldern "Master1" und "MasterTx1" zugewiesen werden.

Die nächste Stufe (hier Herrenmode bzw. Damenmode) muss den Referenzfeldern "Master2" und "MasterTx2" zugewiesen werden.

Die letzte (oberste) Stufe in unserem Beispiel (Bekleidung) wäre den Referenzfeldern "Master3" und "MasterTx3" zuzuweisen. Wir haben dies bewusst unterlassen, um die weitere manuelle Verarbeitung zu verdeutlichen (siehe manuelle Strukturverwaltung).

Strukturverwaltung, siehe dazu auch Datenimport.

In der Importdatei wurden dazu in unserem Beispiel die Daten entsprechend nachfolgender Tabelle bereitgestellt.

Artikel Nummer

Artikelbezeichnung

Preis

Kategorie

Kategoriebezeichnung

Master 1

Master 1

Bezeichnung

Master 2

Master 2

Bezeichung

4711 01

Ledergürtel Verona

12,50

1111

Herrengürtel

1110

Accessoires

1100

Herrenmode

4711 02

Ledergürtel Padua

13,70

1111

Herrengürtel

1110

Accessoires

1100

Herrenmode

Beim Datenimport erzeugt KL-KatGen, mit Ausnahme der Kategorie "1000 Bekleidung" (rot dargestellt), daraus nachfolgend dargestellte Kategorietabellensätze

Kategorie

Kategoriebezeichnung

Master

1000

Bekleidung

1100

Herrenmode

1000

1110

Bekleidung

1100

1111

Herrengürtel

1110

Es müssen nicht zwangsläufig alle Master in der Importdatei mitgeliefert werden. So wurde in diesem Beispiel die Kategorie "1000" nicht in der Importdatei "mitgeliefert", sondern sie ist in der "Kategorien-Verwaltung" manuell hinzugefügt worden.

6.8.2 Automatisierte Ermittlung der Katalogkategorien mit der
Programmfunktion " Erstellen / Verwalten Kategorien

Für die vollständige, automatische Erstellung der Kategorietabellen stehen in den meisten Unternehmen die Daten nicht, bzw. nicht in der gewünschten Form zur Verfügung. Meistens sind in den Artikelstammdaten des Warenwirtschaftssystems die Artikel lediglich einer Artikelgruppe zugeordnet bzw. die Kategoriebezeichnungen und der Kategorienaufbau (MasteràSlave) sind in separaten Tabellen hinterlegt, so dass ein manuelles Erfassen, Ergänzen oder Nachbessern notwendig wird.

KL-KatGen bietet dafür folgende Lösungen an:

6.8.2.1 Ermittlung der Kategorien aus den Kataloggruppen des aktuellen Kataloges

Mit Anwahl dieser Option wird die Kategorietabelle aus den aktuellen Katalogdaten (Datenfeld "Kategorie" der Kataloggruppe) erzeugt / ergänzt.

6.8.2.2 Ermittlung der Kategorien aus der KL-KatGen-eigenen Artikelstammdatei

Mit Anwahl dieser Option wird die Kategorietabelle aus den aktuellen Artikeldaten (Datenfeld "Kategorie" der Artikelstammdatei) erzeugt / ergänzt.

6.8.2.3 Ermittlung der Kategorien aus der Importdatei

Mit Anwahl dieser Option wird der Pfadnamen der aktuell zugewiesen Importstruktur angezeigt. Es kann eine andere Importstruktur ausgewählt und/oder in die Importstrukturverwaltung verzweigt werden. Mit Klick auf den Button "Ausführen" wird die Kategorietabelle aus der zugewiesenen Katalogdatenimportdatei erzeugt / ergänzt. Die weitere Arbeitsweise entspricht der vom Kapitel "Automatische Kategorienermittlung beim Datenimport" (siehe zuvor).

6.8.2.4 Ermittlung der Kategorien aus einer CSV-Datei

Mit Anwahl wird ein Dateiauswahlfenster angezeigt. Mit Klick auf den Button "Ausführen" können aus der ausgewählten CSV-Datei die Daten direkt in die Kategorietabelle übernommen werden.

KL-KatGen erwartet drei mit Semikolon getrennte Datenfelder:

Kategorie;Kategoriebezeichnung;Masterkategorie'

Die Definitionen für 'Texttrenner','Feldtrenner' und 'Code-Page' werden aus dem Katalogdaten-Import übernommen.

Kategorie

Kategoriebezeichnung

Master

1000

Bekleidung

1100

Herrenmode

1000

1110

Bekleidung

1100

1111

Herrengürtel

1110

6.8.3 Manuelle Artikelgruppen/Kategorienverwaltung

Wie bereits in den Kapiteln "Automatische Kategorienermittlung" sowie "Automatische Kategorienermittlung beim datenimport" aufgezeigt, besteht die Möglichkeit die von KL-KatGen zur Verfügung gestellte Kategorientabelle manuell zu erfassen, bzw. zu ergänzen.

In der Regel sind die Artikel in einem Warenwirtschaftssystem einer Artikelgruppe (=Kategorie) zugeordnet bzw. müssen für ein sinnvolles Verarbeiten die Kataloggruppe einer Kategorie zugewiesen sein. Somit kann bereits mit einer der zuvor beschriebenen Funktionen aus diesen Datenbeständen eine (eventuell unvollständige) Kategorietabelle erzeugt werden. So dass nun lediglich mit dem Verwaltungsprogramm die Daten eventuell mit den Kategoriebezeichnungen und Masterzuweisungen und dem zusätzlichen Anlegen der "Mastersätze" ergänzt und korrigiert werden müssen.

In unserem Beispiel zuvor fehlte in der Importdatei lediglich die oberste Gruppe Kategorie "1000" mit der Bezeichnung "Bekleidung", die hier nun manuell dazu erfasst wurde.

Neue Kategoriesätze können nach "Klick" auf den Button "Neuanlage" erfasst werden.

Klick auf den Button "Löschen", löscht den aktuell markierten Kategoriesatz nach einer Abfrage.

Wurde die Tabelle fertig erstellt, ist mit "Klick" auf den Button "Generieren" die Kategorie-Struktur neu zu erzeugen. Kategorien, die einer Masterkategorie zugeordnet wurden, diese jedoch nicht in der Kategorietabelle vorhanden ist, werden angezeigt. Nach Anlegen der entsprechenden, übergeordneten Masterkategorie ist der Generierungslauf zu wiederholen.

Es ist zu beachten, dass nur für solche Kataloggruppen und Artikel Registereinträge gemacht werden können, bei denen im Feld "Kategorie" eine Kategoriezuordnung beim Datenimport oder manuell gemacht wurden.

Es gelten hierbei folgende Prioritäten:
Vorrang hat immer die Kategorie in der Kataloggruppe, bei manueller Kataloganlage aus dem internen Artikelstamm bestimmt die Kategorie des ersten Artikels einer Kataloggruppe die ganze Gruppe.

Es besteht die Möglichkeit, diese nachträglich, in der Maske "Katalog-Gruppen-Zusätze" abzuändern.

Wenn Sie die Einteilung/Zuordnung in Artikelgruppen lediglich dazu benötigen um die Möglichkeit zu haben, Sonderkonditionen auf Artikelgruppen zu erfassen, müssen Sie nur die unterste Stufe (Artikelgruppe, Bezeichnung) der oben beschriebenen Tabelle erfassen.

"

6.9 Kundenstamm / Aktionsstamm verwalten

In der unten abgebildeten Maske besteht die Möglichkeit Kunden manuell zu erfassen und zu pflegen.

Zur Verfügung stehen die folgende Datenfelder: Name1, Name2, Name3, Straße, Postleitzahl, Ort, Gruppe (Kundengruppe), Preisgruppe, Grundrabatt und Status.

Die Möglichkeit einer Übernahme aus einer Schnittstellendatei (evtl. aus Ihrer Vertriebssoftware) besteht über den Button "Datenimport".
Hierbei geht das System von einer Datei im CSV-Format (Felder mit Semikolon getrennt) mit einer festen Satzbeschreibung aus. Diese können Sie der unten dargestellten Abbildung entnehmen.

Achtung: Die hier zu erfassenden Sonderkonditionen wirken auf die aktuell bei der Erfassung im Zugriff befindliche Kundennummer. Unter Umständen kann es sinnvoll sein, Ihre Kunden Kundengruppen zuzuordnen und diesen anschließend gesammelt Sonderkonditionen zuzuweisen.

Beispiel: Sie klassifizieren Ihre Kunden nach getätigten Umsätzen von 1 bis 10 (oder von 001 bis 010, das Datenfeld ist alphanumerisch), und geben der Kundengruppe mit dem meisten Umsatz den besten Preis bzw. den größten Rabatt.

Die genaue Vorgehensweise zum Erfassen von Kundengruppenkonditionen entnehmen Sie dem nachfolgenden Kapitel " Sonderkonditionen verwalten"

· Die Feldinhalte und ihre Wirkungsweise:

·

SK-Art AG=Artikelgruppe Sonderkondition wirkt auf Artikelgruppe

AR=Artikel Sonderkondition wirkt auf Artikelnummer

Nummer abhängig von SK-Art Artikelnummer oder Artikelgruppe

Preis Sonderpreis

Rabatt Rabattsatz

PrGr Preisgruppe spezifiziert Basispreis aus Artikelstamm (1 bis 5)

Gültig ab erster Tag der Gültigkeit der Sonderkondition

Gültig bis letzter Tag der Gültigkeit der Sonderkondition

Bezeichnung1 Text/Bezeichnung bei Anlage wird Artikel- bzw. Artikelgruppenbezeichnung eingestellt

6.10 Kundengruppen verwalten

In diesem Programmmodul könne Sie Kundengruppen erfassen und verwalten. Die Erfassung und Zuordnung von Kundengruppen ermöglicht es Ihnen Kundengruppenspezifische Sonderkonditionen zu vergeben.
(vgl. Kapitel " Zusatzmodul SK".

6.11 Sonderkonditionen verwalten

(Kunden-, Kundengruppen-, Artikel-/Artikelgruppenkonditionen)

In diesem Programmmodul werden die Daten für die Preisermittlung hinterlegt und verwaltet

Spezifiziert werden können dabei

- Artikeleinzelpreise
- Rabatte auf Einzelpreise

- Rabatte für Kundengruppen
- Rabatte für Artikelgruppen
- Zugehörigkeit zu Preisgruppen

- Zugehörigkeit zu Artikelgruppen

- Preisgültigkeit von-bis

Konditionen für Kunden-/Aktionen
(diese Daten unter "Verwalten Kunden/Aktionsstammdaten erfasst werden")

Konditionen für Kundengruppen

Konditionen für einzelne Artikel und Artikelgruppen

Anwendungsbeispiel: Sie haben Ihre Kunden nach getätigten Umsätzen von 1 bis 10 (oder von 001 bis 010, das Datenfeld ist alphanumerisch) klassifiziert.

Nun möchten Sie der Kundengruppe 001 einen Rabatt auf eine Artikelgruppe von 12 % geben.

Hierzu müssen Sie erst die Einstellung "Kundengruppe" (Maske unten links) aktivieren. Als nächstes erfassen Sie die entsprechende Kundengruppe, mittels Doppelklick auf das Eingabefeld Kundengruppe bzw Klick auf die nebenstehende Schaltfläche mit den drei Punkten.
Es öffnet sich eine Tabelle in der Sie die entsprechende(n) Kundengruppe(n) erfassen können

Anschließend das Fenster schließen und die Konditionen erfassen

In dem unten abgebildeten Beispiel geben wir der Kundengruppe 001 alle Artikel, die zur Artikelgruppe 100 gehören einen Rabatt von 15 Prozent. Außerdem bekommt die gleiche Kundengruppe den Artikel "51633M" für einen Sonderpreis von 23,- Euro. Beide Aktionen sind befristet auf den Zeitraum vom 1.9.2008 bis 30.9.2008.

· Die Feldinhalte und ihre Wirkungsweise:

·

SK-Art AG=Artikelgruppe Sonderkondition wirkt auf Artikelgruppe

AR=Artikel Sonderkondition wirkt auf Artikelnummer

Nummer abhängig von SK-Art Artikelnummer oder Artikelgruppe

Preis Sonderpreis

Rabatt Rabattsatz

PrGr Preisgruppe spezifiziert Basispreis aus Artikelstamm (1 bis 5)

Gültig ab erster Tag der Gültigkeit der Sonderkondition

Gültig bis letzter Tag der Gültigkeit der Sonderkondition

Bezeichnung1 Text/Bezeichnung bei Anlage wird Artikel- bzw. Artikelgruppenbezeichnung eingestellt

6.12 Hersteller und Lieferanten verwalten

In der unten abgebildeten Maske besteht die Möglichkeit Lieferanten manuell zu erfassen und zu pflegen.

Zur Verfügung stehen die folgende Datenfelder: Name1, Name2, Name3, Straße, Postleitzahl und Ort.

Die Möglichkeit einer Übernahme aus einer Schnittstellendatei (evtl. aus Ihrer Vertriebssoftware) besteht über den Button "Datenimport".
Hierbei geht das System von einer Datei im CSV-Format (Felder mit Semikolon getrennt) mit einer festen Satzbeschreibung aus. Diese können Sie der unten dargestellten Abbildung entnehmen.

7 Auftragswesen

Erstellen Sie Angebote mit und ohne bebilderte Datenblätter. Drucken Sie zusätzlich personalisierte Lieferscheine, Rechnungen und Briefe.

Achtung: Angebote werden als jeweils eine Kataloggruppe erfasst. Wir empfehlen dafür einen Pseudokatalog, der alle Angebote (oder alle Angebote eines Kunden) beinhaltet anzulegen.

7.1 Erfassen der Auftrags-/Angebotskopfdaten

Nach Aufruf der Funktion Auftragswesen (Hauptmenü) öffnet sich das Fenster zum Erfassen der Auftragskopfkopfdaten

Klick auf Button Neu erzeugt Kataloggruppe mit der Kennung "ANG" für Angebot

Neues Angebot:

Button Neu, hinterlegte Basisdaten werden angezeigt (Betreff, Zahlungsziel, -- Lieferbedingungen usw.) und können abgeändert werden.

Eingabe der Kundennummer oder Zugriff auf Kunde über Kundenauswahlmaske.

Die Kundendaten werden aus dem Kundenstamm eingeblendet.

-Erfassen der Angebotspositionen

Mit "Klick" auf die Taste "V" werden die Kopfdaten als Standardvorgaben für künftige Angebote gespeichert.

Ändern Angebot:

Eingabe der Angebotsnummer (oben links) oder mit Auswahl

7.2 Erfassen der Auftrags-/Angebots-Positionen

Das Erfassen der Auftrags-/Angebotspositionen erfolgt analog der Positionserfassung bei der Katalogerstellung in jeweils eine Kataloggruppe je Angebot.

Details zu Positionserfassung und Artikelauswahl finden Sie unter Katalogerstellung,

7.3 Drucken von Angeboten, Lieferscheinen und Datenblättern

Die so erfassten Daten können als Angebot, Lieferschein, Rechnung oder Datenblatt gedruckt werden.

Wählen Sie die gewünschte Funktion.

7.4 Anpassen des Designs von Angeboten, Lieferscheinen, Datenblättern und Briefen

Die mit dem Programm bei der Installation mitgelieferten Designs für Angebote, Lieferscheine, Rechnungen, Datenblätter und Briefe können Sie entsprechend Ihren Vorstellungen anpassen.

Wählen Sie die gewünschte Funktion und "Klicken" Sie auf den Button 'D'. Es öffnet sich das entsprechende Formular im Berichts-/Katalogdesigner.

Die Beschreibung des Katalogdesigners finden Sie im Kapitel 'Der Katalogdesigner".

7.5 Briefe erstellen und drucken

Wählen Sie den gewünschten zu druckenden "Brief".

Drei Standardbriefe (Brief1, Brief2, Brief3) sind direkt anwählbar. Beliebig viele weitere Briefe sind im System zu hinterlegen und können abgerufen werden.

Klick auf Anzeigen oder Drucken zeigt den vorgewählten Text im "Textfenster"

8 Menü Daten-Import/Export

8.1 Datenimport aus CSV-Datei

Mit Auswahl dieses Menüpunktes startet der Datenimport. Details dazu finden Sie unter "Der Datenimport".

8.2 Datenexport

8.2.1 Export Katalogdaten

Die Katalogdaten können in verschiedenen Datenformaten für die Weiterverarbeitung in anderen Programmen exportiert werden.

Funktion "Katalog Exportieren " (Hauptmenü à Extras à Datenexport à Export Katalogdaten)
Es öffnet sich das abgebildete Vorlauf-Fenster.
· Folgende Selektionen sind möglich:

·
Auswahl der Kataloggruppe: von/bis
Festlegung des Ausgabeformates: ASCII CSV, ASCII SDF, MS-EXCEL 5
Sortierfolge der Ausgabe: Kataloggruppen /-positionen oder Artikelnummer

· Funktion der Schaltflächen am unteren Maskenbereich:

P: öffnet ein Fenster in der die auszuspielenden Datenfelder und deren Reihefolge definiert werden können (Feldname mit Komma getrennt)

Anzeigen: zeigt eine Vorschau, der auszuspielenden Daten.
Ausführen Es öffnet sich das Standard-Fenster "Speichern unter".
Beenden: Zurück zum Hauptprogramm, keine Aktion

Es werden nur Katalogdatensätze exportiert, wenn der betreffende Artikel in der Artikeldatei vorhanden ist.

8.2.2 Export Artikeldaten

Die Daten des Inhaltsregisters des aktuellen Kataloges können in verschiedenen Datenformaten für die Weiterverarbeitung in anderen Programmen exportiert werden.

Zu beachten hierbei ist, dass es sich bei diesen Registerdaten um eine temporär erstellte Datei handelt, welche nur korrekt mit Inhalten gefüllt ist, wenn der komplette Katalog vorher erstellt (gedruckt bzw. mit der Funktion "Anzeige" bis zur letzten Seite angesehen d. h. aufgebaut wurde).

Funktion "Katalog Exportieren " (Hauptmenü à Extras à Datenexport à Export Artikel aus Katalog)
Es öffnet sich das abgebildete Vorlauf-Fenster.
· Folgende Selektionen sind möglich:

Festlegung des Ausgabeformates: ASCII CSV, ASCII SDF, MS-EXCEL 5
Sortierfolge der Ausgabe: Artikelnummer oder Matchcode

· Funktion der Schaltflächen am unteren Maskenbereich:

P: öffnet die Definition der auszuspielenden Datenfelder.
Anzeigen: zeigt eine Vorschau, der auszuspielenden Daten.
Ausführen Es öffnet sich das Standard-Fenster "Speichern unter".
Beenden: Zurück zum Hauptprogramm, keine Aktion

8.2.3 Export Registerdaten

Die Daten des Inhaltsregisters des aktuellen Kataloges können in verschiedenen Datenformaten für die Weiterverarbeitung in anderen Programmen exportiert werden.

Zu beachten hierbei ist, dass es sich bei diesen Registerdaten um eine temporär erstellte Datei handelt, welche nur korrekt mit Inhalten gefüllt ist, wenn der komplette Katalog vorher erstellt (gedruckt bzw. mit der Funktion "Anzeige" bis zur letzten Seite angesehen d. h. aufgebaut wurde).

Funktion "Katalog Exportieren " (Hauptmenü à Extras à Datenexport à Export der Registerdaten)
Es öffnet sich das abgebildete Vorlauf-Fenster.
· Folgende Selektionen sind möglich:

· Auswahl der Registerart, (Standard, Artikel, Kategorien)
Festlegung des Ausgabeformates: ASCII CSV, ASCII SDF, MS-EXCEL 5
Sortierfolge der Ausgabe: Artikelnummer/Bezeichnung oder Katalogseite.

·

· Funktion der Schaltflächen am unteren Maskenbereich:

P: öffnet die Definition der auszuspielenden Datenfelder.
Anzeigen: zeigt eine Vorschau, der auszuspielenden Daten.
Ausführen Es öffnet sich das Standard-Fenster "Speichern unter".
Beenden: Zurück zum Hauptprogramm, keine Aktion

8.2.4 BMEcat Export (Option, nicht im Standard) – Auf Anfrage

Die Katalogdaten werden im Format BMECAT bereitgestellt

8.3 Katalogdaten-Transfer

8.3.1 Katalog-Transfer – Daten bereitstellen

Mit Auswahl dieses Menüpunktes können die kompletten Katalogdaten des aktuell im Zugriff befindlichen Kataloges an einen anderen Speicherort kopiert werden.
Sinnvoll ist diese Funktion, wenn Sie an Ihrem Katalog an einem anderen Ort weiterarbeiten möchten, und diesen mit einem externen Datenträger (z.B. USB-Stick) transferieren möchten.

- Im ersten Schritt wählen Sie einen Speicherort für die Katalogdaten.

- Danach wird der Katalog auf den ausgewählten Datenträger in das ausgewählte Verzeichnis kopiert.

- Anschließend werden Sie noch gefragt, ob auch die Bilder (Bilddateien) des Kataloges sowie die entsprechende Artikeldatei kopiert werden sollen.

-

8.3.2 Katalog-Transfer – Daten übernehmen

Mit Auswahl dieses Menüpunktes können die kompletten Katalogdaten, die Sie vorher von einem anderen Ort gesichert haben in die aktuelle Katgen-Sitzung übernommen werden.
Diese Funktion ist sozusagen das Gegenstück zum oben beschriebenen Menüpunkt "Daten bereitstellen".

8.4 Datenimport aus Shopdaten

Mit Auswahl dieses Menüpunktes startet der Datenimport aus einem Internetshop.

Hinterlegen der Parameter für den File-Transfer

öffnet FTP-batch

8.5 Daten für Internetshop (Option, nicht in der Basislösung)

8.5.1 Daten für Internetshop (Option, nicht in der Basislösung)

Katalogdaten für den Internetshop aufbereiten und Versenden

· KL-KatGen verfügt bereits standardmäßig über die Möglichkeit Daten für einen Internetshop aufzubereiten, diese automatisiert zu versenden und diese mit einem von KL-systems bereitgestellten Script in den Shop zu übertragen. Als Shopsystem ist die Open-Source Version von OS-Commerce vorgegeben. Schnittstellen zu anderen Shop-systemen können auf Anfrage realisiert werden..

· Datenaufbereitung und Versand für Internetshop

Die vorbereitende Parametrisierung (vgl. folgende Abbildung) können Sie im Menüpunkt "Programmverwaltung"à "Daten für Internet-Shop" vornehmen.
Die Datenaufbereitung und der Versand erfolgt unter dem Menüpunkt "Extras" à "Daten für Inetshop" bzw. durch "Ausführen" im oben genannten Menüpunkt

· Parameter für den Datentransfer zum Internetshop

Mit Klick auf die Taste "Ausführen" werden die Daten aufbereitet und zum Shop übertragen.

Mit einem von KL-systems bereitgestellten Script werden die Daten in den Shop eingelesen.

(Löschen der "alten" Shop-Daten, Import der "neuen" Daten).

8.5.2 Datenimport aus Internetshop (FTP) (Option, nicht in der Basislösung)

Strukturverwaltung für Datenimport aus Internet-Shopsystem (optional)

Aufgrund der uneinheitlichen Datenstrukturen der unterschiedlichen Shopanbieter sind die Strukturdefinition entsprechend anzupassen.

Weitere Details auf Anfrage.

9 Menü Programmverwaltung

Unter dem Menü-Punkt Programmverwaltung sind die firmenspezifischen, programmsteuernden Funktionen aufzurufen und zu verwalten. Ein Teil dieser Funktionen ist bereits in den Kapiteln zuvor beschrieben worden.

Da sich Korrekturen dieser Daten entscheidend auf Programmablauf und Verarbeitung auswirken können, sollten Änderungen nur mit größter Sorgfalt durchgeführt werden. Insbesondere gilt dies für die aufgeführten Sonderfunktionen, die nur für spezielle Anwendungen genutzt werden sollten.

Es ist daher zu empfehlen, über die Passcode-Steuerung diesen Menüpunkt nur für entsprechend qualifizierte Mitarbeiter frei zu schalten ("VIP-Modus").

9.1 Firmenstamm-Verwaltung

In der Firmenstamm-Verwaltung ist die Firmenanschrift zu hinterlegen.

Eventuelle firmenspezifische Programmsteuerungen werden über das Firmen-Kennzeichen gesteuert (optional nur bei individuellen Programm-Anpassungen).

Unter der Überschrift "Kopfzeilen / Überschriften für Katalog / Preislisten" sind die Firmen-Bezeichnung, ein Kurz-Werbetext und die Zuordnung eines Firmen-Logos zu erfassen, die sowohl im Startfenster erscheinen, als auch in den Kopfzeilen des Kataloges angedruckt werden können (z.B. im Standard-Design "FORMULAR01").

Achtung !!!

Nach der Lizenzierung des Programms muss nach einer Änderung der anzuzeigenden Firmenbezeichnung das Programm erneut durch KL-systems freigeschaltet werden.

9.2 Lizenznummer

In der "Demoversion" ist die Nutzung von KL-KatGen auf 30 Tage begrenzt. Auch ist das Drucken von Katalogen deaktiviert. Nach Erwerb einer Vollversion ist die persönliche Lizenznummer für die uneingeschränkte Nutzung hier zu erfassen.

9.3 Passcode-Verwaltung

Hinterlegen Sie hier den Mitarbeiternamen, den dazugehörenden User-Namen mit dem entsprechenden Passcode.

Mit der Kennzeichnung "VIP-Modus" legen Sie die Berechtigung des Mitarbeiters fest, d.h. es steht ihm das vollständige Menü zur Verfügung.

9.4 Pfad Bilddateien

KL-KatGen erwartet anzuzeigende bzw. zu druckende Dateien in einem Verzeichnis. Vorgabe für das Dateiverzeichnis der Bilddateien ist im Arbeitsverzeichnis das Unterverzeichnis "IMAGES1".

Gegebenenfalls kann hier ein anderes Verzeichnis bestimmt werden.

9.5 Programmsteuerung

Hier werden grundlegende Programmparameter wie das Dezimalzeichen und der Tausenderseparator bei numerischen Feldern (Komma oder Punkt), das Datumsformat (GERMAN mit Jahrhundertdarstellung) oder die Sortierfolge (relevant bei Registern, um Begriffe mit Umlauten in der richtigen Reihenfolge darzustellen) hinterlegt.

Weitere Details können Sie der folgenden Abbildung entnehmen.

Bei weiteren, Individuelle Fragen kontaktieren Sie bitte die KL-KatGen Hotline.

9.6 Verwalten Darstellungsarten

Passend zu den mitgelieferten Beispielen (Katalogdaten, Designs, Artikel), wurden bereits verschiedene Darstellungsarten definiert und hinterlegt. Mit Ausnahme der "Vordefinierten Darstellungsarten mit integrierten Funktionen" handelt es sich bei der Definition einer Darstellungsart lediglich um einen frei zu vergebenden, vierstelligen, vorerst funktionslosen Schlüssel / Begriff. Im Berichtsdesigner wird dieser Schlüssel, wie zuvor beschrieben, als steuerndes Element genutzt, indem einzelne Objekte nur bei Übereinstimmung der Darstellungsart (z.B. "01S6" ) gedruckt werden.

In der hier abgebildeten Maske können Sie eigene Darstellungsarten definieren bzw. weitere Darstellungsarten aus den mitgelieferten auswählen und in Ihre Favoritenliste vgl "Auswahl von Darstellungsarten anhand schematischer Darstellung". zur schnelleren Zuweisung in Kataloggruppen übernehmen.

Durch Klick auf den Button mit den drei Punkten öffnet sich das unten angezeigte Fenster mit der schematschen Darstellung der vorgefertigten Darstellungsarten. Durch Doppelklick bzw. "Übernehmen" können Sie hier einzelne Darstellungsarten zu den Favoriten in die zuvor abgebildete Auswahlmaske übernehmen.

9.6.1 Auswahl von Darstellungsarten anhand schematischer Darstellung

(Ihre Favoritenliste)

Diese Maske erscheint, wenn Sie in der Hauptmaske auf Darstellungsartenauswahl (Button mit drei Punkten) klicken. Hier können Sie Ihre vorwiegend benutzten Darstellungsarten schematisch dargestellt sehen und diese durch Doppelklick oder "Übernehmen" in die aktuelle Kataloggruppe übernehmen.

Bedienung:

Pfeiltasten nächstes/voriges Bild

Pfeiltasten (weitere) nächste/vorige Seite (falls vorhanden)

Doppelpfeile erste Seite, letzte Seite

Z-Button aktuelle Darstellung wird gezoomt

V-Button Maskengröße auf Standard setzen

Übernehmen Button aktuelle Darstellung wird in Kataloggruppe übernommen.

Rechte Maustaste Darstellung kann aus Favoriten gelöscht werden

9.6.2 Eigene Darstellungsarten

Selbstverständlich können diese Darstellungsarten individuell angepasst und neue entsprechend den Bedürfnissen entwickelt (abgeleitet) werden. Bei Darstellungsarten mit integrierten Funktionen sind jedoch die vorgegebenen Formate zu beachten.

Beispiel: Das gewünschte Bildformat ist kleiner als das von uns vorgegebene und/oder der Langtext ist kürzer. Sie benötigen daher normalerweise maximal 2-Positionen neben dem Kataloggruppenbild, dann können Sie dazu aus der Darstellungsart "06N0" die Darstellungsart "02N0" ableiten, indem Sie das Bildobjekt verkleinern und die Feldobjekte (neben dem Bild) für die Zeilen 3 bis 6 entfernen und die "Druckbedingung" auf die "neue" Darstellungsart korrigieren.

Um eigene, neue Darstellungsarten, in dem Auswahlfenster anzeigen und auswählen zu können, "Klicken" Sie mit der "Rechten-Maus-Taste" in das Feld "Darstellungsart". In dem Fenster "Verwalten Darstellungsarten" können Sie den gewünschten Begriff (Darstellungsart) und eine kurze passende Erläuterung hinterlegen, indem Sie eine n neue Definition erfassen bzw. eine vorhandene Definition abändern und danach speichern.

9.7 Verwalten Spalten-Anzeige

Die Anzeige der Kataloggruppen-Positionen in der Arbeitsansicht (die Spaltenbreite, Reihefolge mit den dazu gehörenden Überschriften) kann für jede Kataloggruppe individuell angepasst werden. Dazu sind entsprechende Spaltensteuerungen zu definieren und der jeweiligen Kataloggruppe zuzuordnen. Gleichzeitig können dabei auch die Überschriften / Feldbezeichnungen für den Katalogdruck hinterlegt werden. Es können beliebig viele Spaltensteuerungen definiert werden. In der Basisversion werden vier Beispiele mitgeliefert.

9.7.1 Erfassen / Verwalten einer Spaltenanzeige

Zum Erfassen / Verwalten der Spalten-Anzeige öffnen Sie mit Klicken auf das Menü Programmverwaltung à Verwalten Spalten-Anzeige (siehe Abbildung) nachfolgendes Fenster:

Schieben Sie die geöffnete Maske an den Bildschirmrand.

Wir empfehlen zuerst eine eigene Standardsteuerung zu definieren, mit der Einstellung die am häufigsten vorkommen wird, und danach je nach Bedarf weitere Abwandlungen zu erstellen.

Um einen eigenen Standard zu definieren wählen Sie die Spaltensteuerung "Leer", also das Feld Spaltensteuerung sollte leer sein. Im Zweifelsfall gelangen Sie durch Blättern nach vorne (Navigationstaste mit Doppelpfeil nach links) auf diese Spaltensteuerung.

1. Bringen Sie nun in der Arbeitsansicht (der Grundmaske, Abbildung unten) die Spalten der Katalogpositionen in die gewünschte Reihenfolge. "Klicken" Sie dazu auf die entsprechende Spaltenüberschrift (diese verfärbt sich schwarz) und ziehen diese mit gedrückter Maus-Taste an die gewünschte Position.

2. Erfassen Sie nun im Fenster "Verwalten Spalten Anzeige" (Abbildung zuvor) auf der linke Seite die in der Grundmaske für die einzelnen Spalten gewünschten Überschriften und die anzuzeigende Anzahl Nachkommastellen (NK).

"Klicken" Sie mit der Maus auf die Trennlinien in der Kopfzeile der Spalten und ziehen Sie diese mit gedrückter Maus-Taste auf die gewünschten Spaltenbreiten.

3. Auf der rechten Seite können Sie Überschriften / Bezeichnungen für den Katalogdruck. hinterlegen.

Dies kann zum Beispiel hilfreich sein, wenn Sie viele variable Preisstaffeln in einem Katalogdesign verwenden möchten. Sie können mittels variabler Spaltenhinterlegung den Preisfeldern je nach Spaltensteuerung unterschiedliche Staffelpreise in dem selben Preisfeld (und der gleichen Katalogposition) zuordnen).

Spaltensteuerung SP1: Preis per Stück, Preis ab 10 Stück, Preis ab 25 Stück, Preis ab 50 Stück usw.

Spaltensteuerung SP2: Preis per Stück, Preis ab 6 Stück, Preis ab 12 Stück, Preis ab 24 Stück usw.

Spaltensteuerung SP3: Preis per Stück, Preis ab 100 Stück, Preis ab 250 Stück, Preis ab 500 Stück usw.

Den Variablennamen, mit dem die Spaltenüberschrift im Berichtsdesigner angesprochen wird, entspricht der Bezeichnung der Erfassungsmaske (spB1,spB2 usw.),.

4. Haben Sie diese "designerischen" Maßnahmen nach Ihrer Zufriedenheit abgeschlossen, klicken Sie in der (noch geöffneten) Maske "Verwalten Spalten-Anzeige" auf den Button "Speichern". Das System merkt sich diese Steuerung und fragt, ob dies auch der aktuellen Kataloggruppe zugewiesen werden soll.

ACHTUNG: Das Ändern einer Spaltensteuerung bewirkt, dass alle Kataloggruppen denen diese Steuerung zugeordnet war, entsprechend der neuen Darstellung angezeigt werden und ggflls. auch geänderte Überschriften bei diesen Kataloggruppen gedruckt werden.

9.7.2 Zuweisen einer Spaltensteuerung

Die Anzeige der Kataloggruppen-Positionen in der Arbeitsansicht (die Spaltenbreite, Reihenfolge mit den dazu gehörenden Überschriften) kann für jede Kataloggruppe individuell angepasst werden. Gleichzeitig können so auch die Überschriften / Feldbezeichnungen für den Katalogdruck zugeordnet werden. Dazu sind die entsprechenden Spaltensteuerungen zu definieren (siehe Abschnitt zuvor).

Um die entsprechende Darstellung den einzelnen Kataloggruppen für die Anzeige in der Grundmaske und für die Spaltenüberschriften/Bezeichnungen beim Druck zuzuordnen, klicken Sie in der Grundmaske im Segment Spaltensteuerung auf den Button "Übernehmen".

Wählen Sie durch Eingabe der "Spaltensteuerungsnummer/Bezeichnung" oder durch "Blättern" die gewünschte Spaltensteuerung und ordnen Sie dies durch "Klick" auf die "Übernahme-Taste" der entsprechenden Kataloggruppe zu.

Wir empfehlen zuerst eine eigene Standardsteuerung zu definieren und danach je nach Bedarf weitere Abwandlungen zu erstellen.

Um einen eigenen Standard zu definieren, wählen Sie die Spaltensteuerung Leer, also das Feld Spaltensteuerung muss leer sein. Im Zweifelsfall gelangen Sie durch Blättern nach vorne (Navigationstaste mit Doppelpfeil nach links) auf diese Spaltensteuerung.

9.8 Verwalten Steuerung Katalog-Gruppen-Nummern

Unter diesem Menüpunkt ersehen Sie die zuletzt vom Programm vergebene laufendende Katalog-Gruppen-Nummer.

Die Katalog-Gruppen-Nummer kann sowohl manuell, als auch vom System automatisiert vergeben werden.

Sie ist maximal 12 Stellen lang und alphanumerisch.

Bei der automatisierten Nummernvergabe kann der sechsstellige Zähler (hier rot dargestellt "000050") durch vorlaufende drei und nachfolgende drei Stellen ergänzt werden, z.B. ABC123456-10

Wir empfehlen, insbesondere bei der automatischen Kataloggruppenerstellung, die beiden letzten Stellen numerisch zu verwenden (siehe dazu auch "Verwenden importierter Artikeldaten für die Katalogerstellung").

Zur automatisierten Nummernvergabe ist das entsprechende Feld zu markieren (Voreinstellung).

Für ein schnelles manuelles Erfassen von Kataloggruppen positioniert KL-KatGen sofort in den Artikel-Positionsbereich der Arbeitsansicht, soll zuvor die Kataloggruppennummer manuell modifiziert werden, so ist die Option "Positionieren auf Katalog-Gruppen-Nummer" zu aktivieren.

9.9 Verwalten Textbausteine

Textbausteine können beliebig in den Reports integriert werden.

Dazu ist ein Textobjekt mit der Funktion 'textbaustein("xxxxx")' (xxx=Name des Bausteins) im Report an die gewünschte Stelle zu hinterlegen.

Neuanlage von Briefen

Klick-Neu -> Erfassen der Kurzbezeichnung (unten links)

Danach Textbezeichnung (für Auswahl) und Brieftext.

Das Briefdesign kann in der Grundmaske des Auftragswesens angepasst werden.

( 3 unterschiedliche Designs = Brief1,2,3 sind möglich)

Erste Zeile = Betreff

Mit "Klick" auf die "Browse-Taste" erhalten Sie die Übersicht der verfügbaren Texte. Dort können neue Kopfzeilen für weitere Texte hinterlegt und anschließend erfasst werden.
9.10 Verwalten Textvariable

Sie haben die Möglichkeit beliebige viele, unabhängige Texte / Textbausteine, d.h. Texte, die nicht an Artikel oder Überschriften gebunden sind im Katalog zu drucken. In der Regel wird diese Funktion auf Deck- oder Zwischenblättern genutzt.

Im Katalogdesigner werden solche Texte mit der Funktion textholen("xxx") , wobei "xxx" die Kennung des Textes ist, abgerufen.

Erfasst werden solche Texte mit der hier beschriebenen Programmfunktion.

Der Aufruf erfolgt im Hauptmenü unter "Programmverwaltung" à "Verwalten Textvariable".

Zur Identifizierung ist vor der Textkennung (max. 12 Buchstaben oder Zahlen) die Buchstabenfolge "txt" zu erfassen.

Beachten Sie, dass die Textkennung bei der Ansteuerung im Katalogdesigner mit der Textkennung bei dem erfassten Baustein übereinstimmen muss (Groß-/Kleinschreibung beachten!).

Z.B. Der Name des Textes soll "unseruntn" sein.

Erfasst wird dieser Text in der abgebildeten Erfassungsmaske mit dem Schlüssel "txt unseruntn ".

Der Aufruf im Designer erfolgt mit der Funktion textholen("unseruntn ").

(Im Designer à Hauptmenü à Berichtssteuerelemente à Feld Typ "Feld" à Ausdruck
textholen("unseruntn"). Für Textnamen können auch numerische Werte genutzt werden z.B "txt001" à Aufruf mit textholen("001").

9.11 Verwalten Textkonvertierung

Der Text-/Importkonverter ermöglicht beim Datenimport Texte und Daten der Importdatei vor Übernahme in die Katalogdaten bzw. Artikelstammdaten zu verändern.

Lesen Sie hierzu im Kapitel "Datenimport" die Rubrik "Importkonverter"

9.12 Steuerung kein Wiederholdruck

Um zu verhindern dass gleiche Inhalte (z.B. gleiche Artikel-Bezeichnungen) im Detailbereich mehrfach gedruckt werden, kann die Funktion "keinwdhdruck" genutzt werden.

Hierzu muss im Detailbereich (grauer Balken, in der Option "bei Ende" der Eintrag 'keinwdhdruck()' gemacht werden.

Die entsprechende Definition wird im Menü "Programmverwaltung" unter dem Menüpunkt "Kein Wiederholdruck" angelegt.

In diesem Satz muss eine Hilfsvariable definiert werden.

Beispiel Numerisch public Preis1_vgl

defn Preis1_vgl

Preis1_vgl=preisarti.vkbasis

(Verhindert Andruck gleicher Preise in einer Kataloggruppe)

Beispiel Alphanum. public Artbez1_vgl

defa Artbez1_vgl

Artbez1_vgl=Preisarti.Artbezkat

(Verhindert Andruck gleicher Bezeichnungen in einer Kataloggruppe)

Im Designer, im anzudruckenden Objekt (in unserem Beispiel Preisarti.Artbez1) ist bei "Nur Drucken wenn Ausdruck wahr" folgendes zu definieren: preisarti.artbez1 <> Artbez1_vgl

9.13 Steuerung doch Wiederholdruck

Wenn Sie bei der Unterdrückung gleicher Inhalte (vgl. vorheriges Kapitel) bei bestimmten Konstellationen diese doch angedruckt haben möchten, kann die Funktion "dochwdhdruck" genutzt werden.
Eine solche Konstellation ist beispielsweise gegeben, wenn eine Kataloggruppe sich auf einer neuen Seite fortsetzt. Dann ist es sinnvoll, wenn auch gleiche Bezeichnungen auf der Folgeseite noch einmal angedruckt werden.

Hierzu muss im entsprechenden Designbereich (Seitenkopf, grauer Balken, in der Option "bei Ende" der Eintrag 'dochwdhdruck()' gemacht werden.

Die entsprechende Definition wird im Menü "Programmverwaltung" unter dem Menüpunkt "Doch Wiederholdruck" angelegt.

In diesem Satz wird die Hilfsvariable, die im Satz "keinwdhdruck" definiert wurde, gewissermaßen geleert bzw. mit einem Phantasiewert belegt (hier 999999999,99 bzw. "xxx")..

Beispiel Numerisch Preis1_vgl=999999999,99

Beispiel Alphanum. Artbez1_vgl="xxx"

9.14 Verwalten Label-Zusatztexte

In diesem Programmzweig ist es möglich die Bezeichnungen der Zusatztextfelder von Kataloggruppen zu erfassen und zu verändern. Weitere Details hierzu finden Sie im Kapitel " Kataloggruppen-Zusatzdaten".

9.15 Datenreorganisation

Zur Optimierung des Laufzeitverhaltens und zur Minimierung des Platzbedarfs, insbesondere nach größeren Änderungen an den Katalogen, empfehlen wir eine Reorganisation der Datenbestände.

Achtung !!!
Nach Durchführung muss das Programm beendet werden.

9.16 Verwalten Parameterdatei

Achtung !!!

Sonderfunktion, nur für spezielle Anwendungen.

Mit dieser Programmfunktion können die Daten der Programm-Parameterdatei angezeigt und verändert werden.

Änderungen der Parameterdaten können sich entscheidend auf Programmablauf und Verarbeitung auswirken.

Sie sollten daher nur mit größter Sorgfalt und durch entsprechend qualifizierte Mitarbeiter durchgeführt werden.

9.17 Standard-Designs wieder herstellen

Mit dieser Funktion werden die folgenden Standard-Designs der Programmauslieferung wieder aktiviert:

Katalog standard01

Deckblatt deckstandard

Rückblatt rueckstandard

Register regstandard

9.18 Anzeige Programminformation

Über diesen Menüpunkt erfahren Sie alles über Ihre Version und die Installation von KL-Katgen.

Angezeigt werden folgenden Informationen:

· Programmversion

· Programmnummer

· Installation, Installationsdatum

· Registriername

· Lizenznummer

· Lizenz-Zusatzmodule

· Zusatzlizenzen

· Maximale Positionen je Katalog

· Freigeschaltete Programmzusatzmodule

10 Was ist neu in KL-Katgen11?

Auf den folgenden Seiten erhalten Sie kurz beschrieben die neuen Funktionen und Leistungsmerkmale von KL-Katgen Release 11.x.

Diese Beschreibung soll Ihnen dabei lediglich Hinweise dazu geben, welche wesentlichen Funktionen neu in das Programm aufgenommen und welche Ergänzungen und Verbesserungen integriert wurden. Viele Neuerungen insbesondere in den Datenstrukturen, wie Datenfelderweiterungen, neue Eingabefelder, modifizierte Programmabläufe usw. finden im Hintergrund statt und werden hier ebenso, wie Modifikationen der Programmmenüs und der Bildschirmmasken nicht tiefergehend erläutert.

Weiterführende Detailinformationen finden Sie dazu im Anwenderhandbuch und in der interaktiven Hilfe.

An dieser Stelle bedanken wir uns nochmals herzlichst bei unseren Kunden und Anwendern die uns viele konstruktive Ideen geliefert haben und hoffen auch für die Zukunft auf ihre aktive Unterstützung.

10.1 Neue Funktionen im Überblick.

Allgemeine Neuerungen:

KL-KatGen auf verschiedenen Rechnern nutzen
Blitzkatalog und weitere Hilfen
Der "Blitzkatalog"
Die neue Grundmaske
Die Bildautomatik
Label Feldbezeichner
Detailanzeige der Positionen erweitert
Artikelauswahl in der Artikelstammdatei
Artikel im Katalog suchen

Neue Funktionen zur manuellen Pflege der Katalogdaten:

- Artikel(daten) in den Positionen tauschen und löschen
- Aktions-/ Sonderpreiserfassung
- Kataloggruppen verschieben und reorganisieren
- Verwaltung Katalogsortierung nach Kataloggruppen
- Katalog-Gruppen Zusatztexte

Stammdatenverwaltung und -Listen

- Artikelstammverwaltung
- Artikelauswahl und Suche
- Artikellisten
- Kunden Aktionsstammverwaltung
- Verwalten Kundengruppen
- Verwalten Hersteller- /Lieferantenstamm

Darstellungsarten

- Spezielle Darstellungsarten für Seiten- und Zwischenüberschriften

- Auswahl von Darstellungsarten

- Katalogstruktur mit Kategoriebaum verwalten

Daten Import / Export

- Anzeige und automatische Korrektur der Importdaten beim Import

- Daten-Export

- Export von Katalogdaten

- Export Artikeldaten

- Export Registerdaten

- Katalogdatentransfer

Auftragswesen

Datenimport aus Shopdateien

10.2 KL-KatGen mit Dongle auf verschiedenen Computern nutzen

KL-KatGen11 ist in Verbindung mit einem USB-Dongle zu nutzen. Damit kann das Programm auf beliebig vielen Rechnern, die zu einem Unternehmen gehören, installiert und in Verbindung mit dem mitgelieferten USB-Dongle betrieben werden.
Soll KL-Katgen auf mehreren Rechnern gleichzeitig genutzt werden, ist die entsprechende Anzahl Zusatzlizenzen (einschl. der Dongles) zu erwerben. Das Programm ist nicht mehrplatzfähig das heißt die Programme laufen dabei unabhängig mit jeweils eigenem Datenbestand.

10.3 Blitzkatalog und weitere Hilfen

Kataloge werden in der Regel nicht allzu oft erstellt und geändert. Arbeitsweise und Bedienung von KL-KatGen geraten daher schnell in Vergessenheit. Dies war uns Grund genug weitere Hilfestellungen in das Programm zu integrieren und diese auch mit den Funktionstasten F1 bis F6 abrufbar bereit zu stellen.

F1-Taste Standard interaktive Hilfe

F2-Taste Öffnet das Programm "Editor" zum einfachen Notieren und Anzeigen beliebiger Notizen.

F3 Bei individuellen Programmanpassung werden hier von uns beschriebene Programminformationen abrufbar (PDF-Datei) hinterlegt.

F4 Sofortanzeige des Anwenderhandbuchs (PDF-Datei)

F5 Auswahl und Anzeige beliebiger PDF-Dateien

F6 "Bitzkatalog" Vollautomatische Erstellung eines Kataloges aus einer
CSV-Importdatei bzw. aus der KL-KatGen Artikelstammdatei.

10.3.1 Der "Blitzkatalog"

Diese Funktion erlaubt es "per Knopfdruck" Kataloge vollautomatisch direkt aus einer
vorhandenen externen CSV-Datei oder aus der KL-KatGen eigenen Artikelstammdatei zu erzeugen.
Der Aufruf erfolgt mit der F6-Taste bzw. unter dem Menü-Punkt "Extras/Hilfe -> Blitzkatalog".

Wurde die Schnittstellenstruktur der Importdatei einmal definiert bzw. der von uns vorgegebene Aufbau gewählt, genügt zukünftig ein Knopfdruck auf die Taste "mit Drucken" und Sie erhalten den Ausdruck Ihres neuen Kataloges ohne weiteres Zutun.
Selbstverständlich müssen Sie dem Programm zuvor noch (einmalig) mitteilen woher die Daten kommen sollen. Genauer, aus welcher Importdatei diese zu übertragen sind und eventuell wie der "neue" Katalog heißen soll.

Wollen Sie dabei ein wenig hinter die "Kulissen" des Programms schauen, wählen Sie "Schritt für Schritt" und Sie können den Ablauf genau verfolgen.

10.3.2 Die neue Grundmaske

Mit der Maßgabe "Evolution statt Revolution" waren wir bemüht die "neue" Grundmaske nicht gravierend umzugestalten und dennoch die ein oder andere Funktion hier direkt zur Verfügung zu stellen. Zum Erhalt der Übersichtlichkeit und um die Kompatibilität zu früheren Programmversionen zu wahren wurden einzelne nicht so häufig genutzte Programmteile in das Hauptmenü verlagert.

Zu 1 Detailanzeige der Positionen

Zu 2 Artikel im Katalog suchen

Zu 3 Kataloggruppen verschieben und reorganisieren

Zu 4 Kataloggruppen Kategorien zuordnen

Zusatztexte Funktionen und Arbeitsweise geändert

Die Steuerfelder ST-Feld 1,2,3 jetzt hier in der Grundmaske

10.3.3 Label Feldbezeichner

Die in "Verwalten Spalten-Anzeige" zugewiesenen Label für die einzelnen Positionsspalten in der Grundmaske, werden nun auch in der Positionsdetailanzeige und in der Artikelstammdatenerfassung zur Benennung des entsprechenden Datenfeldes angezeigt.

Siehe nachfolgende Abbildung:
Feld "T1" wird für die "ACE-Nummer" genutzt, Feld "T2" für die "VE" (Verpackungseinheit)

Zu Punkt 1: Detailanzeige der Positionen erweitert

Mit "Klick" auf den entsprechenden Button erhalten Sie das obige Anzeige/Erfassungsfenster:

- Anzeige und Verwalten der einzelnen Katalog-Position im Detail (anstelle bzw. zusätzlich zum Positionsteil in der Grundmaske).

- Bis 5 Zusatztexte (Langtexte à 64.000 Zeichen)

- Wahlweise mit "Artikel-Update" Sofort Aktualisierung bzw. Neuanlage der Artikelstammdatei (d.h. Positionsdaten werden in den Artikelstammsatz übernommen).

D.h. Sie können Änderungen/Neuerfassungen direkt in den Katalogpositionen vornehmen und diese per Knopfdruck in die Artikelstammdatei übernehmen.
Welche Felder übertragen werden, ist unter "Menü --> Daten-Import --> Katalogdaten nach Artikelstamm übertragen" zu bestimmen.

10.3.4 Artikelauswahl in der Artikelstammdatei bei der Katalogdatenerfassung mit integrierter Stammdatenpflege

Erweiterte Filtersuchfunktion (Artikelstamm)

Suchen von Artikeln in der Artikelstammdatei und Übernahme in den Katalog

Integrierte Artikelstammpflege

Erlaubt nun auch die Artikelneuanlage, Änderung einzelner Datenfelder und das sofortige Löschen von Artikelsätzen aus der Artikelstammdatei.

Zu Punkt 2: Artikel im Katalog suchen Aufruf in der Grundmaske (s.o. Punkt 2)

- Volltextsuche in den markierten Datenfeldern der Katalogpositionen.

"Oder-Verknüpfung" Suchbegriff muss in einem der markierten Felder sein.

"Und-Verknüpfung" Suchbegriff muss in allen markierten Feldern sein.

Nach Eingabe des Suchbegriffs erfolgt die Volltextsuche in den markierten Feldern des Kataloges-
Positionsdatei. Die entsprechenden Positionen werden angezeigt. Mit "Klick" auf die "gefundene(n)" Katalogposition(en) im Anzeigefenster "springt" das Programm in der Grundmaske auf die entsprechende Kataloggruppe und Position

10.3.5 Die Bildautomatik

KL-KatGen erwartet anzuzeigende bzw. anzudruckende Bilder in einem Verzeichnis.

Für Bilder zu den Kataloggruppen oder Positionen z.B. im (Unter-)Verzeichnis "Images1" (soweit kein anderes zugewiesen wurde).

Bisher mussten dazu die Bilder manuell in das Verzeichnis kopiert oder verschoben werden, falls diese sich an anderen Verzeichnissen (Ordnern) auf dem Datenträger befanden.

Nun wird eine Kopie des jeweiligen Bildes nach Suche und Auswahl automatisch in das entsprechende (KL-KatGen-) Bildverzeichnis kopiert.

Weitere Informationen über die Einstellung des KL-Katgen Bildverzeichnisses lesen Sie im Kapitel "Pfad Bilddateien".

Achtung: Änderungen an dem Ursprungsbild werden nicht automatisch in das Bild im KL-KatGen- Bildverzeichnis übertragen.

10.4 Neue Funktionen zur manuellen Pflege der Katalogdaten:

- "Artikel in den Positionen tauschen und löschen"

- Verwalten Kataloggruppen (Übersicht)

10.4.1 Artikel(daten) in den Positionen tauschen und löschen

Mit "Klick" auf die entsprechende Funktionstaste erhalten Sie das obige Anzeige/Erfassungsfenster:

Mit Doppel-Klick im Feld Artikelnummer erfolgt die Auswahl des Artikelstammsatzes (im Artikel-Auswahlfenster) dessen Daten in die Katalogposition(en) zu übertragen ist (sind) bzw. die mit den Artikeldaten des (der) "mit Artikel" zu ersetzen Artikel(s) (sind).

Mit "Klick" auf "im Katalog löschen" werden die entsprechenden Katalogpositionen gelöscht.

10.4.2 Aktions-/ Sonderpreiserfassung

Bei der manuellen Positionserfassung und aktivem Fenster werden eventuell hinterlegte Sonderpreise berücksichtigt.
Die zu verwendenden Aktionspreise bzw. Kundenkonditionen können ausgewählt werden.

Zu 3 Kataloggruppen verschieben und reorganisieren

Mit "Klick" auf den Button ">Z<" (Zusatzfunktionen) öffnet sich ein Fenster mit Funktionstaten zum Kopieren, Ausschneiden, Einfügen und Löschen von einzelnen Kataloggruppen einschließlich der dazu gehörenden Positionen.

Mit "Klick" auf den Button "Verwalten" gelangt man in die Kataloggruppenverwaltung die Operationen mit mehreren Kataloggruppen gleichzeitig erlaubt (siehe nachfolgend).

10.4.3 Verwaltung Katalogsortierung nach Kataloggruppen

Die Reihenfolge der Kataloggruppen in einem bestehenden Katalog kann mit der Programmfunktion "Verwaltung Katalogsortierung nach Kataloggruppen" geändert werden.
Funktionsaufruf über Menü "Katalogverwaltung -> Verwalten Kataloggruppen(Übersicht)" oder mit der Funktionstaste "Z" in der Grundmaske -> "Verwalten" (siehe zuvor).

In dieser Funktion können Kataloggruppen ausgewählt, gelöscht, kopiert, eingefügt und neu "durchnummeriert" werden.

- Markieren der relevanten Kataloggruppen mit Tastenkombinationen (siehe Tooltips).

- Zum Verschieben: Positionieren Sie anschließend auf die Kataloggruppe nach der die gewählten Gruppen einzufügen sind und klicken Sie auf den Button "verschieben".
Die neue Position der Kataloggruppen wird dargestellt.

- Zum Löschen: Mit "Klick" auf den Button "Löschen" werden die gewählten Kataloggruppen gelöscht. Die neue Reihenfolge wird dargestellt.

Achtung: Erst nach "Klick" auf "Daten übernehmen" werden die Änderungen im Katalog durchgeführt.

10.4.4 Katalog-Gruppen Zusatztexte

Bis zu fünf Zusatztexte (jeweils bis 64.000 Zeichen) können für jede Kataloggruppe hinterlegt werden.
In der Fußleiste kann der gewünschte Text (Text1 bis 5) angewählt und geändert werden.

Gezeigt wird jeweils der (die) Text(e) der aktiven Kataloggruppe.
Sowohl in der Grundmaske als auch in dem oben dargestellten Zusatztextfenster können die Kataloggruppen gewechselt werden ("blättern").

10.4.4.1 Nutzungsvarianten der Zusatztexte

Je nach Anforderung können die Zusatztexte unterschiedlich genutzt werden:

- Zusatztext als ein durchgehender, editierbarer Text (Langtext):

Lange, unformatierte frei editierbare Texte (siehe Abbildung zuvor)

- Aufteilen des Zusatztextes in bis zu 20 Textzeilen bzw. Textblöcke mit den entsprechenden Labels (siehe nachfolgende Abbildung)

Dies erlaubt auf einfache Weise entsprechende Tabellen im Katalog zu drucken

Um die Labels für die entsprechenden Zeilen erfassen zu können, klicken Sie auf den "L' -Button.

Für eine schnellere Erfassung, insbesondere bei nachträglichen Korrekturen (z.B. Zeile einschieben) kann der Editiermodus mit Klick auf die "LS" = Labelerfassung und "TS" = Texterfassung Taste geändert werden. In den einzelnen Feldern (siehe Abbildung "gelb und rosa") können nun Zeilen eingefügt und gelöscht werden.

ACHTUNG:
Prüfen Sie durch Wechsel des Editiermodus, dass Bezeichnung und Daten übereinstimmen. Vergleichen Sie das Ergebnis insbesondere auch in Ihren bereits erstellen Reports

10.4.5 Kataloggruppenzusatztexte Kopieren

Sie können die Labels und die Zusatztexte einer Kataloggruppe in andere Kataloggruppen übertragen.

Klicken Sie dazu auf "Merken"

Das Programm übernimmt Texte und Labels in den Zwischenspeicher

Wählen Sie nun "Was Sie übertragen wollen"

- Nur den aktuellen Text (hier Text 1)

- Text1 mit den entsprechenden Labels

- Alle Texte (1-5)

- Alle Texte (1-5) mit den entsprechenden Labels

- Nur die Labels der aktuellen Kataloggruppe von Zusatztext 1

- Alle Labels (1-5) der aktuellen Kataloggruppe

Wählen Sie nun "Wohin Sie übertragen wollen"

- In eine bestimmte Kataloggruppe

Indem Sie in der Grundmaske oder in dem Kataloggruppenzusatztextfenster (hier) die gewünschte Kataloggruppe wählen (z.B. durch Blättern oder Anwahl)

In alle Kataloggruppen des Kataloges

Indem Sie auf die entsprechende Auswahltaste "Klicken"

10.4.6 Kataloggruppenzusatztexte und –Labels Löschen

Mit "Klick" auf den "Löschen Button" werden die gewählten Texte und Labels (siehe Kopieren) der entsprechenden Kataloggruppen gelöscht.

10.5 Stammdatenverwaltung und -Listen

10.5.1 Artikelstammverwaltung

10.5.2 Neue Artikelauswahl und Suche

Die Auswahl und Suche von Artikeln in der Artikelstammdatei ist im neuen Programm-Release erweitert.

Sowohl in der Stammdatenpflege als auch in der Katalogerfassung wurden zusätzliche Datenfelder für die Volltextsuche in der Artikelstammdatei aufgenommen.

10.5.3 Artikellisten

Die gewählten Artikel der Artikelstammdatei können entsprechend der erfassten Selektionsmerkmale in der "Anzeige" bzw. dem "Druck" nach Artikelnummer, Bezeichnung oder Artikelgruppen sortiert, einzeln oder summiert gelistet werden.

10.5.4 Kunden Aktionsstammverwaltung

KL-Katgen ermöglicht kundenspezifische Kataloge und Preislisten zu erstellen. Welche Artikel in dem Katalog erscheinen sollen und welche Preise hierbei angedruckt werden sollen, kann dabei automatisiert sowohl bei der automatisierten als auch bei der manuellen Erstellung selektiv erfolgen.

Die entsprechenden Informationen sind dazu in den erweiterten "Kunden/Aktionsstammdaten" zu hinterlegen (siehe auch Aktions-/Sonderpreiserfassung).

10.5.5 Verwalten Kundengruppen

Zur Erfassung/Auswahl von Kundengruppen kann das Fenster "Verwalten Kundengruppen" geöffnet werden.

10.5.6 Verwalten Sonderkonditionen

Kunden-/Aktionsspezifische Sonderkonditionen werden im Register2 der "Kunden-/Aktionsstammverwaltung" gepflegt.

10.5.7 Verwalten Hersteller- /Lieferantenstamm

10.5.8 Darstellungsarten

Spezielle Darstellungsarten für Seiten- und Zwischenüberschriften

Im Gegensatz zu der bisherigen Behandlung von Überschriften erlauben diese neu hinzugekommenen Darstellungsarten Überschriften automatisiert bereits beim Datenimport korrekt zu positionieren.
Dabei wird die entsprechende Überschrift in die Katalogdaten an der gewünschten Stelle als Kataloggruppe mit der Darstellungsart "SUEB" oder "ZUEB" eingefügt. Beim Drucken der "Überschriften" stehen somit alle Felder, entsprechend einer Datengruppe zur Verfügung.

SUEB Seitenüberschrift

Entspricht weitgehend einer "normalen" Kataloggruppe, d.h. alle Datenfelder der Kataloggruppe (z.B. "Katgruppe.bez1" usw.) stehen zur Verfügung und können im Designer entsprechend angesprochen werden.

ZUEB Zwischenüberschrift

Entspricht weitgehend einer "normalen" Kataloggruppe, d.h. alle Datenfelder der Kataloggruppe (z.B. "Katgruppe.bez1" usw.) stehen zur Verfügung und können im Designer entsprechend angesprochen werden.

10.5.9 Auswahl von Darstellungsarten

Mit "Rechts-Klick" auf den Auswahlbutton der Darstellungsarten werden die mitgelieferten gängigsten Darstellungsarten zur Auswahl grafisch dargestellt angezeigt. Nach Auswahl wird die gewählte Darstellungsart in die "Favoritenliste" (Favoriten des Anwenders) übernommen, die zukünftig mit "Normal/Links-Klick" angezeigt werden kann.

Neue zusätzliche (eigene) Darstellungsarten können unter dem Menüpunkt "Menü à Programmverwaltung -> Verwalten Darstellungsarten" erfasst werden.

10.5.10 Katalogstruktur mit Kategoriebaum verwalten

KL-KatGen ermöglicht es Ihnen, Kataloge entsprechend den Vorgaben, sortiert nach Kategorien automatisiert beim Datenimport zu erstellen.

Beim Drucken lassen sich mehrstufige Katalogregister nach Kategorien erzeugen. Die dazu notwendigen Informationen (Katalogstruktur) können automatisiert direkt mit den Importdaten erzeugt und / oder nachträglich in o.gen. Maske erfasst und verwaltet werden.
(d.h. der Artikel gehört zu einer Kategorie, diese zu einer übergeordneten Kategorie usw.) Zur Kontrolle kann der "Kategoriebaum" d.h. die Struktur gelistet werden.

10.5.11 Verwalten Textbausteine

Textbausteine können beliebig in den Reports integriert werden.

Dazu ist ein Textobjekt mit der Funktion 'textbaustein("xxxxx")' (xxx=Name des Bausteins) im Report an die gewünschte Stelle zu hinterlegen.

10.6 Daten Import / Export

Siehe dazu auch "Blitzkatalog"

10.6.1 Datenimport aus CSV

10.6.1.1 Katalogdaten Aktualisieren

Neu: Direktes Aktualisieren der Katalogdaten aus einer Importdatei oder aus der Artikelstammdatei

Zusatzfelder und deren Steuerung beim Import

unterdrücken identischer Bezeichnungen (bei mehreren Artikeln mit gleicher Bezeichnung)

Die Bezeichnung wird ggflls. im Kopfbereich (Kataloggruppe) um den variablen Teil der Artikelbezeichnung der Positionssätze gekürzt. In den Positionen bleibt die komplette Bezeichnung erhalten (Z.B. aus "Holzschraube 35 mm" im Positionssatz wird "Holzschraube" im Kopfsatz, im Positionssatz bleibt nicht nur "35 mm" sondern es bleibt "Holzschraube 35 mm").

Automatische Kategoriekorrekturen beim Import

Unvollständige Importdaten können horizontal / vertikal ergänzt werden.

Automatische Übernahme des Kataloggruppierungsfeldes beim Import

"Leere" Kataloggruppierungsfelder werden mit dem (gefüllten) Wert des vorherigen Datensatzes geladen.

10.6.2 Zusätzliche Datenfelder mit integrierten Funktionen

Sortierung beim Import

Neu Sortiermöglichkeiten beim Datenimport
"nach Kategorie Nummer / Bezeichnung / Sortiernummer"

10.6.3 Zusätzliche steuernde Importfelder

"katGrVorNr" (Kataloggruppenvornummer)

Wird dieses Feld bei der automatischen Katalogerstellung aus der CSV-Datei beschickt, erfolgt ein "Sprung" bei der Kataloggruppennummernvergabe um 10.000 sobald ein neuer (anderer Wert) in diesem Feld erkannt wird. Damit ist z.B. die Möglichkeit gegeben, sich ändernden Katalogdaten eines Kataloges (z.B. hinzufügen von neuen Artikeln) in weitgehend fixe Teilkataloge aufzuteilen, um diesen mit zusätzlichen Zwischenblättern vor den einzelnen Teilbereichen als Gesamtkatalog zu drucken ohne die Katalogstruktur (Positionen) erneut prüfen zu müssen. Z.B. Damensocken sind ab Kataloggruppenummer 1 0.000 bis max.1 9.990. Herrensocken ab Kataloggruppennummer 2 0.000.

10.6.4 Anzeige und automatische Korrektur der Importdaten beim Import

KL-KatGen ermöglicht es, die zu importierenden Daten beim Import automatisiert zu ändern.
So können Inhalte einzelner Datenfelder z.B. im Feld: Artikelbezeichnung alle "ß" durch "ss" ersetzt werden (Textkonvertierung) oder es kann für alle Artikel die "Artikelbezeichnung 2" in das Feld "T1" übertragen werden (Konvertierzusatzbefehl)

Konvertierzusatzbefehle

Unmittelbar beim Datenimport (d.h. nach dem Einlesen der Daten, vor der Übernahme in den Katalog bzw. in die Artikelstammdatei) können die einzelnen Datensätze automatisiert korrigiert oder ergänzt werden ( z.B. Bildnamen aus der Artikelnummer erzeugen und diesen in einem separaten Datenfeld des Datensatzes speichern Artikelnummer "4711" à Bildname "Bild4711.jpg".

Werte Textkonvertierung

Die beim Einlesen im Import zu ändernden Daten / Datenfelder (beim Einlesen) können hier erfasst und verwaltet werden (Textkonvertierung).

Anzeige CSV-Datei

Bewirkt die direkte Anzeige der gewählten Importdatei.

10.7 Daten Export / Transfer

10.7.1 Export von Katalogdaten

Die Daten des Kataloges, Kataloggruppen und Katalog-Positionen werden exportiert.

Wahlweise:

sortiert nach Kataloggruppen /- Positionen

nach Artikelnummer

Format ASCII CSV

ASCII SDF

MS-EXCEL 5

Mit Klick auf den Button "P" öffnet sich ein Fenster, wo die zu übertragenden Datenfelder und deren Reihenfolge definiert werden (Feldname mit Komma getrennt)

10.7.2 Export Artikelstammdaten

Die Artikelstammdaten werden exportiert.

Wahlweise:

sortiert nach Kataloggruppen /- Positionen

nach Matchcode

Format ASCII CSV

ASCII SDF

MS-EXCEL 5

Mit Klick auf den Button "P" öffnet sich ein Fenster, wo die zu übertragenden Datenfelder und deren Reihenfolge definiert werden (Feldname mit Komma getrennt)

10.7.3 Export Registerdaten

Die Registerdaten werden exportiert.

Wahlweise:

Standard-Register

Artikel-Register

Kategorien-Register (Stufe von – bis)

sortiert nach Artikelnummer oder Artikelbezeichnung

nach Seite

Format ASCII CSV

ASCII SDF

MS-EXCEL 5

Mit Click auf den Button "P" öffnet sich ein Fenster, wo die zu übertragenden Datenfelder und deren Reihenfolge definiert werden können (Feldname mit Komma getrennt)

10.8 Katalogdatentransfer

·

10.8.1 Katalogdaten nach Artikelstammdatei übertragen

Die in einem Katalog enthaltenen Daten werden in die "eigene" Artikelstammdatei übertragen. Welche Daten im einzelnen, woher (Kataloggruppe oder Katalogposition) aktualisiert werden. Kann in dem nachfolgend abgebildeten Fenster nach Funktionsaufruf gewählt werden.

10.8.2 Katalogtransfer Daten bereit stellen / Katalogtransfer Daten übernehmen

Katalogdaten können für die Übernahme auf einen anderen Rechner in dem Transferverzeichnis bereit gestellt bzw. aus diesem übernommen werden (z.B. Weiterbearbeitung auf einem PC).

Auswahl des Verzeichnisses wohin die Daten abgestellt werden sollen. Dieses Verzeichnis ist als Quelle für die Datenübernahme auszuwählen (ggflls. nach Kopieren auf Ziel-PC oder Versand per Mail).

Das Programm erfragt welche Daten übertragen werden sollen und ob diese gflls einzeln oder gesamt. überschrieben werden können.

- Katalogdaten

- Bilder

- Artikeldatenstammdaten der im Katalog aufgeführten Artikel

10.9 Auftragswesen

Der Bereich "Auftragswesen" wurde In KL-KatGen neu aufgenommen. Dieser erlaubt auf einfache Art Angebote, Lieferscheine einschl. detaillierter Datenblätter bis hin zu Rechnungen und Standard-Briefen zu erstellen. Design und Inhalte der einzelnen Ausdrucke kann individuell im Designer angepasst werden (Button "D").

Einzelne Angebote, Lieferscheine usw. werden jeweils in einer gesonderten Kataloggruppe erfasst.

Empfehlung: Ein Pseudokatalog der alle Angebote (alle, oder alle eines Kunden) beinhaltet.

Nach Aufruf der Funktion öffnet sich das Fenster zum "Erfassen der Auftragskopfkopfdaten"

Neues Angebot:

Button "Neu" hinterlegte Basisdaten werden angezeigt (Betreff, Zahlungsziel, -- Lieferbedingungen usw.) und können abgeändert werden.

Button "V" Daten werden als Standardvorgaben für künftige Angebote gespeichert.

Drei Standardbriefe sind direkt anwählbar

Beliebig viele weitere Briefe sind im System hinterlegbar und können abgerufen werden.

10.9.1 Brieftexte erfassen und verwalten

Klick auf Anzeigen oder Drucken zeigt den vorgewählten Text

"Anzeigen" Anzeigen des gewählten Dokumentes

"Drucken" Drucken des gewählten Dokumentes

"D" Designeraufruf

Das Briefdesign kann in der Auftragswesengrundmaske (s.o) angepasst werden.

( 3 unterschiedliche voreingestellte Designs = Brief1,2,3)

10.9.2 Datenimport aus Shopdateien (optional)

Hinterlegen der Parameter für den File-transfer

öffnet FTP-batch

FTP- aus Shop

Startet den FTP-batch

Holt die im Shopsystem bereitgestellten CSV-Daten per FTP (Filetransfer)

Strukturverwaltung für Datenimport aus Internet-Shopsystem (optional)

Aufgrund der uneinheitlichen Datenstrukturen der unterschiedlichen Shopanbieter sind die Strukturdefinition entsprechend anzupassen.

Weitere Details auf Anfrage.

10.10 Aktualisieren der Daten in einem vorhandenen Katalog

10.10.1 Manuelles Verwalten von Kataloggruppen

10.10.1.1 Einfügen einer neuen Kataloggruppe

10.10.1.2 Einfügen einer neuen leeren Kataloggruppe

Mit KLICK auf den Button "Neu" (1) wird nach der aktuell angezeigten Kataloggruppe eine neue, leere Kataloggruppe eingefügt. Positionsdaten können nun erfasst werden (siehe Folgeseiten).

10.10.1.3 Löschen einer Kataloggruppe

Mit KLICK auf den Button "Löschen" (4) wird die aktuell angezeigte Kataloggruppe einschließlich der zugehörigen Positionen gelöscht.

10.10.1.4 Kopieren, Verschieben einer einzelnen Kataloggruppe

Mit "Klick" auf den Button ">Z<" (2) (Zusatzfunktionen) öffnet sich ein Fenster mit Funktionstasten zum Kopieren, Ausschneiden und beliebig oft Einfügen (3) von einzelnen Kataloggruppen einschließlich der dazu gehörenden Positionen.

Zum Verschieben einer einzelnen Kataloggruppe kann alternativ die Kataloggruppennummer, der zu verschiebenden Kataloggruppe mit einer neuen (Platzierung)-Nummer überschrieben werden. Die Kataloggruppe einschließlich der Positionen wird an die entsprechende Stelle im Katalog verschoben.

10.10.2 Kataloggruppen in einer Übersicht manuell verwalten

Einzelne oder mehrere Kataloggruppen können in einer Kataloggruppenübersicht verwaltet werden.

Diese Funktion kann sowohl über den Button ">Z<" in der Grundmaske (siehe Seite zuvor) als auch über das Hauptmenü "Kataloge verwalten" -> "Verwalten Kataloggruppen (Übersicht)" aufgerufen werden

In dem nun angezeigten Fenster Verwaltung Katalogsortierung nach Kataloggruppen
können eine oder mehrere Kataloggruppen ausgewählt, gelöscht, kopiert, eingefügt und neu "durchnummeriert" werden.

Markieren der Kataloggruppen

"Rechts-Klick" Markieren einer Kataloggruppe

"STR-Klick" Markieren einer Kataloggruppe

"Shift-Klick" Markieren von/bis Kataloggruppe

"Alt-Klick" Markieren eines Bereiches (z.B. Kategorie oder Bezeichnung
ab der gewählten Stelle) werden die Felder mit gleichem Inhalt markiert.

Verschieben

Positionieren Sie auf die Kataloggruppe nach der die gewählte(n) Gruppe(n) einzufügen sind und "Klicken" Sie auf den Button "verschieben". Die neue Position der Kataloggruppen wird dargestellt.

Löschen

Mit "Klick" auf den Button "Löschen" werden die gewählten Kataloggruppen gelöscht. Die neue Reihenfolge wird dargestellt.

Reorganisation

Die Kataloggruppen werden in 10er Schritten neu nummeriert.

Achtung: Auf Kataloggruppennummer bezogene Informationen und Abhängigkeiten stehen danach eventuell nicht mehr zur Verfügung (z.B. Überschriften ab Katalognummer).

10.11 Verwalten der Katalog-Positionen in einem vorhandenen Katalog.

In einem bestehenden Katalog können komplette Kataloggruppen mit den Artikelpositionen wie zuvor beschrieben eingefügt, kopiert und gelöscht werden.

Um einzelne Katalogpositionen (Artikel) innerhalb der Kataloggruppen zu verwalten, bietet KL-Katgen ebenfalls verschiedene Lösungswege an. Welche Alternative am sinnvollsten ist, ist im Einzelfall zu prüfen.
So bestimmen Datenmengen, Zeitpunkte, Produktwechsel, Preisentwicklung usw. welcher Weg dazu am sinnvollsten zu wählen ist.

- Aktualisierung der Katalogpositionen durch erneuten Datenimport

- Aktualisierung der Katalogpositionen beim Katalogdruck
mit den Daten aus der Artikelstammdatei

- Manuelles Verwalten der Katalogpositionen (Artikel) in der Grundmaske

10.11.1 Aktualisierung der Katalogpositionen durch erneuten Datenimport

Die Katalogpositionen können mit den Daten einer externen Datei (CSV-Format aus EXCEL) aktualisiert werden.
D.h. die zugelassenen Datenfelder (Update-Steuerung) der im Katalog vorhandenen Artikel-Positionen werden mit den entsprechenden Werten der Importdatei ersetzt.

Hauptmenü "Daten-Import/Export" -> "Datenimport"

Weitere Details unter "Datenimport"

10.11.2 Aktualisierung der Katalogpositionen beim Katalogdruck mit den Daten aus der Artikelstammdatei

Die einfachste Methode Katalogpositionen zu aktualisieren (z.B. Preise) kann automatisiert beim Katalogdruck erfolgen, indem Sie in den Druckoptionen (3+4) die entsprechende Auswahl treffen.

Grundmaske "Klick" auf "Katalog Drucken"(1) -> Register "Updateoptionen" (2)

Die in der Updatesteuerung (5) zugelassenen Datenfelder (6) (hier nur die Preise 1 bis 5) der Artikelpositionen werden mit den Werten der entsprechenden Artikel aus der Artikelstammdatei aktualisiert.

Voraussetzung ist natürlich, dass die Daten der Artikelstammdatei korrekt nach Datenimport oder manuell gepflegt zur Verfügung stehen.

Weitere Details finden Sie unter "Katalogdruck".

10.11.3 Manuelles Verwalten der Katalogpositionen (Artikel) in der Grundmaske

In der Grundmaske können Katalogpositionen (Artikel) manuell gepflegt werden. So lässt sich beispielsweise der Preis eines Artikels durch einfaches überschreiben in der Position ändern oder es können Positionen hinzugefügt, ersetzt und gelöscht werden. Dazu gibt es in KL-KatGen verschiedene unterstützende Funktionen.

10.11.3.1 Die "Integrierte Positions-/Artikelstammverwaltung"

KL-KatGen verfügt über eine integrierte Positions-/Artikelstammverwaltung, die es erlaubt beim Erfassen und Ändern von Positionen die Daten der Artikelstammdatei zu übernehmen aber auch umgekehrt Daten aus der Katalogposition in die Artikelstammdatei zu übertragen. Dabei ist nicht nur das Aktualisieren des Artikelstammsatzes gegeben, sondern auch das sofortige Löschen oder das Ersetzen durch einem neuen Artikel (bisheriger Artikel wird gelöscht und ein neuer Artikel angelegt).

10.11.3.2 Die "Multi-Change Funktion"

Sind in einem Katalog Artikel mehrfach vorhanden, können diese automatisiert geändert, ersetzt oder gelöscht werden. Dazu können die Werte aus dem entsprechenden Artikelstammsatz oder aus der gerade bearbeiteten Position verwendet werden.

10.11.3.3 Manuelles Hinzufügen von Katalogpositionen

Um eine neue Katalogposition innerhalb einer Kataloggruppe hinzuzufügen, klicken Sie auf den "NEU-Button" (Positionsteuerung (2)) oder drücken Sie 'ALT+"U" '. Das Programm erzeugt eine leere Positionszeile nach der zuletzt markierten. Handelt es sich um die erste Position einer Kataloggruppe dienen die relevanten Werte (Bezeichnung, Bild usw.) auch als Voreinstellung für die Kataloggruppe und können wunschgemäß modifiziert werden. Nach Eingabe der Artikelnummer prüft das Programm, ob ein entsprechender Artikel in der Stammdatei vorhanden ist. Ist dies der Fall, werden die entsprechenden Werte in die Positionszeile übertragen. Ist der Artikel nicht vorhanden, erfolgt eine Meldung. Sollen Positionen ohne Bezug auf Artikelstammdaten erfasst werden, kann diese Meldung unterdrückt werden.

Die Integrierte Positions-/Artikelstammverwaltung (siehe oben) ermöglicht mit Klick auf "Artikel-Update" (4+ 5) automatisiert den Artikel mit den Positionswerten anzulegen.

TIPP: Befinden Sie sich auf der letzten Position einer Kataloggruppe, wird durch die Cursor-Taste "Pfeil nach unten" automatisch eine leere Positionszeile angelegt.

10.11.4 Manuelles Löschen von Katalogpositionen

Um eine Katalogposition innerhalb einer Kataloggruppe zu löschen, klicken Sie nach Markieren der gewünschten Position auf den "Löschen-Button" (Positionssteuerung (2)) oder drücken Sie 'ALT+"Ö" '. Das Programm löscht die markierte Positionszeile.

Sind in einem Katalog Artikel mehrfach vorhanden, können diese Positionen mit der "Multi-Change Funktion" (siehe unten) automatisiert gelöscht werden.

10.11.5 Manuelles Ändern von Katalogpositionen
(Ändern der Werte eines Artikels)

Änderungen einzelner Katalogpositionen (gleicher Artikel) können direkt in dem entsprechenden Datenfeld der Positionszeile (1) der Grundmaske erfasst werden (hier z.B. Preise 1). Bei geöffneter Positionsdetailanzeige (öffnen mit "Klick" auf "Details"(2)) können solche Änderungen auch in dem übersichtlicheren "Detailfenster" vorgenommen werden (3).

Sind in einem Katalog Artikel mehrfach vorhanden, können diese Positionen mit der "Multi-Change Funktion" (siehe unten) automatisiert mit den Werten dieser Position geändert werden.

Die "Integrierte Positions-/Artikelstammverwaltung" (Funktion, siehe unten) erlaubt die neuen Werte auch direkt in den Artikelstammsatz (ggfls.) nach Neuanlage per Knopfdruck (4 + 5) oder per Update-Automatik (6+7) zu übertragen.

TIPP: Ein Klick mit der rechten Maus-Taste auf die Artikelnummer der Positionszeile aktualisiert die Positionswerte mit den Werten des Artikelstammsatzes.

10.11.6 Manuelles Ersetzen von Katalogpositionen (anderer Artikel)

Um eine Katalogposition (Artikel) innerhalb einer Kataloggruppe durch einen anderen Artikel zu ersetzen, überschreiben Sie die Artikelnummer in der entsprechenden Positionszeile. Das Programm prüft, ob ein entsprechender Artikel in der Stammdatei vorhanden ist. Falls vorhanden, werden die entsprechenden Werte in die Positionszeile übertragen. Nach Bedarf können die Positionswerte geändert werden. Ist der Artikel nicht vorhanden erfolgt eine Meldung

Sind in einem Katalog Artikel mehrfach vorhanden, können diese Positionen mit der "Multi-Change Funktion" (siehe unten) automatisiert mit den Werten dieser Position geändert werden.

Die "Integrierte Positions-/Artikelstammverwaltung" (Funktion, siehe unten) erlaubt die neuen Werte auch direkt in den Artikelstammsatz (ggfls.) nach Neuanlage per Knopfdruck (4 + 5) oder per Update-Automatik (6+7) zu übertragen.

10.11.7 Sofortige Aktualisierung im Artikelstamm

Mit Klick auf "A-Update" (4 bzw. 5) können die Daten direkt in die Artikelstammdatei übertragen werden. Ist der Artikel noch nicht in der Stammdatei vorhanden wird dieser neu angelegt.

Wurde die "Update-Automatik" (6 bzw. 7) aktiviert, erfolgen diese Vorgänge automatisch.

10.11.8 Die "Multi-Change Funktion"

Artikel in den Positionen verwalten, tauschen und löschen

Um einen einzelnen, einmal oder mehrfach im Katalog vorhandenen Artikel automatisch durch einen anderen zu ersetzen, zu löschen oder zu aktualisieren, steht die Funktion "Artikel in den Positionen verwalten, tauschen und löschen" im Hauptmenü unter "Kataloge verwalten" zur Verfügung(1).

Alternativ kann diese Funktion auch im Fenster "Katalogpositionssuche" à Button "Direkt-Update" aufgerufen werden. Es öffnet sich das Fenster "Direktaktualisierung Artikelpositionen" (2).

Auswahl der zu bearbeitenden Positionsartikel

Mit Auswahl der gewünschten Positionszeile (3) wird die Artikelnummer der zu ändernden Position in das obere Eingabefeld des Fensters "Direktaktualisierung Artikelpositionen" übertragen.

Alternativ kann auch Eingabe der Artikelnummer manuell erfolgen oder die Artikelnummer wird aus der Artikelauswahl (siehe unten, Aufruf mit Doppel-Klick (4)) übernommen.

10.11.9 Löschen von Positionen

Mit Klick auf (Löschen im) "Katalog" (5) werden die Positionen mit der entsprechenden Artikelnummer (4) gelöscht. (War dies die letzte bzw. einzige Position in der Kataloggruppe ist die Kataloggruppe ggflls. manuell zu löschen).

10.11.10 Löschen Artikelstamm

Mit Klick auf (Löschen im) "Artikelstamm" (6) kann gegebenenfalls der entsprechende Artikel (4) direkt in der Artikelstammdatei gelöscht werden.

10.11.11 Artikelwerte / Positionswerte im Katalog ersetzen

Erfolgt keine Eingabe (8) des "Ersatzartikels" oder ist dieser identisch mit dem zu ersetzenden Artikel, werden nach "Klick" auf (Ersetzen im) "Katalog" (9) Katalog-Positionen mit gleicher Artikelnummer aktualisiert.

Wahlweise kann bestimmt werden, ob dies mit den Werten aus der Artikelstammdatei oder aus dem markierten Positionssatz erfolgen soll (Auswahl (7)).

(Welche Werte aktualisiert werden, ist im erweiterten Fenster "Direktaktualisierung Artikelpositionen" zu hinterlegen (siehe unten))

10.11.12 Artikel / Positionen im Katalog ersetzen

Die Nummer eines Ersatz Artikels kann in das Eingabefeld "Ersetzen mit den Daten" (7) manuell erfasst oder aus der Artikelauswahl (siehe unten) übernommen werden.

TIPP: Wird eine zu ersetzende Artikelnummer im Feld Artikelnummer der Positionszeile unmittelbar nach Auswahl der entsprechenden Positionszeile abgeändert, wird die "neue" Artikelnummer sofort in das Eingabefeld (8) übertragen.

Mit "Klick" auf (Ersetzen im) "Katalog" (9) wird der Artikel in den entsprechenden Positionen ausgetauscht.

10.11.13 Löschen Artikelstamm

Mit Klick auf (Ersetzen im) "Artikelstamm" (10) wird in der Artikelstammdatei der Ursprungsartikel (4) durch den Ersatzartikel ersetzt. (Der Ursprungsartikel wird gelöscht, der Ersatzartikel ggflls. neu angelegt.

10.11.14 Bestimmen der Update-Felder

Welche Werte aktualisiert werden sollen, ist im erweiterten Fenster "Direktaktualisierung Artikelpositionen" zu hinterlegen.

Mit Klick auf den Button "Upd-Felder" erhalten Sie in der "Erweiterten Ansicht" die Steuerungsfelder, mit denen Sie bestimmen können welche Datenfelder zu aktualisieren sind. Sollen diese Einstellungen als Standard erhalten bleiben, klicken Sie auf "Werte als Standard übernehmen".

Mit erneutem Klick auf "Upd-Felder" wird die "Erweiterte Ansicht" geschlossen.

10.11.15 Artikel Positionen im Katalog suchen

Um Artikel in einem Katalog zu finden bietet KL-KatGen verschiedene Möglichkeiten:

- Direkte Suche im Katalog (in den Katalogpositionen)

- Indirekte Suche durch Artikelauswahl in der Artikelstammdatei mit Anzeige in welcher Kataloggruppe sich der entsprechende Artikel befindet.

10.11.16 Direkte Suche in den Katalogpositionen

Mit Klick auf "Suche" (siehe zuvor Grundmaske "Position" (2)) öffnet sich das Fenster "Katalogpositionssuche.

Nach Eingabe des "Suchbegriffs" (1) werden alle Artikel die in den gewählten Datenfeldern den Suchbegriff enthalten mit der Kataloggruppennummer, Positionsnummer und Bezeichnung angezeigt (3).

(Volltextsuche).

Mit Doppelklick auf die gewünschte Anzeigezeile(3) wird in der Grundmaske die Kataloggruppe mit der gesuchten Position angezeigt.

Indirekte Suche durch Artikelauswahl in der Artikelstammdatei mit Anzeige in welcher Kataloggruppe sich der entsprechende Artikel befindet.

Im Gegensatz zu der zuvor beschriebenen Möglichkeit der direkten Suche in den Katalogpositionen. werden mit dieser Funktion die Artikel in der Artikelstammdatei gesucht und die Platzierung innerhalb des Kataloges angezeigt (siehe Abbildung rechte Spalte).

Somit ist zusätzlich die Möglichkeit gegeben * zu erkennen, welche

- Artikel im Katalog einmal enthalten sind

- Artikel im Katalog mehrfach enthalten sind

- Artikel die noch nicht im enthalten sind

Mit Doppel-Klick auf die angezeigte Kataloggruppen-Nummer wird die entsprechende Kataloggruppe die den gewählten Artikel beinhaltet in der Grundmaske angezeigt

* Achtung: Um die korrekte Anzeige bei der "Selektion der Verteilung" (verteilte, mehrfach verteilte usw.) sicher zu stellen, ist nach Hinzufügen oder Löschen von Artikeln in den Katalogdaten das erneute Generieren erforderlich.

10.11.17 Indirekte Suche durch Artikelauswahl in der Artikelstammdatei mit Anzeige in welcher Kataloggruppe sich der entsprechende Artikel befindet.

Im Gegensatz zu der zuvor beschriebenen Möglichkeit der direkten Suche in den Katalogpositionen. werden mit dieser Funktion die Artikel in der Artikelstammdatei gesucht und die Platzierung innerhalb des Kataloges angezeigt (siehe Abbildung rechte Spalte).

Somit ist zusätzlich die Möglichkeit gegeben * zu erkennen, welche

- Artikel im Katalog einmal enthalten sind

- Artikel im Katalog mehrfach enthalten sind

- Artikel die noch nicht im enthalten sind

Mit Doppel-Klick auf angezeigte Kataloggruppen-Nummer wird die entsprechende Kataloggruppe die den gewählten Artikel beinhaltet in der Grundmaske angezeigt

* Achtung: Um die korrekte Anzeige bei der "Selektion der Verteilung" (verteilte, mehrfach verteilte usw.) sicher zu stellen, ist nach Hinzufügen oder Löschen von Artikeln in den Katalogdaten das erneute Generieren erforderlich.

11 Der Blitzkatalog "Was wollen Sie tun"

Warum Blitzkatalog?

Diese Programmfunktion ermöglicht per einfachem Tasten-Klick vollautomatisiert einen neuen Katalog direkt aus einer vorhandenen Importdatei zu erstellen und/oder Importdaten in die KL-KatGen eigene Artikelstammdatei für die weitere Verarbeitung zu übernehmen.

Nach Neuinstallation des Programms wird diese Funktion automatisch gestartet. Sie können den automatischen Start dieser Funktion ausschalten, indem Sie das Häkchen aus dem Feld "Fenster immer nach Programmstart anzeigen" am unteren linken Bildschirmrand entfernen.

Über den Menüpunkt "Hilfe" oder mit der "F6-Taste" gelangen Sie jederzeit erneut in diese Funkton.

Die Programmausführung erfolgt entsprechend dem "Klick" auf die gewählte Funktionstaste am unteren Rand des Fensters. Wählen Sie dort, ob Sie die Daten für die manuelle Weiterverarbeitung nur in die Artikeldatei importieren wollen oder ob sofort ein fertiger Katalog mit einem gewünschten Design angezeigt oder gedruckt werden soll.

Im Demonstrationsmodus (Markierung oben) haben wir zwei Beispiele vorbereitet, welche die Möglichkeiten aufzeigen sollen.

Den eigenen Katalog mit eigenen Daten und eigenem Design automatisiert erstellen

Nach Entfernen der Markierung "Demonstrationsmodus" können Sie hier Ihre individuellen Parameter (Importstruktur, Importdatei, Design) hinterlegen und so zukünftig "den neuesten Katalog per einfachen Knopfdruck in einem Zug" erzeugen.

Für individuelle Modifikationen können Sie die hier automatisch hintereinander ablaufenden Funktionen in der Grundmaske selbstverständlich auch einzeln verwenden.

11.1 Sie haben folgende Programmfunktionen in dieser Maske zur Auswahl.

11.1.1 Datentest

Hier wird Ihnen eine Vorschau aus den Daten der ausgewählten CSV-Datei angezeigt.

Folgende Abbildung zeigt eine Vorschau wie sie mit der Funktion "Datentest" aussehen könnte.

11.1.2 nur Import

Hier wird die entsprechende CSV-Datei in einen neuen bzw. vorhandenen Katalog eingelesen.

Optional kann auch (noch) die interne Artikeldatei gefüllt bzw . aktualisiert werden

Folgende Abbildung zeigt die Meldung nach einem erfolgreichen Datenimport aus einer CSV-Datei in einen Katalog.

Nach erfolgreichem Import mit Katalogerstellung stehen die Daten in der Grundmaske zur weiteren Verwendung (Anzeige, Druck, Korrektur usw.) zur Verfügung.

Wurde die Option "mit Artikelstamm Import bzw. Aktualisierung" gewählt. Stehen die neuen bzw. aktualisierten Artikeldaten in der KL-KatGen eigenen Artikelstammdatei zu Verfügung. In der Artikelstammverwaltung können diese gegebenenfalls noch modifiziert werden und stehen dann für die Erfassung in den Katalog oder zur Aktualisierung beim Katalogdruck zur Verfügung.

Weiterführende Details dazu finden Sie im Anwenderhandbuch, in den Hilfetexten sowie über die Tooltipfunktion (Mauszeiger über ein Objekt führen).

11.1.3 mit Anzeigen

Hier wird die entsprechende CSV-Datei in einen neuen bzw. vorhandenen Katalog eingelesen und der entsprechende Katalog am Bildschirm angezeigt.

Folgende Abbildung zeigt eine mögliche Kataloganzeige.

11.1.4 mit Drucken

Die CSV-Datei wird in einen neuen bzw. vorhandenen Katalog eingelesen und der entsprechende Katalog wird gedruckt. Die Ausgabe erfolgt an den gewählten Drucker.

Für die Weiterverarbeitung (z.B. Weitergabe an eine Druckerei) kann die Ausgabe an einen virtuellen Drucker im PDF-Format erfolgen. Die Druckausgabe erfolgt im RGB-Format. Das "PDF-Programm" ist kein Bestandteil von KL-KatGen.

11.2 Demonstrationsmodus

In diesem Modus werden Sie durch die einzelnen Schritte einer Katalogerstellung aus einer CSV-Schnittstellendatei geführt.

Die in diesem Demonstrationsmodus benutzten Einstellungen und Dateien sind von KL-Systems vorgefertigt und werden bei der Programminstallation mitinstalliert.

Es ist eine CSV-Schnittstellendatei mit dem Namen "DemoArtikel.csv" die in dem Unterverzeichnis "Import" vom Installationsverzeichnis von KL-Katgen zu finden ist.

Ferner ist die entsprechende Definition bzw. Zuweisung der einzelnen Feldinhalte dieser CSV-Schnittstellendatei (siehe "Schnittstelle definieren") unter dem Namen "DemoArtikel" vordefiniert.

11.3 Expertenmodus (= Demonstrationsmodus deaktiviert)

In diesem Modus können Sie Ihre individuellen Parameter (Importstruktur, Importdatei, Design) hinterlegen und so zukünftig den "neuesten Katalog per einfachen Knopfdruck in einem Zug" erzeugen.

11.3.1 Katalogname

Ein von Ihnen frei wählbarer Name für Ihren Katalog (Achtung: keine Leerstellen im Namen verwenden)

11.3.2 Importdatei

Der Pfadname Ihrer aus EXCEL oder einer Warenwirtschaft erzeugten CSV-Datei mit den Produktdaten für Ihren Katalog

11.3.3 Automatisch einen Katalog aus einer Importdatei erstellen

Hier legen Sie fest, ob die Daten aus Ihrer Schnittstellendatei in einen vorhandenen bzw. neu zu erstellenden Katalog übernommen werden sollen. Beachten Sie die Option "zuvor Katalog leeren", damit legen Sie fest, ob das Programm den von Ihnen gewählten Katalog vor dem Import leert.

11.3.4 Daten aus einer Importdatei in die Artikelstammdatei übernehmen

Hier legen Sie fest, ob die Daten aus Ihrer Schnittstellendatei in den internen Artikelstamm von KL-Katgen übernommen werden soll.

Weitere Optionen sind "Artikelstammdatei zuvor löschen" oder "Artikelstammdatei ergänzen bzw. aktualisieren"

11.3.5 Ich möchte dabei Schritt für Schritt vom Programm geführt werden.

Hier legen Sie fest, ob Sie bei jedem einzelnen Schritt der gewählten Aktion gefragt werden und gegebenenfalls die gesamte Aktion abbrechen können.

11.3.6 Hilfe Schnittstelle

Dieser Text wird angezeigt.

11.3.7 Darstellung

Hier können Sie weitere, dem Programmpaket beigefügte Darstellungsarten auswählen

11.3.8 Reportname

Dieses Feld korrespondiert mit dem Feld "Darstellung". Es wird ein Report mit dem Namen "Design_xxxx" eingestellt. Wobei xxxx das Kürzel für die Darstellungsart ist.

11.3.9 Schnittstelle definieren

Durch "Klick" auf diesen Button öffnet sich der Programmteil "Datenimport" und "Verwalten der Importschnittstellen". Hier können Sie weitere Datenfelder und vielfältige Optionen für den Datenimport Ihrer individuellen CSV-Schnittstellendatei definieren. Lesen Sie hierzu in der Dokumentation bzw. der Online-Hilfe (F1-Taste) das Kapitel "Der Datenimport".

Eine kurze Anleitung finden Sie auf den nachfolgenden Seiten.

12 Anleitung CSV-Schnittstelle

Das Dateiformat CSV (Comma-Separated Values) beschreibt den Aufbau einer Textdatei zur Speicherung oder zum Austausch von Daten.
Sie können eine CSV-Datei auf vielerlei Arten erzeugen. Die sinnvollste Methode in diesem Zusammenhang ist, wenn Sie die entsprechende Exportfunktion Ihres Warenwirtschaftssystems nutzen (da hier in der Regel die meisten relevanten Daten zur Erstellung eines Produktkataloges bereits erfasst sind) oder einfach mit MS-Excel auf vorhandene, bzw. neu erfasste Daten zugreifen.
Exemplarisch soll hier die zuletzt genannte Methode erläutert werden.

Die Standardschnittstellenbeschreibung (DemoArtikel) von KL-Katgen geht von einer Datei aus, welche die folgenden Felder (in der genannten Reihenfolge) beinhaltet:

Dies ist nur ein einfaches Beispiel für einen Aufbau einer solchen Datei. In den meisten Fällen sind mehr Datenfelder für die Erstellung eines Kataloges nötig.

1. Artikelnummer artnr Spalte A

2. Bezeichnung1 bez1 Spalte B

3. Bezeichnung2 bez2 Spalte C

4. Preis1 vkbasis Spalte D

5. Bildname Bild Spalte E

6. Zusammen zusammen Spalte F

Um die Funktion in Zusammenhang mit Ihren Daten zu testen, legen Sie in EXCEL eine Tabelle, mit einigen wenigen Datensätzen, mit den oben aufgeführten Datenfeldern (Spalten) an. Folgende Abbildung zeigt, wie eine entsprechende EXCEL-Tabelle erfasst sein könnte, bzw. wie sie aus einem Warenwirtschaftssystem erzeugt werden kann.

Beim Import (in der Importstruktur s.u.) kann bestimmt werden welche Artikel (in der Regel Varianten eines Artikels) gemeinsam in einer Kataloggruppe erscheinen sollen. (Z.B. unter oder neben einem Bild, Text, Spaltenüberschrift usw.).

Dazu erhalten solche Artikel die gleiche Kennzeichnung, hier in Spalte "F" (z.B. "Standard Ordner" die "109"). Beim Import wurde dieser Spalte das Datenfeld "Zusammen" zugewiesen und in der Importstruktur dieses Datenfeld als Gruppierungsfeld benannt (sehe Abbildung "Verwalten der Importschnittstelle" ff).

Wenn Sie die Daten in einer Excel-Tabelle erfasst haben, erzeugen Sie hieraus eine CSV-Datei indem Sie in EXCEL den Menüpunkt "Datei" à "Speichern Unter" und im anschließenden Fenster den Dateityp "CSV-Format", wählen. Vergeben Sie einen Dateinamen Ihrer Wahl und bestimmen Sie den Speicherort (ein Verzeichnis z.B KL-Katgen11-> Import) und klicken Sie auf Speichern.

Kontrollieren Sie das Ergebnis in dem Sie sich diese mit dem Text-Editor anzeigen lassen. In unserem Beispiel sieht dies wie in der Abbildung dargestellt aus.

Um einen Dateischutzfehler zu vermeiden schließen Sie vor dem Import Excel bzw. die Ansicht im Editor.

Die Importstruktur

Anschließend können Sie im KL-Katgen Programm im Menüpunkt "Daten-Import" die entsprechend zuvor abgespeicherte Datei zuweisen und in den Katalog- bzw. den Artikelstamm einlesen.

Hier die Vorgehensweise:

Klicken Sie auf "Neue Importstruktur definieren"

Vergeben Sie einen Namen für Ihre Importstruktur im entsprechenden Feld.

Geben Sie den Pfadnamen der CSV-Datei ein oder wählen Sie mittels Klick auf den Auswahlbutton die entsprechende Datei auf Ihrem Computer.

Klicken Sie auf den Button "Struktur einlesen"

Es erscheint in der Feldnamentabelle der erste Datensatz (Idealerweise mit den Feldnamen)

Nun können Sie die Feldnamen der CSV-Datei Datenfelder im KL-Katgen zuweisen.
(vgl Abbildung)

Weitere Details finden Sie im Anwender-Handbuch bzw. in den Hilfetexten.

13 Kalkulation

Die Grundmaske

13.1 Zuordnen der Kalkulationsnummern zu den Artikelstammdaten.

Folgende Optionen sind gegeben:

Ersetze
Kalkulationsnummer

Mit

Funktion

'B456'

Die Kalkulationsnummer "B456" wird in alle Artikel* übernommen.

'K123'

'B456'

Die Kalkulationsnummer "K123" wird in den Artikeln* mit der Kalkulationsnummer "B456" ersetzt.

""

'B456'

Artikel* ohne Kalkulationsnummer erhalten die Kalkulationsnummer "B456".

""

Die Kalkulationsnummern werden in allen Artikeln* gelöscht.

'K123'

""

Die Kalkulationsnummer "K123" wird in den Artikeln* gelöscht.

* Begrenzen Sie ggflls. den Vorgang auf bestimmte Artikel durch Artikelselektion

13.2 Die Kalkulationsparameter

Erfassen und Verwalten der Kalkulationsparameter (Kalkulationsnummern)

Die Erfassung und Verwaltung der Kalkulationsparameter(Kalkulationsnummern) erfolgt in der Grundmaske in den Eingabefeldern unter der Überschrift "Kalkulationsparameter". Dort sind die für die Preisfindung notwendigen Kalkulationsparameter für die Preisermittlung hinterlegt. Das heißt, klassisch ausgehend von einem Ursprungswert werden die neuen Preise durch Prozent-oder Wertzuschläge ermittelt. In der Regel wird man dabei zum Beispiel auf einen Basiswert der Artikelstammdatei zugreifen (z.B. Händlerlistenpreis), den vereinbarten Einkaufsrabatt abziehen, den Gewinnzuschlag addieren und den Netto-Preis bzw. nach Hinzurechnen der Mehrwertsteuer den Bruttopreis im Artikelstammsatz zur weiteren Verwendung abstellen

Dabei können die entsprechenden Kalkulationsparameter direkt als Zahl oder indirekt als Variable eingegeben werden.

13.3 Anlegen der Kalkulationsparameter

Mit Klick auf die Taste "Neu" wird eine "neue Kalkulationsnummer" angelegt. Vergeben Sie eine "Nummer" (=Identifikationsbezeichnung) die auch in der Artikelstammdatei für die Zuordnung des Artikels zu einer Kalkulationsnummer dient.

Anschließend verlangt das System eine Kurzbeschreibung, die später das Auffinden und Zuordnen erleichtern soll.

Sie können nun Zeile für Zeile die einzelnen Parameter erfassen. In der Regel wird man zu Beginn eine Basisvariable als Erste Position in die Kalkulationsparameter aufnehmen. Klicken sie dazu auf den Button "Basis-Variable".

Es öffnet sich das Fenster mit den Basis-Variablen. Wählen Sie die gewünschte Variable und übernehmen Sie diese in die Kalkulationsparameter durch "Doppel-Klick" oder" Klick" auf den Button "Übernehmen".

In unserem Beispiel wählen wir "artikel.ek1" (den in der Artikelstamm hinterlegten Einkaufspreis 1

Fahren wir in unserem Beispiel mit folgenden Vorgaben fort.

Unser Einkaufspreis Netto 24,-- Hinterlegt(importiert ) in EK1 der Artikelstemmdatei
Unser Gewinnzuschlag 35,5 %

Der so ermittelte Preis soll sobald der "Cent" Bereich > 80 Cent auf den nächst höheren Euro Betrag aufgerundet werden und auf eine "Verkaufsfördernden Betrag" € xx,95 reduziert werden. D.h. der "volle Euro-Betrag" ist um 5 Cent zu reduzieren.

Der so ermittelte Preis soll vor der endgültigen Übernahme in Preis 3 der Artikelstammdatei in den "KalkPreis3" (temporärer Anzeigepreis) abgestellt und angezeigt werden.
Erst mit Klick auf "Artikel" ( Punkt 5 der Abbildung) soll die Übernahme in Preis 3 erfolgen.

Die Kalkulationsparameter sind dazu wie folgt zu erfassen :

Nach Übernahme der Basisvariablen "artikel.ek1" wird der entsprechende Wert aus dem aktuellen Artikelstammsatz angezeigt (hier € 24,--).

In der nächsten Zeile erfassen Sie im Wertfeld 35,5 und in der Kalkulationsart "%" für 35,5 % (unser Gewinnzuschlag).

Artikel.ek1 W =Wertanzeige € 24,-

35,5 % = prozentualer Aufschlag € 32,52

mwstv % = 19 % Mehrwertsteuer € 37,13

VKFRUNDEN Ü = Runden auf VKF-Preis (Details dazu unter VKF-Runden)

KalkPreis3 Ü =Wert wird in den kalkulatorischen Preis 2 übernommen

13.4 Kalkulationsparameter

Um eine artikelspezifische Preisermittlung zu ermöglichen, sind den einzelnen Artikeln unterschiedliche Kalkulationsalgorithmen zuzuordnen. Diese werden in den Kalkulationsparametern hinterlegt und mit der entsprechenden Kalkulationsnummer (Nummer der Kalkulationsparameter) dem jeweiligen Artikel in der Artikelstammdatei zugeordnet.

Diese Zuordnung kann sowohl manuell, automatisiert und, falls diese Information bereits in den Ursprungsdaten direkt oder indirekt (z.B. Artikelgruppe, Lieferant) vorhanden ist, auch bereits beim Datenimport erfolgen. (Siehe dazu: Zuordnen der Kalkulationsnummern zu den Artikelstammdaten und Datenimport).

13.5 Arten der Kalkulationsparameter

Wie bereits beschrieben, beinhaltet KL-KonvKalk eine Zuschlagskalkulation bei der ausgehend von einem Basiswert Werte übernommen (+/-) und hinzu addiert oder abgezogen werden. Die so ermittelten Ergebnisse können in Datenfeder (in der Regel Preisfelder) oder für weitere Preisermittlungen auch in Zwischensummenspeicher übergeben werden .

Folgende Parameter bzw. Berechnungsarten sind zu unterscheiden:

Art

Funktion

Beschreibung

W

+/-

Addieren eines Wertes aus einer Variablen, eines eingegebenen Betrages oder aus dem Ergebnis einer hinterlegten Formel

%

+/-

Prozentualer Zu- oder Abschlag auf den ermittelten Wert

R

+/-

Prozentuale Rückrechnung, % aus 100, z.B. Mwst.-Rückrechnung

N

0 >+/-

Wertübernahme nach Wert auf Nullsetzung
Z.B. in einer Kalkulation Ausgehend von Preis 1 +25%, Preis 2 +40 %

Ü

Wertübergabe

Der ermittelte Wert wird in ein Datenfeld übergeben. Dies kann direkt ein Preisfeld der Artikelstammdatei, eine Standardvariable oder zum Speichern von Zwischenergebnissen eine selbst definierte Variable sein.

13.6Vertikale Wertübernahme

Sind in der Importdatei einzelne Datenfelder nicht "gefüllt", da ein Begriff für die nachfolgenden Datensätze ebenfalls gelten sollen, können diese fehlenden Werte beim Import automatisiert in der Importdatei vervollständigt werden.
Solche "fehlende Daten" erhält man meist beim Datenexport aus Kalkulationstabellen (z.B. EXCEL o.ä), da man dort zur übersichtlicheren Darstellung bewusst nicht alle Informationen in allen Zeilen erfasst (Gruppenüberschriften oder Artikel mit Varianten, Leistungsdaten für mehrere Artikel usw siehe Abbildung).
Damit die relevanten Informationen jedoch auch in jedem Artikelstammsatz und in den entsprechenden Katalogpositionen für die weitere Verwendung verfügbar sind, sind die zu übertragenden Datenfelder im Fenster "ergaenzfelder" zu benennen (Feldname aus der Importstruktur Spalte 3). Das Programm überträgt die entsprechenden Inhalte in die folgenden Datensätze, solange diese "leer" sind und übernimmt den "neuen Inhalt" für die folgenden "leeren" Datensätze.

Beispiel:
In Spalte A wird von Zeile 1 bis 8 der Begriff "Computerzubehör" beim Export ergänzt. Ab Zeile 10 wird "Netzwerkzubehör" übernommen. Dazu wurde in der Importstruktur bestimmt, dass Spalte A in die Kataloggruppenbezeichnung 1 (= "kgrbez1") zu übernehmen ist.

Im Fenster "ergaenzfelder" wurden die Felder "kgrbez1", "zusammen" und "t1" als Datenfeld deren Inhalt "vertikal" in die folgenden Sätze zu übernehmen" sind erfasst.

13.7 Basisvariable und Formeln

In KL-KonvKalk stehen für gemeinsame Verwendung und Steuerung in den Kalkulationsalgorithmen Basisvariablen als "feste Variable", "individuelle Variable" und Formeln zu Verfügung.

Pflege und Verwaltung und Auswahl für die Übernahme in die einzelnen Kalkulationsnummern erfolgt in der Funktion (Fenster) "Basis-Variable auswählen und Definieren". Dorthin gelangen Sie mit Klick auf den Button "Basis-Variable" in der Grundmaske.

13.7.1 Feste Basisvariable

Für die Preisermittlung kann KL-KonvKalk Werte aus Variablen nutzen. Dazu stehen als "feste" Basisvariable Werte aus der Artikelstammdatei für die Ein-/und Ausgabe und "feste" Variable für die Ausgabe der ermittelten Preise (KalkPreis1 bis 5) zur Verfügung.
Die Werte aus der Artikelstammdatei werden dabei als Basis für die Ermittlung der Preise herangezogen.

Zum Beispiel: Auf den Preis 1(aus Artikelstamm) wird in Abhängigkeit des Gewichtes (ebenfalls im Artikelstammsatz hinterlegt) ein Frachtzuschlag (als individuelle Basisvariable(s.u.) hinterlegt) erhoben..

Artikel.VkBasis

Artikel.p2

Artikel.p3

Artikel.p4

Artikel.p5

Artikel.EK1

Artikel.EK2

Artikel.n1

Artikel.n2

Artikel.n3

Artikel.n4

Artikel.n5

Artikel.Vpe1n

Artikel.Vpe2n

Artikel.Vpe3n

Artikel.Gewicht

Zusätzlich als feste Basisvariable stehen die Variablen"KalkPreis1" bis "KalkPreis5" zur Verfügung.

KalkPreis1

KalkPreis2

KalkPreis3

KalkPreis4

KalkPreis5

KalkPreisEK1

KalkPreisEK2

VKFRUNDEN

Genutzt können diese Variablen werden, um die neu kalkulierten Preise vor der Übernahme in die tatsächlichen Preisfelder am Bildschirm anzuzeigen (siehe Abbildung Punkt 2) und erst mit "KLICK" auf "Artikel" (5) in den Artikelstammsatz zu übertragen.

Diese Vorgehensweise erlaubt die Ergebnisse Artikel für Artikel visuell zu prüfen und gegebenenfalls noch manuell zu korrigieren (Datenfeld 2). Wurde" automatik" aktiviert (6), erfolgt diese Fortschreibung sofort beim Blättern im Artikelstamm. Gegebenenfalls können aber auch noch Korrekturen vorgenommen werden. Diese sind dann, da bereits übertragen, direkt im Artikelstammsatz vorzunehmen (1, Preisfelder der Artikelstammdatei).

13.7.2 Individuelle Basisvariable

Zusätzlich können individuelle Basisvariablen hinterlegt werden, die einheitlich in allen Kalkulationsnummern zu verwenden sind und die somit an einer Stelle änderbar, sich auf alle Kalkulationsnummern auswirken. Ein typisches Beispiel wäre der Mehrwertsteuerprozentsatz oder Stunden-/Minutenpreise bei Arbeitswerten.

Beispiel:

Mit der Variablen "mwstV" wurde ein Prozent-Wert als Basisvariable mit Wert 19 % definiert. die in allen Kalkulationsnummern hinterlegt werden kann. Wird der Wert "hier" (in den Basisvariablen) auf 20% geändert wirkt sich diese Änderung auf alle diese Kalkulationsnummern aus.

Direkte Variable

Variablen können auch direkt in einer Kalkulationsnummer erstellt werden. Diese wirken sich dann natürlich nur für diese Kalkulation aus. Details dazu finden Sie unter "Direkte Variable" unter "Erfassen und Verwalten der Kalkulationsparameter (Kalkulationsnummern)" auf den Folgeseiten.

13.7.3 Formeln

Für die Preisermittlung können Formeln hinterlegt und als Variable in die Kalkulationsparameter eingebunden werden. Diese nehmen Bezug auf feste oder individuelle Variablen und liefern einen errechneten Wert zurück.

Beispiel:

Eine Formel zum Berücksichtigen des Materialverbrauchs kann folgendermaßen aussehen:

cm² x Preis je cm² = Materialzuschlag1

Der Preis je cm² beträgt € 1,25 als Basis-Variable oder als "Direkte-Variable" in der Kalkulationsnummer hinterlegt

Die Anzahl cm² aus dem Artikelstammsatz im Wertfeld "n1" hinterlegt = 100 cm²

Daraus ergibt sich ein Materialzuschlag für Material 1 von 100 x € 1,25 = € 125

Materialzuschlag1 = "artikel.n1*material1"

Im Artikelstamm z.B. im Wertfeld "n1" ist der Materialverbrauch eines Materials in Quadratzentimeter für den jeweiligen Artikel Hinterlegt

Der cm²-Preis .des Materials kann mit der Variablen "material1" ebenfalls als Basisvariable (siehe zuvor) oder als Direkte Variable (siehe nachfolgend) angelegt werden.

In der Abbildung zuvor sehen wir ein Beispiel für die automatisierte Berechnung eines Versandzuschlages in Abhängigkeit vom Gewicht des jeweiligen Artikels.

13.8 VKFRUNDEN

Runden auf Verkaufsfördernde Preise

Mit KL-KonvKalk können über die üblichen Preis-Rundungsverfahren hinausgehend, Preise nach speziellen Kriterien automatisiert gerundet und "korrigiert" werden. So lassen sich Preise auf volle € 100, € 25 usw. runden aber auch Aktionspreise wie € 49,95 oder € 0,99 ermitteln und in den Artikelstamm übernehmen.

Preisbeispiele:

Auf-/abrunden auf vollen Euro-Betrag abzüglich 5 Cent ( € 1,95, € 2,95 usw.)

Auf-/abrunden auf volle € 100 Euro abzüglich € 5 ( € 195, € 1.295 usw.)

Damit ein Preis entsprechend modifiziert wird, ist in den gewünschten Kalkulationsalgorithmen der Kalkulationsparameter "VKFRUNDEN" aufzunehmen. Art und Weise der "Preiskorrektur" wird in der Preisrundungs- / Korrekturtabelle definiert.

Der Parameter "VKFRUNDEN" kann sowohl aus den Basisvariablen, als auch mit Klick auf VKF-Runden in die Kalkulationsnummer eingefügt werden.

Die nachfolgende Abbildung zeigt ein einfaches Beispiel der "VKF-RUNDUNG"

Beispiel:

Artikel EK-Preis 24,00 €

Gewinnzuschlag 35,5 % 8,52 €

Zuzüglich 19 % Mwst. 6,18 €

Ergebnis 38,70 €

Aufgrund der VKF-Preis-Ermittlung errechnet das Programm den VKF-Preis 38,95 €..

Dazu wurde in der Preisrundungs- / Korrekturtabelle hinterlegt, dass Beträge die in den letzten 2 Stellen (im "Cent-Bereich") höher als 0 sind (also immer) auf volle Euro aufzurunden und vom erzielten Ergebnis 5 Cent abzuziehen sind. Damit diese Berechungsweise nicht für alle Preise angewendet wird, wurde dort zusätzlich der Gültigkeitsbereich (Preise von € 10 bis € 99.99) festgelegt.

In diesem Beispiel wird der Preis nicht direkt in die Artikelstammdatei übernommen, sondern er wird lediglich an den temporären Preis "KalkPreis3" (siehe Punkt 1 unter Preis 3) übergeben und angezeigt.

Mit "Klick" auf den Button "Artikel" werden alle Werte aus der Zeile "Preis-Kalk 1 bis 5" in die Preisfelder der Artikelstammdatei übertragen.

Wurde die automatische Übernahme mit "autom" (Abbildung Punkt 6) aktiviert, erfolgt sowohl beim manuellen "Durchblättern" als auch bei der "automatischen Preiskorrektur" (alle selektierten Artikel werden abgearbeitet) die sofortige Preisübernahme .

13.8.1 Die Preisrundungs- / Korrekturtabelle

Für die Ermittlung der " VKF-Preise" sind einmalig die notwendigen Informationen in der Preiskorrekturtabelle zu hinterlegen.

Dort wird bestimmt, wie die "Rundung" und zusätzlich "Korrektur" der Artikelpreise erfolgen soll.

So lässt sich bestimmen, ab welcher Höhe ein Preis aufzurunden ist bzw. bis zu welchem Betrag abgerundet werden soll. Damit dies nicht für alle Preisstufen einheitlich erfolgt, können unterschiedliche Berechnungsmodalitäten für verschiedene Preisstufen festgelegt werden. So ist es beispielweise möglich Preise ab € 1.000 anders zu runden als Preise zwischen €10 und € 100.

Die Festlegung der Parameter für verschiedene Preisrahmen bittet die Möglichkeit mit wenigen Informationen Rundungs-/Preiskorrekturen für ganze Preisbereiche (z.B. gültig für Preise bis € 1000 oder für Preise von €1 0 bis € 100 realisieren. So kann beispielweise mit einer einzeiligen Definition bestimmt werden, dass bei Preisen über 1.000 € immer auf volle 50€ gerundet werden soll und von dem jeweiligen Ergebnis 1€ abzuziehen ist.

In der nachfolgenden Abbildung ist zur Erläuterung ein Beispiel dargestellt.

Nr laufende Nummer Für eine sortierte Darstellung der Tabelle

S Sperre (gesperrt) Der Korrektursatz (Zeile) wird bei der Preiskorrektur ignoriert

Preis ab Preisspanne Preisspanne, ab "Preis ab" bis zum Preis "Preis bis"
Preis bis sind die in der Zeile aufgeführten Korrekturen durchzuführen.

aufrunden ab Aufrunden Ab dem jeweils* aufgeführten Wert ist aufzurunden
auf volle Wert auf den aufzurunden ist
+/- Wert mit dem das aufgerundete Ergebnis zu korrigieren ist.

abrunden bis Abrunden Bis zu dem jeweils* aufgeführten Wert ist aufzurunden
auf volle Wert auf den abzurunden ist
+/- Wert mit dem das abgerundete Ergebnis zu korrigieren ist.

* "jeweils" Damit nicht für alle Preise einzelne Rundungswerte hinterlegt werden müssen, beziehen sich die Werte auf die letzten Stellen innerhalb der angegebenen Spanne. D.h. z.B. auf-/abrunden auf volle 100 ab einem Betrag von 50 innerhalb der Spanne 1000 bis 3000, dass die Preisermittlung innerhalb dieses Bereichs für alle "100er-Werte" gilt (z.B. 1150 aufrunden,1230 abrunden usw.).

Beispiel 1:

Zeile Nr.5: Die Preise zwischen € 100 € und € 500 sind ab jeweils* € 40 auf jeweils € 50 aufzurunden und unter jeweils € 10 auf volle € 50 abzurunden. Der so ermittelte Preis ist um 50 Cent sowohl beim Abrunden als auch beim Aufrunden zu reduzieren.

Der aufgeführte Wert in der Spalte "aufrunden ab" bzw. "abrunden bis" ist der in der Kalkulation ermittelte, auf die letzten Stellen reduzierte Preis, der bei der Rundung zu berücksichtigen ist. Die Anzahl der "letzten Stellen" ergibt sich aus der Stellenanzahl des Betrages auf den zu Runden ist.

Z.B. Ermittelter Preis 1234,56 auf-/abzurunden "auf volle 100,00". Für die Rundungsprüfung werden hier, da auf volle 100,00 gerundet werden soll, die letzten 5 Stellen (3 Vorkomma- + 2 Nachkommastellen = 234,56) berücksichtigt

Beispiel 2:

Der Ermittelte Preis vor "VKFRUNDEN" beträgt € 1.235,00

Somit gelten die Werte der Zeile 2 und 3, da dort die Definition für Preise im Bereich ab 1000 bis 3000 Euro hinterlegt wurden.

In Zeile 2 wurde festgelegt, dass wenn der jeweilige kalkulierte Preis innerhalb dieser Spanne in den letzten Stellen > 800,00 ergibt, auf "volle 1000" aufzurunden und bei Preisen bis 200 in den letzten Stellen auf "volle 1000" abzurunden ist. Das so ermittelte Ergebnis ist um 50 Euro zu reduzieren um auf einen "gefälligen Preis" zu kommen.

In unserem Beispiel liegt der ermittelte Preis in den letzten Stellen jedoch unterhalb von 800.

Somit kommt, da auch innerhalb der Spanne, die nächste Zeile zum Tragen.

Da unser Preis in den letzten Stellen auch unterhalb von 49 liegt, ist dieser auf volle 100 abzurunden und vom Ergebnis 1 EURO abzuziehen. Als Ergebnis erhaltern wir 1.199,00

14 Anhang

Erläuterungen zu den mitgelieferten Beispielen:

01S0

01S6

08S0

08S6

S110

S116

S126

S140

S240

06N0

06N2

P01_PRL

P02_PRL

P02b_PRL

S110RL

S11xMIX

Übersicht der mitgelieferten Design- / Katalogbeispiele

Satp

ssSp

ppNa

Eine Kataloggruppe je Zeile
Positionen einspaltig unter dem Bild / den Gruppendaten

S110

01S0

Eine Kataloggruppe je Zeile
Positionen einspaltig neben dem Bild / den Gruppendaten

Satp = max. 9

ppNa = max. 99

Positionen neben dem Bild

S116

01S6

06N0

Mehrere Kataloggruppen nebeneinander

Ein Viertel der Zeile
Positionen einspaltig unter dem Bild / den Gruppendaten

S140

Mehrere Kataloggruppen nebeneinander

Zwei Viertel der Zeile
Positionen einspaltig unter dem Bild / den Gruppendaten

S240

Mehrere Kataloggruppen nebeneinander

Eine Hälfte der Zeile
Positionen neben dem Bild / den Gruppendaten

S126

06N2

Eine Kataloggruppe je Zeile

Positionen mehrspaltig (max. 99 ) unter dem Bild / den Gruppendaten

8 Positionen je Zeile (Matrix)

08S0

Eine Kataloggruppe je Zeile Positionen mehrspaltig (max 99) unter dem Bild / den Katalog-gruppendaten

8 Positionen je Zeile (Matrix)

08S6

Pxx_PRL

Kombinierte Designs

Einfache Preisliste
einspaltig

P01_PRL

Einfache Preisliste
mehrspaltig
hier zweispaltig

P02_PRL

Einfache Preisliste
zweispaltig

hier zweispaltig
mit Bild je Kataloggruppe

P02b_PRL

Linke / rechte Seite im Wechsel
Eine Kataloggruppe je Zeile
Positionen einspaltig unter dem Bild / den Gruppendaten

S110RL

Zwei Darstellungsarten in einem Design.

Hier S110 = Positionen unter dem Bild

Und S116 =Positionen neben dem Bild

S11xMIX

Deck und Zwischenblätter

Diverse Deck- und Zwischenblätter

Einzelblätter zum einfügen

Im Sammeldruck

Sammeldruck

Sammeldruck

Zusammenführen von verschiedenen Katalogen, Teilkatalogen, Deck- und Zwischenblättern

S110

Abstand

S116

S126

S140

S240

01S0

01S6

08S0

08S6

06N0

06N2

Muster P01_PRL

Muster P02_PRL

Muster P02b_PRL

2 spaltig mit Bild

S110RL

Muster S11xMIX

Mehrere Darstellungsarten in einem Design

KL-systems , KOCH-LÖFFELHOLZ GmbH

seit mehr als 20 Jahren unterstützt die Firma KL-systems Ihre Kunden bei der Sicherstellung Ihrer wirtschaftlichen Erfolge. Kreative Lösungen in den Bereichen Programmentwicklung, Projekt-Management, Beratung und Organisation machen KL-systems zu einem verlässlichen Partner für viele Unternehmen.

Die Kunden von KL-systems kommen aus den Bereichen Industrie, Handel, Fertigung, Dienstleistungen und öffentliche Verwaltungen.

Sitz der Unternehmung ist Eschborn. Die Nähe zu Frankfurt am Main, den Industriezentren rund um die Main-Metropole und die zentrale Lage in Deutschland bilden dabei den idealen und verkehrsgünstig zentral gelegenen Standort.

Die Leistungen im Überblick:

· EDV-Komplettlösungen für den Mittelstand

· Organisationsberatung

· Beratung und Projektmanagement

· Software Entwicklung / Programmierung

· Softwareschulung


Seite 10 KL-KatGen professionell 11.0 Programmbeschreibung

KL-KatGen professionell 11.0 Programmbeschreibung Seite 11

© KL-systems, Koch-Löffelholz GmbH

© KL-systems, Koch-Löffelholz GmbH